]> git.pld-linux.org Git - packages/trousers.git/blame - trousers.spec
add systemd unit for tcsd
[packages/trousers.git] / trousers.spec
CommitLineData
6d904fb9 1# TODO: tcsd init script (see dist/fedora/fedora.initrd.tcsd)
a47235a5
JB
2#
3# Conditional build:
4%bcond_with gtk # use GTK+ popups instead of openssl
5#
6d904fb9
JB
6Summary: TrouSerS - The open-source TCG Software Stack
7Summary(pl.UTF-8): TrouSerS - programowy stos TCG o otwartych źródłach
8Name: trousers
8d727b86 9Version: 0.3.13
bf7bcbf0 10Release: 2
d3cc84b4 11License: BSD
6d904fb9 12Group: Applications/System
a47235a5 13Source0: http://downloads.sourceforge.net/trousers/%{name}-%{version}.tar.gz
8d727b86 14# Source0-md5: ad508f97b406f6e48cd90e85d78e7ca8
1e212545 15Source1: tcsd.service
4b0ed762 16Patch0: no_inline.patch
6d904fb9
JB
17URL: http://trousers.sourceforge.net/
18BuildRequires: autoconf
19BuildRequires: automake >= 1.6
a47235a5 20%{?with_gtk:BuildRequires: gtk+2-devel >= 1:2.0.0}
6d904fb9
JB
21BuildRequires: libtool
22BuildRequires: openssl-devel
23BuildRequires: pkgconfig
1e212545 24BuildRequires: rpmbuild(macros) >= 1.644
5b53c265 25BuildRequires: sed >= 4.0
6d904fb9
JB
26Requires(pre): /bin/id
27Requires(pre): /usr/bin/getgid
28Requires(pre): /usr/sbin/groupadd
29Requires(pre): /usr/sbin/useradd
30Requires(postun): /usr/sbin/groupdel
31Requires(postun): /usr/sbin/userdel
32Requires: %{name}-libs = %{version}-%{release}
1e212545 33Requires: systemd-units >= 38
6d904fb9
JB
34Provides: group(tss)
35Provides: user(tss)
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
39TrouSerS is an open-source TCG Software Stack (TSS), released under
40the Common Public License. TrouSerS aims to be compliant with the 1.1b
41and 1.2 TSS specifications available from the Trusted Computing Group
42website: <http://www.trustedcomputinggroup.org/>.
43
44%description -l pl.UTF-8
45TrouSerS to programowy stos TCG (TSS, czyli TCG Software Stack) o
46otwartych źródłach wydany na licencji Common Public License. Celem
47projektu jest zgodność ze specyfikacjami TSS 1.1b i 1.2 dostępnymi na
48stronie Trusted Computing Group:
49<http://www.trustedcomputinggroup.org/>.
50
51%package libs
52Summary: TrouSerS shared library
53Summary(pl.UTF-8): Biblioteka współdzielona TrouSerS
54Group: Libraries
55
56%description libs
57TrouSerS shared library.
58
59%description libs -l pl.UTF-8
60Biblioteka współdzielona TrouSerS.
61
62%package devel
63Summary: Header files for TrouSerS library
64Summary(pl.UTF-8): Pliki nagłówkowe biblioteki TrouSerS
65Group: Development/Libraries
66Requires: %{name}-libs = %{version}-%{release}
a47235a5 67%{?with_gtk:Requires: gtk+2-devel >= 1:2.0.0}
6d904fb9
JB
68Requires: openssl-devel
69
70%description devel
71Header files for TrouSerS library.
72
73%description devel -l pl.UTF-8
74Pliki nagłówkowe biblioteki TrouSerS.
75
76%package static
77Summary: Static TrouSerS library
78Summary(pl.UTF-8): Statyczna biblioteka TrouSerS
79Group: Development/Libraries
80Requires: %{name}-devel = %{version}-%{release}
81
82%description static
83Static TrouSerS library.
84
85%description static -l pl.UTF-8
86Statyczna biblioteka TrouSerS.
87
88%prep
89%setup -q
6d904fb9 90
4b0ed762
JK
91%patch0 -p1
92
5b53c265
JB
93# there is some unused variable causing warning
94sed -i -e 's/-Werror //' configure.in
95
6d904fb9
JB
96%build
97%{__libtoolize}
98%{__aclocal}
99%{__autoconf}
100%{__automake}
101%configure \
a47235a5 102 --enable-static \
8d727b86
AM
103 %{?with_gtk:--with-gui=gtk} \
104 --disable-usercheck
6d904fb9
JB
105%{__make}
106
107%install
108rm -rf $RPM_BUILD_ROOT
109
110%{__make} install \
111 DESTDIR=$RPM_BUILD_ROOT
112
1e212545
JK
113install %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}/tcsd.service
114
6d904fb9
JB
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%pre
119%groupadd -g 139 tss
120%useradd -u 139 -d %{_localstatedir}/lib/tpm -s /bin/false -c "TrouSerS user" -g tss tss
121
1e212545
JK
122%post
123%systemd_post tcsd.service
124
125%preun
126%systemd_preun tcsd.service
127
6d904fb9
JB
128%postun
129if [ "$1" = "0" ]; then
130 %userremove tss
131 %groupremove tss
132fi
1e212545 133%systemd_reload
6d904fb9
JB
134
135%post libs -p /sbin/ldconfig
136%postun libs -p /sbin/ldconfig
137
138%files
139%defattr(644,root,root,755)
140%doc AUTHORS ChangeLog LICENSE NICETOHAVES README README.selinux TODO
141%attr(755,root,root) %{_sbindir}/tcsd
142%attr(640,root,tss) %{_sysconfdir}/tcsd.conf
143%attr(700,tss,tss) %{_localstatedir}/lib/tpm
144%{_mandir}/man5/tcsd.conf.5*
145%{_mandir}/man8/tcsd.8*
1e212545 146%{systemdunitdir}/tcsd.service
6d904fb9
JB
147
148%files libs
149%defattr(644,root,root,755)
150%attr(755,root,root) %{_libdir}/libtspi.so.*.*.*
a47235a5 151%attr(755,root,root) %ghost %{_libdir}/libtspi.so.1
6d904fb9
JB
152
153%files devel
154%defattr(644,root,root,755)
155%doc doc/{LTC-TSS_LLD_08_r2.pdf,TSS_programming_SNAFUs.txt}
156%attr(755,root,root) %{_libdir}/libtspi.so
157%{_libdir}/libtspi.la
158%{_libdir}/libtddl.a
159%{_includedir}/trousers
160%{_includedir}/tss
161%{_mandir}/man3/Tspi_*.3*
162
163%files static
164%defattr(644,root,root,755)
165%{_libdir}/libtspi.a
This page took 0.658038 seconds and 4 git commands to generate.