]> git.pld-linux.org Git - packages/tpm_emulator.git/commitdiff
- fix building with linux 4.7 auto/th/tpm_emulator-0.7.4-15
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 1 Aug 2016 20:22:11 +0000 (22:22 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 1 Aug 2016 20:22:11 +0000 (22:22 +0200)
- rel 15

linux-4.7.patch [new file with mode: 0644]
tpm_emulator.spec

diff --git a/linux-4.7.patch b/linux-4.7.patch
new file mode 100644 (file)
index 0000000..49567eb
--- /dev/null
@@ -0,0 +1,14 @@
+--- tpm_emulator-0.7.4/tpmd_dev/linux/tpmd_dev.c~      2016-08-01 22:08:44.000000000 +0200
++++ tpm_emulator-0.7.4/tpmd_dev/linux/tpmd_dev.c       2016-08-01 22:20:50.942899171 +0200
+@@ -140,7 +140,11 @@
+ #endif
+   oldmm = get_fs();
+   set_fs(KERNEL_DS);
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4,7,0)
+   res = sock_recvmsg(tpmd_sock, &msg, tpm_response.size, 0);
++#else
++  res = sock_recvmsg(tpmd_sock, &msg, 0);
++#endif
+   set_fs(oldmm);
+   if (res < 0) {
+     error("sock_recvmsg() failed: %d\n", res);
index e136c406b1494f3433c30f00576c1657d6bda502..0e18a4257a69367769ab0b391cc78c51cc8633fa 100644 (file)
@@ -21,7 +21,7 @@ exit 1
 %define                _duplicate_files_terminate_build        0
 
 %define        pname   tpm_emulator
-%define        rel     14
+%define        rel     15
 Summary:       Software-based TPM and MTM Emulator
 Summary(pl.UTF-8):     Programowy emulator TPM i MTM
 Name:          %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
@@ -34,6 +34,7 @@ Source0:      http://downloads.sourceforge.net/tpm-emulator.berlios/%{pname}-%{versio
 Patch0:                %{pname}-libdir.patch
 Patch1:                linux-3.19.patch
 Patch2:                linux-4.1.patch
+Patch3:                linux-4.7.patch
 URL:           http://tpm-emulator.berlios.de/
 BuildRequires: cmake >= 2.4
 BuildRequires: gmp-devel
@@ -126,6 +127,7 @@ przekazujący odebrane polecenia do tpmd.\
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 # separate kernel module from userspace build
 echo > tpmd_dev/CMakeLists.txt
This page took 0.059512 seconds and 4 git commands to generate.