]> git.pld-linux.org Git - packages/tora.git/blame - tora.spec
- fix building with qscintilla 2.11
[packages/tora.git] / tora.spec
CommitLineData
cf4ba209 1#
12df82dd
JR
2# Conditional build:
3%bcond_with oracle # build with oracle support
1be3bba7 4%bcond_with instantclient # build oracle support with oracle-instantclient
7c7f5751 5
cf4ba209 6Summary: A graphical toolkit for database developers and administrators
6dcda7ee 7Summary(pl.UTF-8): Zestaw graficznych narzędzi dla programistów i administratorów baz danych
d47c5232 8Name: tora
bb10b606 9Version: 2.1.3
339c1232 10Release: 9
6cc0d870 11License: GPL v2
81ccb641 12Group: Applications/Databases/Interfaces
6f269cb5 13Source0: http://downloads.sourceforge.net/tora/%{name}-%{version}.tar.gz
bb10b606 14# Source0-md5: ea4a75a9daeaf58492413e3f7fe40293
9c072a02 15Source1: %{name}.desktop
f8ade871 16Patch0: %{name}-postgresql.patch
1be3bba7 17Patch1: %{name}-gcc.patch
bb10b606 18Patch2: %{name}-build.patch
63c5c51a 19Patch3: gethostname.patch
339c1232 20Patch4: qscintilla.patch
79dec357 21URL: http://tora.sourceforge.net/
1be3bba7
JR
22BuildRequires: QtCore-devel
23BuildRequires: QtGui-devel
1be3bba7 24BuildRequires: QtNetwork-devel
6f269cb5 25BuildRequires: QtSql-devel
1be3bba7 26BuildRequires: QtXml-devel
4f290de3 27BuildRequires: cppunit-devel
1be3bba7 28%{?with_instantclient:BuildRequires: oracle-instantclient-devel}
42fd89c5 29BuildRequires: pcre-devel
cdaca0ba 30BuildRequires: postgresql-devel
27a0d6d3 31BuildRequires: qscintilla2-qt4-devel
1be3bba7
JR
32BuildRequires: qt4-build
33BuildRequires: qt4-linguist
339c1232 34BuildRequires: texinfo
1be3bba7 35BuildRequires: xorg-lib-libICE-devel
13c0fe2d 36Suggests: QtSql-pgsql
d47c5232 37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
cdaca0ba
JR
39%if %{with oracle}
40# ORACLE_HOME is required for oracle
41%define _preserve_env %_preserve_env_base ORACLE_HOME
42%endif
43
d47c5232 44%description
42fd89c5
JB
45TOra features a schema browser, SQL worksheet, PL/SQL editor and
46debugger, storage manager, rollback segment monitor, instance manager,
47and SQL output viewer. Via qt3 it can access PostgreSQL and MySQL
48directly. Any other database systems can be accessed via ODBC.
49
0a31a46d
JR
50%description -l pl.UTF-8
51TOra zawiera przeglądarkę schematów, arkusz roboczy SQL, edytor i
52debugger PL/SQL, zarządcę danych, monitor segmentów wycofań, zarządcę
53instancji i przeglądarkę wyjścia SQL. Poprzez qt3 może współpracować
54bezpośrednio z bazami PostgreSQL i MySQL. Inne systemy baz danych mogą
55być obsługiwane poprzez ODBC.
d47c5232 56
57%prep
58%setup -q
58a5a6e7 59%patch0 -p1
1be3bba7 60%patch1 -p1
6f269cb5 61%patch2 -p1
63c5c51a 62%patch3 -p1
339c1232 63%patch4 -p1
d47c5232 64
cdaca0ba
JR
65rm -f src/moc_*
66
d47c5232 67%build
cdaca0ba
JR
68%{__libtoolize}
69%{__aclocal} -I config/m4
70%{__autoconf}
71%{__automake}
07ae61a6 72%configure \
cdaca0ba 73 --libdir=%{_datadir}/%{name} \
1be3bba7
JR
74 --with-qt-libraries=%{_libdir} \
75%if %{with oracle}
7c7f5751 76 %if %{with instantclient}
1be3bba7
JR
77 --with-instant-client \
78 --with-oracle-includes=%{_includedir}/oracle/client \
79 --with-oracle-libraries=%{_libdir} \
7c7f5751 80 %endif
1be3bba7
JR
81 --with-oracle
82%else
83 --without-oracle
84%endif
07ae61a6 85
d47c5232 86%{__make}
87
88%install
89rm -rf $RPM_BUILD_ROOT
58a5a6e7 90install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
a4f6d35b 91%{__make} install \
07ae61a6 92 DESTDIR=$RPM_BUILD_ROOT
391b5823 93
7c7f5751
ER
94cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
95cp -p src/icons/tora.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
cdaca0ba 96cp -a src/templates $RPM_BUILD_ROOT%{_datadir}/%{name}
4f1340cd 97
d47c5232 98%clean
99rm -rf $RPM_BUILD_ROOT
100
7c7f5751
ER
101%post -p /sbin/postshell
102-/usr/sbin/fix-info-dir -c %{_infodir}
103
104%postun -p /sbin/postshell
105-/usr/sbin/fix-info-dir -c %{_infodir}
106
d47c5232 107%files
108%defattr(644,root,root,755)
39781324 109%doc BUGS NEWS README TODO
d47c5232 110%attr(755,root,root) %{_bindir}/*
cdaca0ba
JR
111%dir %{_datadir}/%{name}
112%{_datadir}/%{name}/help
113%{_datadir}/%{name}/templates
114%{_datadir}/%{name}/*.qm
65d26215 115%{_desktopdir}/*.desktop
7c7f5751 116%{_pixmapsdir}/*.xpm
b2328e52 117%{_infodir}/tora*
This page took 0.146608 seconds and 4 git commands to generate.