]> git.pld-linux.org Git - packages/tomcat.git/commitdiff
allow build with older ecj
authorElan Ruusamäe <glen@delfi.ee>
Sun, 26 Jul 2015 18:53:22 +0000 (21:53 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Sun, 26 Jul 2015 18:54:12 +0000 (21:54 +0300)
https://bugzilla.redhat.com/show_bug.cgi?id=1050927#c3

jdt18.patch [new file with mode: 0644]
tomcat.spec

diff --git a/jdt18.patch b/jdt18.patch
new file mode 100644 (file)
index 0000000..0a68e81
--- /dev/null
@@ -0,0 +1,25 @@
+https://bz.apache.org/bugzilla/show_bug.cgi?id=56373
+
+--- java/org/apache/jasper/compiler/JDTCompiler.java   (revision 1585931)
++++ java/org/apache/jasper/compiler/JDTCompiler.java   (working copy)
+@@ -335,7 +335,7 @@ 
+                              CompilerOptions.VERSION_1_7);
+             } else if(opt.equals("1.8")) {
+                 settings.put(CompilerOptions.OPTION_Source,
+-                             CompilerOptions.VERSION_1_8);
++                             "1.8"); // CompilerOptions.VERSION_1_8
+             } else {
+                 log.warn("Unknown source VM " + opt + " ignored.");
+                 settings.put(CompilerOptions.OPTION_Source,
+@@ -379,9 +379,9 @@ 
+                         CompilerOptions.VERSION_1_7);
+             } else if(opt.equals("1.8")) {
+                 settings.put(CompilerOptions.OPTION_TargetPlatform,
+-                             CompilerOptions.VERSION_1_8);
++                             "1.8"); // CompilerOptions.VERSION_1_8
+                 settings.put(CompilerOptions.OPTION_Compliance,
+-                        CompilerOptions.VERSION_1_8);
++                        "1.8"); // CompilerOptions.VERSION_1_8
+             } else {
+                 log.warn("Unknown target VM " + opt + " ignored.");
+                 settings.put(CompilerOptions.OPTION_TargetPlatform,
index 50f272ea52843e0d0807123fec7f0591d1e63246..bd02867e4e7703619c9d950d66f407c899f92ec9 100644 (file)
@@ -38,16 +38,17 @@ Patch2:             %{name}-LDAPUserDatabase.patch
 Patch3:                %{name}-catalina.policy-javadir.patch
 Patch4:                %{name}-userdir.patch
 Patch5:                logging.patch
+Patch6:                jdt18.patch
 Patch100:      jcl-build.xml.patch
 URL:           http://tomcat.apache.org/
 BuildRequires: ant >= 1.5.3
-BuildRequires: eclipse-jdt >= 4.2.2
 BuildRequires: java(JSR109)
 BuildRequires: java-avalon-framework
 BuildRequires: java-avalon-logkit
 BuildRequires: java-commons-daemon >= 1.0
 BuildRequires: java-commons-dbcp-tomcat5 >= 0:1.1
 BuildRequires: java-commons-pool-tomcat5
+BuildRequires: java-eclipse-jdt >= 4.3.2
 BuildRequires: java-geronimo-spec-jaxrpc
 BuildRequires: java-jdbc-mysql
 BuildRequires: java-junit
@@ -266,6 +267,7 @@ javax.servlet.http, javax.servlet.jsp i java.servlet.jsp.tagext).
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
+%patch6 -p0
 
 # Prepare java-commmons-logging sources
 install -d output/extras/logging
This page took 0.138074 seconds and 4 git commands to generate.