can not build for older source level:
authorElan Ruusamäe <glen@delfi.ee>
Wed, 23 Oct 2013 15:21:54 +0000 (18:21 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Wed, 23 Oct 2013 15:21:54 +0000 (18:21 +0300)
compile:
jni/dist/src/java/org/apache/tomcat/jni/socket/AprSocketContext.java:111: error: diamond operator is not supported in -source 1.6
    private final List<AprPoller> pollers = new ArrayList<>();
                                                          ^
jni/dist/src/java/org/apache/tomcat/jni/socket/AprSocketContext.java:795: error: try-with-resources is not supported in -source 1.6
              try (java.net.Socket sock = new java.net.Socket()) {

tomcat-native.spec

index 22deeabb4d721b1de3cfb676de1025fa3ba11314..f1dab81ee0b97adb95d92a015ef37fad12cdd933 100644 (file)
@@ -86,7 +86,10 @@ Statyczna biblioteka tcnative.
 %build
 # build java part
 cd jni
-%ant clean jar
+%ant clean jar \
+       -Dcompile.source=1.7 \
+       -Dcompile.target=1.7 \
+       %{nil}
 
 # build native part
 cd native
This page took 0.261055 seconds and 4 git commands to generate.