]> git.pld-linux.org Git - packages/tomcat-native.git/blob - tomcat-native.spec
- up to 1.1.22
[packages/tomcat-native.git] / tomcat-native.spec
1
2 %include        /usr/lib/rpm/macros.java
3
4 %define         jarver  1.1.17
5
6 Summary:        Native Tomcat Connector based on APR
7 Summary(pl.UTF-8):      Natywny Connector Tomcata oparty o APR
8 Name:           tomcat-native
9 Version:        1.1.22
10 Release:        1
11 License:        Apache v2
12 Group:          Libraries
13 Source0:        http://www.apache.org/dist/tomcat/tomcat-connectors/native/%{version}/source/%{name}-%{version}-src.tar.gz
14 # Source0-md5:  44d764f8d99d0454c7337ba9701558ee
15 URL:            http://tomcat.apache.org/native-doc
16 BuildRequires:  ant
17 BuildRequires:  apr-devel
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  jdk
21 BuildRequires:  jpackage-utils
22 BuildRequires:  libtool
23 BuildRequires:  openssl-devel
24 BuildRequires:  rpm >= 4.4.9-56
25 BuildRequires:  rpm-javaprov
26 BuildRequires:  rpmbuild(macros) >= 1.300
27 BuildConflicts: java-gcj-compat
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Tomcat can use the Apache Portable Runtime to provide superior
32 scalability, performance, and better integration with native server
33 technologies. The Apache Portable Runtime is a highly portable library
34 that is at the heart of Apache HTTP Server 2.x. APR has many uses,
35 including access to advanced IO functionality (such as sendfile, epoll
36 and OpenSSL), OS level functionality (random number generation, system
37 status, etc), and native process handling (shared memory, NT pipes and
38 Unix sockets).
39
40 These features allows making Tomcat a general purpose webserver, will
41 enable much better integration with other native web technologies, and
42 overall make Java much more viable as a full fledged webserver
43 platform rather than simply a backend focused technology.
44
45 %description -l pl.UTF-8
46 Tomcat może wykorzytać Apache Portable Runtime aby zapewnić najwyższą,
47 saklowalność, wydajność i lepszą integrację z natywnymi technologiami
48 serwerowymi.
49
50 Apache portable Runtime jest wysoce przenośną biblioteką, która jest
51 sercem serwera Apache HTTPD 2.x. APR ma wiele zestosowań, m. in.
52 dostępd do zaawansowanych funkcjonalnośći IO (takich jak sendfile,
53 epoll i OpenSSL), funkcjonalności posiomu systemu operacyjnego
54 (generacja liczb losowych, stan systemu, itp.) i natywną obsługę
55 procesów (współdzielona pamięć, potoki NT i gniazda uniksowe).
56
57 Te cechy pozwalają na wykorzystanie Tomcata jako sewera www do
58 zastosowań ogólnych, pozwalają na o wiele lepszą integrację z innymi
59 natywnymi technologiami www i w ogólności pozwalają na traktowanie
60 Javy jako zaawansowanej i kompletnej platformy www a nie tylko
61 technologii backendowej.
62
63 %package devel
64 Summary:        Header files for tcnative library
65 Summary(pl.UTF-8):      Pliki nagłówwkowe biblioteki tcnative
66 Group:          Development/Libraries
67 Requires:       %{name} = %{version}-%{release}
68
69 %description devel
70 Header files for tcnative library.
71
72 %description devel -l pl.UTF-8
73 Pliki nagłówkowe biblioteki tcnative.
74
75 %package static
76 Summary:        Static tcnative library
77 Summary(pl.UTF-8):      Statyczna biblioteka tcnative
78 Group:          Development/Libraries
79 Requires:       %{name}-devel = %{version}-%{release}
80
81 %description static
82 Static tcnative library.
83
84 %description static -l pl.UTF-8
85 Statyczna biblioteka tcnative.
86
87 %prep
88 %setup -q -n %{name}-%{version}-src
89
90 %build
91 # build java part
92 cd jni
93 %ant clean jar
94
95 # build native part
96 cd native
97 ./buildconf --with-apr=%{_datadir}/apr
98 %configure \
99         --with-java-home=%{java_home} \
100         --with-apr=/usr
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 cd jni
107 install -d $RPM_BUILD_ROOT/%{_javadir}
108 install dist/tomcat-native-%{jarver}-dev.jar $RPM_BUILD_ROOT/%{_javadir}/tomcat-native-%{jarver}.jar
109 ln -s tomcat-native-%{jarver}.jar $RPM_BUILD_ROOT/%{_javadir}/tomcat-native.jar
110
111 cd native
112 %{__make} install \
113         prefix=%{_prefix} \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 # Why Makefile doesn't do that?
117 install -d $RPM_BUILD_ROOT/%{_includedir}
118 install include/*.h $RPM_BUILD_ROOT/%{_includedir}
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post   -p /sbin/ldconfig
124 %postun -p /sbin/ldconfig
125
126 %files
127 %defattr(644,root,root,755)
128 %doc CHANGELOG.txt KEYS README.txt
129 %{_javadir}/%{name}-%{jarver}.jar
130 %{_javadir}/%{name}.jar
131 %attr(755,root,root) %{_libdir}/libtcnative-1.so.*.*
132 %attr(755,root,root) %ghost %{_libdir}/libtcnative-1.so.0
133 %{_libdir}/libtcnative-1.so
134
135 %files devel
136 %defattr(644,root,root,755)
137 %{_libdir}/libtcnative-1.la
138 %{_pkgconfigdir}/tcnative-1.pc
139 %{_includedir}/*.h
140
141 %files static
142 %defattr(644,root,root,755)
143 %{_libdir}/libtcnative-1.a
This page took 0.071486 seconds and 4 git commands to generate.