]> git.pld-linux.org Git - packages/tomcat-native.git/blob - tomcat-native.spec
- up to 1.2.2
[packages/tomcat-native.git] / tomcat-native.spec
1 %include        /usr/lib/rpm/macros.java
2 Summary:        Native Tomcat Connector based on APR
3 Summary(pl.UTF-8):      Natywny Connector Tomcata oparty o APR
4 Name:           tomcat-native
5 Version:        1.2.2
6 Release:        1
7 License:        Apache v2
8 Group:          Libraries
9 Source0:        http://www.apache.org/dist/tomcat/tomcat-connectors/native/%{version}/source/%{name}-%{version}-src.tar.gz
10 # Source0-md5:  b942be2f6216142dd0dc42d69c54d148
11 URL:            http://tomcat.apache.org/native-doc/
12 BuildRequires:  ant
13 BuildRequires:  apr-devel
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  jdk >= 1.7.0
17 BuildRequires:  jpackage-utils
18 BuildRequires:  libtool
19 BuildRequires:  openssl-devel
20 BuildRequires:  rpm >= 4.4.9-56
21 BuildRequires:  rpm-javaprov
22 BuildRequires:  rpmbuild(macros) >= 1.300
23 BuildConflicts: java-gcj-compat
24 Requires:       nss
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Tomcat can use the Apache Portable Runtime to provide superior
29 scalability, performance, and better integration with native server
30 technologies. The Apache Portable Runtime is a highly portable library
31 that is at the heart of Apache HTTP Server 2.x. APR has many uses,
32 including access to advanced IO functionality (such as sendfile, epoll
33 and OpenSSL), OS level functionality (random number generation, system
34 status, etc), and native process handling (shared memory, NT pipes and
35 Unix sockets).
36
37 These features allows making Tomcat a general purpose webserver, will
38 enable much better integration with other native web technologies, and
39 overall make Java much more viable as a full fledged webserver
40 platform rather than simply a backend focused technology.
41
42 %description -l pl.UTF-8
43 Tomcat może wykorzytać Apache Portable Runtime aby zapewnić najwyższą,
44 skalowalność, wydajność i lepszą integrację z natywnymi technologiami
45 serwerowymi.
46
47 Apache portable Runtime jest wysoce przenośną biblioteką, która jest
48 sercem serwera Apache HTTPD 2.x. APR ma wiele zestosowań, m. in.
49 dostępd do zaawansowanych funkcjonalnośći IO (takich jak sendfile,
50 epoll i OpenSSL), funkcjonalności posiomu systemu operacyjnego
51 (generacja liczb losowych, stan systemu, itp.) i natywną obsługę
52 procesów (współdzielona pamięć, potoki NT i gniazda uniksowe).
53
54 Te cechy pozwalają na wykorzystanie Tomcata jako sewera www do
55 zastosowań ogólnych, pozwalają na o wiele lepszą integrację z innymi
56 natywnymi technologiami www i w ogólności pozwalają na traktowanie
57 Javy jako zaawansowanej i kompletnej platformy www a nie tylko
58 technologii backendowej.
59
60 %package devel
61 Summary:        Header files for tcnative library
62 Summary(pl.UTF-8):      Pliki nagłówwkowe biblioteki tcnative
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65
66 %description devel
67 Header files for tcnative library.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe biblioteki tcnative.
71
72 %package static
73 Summary:        Static tcnative library
74 Summary(pl.UTF-8):      Statyczna biblioteka tcnative
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 Static tcnative library.
80
81 %description static -l pl.UTF-8
82 Statyczna biblioteka tcnative.
83
84 %prep
85 %setup -q -n %{name}-%{version}-src
86
87 %build
88 # build java part
89 %ant clean jar \
90         -Dcompile.source=1.7 \
91         -Dcompile.target=1.7 \
92         %{nil}
93
94 # build native part
95 cd native
96 ./buildconf --with-apr=%{_datadir}/apr
97 %configure \
98         --with-java-home=%{java_home} \
99         --with-apr=/usr
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 install -d $RPM_BUILD_ROOT%{_javadir}
105 cp -p dist/tomcat-native-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/tomcat-native-%{version}.jar
106 ln -s tomcat-native-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/tomcat-native.jar
107
108 cd native
109 %{__make} install \
110         prefix=%{_prefix} \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 # Why Makefile doesn't do that?
114 install -d $RPM_BUILD_ROOT/%{_includedir}
115 cp -p include/*.h $RPM_BUILD_ROOT/%{_includedir}
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post   -p /sbin/ldconfig
121 %postun -p /sbin/ldconfig
122
123 %files
124 %defattr(644,root,root,755)
125 %doc CHANGELOG.txt README.txt
126 %{_javadir}/%{name}-%{version}.jar
127 %{_javadir}/%{name}.jar
128 %attr(755,root,root) %{_libdir}/libtcnative-1.so.*.*
129 %attr(755,root,root) %ghost %{_libdir}/libtcnative-1.so.0
130 %{_libdir}/libtcnative-1.so
131
132 %files devel
133 %defattr(644,root,root,755)
134 %{_libdir}/libtcnative-1.la
135 %{_pkgconfigdir}/tcnative-1.pc
136 %{_includedir}/*.h
137
138 %files static
139 %defattr(644,root,root,755)
140 %{_libdir}/libtcnative-1.a
This page took 0.068173 seconds and 4 git commands to generate.