]> git.pld-linux.org Git - packages/tomcat-native.git/blob - tomcat-native.spec
-up to 1.1.31
[packages/tomcat-native.git] / tomcat-native.spec
1 %include        /usr/lib/rpm/macros.java
2 Summary:        Native Tomcat Connector based on APR
3 Summary(pl.UTF-8):      Natywny Connector Tomcata oparty o APR
4 Name:           tomcat-native
5 Version:        1.1.32
6 Release:        1
7 License:        Apache v2
8 Group:          Libraries
9 Source0:        http://www.apache.org/dist/tomcat/tomcat-connectors/native/%{version}/source/%{name}-%{version}-src.tar.gz
10 # Source0-md5:  90b4f55d9e3f3614c7b780500268570b
11 URL:            http://tomcat.apache.org/native-doc/
12 BuildRequires:  ant
13 BuildRequires:  apr-devel
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  jdk >= 1.7.0
17 BuildRequires:  jpackage-utils
18 BuildRequires:  libtool
19 BuildRequires:  openssl-devel
20 BuildRequires:  rpm >= 4.4.9-56
21 BuildRequires:  rpm-javaprov
22 BuildRequires:  rpmbuild(macros) >= 1.300
23 BuildConflicts: java-gcj-compat
24 Requires:       nss
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Tomcat can use the Apache Portable Runtime to provide superior
29 scalability, performance, and better integration with native server
30 technologies. The Apache Portable Runtime is a highly portable library
31 that is at the heart of Apache HTTP Server 2.x. APR has many uses,
32 including access to advanced IO functionality (such as sendfile, epoll
33 and OpenSSL), OS level functionality (random number generation, system
34 status, etc), and native process handling (shared memory, NT pipes and
35 Unix sockets).
36
37 These features allows making Tomcat a general purpose webserver, will
38 enable much better integration with other native web technologies, and
39 overall make Java much more viable as a full fledged webserver
40 platform rather than simply a backend focused technology.
41
42 %description -l pl.UTF-8
43 Tomcat może wykorzytać Apache Portable Runtime aby zapewnić najwyższą,
44 skalowalność, wydajność i lepszą integrację z natywnymi technologiami
45 serwerowymi.
46
47 Apache portable Runtime jest wysoce przenośną biblioteką, która jest
48 sercem serwera Apache HTTPD 2.x. APR ma wiele zestosowań, m. in.
49 dostępd do zaawansowanych funkcjonalnośći IO (takich jak sendfile,
50 epoll i OpenSSL), funkcjonalności posiomu systemu operacyjnego
51 (generacja liczb losowych, stan systemu, itp.) i natywną obsługę
52 procesów (współdzielona pamięć, potoki NT i gniazda uniksowe).
53
54 Te cechy pozwalają na wykorzystanie Tomcata jako sewera www do
55 zastosowań ogólnych, pozwalają na o wiele lepszą integrację z innymi
56 natywnymi technologiami www i w ogólności pozwalają na traktowanie
57 Javy jako zaawansowanej i kompletnej platformy www a nie tylko
58 technologii backendowej.
59
60 %package devel
61 Summary:        Header files for tcnative library
62 Summary(pl.UTF-8):      Pliki nagłówwkowe biblioteki tcnative
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65
66 %description devel
67 Header files for tcnative library.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe biblioteki tcnative.
71
72 %package static
73 Summary:        Static tcnative library
74 Summary(pl.UTF-8):      Statyczna biblioteka tcnative
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 Static tcnative library.
80
81 %description static -l pl.UTF-8
82 Statyczna biblioteka tcnative.
83
84 %prep
85 %setup -q -n %{name}-%{version}-src
86
87 %build
88 # build java part
89 cd jni
90 %ant clean jar \
91         -Dcompile.source=1.7 \
92         -Dcompile.target=1.7 \
93         %{nil}
94
95 # build native part
96 cd native
97 ./buildconf --with-apr=%{_datadir}/apr
98 %configure \
99         --with-java-home=%{java_home} \
100         --with-apr=/usr
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 cd jni
106 install -d $RPM_BUILD_ROOT%{_javadir}
107 cp -p dist/tomcat-native-%{version}-dev.jar $RPM_BUILD_ROOT%{_javadir}/tomcat-native-%{version}.jar
108 ln -s tomcat-native-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/tomcat-native.jar
109
110 cd native
111 %{__make} install \
112         prefix=%{_prefix} \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 # Why Makefile doesn't do that?
116 install -d $RPM_BUILD_ROOT/%{_includedir}
117 cp -p include/*.h $RPM_BUILD_ROOT/%{_includedir}
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post   -p /sbin/ldconfig
123 %postun -p /sbin/ldconfig
124
125 %files
126 %defattr(644,root,root,755)
127 %doc CHANGELOG.txt README.txt
128 %{_javadir}/%{name}-%{version}.jar
129 %{_javadir}/%{name}.jar
130 %attr(755,root,root) %{_libdir}/libtcnative-1.so.*.*
131 %attr(755,root,root) %ghost %{_libdir}/libtcnative-1.so.0
132 %{_libdir}/libtcnative-1.so
133
134 %files devel
135 %defattr(644,root,root,755)
136 %{_libdir}/libtcnative-1.la
137 %{_pkgconfigdir}/tcnative-1.pc
138 %{_includedir}/*.h
139
140 %files static
141 %defattr(644,root,root,755)
142 %{_libdir}/libtcnative-1.a
This page took 0.057409 seconds and 3 git commands to generate.