]> git.pld-linux.org Git - packages/tomcat-native.git/blob - tomcat-native.spec
can not build for older source level:
[packages/tomcat-native.git] / tomcat-native.spec
1 %include        /usr/lib/rpm/macros.java
2 Summary:        Native Tomcat Connector based on APR
3 Summary(pl.UTF-8):      Natywny Connector Tomcata oparty o APR
4 Name:           tomcat-native
5 Version:        1.1.29
6 Release:        1
7 License:        Apache v2
8 Group:          Libraries
9 Source0:        http://www.apache.org/dist/tomcat/tomcat-connectors/native/%{version}/source/%{name}-%{version}-src.tar.gz
10 # Source0-md5:  98dd26555a600928238dd9f1d87b22da
11 URL:            http://tomcat.apache.org/native-doc/
12 BuildRequires:  ant
13 BuildRequires:  apr-devel
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  jdk >= 1.7.0
17 BuildRequires:  jpackage-utils
18 BuildRequires:  libtool
19 BuildRequires:  openssl-devel
20 BuildRequires:  rpm >= 4.4.9-56
21 BuildRequires:  rpm-javaprov
22 BuildRequires:  rpmbuild(macros) >= 1.300
23 BuildConflicts: java-gcj-compat
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Tomcat can use the Apache Portable Runtime to provide superior
28 scalability, performance, and better integration with native server
29 technologies. The Apache Portable Runtime is a highly portable library
30 that is at the heart of Apache HTTP Server 2.x. APR has many uses,
31 including access to advanced IO functionality (such as sendfile, epoll
32 and OpenSSL), OS level functionality (random number generation, system
33 status, etc), and native process handling (shared memory, NT pipes and
34 Unix sockets).
35
36 These features allows making Tomcat a general purpose webserver, will
37 enable much better integration with other native web technologies, and
38 overall make Java much more viable as a full fledged webserver
39 platform rather than simply a backend focused technology.
40
41 %description -l pl.UTF-8
42 Tomcat może wykorzytać Apache Portable Runtime aby zapewnić najwyższą,
43 saklowalność, wydajność i lepszą integrację z natywnymi technologiami
44 serwerowymi.
45
46 Apache portable Runtime jest wysoce przenośną biblioteką, która jest
47 sercem serwera Apache HTTPD 2.x. APR ma wiele zestosowań, m. in.
48 dostępd do zaawansowanych funkcjonalnośći IO (takich jak sendfile,
49 epoll i OpenSSL), funkcjonalności posiomu systemu operacyjnego
50 (generacja liczb losowych, stan systemu, itp.) i natywną obsługę
51 procesów (współdzielona pamięć, potoki NT i gniazda uniksowe).
52
53 Te cechy pozwalają na wykorzystanie Tomcata jako sewera www do
54 zastosowań ogólnych, pozwalają na o wiele lepszą integrację z innymi
55 natywnymi technologiami www i w ogólności pozwalają na traktowanie
56 Javy jako zaawansowanej i kompletnej platformy www a nie tylko
57 technologii backendowej.
58
59 %package devel
60 Summary:        Header files for tcnative library
61 Summary(pl.UTF-8):      Pliki nagłówwkowe biblioteki tcnative
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64
65 %description devel
66 Header files for tcnative library.
67
68 %description devel -l pl.UTF-8
69 Pliki nagłówkowe biblioteki tcnative.
70
71 %package static
72 Summary:        Static tcnative library
73 Summary(pl.UTF-8):      Statyczna biblioteka tcnative
74 Group:          Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76
77 %description static
78 Static tcnative library.
79
80 %description static -l pl.UTF-8
81 Statyczna biblioteka tcnative.
82
83 %prep
84 %setup -q -n %{name}-%{version}-src
85
86 %build
87 # build java part
88 cd jni
89 %ant clean jar \
90         -Dcompile.source=1.7 \
91         -Dcompile.target=1.7 \
92         %{nil}
93
94 # build native part
95 cd native
96 ./buildconf --with-apr=%{_datadir}/apr
97 %configure \
98         --with-java-home=%{java_home} \
99         --with-apr=/usr
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 cd jni
105 install -d $RPM_BUILD_ROOT%{_javadir}
106 cp -p dist/tomcat-native-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/tomcat-native-%{version}.jar
107 ln -s tomcat-native-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/tomcat-native.jar
108
109 cd native
110 %{__make} install \
111         prefix=%{_prefix} \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 # Why Makefile doesn't do that?
115 install -d $RPM_BUILD_ROOT/%{_includedir}
116 cp -p include/*.h $RPM_BUILD_ROOT/%{_includedir}
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post   -p /sbin/ldconfig
122 %postun -p /sbin/ldconfig
123
124 %files
125 %defattr(644,root,root,755)
126 %doc CHANGELOG.txt README.txt
127 %{_javadir}/%{name}-%{version}.jar
128 %{_javadir}/%{name}.jar
129 %attr(755,root,root) %{_libdir}/libtcnative-1.so.*.*
130 %attr(755,root,root) %ghost %{_libdir}/libtcnative-1.so.0
131 %{_libdir}/libtcnative-1.so
132
133 %files devel
134 %defattr(644,root,root,755)
135 %{_libdir}/libtcnative-1.la
136 %{_pkgconfigdir}/tcnative-1.pc
137 %{_includedir}/*.h
138
139 %files static
140 %defattr(644,root,root,755)
141 %{_libdir}/libtcnative-1.a
This page took 0.053678 seconds and 3 git commands to generate.