]> git.pld-linux.org Git - packages/tomcat-native.git/blob - tomcat-native.spec
Up to 1.2.31.
[packages/tomcat-native.git] / tomcat-native.spec
1 Summary:        Native Tomcat Connector based on APR
2 Summary(pl.UTF-8):      Natywny Connector Tomcata oparty o APR
3 Name:           tomcat-native
4 Version:        1.2.31
5 Release:        1
6 License:        Apache v2
7 Group:          Libraries
8 Source0:        http://www.apache.org/dist/tomcat/tomcat-connectors/native/%{version}/source/%{name}-%{version}-src.tar.gz
9 # Source0-md5:  a6943e123b1eca0795e106af132df93d
10 URL:            http://tomcat.apache.org/native-doc/
11 BuildRequires:  ant
12 BuildRequires:  apr-devel
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  jdk >= 1.7.0
16 BuildRequires:  jpackage-utils
17 BuildRequires:  libtool
18 BuildRequires:  openssl-devel
19 BuildRequires:  rpm >= 4.4.9-56
20 BuildRequires:  rpm-javaprov
21 BuildRequires:  rpmbuild(macros) >= 1.300
22 BuildConflicts: java-gcj-compat
23 Requires:       nss
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Tomcat can use the Apache Portable Runtime to provide superior
28 scalability, performance, and better integration with native server
29 technologies. The Apache Portable Runtime is a highly portable library
30 that is at the heart of Apache HTTP Server 2.x. APR has many uses,
31 including access to advanced IO functionality (such as sendfile, epoll
32 and OpenSSL), OS level functionality (random number generation, system
33 status, etc), and native process handling (shared memory, NT pipes and
34 Unix sockets).
35
36 These features allows making Tomcat a general purpose webserver, will
37 enable much better integration with other native web technologies, and
38 overall make Java much more viable as a full fledged webserver
39 platform rather than simply a backend focused technology.
40
41 %description -l pl.UTF-8
42 Tomcat może wykorzytać Apache Portable Runtime aby zapewnić najwyższą,
43 skalowalność, wydajność i lepszą integrację z natywnymi technologiami
44 serwerowymi.
45
46 Apache portable Runtime jest wysoce przenośną biblioteką, która jest
47 sercem serwera Apache HTTPD 2.x. APR ma wiele zestosowań, m. in.
48 dostępd do zaawansowanych funkcjonalnośći IO (takich jak sendfile,
49 epoll i OpenSSL), funkcjonalności posiomu systemu operacyjnego
50 (generacja liczb losowych, stan systemu, itp.) i natywną obsługę
51 procesów (współdzielona pamięć, potoki NT i gniazda uniksowe).
52
53 Te cechy pozwalają na wykorzystanie Tomcata jako sewera www do
54 zastosowań ogólnych, pozwalają na o wiele lepszą integrację z innymi
55 natywnymi technologiami www i w ogólności pozwalają na traktowanie
56 Javy jako zaawansowanej i kompletnej platformy www a nie tylko
57 technologii backendowej.
58
59 %package devel
60 Summary:        Header files for tcnative library
61 Summary(pl.UTF-8):      Pliki nagłówwkowe biblioteki tcnative
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64
65 %description devel
66 Header files for tcnative library.
67
68 %description devel -l pl.UTF-8
69 Pliki nagłówkowe biblioteki tcnative.
70
71 %package static
72 Summary:        Static tcnative library
73 Summary(pl.UTF-8):      Statyczna biblioteka tcnative
74 Group:          Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76
77 %description static
78 Static tcnative library.
79
80 %description static -l pl.UTF-8
81 Statyczna biblioteka tcnative.
82
83 %prep
84 %setup -q -n %{name}-%{version}-src
85
86 %build
87 # build java part
88 %ant clean jar \
89         -Dcompile.source=1.7 \
90         -Dcompile.target=1.7 \
91         %{nil}
92
93 # build native part
94 cd native
95 ./buildconf --with-apr=%{_datadir}/apr
96 %configure \
97         --with-java-home=%{java_home} \
98         --with-apr=/usr
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 install -d $RPM_BUILD_ROOT%{_javadir}
104 cp -p dist/tomcat-native-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/tomcat-native-%{version}.jar
105 ln -s tomcat-native-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/tomcat-native.jar
106
107 cd native
108 %{__make} install \
109         prefix=%{_prefix} \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 # Why Makefile doesn't do that?
113 install -d $RPM_BUILD_ROOT/%{_includedir}
114 cp -p include/*.h $RPM_BUILD_ROOT/%{_includedir}
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %post   -p /sbin/ldconfig
120 %postun -p /sbin/ldconfig
121
122 %files
123 %defattr(644,root,root,755)
124 %doc CHANGELOG.txt README.txt
125 %{_javadir}/%{name}-%{version}.jar
126 %{_javadir}/%{name}.jar
127 %attr(755,root,root) %{_libdir}/libtcnative-1.so.*.*
128 %attr(755,root,root) %ghost %{_libdir}/libtcnative-1.so.0
129 %{_libdir}/libtcnative-1.so
130
131 %files devel
132 %defattr(644,root,root,755)
133 %{_libdir}/libtcnative-1.la
134 %{_includedir}/*.h
135
136 %files static
137 %defattr(644,root,root,755)
138 %{_libdir}/libtcnative-1.a
This page took 0.030953 seconds and 3 git commands to generate.