]> git.pld-linux.org Git - packages/tomcat-native.git/blob - tomcat-native.spec
22deeabb4d721b1de3cfb676de1025fa3ba11314
[packages/tomcat-native.git] / tomcat-native.spec
1 %include        /usr/lib/rpm/macros.java
2 Summary:        Native Tomcat Connector based on APR
3 Summary(pl.UTF-8):      Natywny Connector Tomcata oparty o APR
4 Name:           tomcat-native
5 Version:        1.1.29
6 Release:        1
7 License:        Apache v2
8 Group:          Libraries
9 Source0:        http://www.apache.org/dist/tomcat/tomcat-connectors/native/%{version}/source/%{name}-%{version}-src.tar.gz
10 # Source0-md5:  98dd26555a600928238dd9f1d87b22da
11 URL:            http://tomcat.apache.org/native-doc/
12 BuildRequires:  ant
13 BuildRequires:  apr-devel
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  jdk >= 1.7.0
17 BuildRequires:  jpackage-utils
18 BuildRequires:  libtool
19 BuildRequires:  openssl-devel
20 BuildRequires:  rpm >= 4.4.9-56
21 BuildRequires:  rpm-javaprov
22 BuildRequires:  rpmbuild(macros) >= 1.300
23 BuildConflicts: java-gcj-compat
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Tomcat can use the Apache Portable Runtime to provide superior
28 scalability, performance, and better integration with native server
29 technologies. The Apache Portable Runtime is a highly portable library
30 that is at the heart of Apache HTTP Server 2.x. APR has many uses,
31 including access to advanced IO functionality (such as sendfile, epoll
32 and OpenSSL), OS level functionality (random number generation, system
33 status, etc), and native process handling (shared memory, NT pipes and
34 Unix sockets).
35
36 These features allows making Tomcat a general purpose webserver, will
37 enable much better integration with other native web technologies, and
38 overall make Java much more viable as a full fledged webserver
39 platform rather than simply a backend focused technology.
40
41 %description -l pl.UTF-8
42 Tomcat może wykorzytać Apache Portable Runtime aby zapewnić najwyższą,
43 saklowalność, wydajność i lepszą integrację z natywnymi technologiami
44 serwerowymi.
45
46 Apache portable Runtime jest wysoce przenośną biblioteką, która jest
47 sercem serwera Apache HTTPD 2.x. APR ma wiele zestosowań, m. in.
48 dostępd do zaawansowanych funkcjonalnośći IO (takich jak sendfile,
49 epoll i OpenSSL), funkcjonalności posiomu systemu operacyjnego
50 (generacja liczb losowych, stan systemu, itp.) i natywną obsługę
51 procesów (współdzielona pamięć, potoki NT i gniazda uniksowe).
52
53 Te cechy pozwalają na wykorzystanie Tomcata jako sewera www do
54 zastosowań ogólnych, pozwalają na o wiele lepszą integrację z innymi
55 natywnymi technologiami www i w ogólności pozwalają na traktowanie
56 Javy jako zaawansowanej i kompletnej platformy www a nie tylko
57 technologii backendowej.
58
59 %package devel
60 Summary:        Header files for tcnative library
61 Summary(pl.UTF-8):      Pliki nagłówwkowe biblioteki tcnative
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64
65 %description devel
66 Header files for tcnative library.
67
68 %description devel -l pl.UTF-8
69 Pliki nagłówkowe biblioteki tcnative.
70
71 %package static
72 Summary:        Static tcnative library
73 Summary(pl.UTF-8):      Statyczna biblioteka tcnative
74 Group:          Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76
77 %description static
78 Static tcnative library.
79
80 %description static -l pl.UTF-8
81 Statyczna biblioteka tcnative.
82
83 %prep
84 %setup -q -n %{name}-%{version}-src
85
86 %build
87 # build java part
88 cd jni
89 %ant clean jar
90
91 # build native part
92 cd native
93 ./buildconf --with-apr=%{_datadir}/apr
94 %configure \
95         --with-java-home=%{java_home} \
96         --with-apr=/usr
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101 cd jni
102 install -d $RPM_BUILD_ROOT%{_javadir}
103 cp -p dist/tomcat-native-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/tomcat-native-%{version}.jar
104 ln -s tomcat-native-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/tomcat-native.jar
105
106 cd native
107 %{__make} install \
108         prefix=%{_prefix} \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 # Why Makefile doesn't do that?
112 install -d $RPM_BUILD_ROOT/%{_includedir}
113 cp -p include/*.h $RPM_BUILD_ROOT/%{_includedir}
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %files
122 %defattr(644,root,root,755)
123 %doc CHANGELOG.txt README.txt
124 %{_javadir}/%{name}-%{version}.jar
125 %{_javadir}/%{name}.jar
126 %attr(755,root,root) %{_libdir}/libtcnative-1.so.*.*
127 %attr(755,root,root) %ghost %{_libdir}/libtcnative-1.so.0
128 %{_libdir}/libtcnative-1.so
129
130 %files devel
131 %defattr(644,root,root,755)
132 %{_libdir}/libtcnative-1.la
133 %{_pkgconfigdir}/tcnative-1.pc
134 %{_includedir}/*.h
135
136 %files static
137 %defattr(644,root,root,755)
138 %{_libdir}/libtcnative-1.a
This page took 0.030595 seconds and 2 git commands to generate.