]> git.pld-linux.org Git - packages/tomcat-native.git/blame_incremental - tomcat-native.spec
rebuild with openssl 3.0.0
[packages/tomcat-native.git] / tomcat-native.spec
... / ...
CommitLineData
1Summary: Native Tomcat Connector based on APR
2Summary(pl.UTF-8): Natywny Connector Tomcata oparty o APR
3Name: tomcat-native
4Version: 1.2.10
5Release: 3
6License: Apache v2
7Group: Libraries
8Source0: http://www.apache.org/dist/tomcat/tomcat-connectors/native/%{version}/source/%{name}-%{version}-src.tar.gz
9# Source0-md5: 7529a2240f1405f206d2c47dce2f5e6d
10URL: http://tomcat.apache.org/native-doc/
11BuildRequires: ant
12BuildRequires: apr-devel
13BuildRequires: autoconf
14BuildRequires: automake
15BuildRequires: jdk >= 1.7.0
16BuildRequires: jpackage-utils
17BuildRequires: libtool
18BuildRequires: openssl-devel
19BuildRequires: rpm >= 4.4.9-56
20BuildRequires: rpm-javaprov
21BuildRequires: rpmbuild(macros) >= 1.300
22BuildConflicts: java-gcj-compat
23Requires: nss
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27Tomcat can use the Apache Portable Runtime to provide superior
28scalability, performance, and better integration with native server
29technologies. The Apache Portable Runtime is a highly portable library
30that is at the heart of Apache HTTP Server 2.x. APR has many uses,
31including access to advanced IO functionality (such as sendfile, epoll
32and OpenSSL), OS level functionality (random number generation, system
33status, etc), and native process handling (shared memory, NT pipes and
34Unix sockets).
35
36These features allows making Tomcat a general purpose webserver, will
37enable much better integration with other native web technologies, and
38overall make Java much more viable as a full fledged webserver
39platform rather than simply a backend focused technology.
40
41%description -l pl.UTF-8
42Tomcat może wykorzytać Apache Portable Runtime aby zapewnić najwyższą,
43skalowalność, wydajność i lepszą integrację z natywnymi technologiami
44serwerowymi.
45
46Apache portable Runtime jest wysoce przenośną biblioteką, która jest
47sercem serwera Apache HTTPD 2.x. APR ma wiele zestosowań, m. in.
48dostępd do zaawansowanych funkcjonalnośći IO (takich jak sendfile,
49epoll i OpenSSL), funkcjonalności posiomu systemu operacyjnego
50(generacja liczb losowych, stan systemu, itp.) i natywną obsługę
51procesów (współdzielona pamięć, potoki NT i gniazda uniksowe).
52
53Te cechy pozwalają na wykorzystanie Tomcata jako sewera www do
54zastosowań ogólnych, pozwalają na o wiele lepszą integrację z innymi
55natywnymi technologiami www i w ogólności pozwalają na traktowanie
56Javy jako zaawansowanej i kompletnej platformy www a nie tylko
57technologii backendowej.
58
59%package devel
60Summary: Header files for tcnative library
61Summary(pl.UTF-8): Pliki nagłówwkowe biblioteki tcnative
62Group: Development/Libraries
63Requires: %{name} = %{version}-%{release}
64
65%description devel
66Header files for tcnative library.
67
68%description devel -l pl.UTF-8
69Pliki nagłówkowe biblioteki tcnative.
70
71%package static
72Summary: Static tcnative library
73Summary(pl.UTF-8): Statyczna biblioteka tcnative
74Group: Development/Libraries
75Requires: %{name}-devel = %{version}-%{release}
76
77%description static
78Static tcnative library.
79
80%description static -l pl.UTF-8
81Statyczna biblioteka tcnative.
82
83%prep
84%setup -q -n %{name}-%{version}-src
85
86%build
87# build java part
88%ant clean jar \
89 -Dcompile.source=1.7 \
90 -Dcompile.target=1.7 \
91 %{nil}
92
93# build native part
94cd native
95./buildconf --with-apr=%{_datadir}/apr
96%configure \
97 --with-java-home=%{java_home} \
98 --with-apr=/usr
99%{__make}
100
101%install
102rm -rf $RPM_BUILD_ROOT
103install -d $RPM_BUILD_ROOT%{_javadir}
104cp -p dist/tomcat-native-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/tomcat-native-%{version}.jar
105ln -s tomcat-native-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/tomcat-native.jar
106
107cd native
108%{__make} install \
109 prefix=%{_prefix} \
110 DESTDIR=$RPM_BUILD_ROOT
111
112# Why Makefile doesn't do that?
113install -d $RPM_BUILD_ROOT/%{_includedir}
114cp -p include/*.h $RPM_BUILD_ROOT/%{_includedir}
115
116%clean
117rm -rf $RPM_BUILD_ROOT
118
119%post -p /sbin/ldconfig
120%postun -p /sbin/ldconfig
121
122%files
123%defattr(644,root,root,755)
124%doc CHANGELOG.txt README.txt
125%{_javadir}/%{name}-%{version}.jar
126%{_javadir}/%{name}.jar
127%attr(755,root,root) %{_libdir}/libtcnative-1.so.*.*
128%attr(755,root,root) %ghost %{_libdir}/libtcnative-1.so.0
129%{_libdir}/libtcnative-1.so
130
131%files devel
132%defattr(644,root,root,755)
133%{_libdir}/libtcnative-1.la
134%{_pkgconfigdir}/tcnative-1.pc
135%{_includedir}/*.h
136
137%files static
138%defattr(644,root,root,755)
139%{_libdir}/libtcnative-1.a
This page took 0.028561 seconds and 4 git commands to generate.