]> git.pld-linux.org Git - packages/tomcat-native.git/blame_incremental - tomcat-native.spec
- do not pull java-sun via BR - icedtea6 should be enough in all (most) cases
[packages/tomcat-native.git] / tomcat-native.spec
... / ...
CommitLineData
1
2%include /usr/lib/rpm/macros.java
3
4%define jarver 1.1.17
5
6Summary: Native Tomcat Connector based on APR
7Summary(pl.UTF-8): Natywny Connector Tomcata oparty o APR
8Name: tomcat-native
9Version: 1.1.20
10Release: 2
11License: Apache v2
12Group: Libraries
13Source0: http://www.apache.org/dist/tomcat/tomcat-connectors/native/%{version}/source/%{name}-%{version}-src.tar.gz
14# Source0-md5: fb2b9d073cb6575c2d0020eda266ca0c
15URL: http://tomcat.apache.org/native-doc
16BuildRequires: ant
17BuildRequires: apr-devel
18BuildRequires: autoconf
19BuildRequires: automake
20BuildRequires: jdk
21BuildRequires: jpackage-utils
22BuildRequires: libtool
23BuildRequires: openssl-devel
24BuildRequires: rpm >= 4.4.9-56
25BuildRequires: rpm-javaprov
26BuildRequires: rpmbuild(macros) >= 1.300
27BuildConflicts: java-gcj-compat
28ExclusiveArch: i586 i686 pentium3 pentium4 athlon %{x8664}
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32Tomcat can use the Apache Portable Runtime to provide superior
33scalability, performance, and better integration with native server
34technologies. The Apache Portable Runtime is a highly portable library
35that is at the heart of Apache HTTP Server 2.x. APR has many uses,
36including access to advanced IO functionality (such as sendfile, epoll
37and OpenSSL), OS level functionality (random number generation, system
38status, etc), and native process handling (shared memory, NT pipes and
39Unix sockets).
40
41These features allows making Tomcat a general purpose webserver, will
42enable much better integration with other native web technologies, and
43overall make Java much more viable as a full fledged webserver
44platform rather than simply a backend focused technology.
45
46%description -l pl.UTF-8
47Tomcat może wykorzytać Apache Portable Runtime aby zapewnić najwyższą,
48saklowalność, wydajność i lepszą integrację z natywnymi technologiami
49serwerowymi.
50
51Apache portable Runtime jest wysoce przenośną biblioteką, która jest
52sercem serwera Apache HTTPD 2.x. APR ma wiele zestosowań, m. in.
53dostępd do zaawansowanych funkcjonalnośći IO (takich jak sendfile,
54epoll i OpenSSL), funkcjonalności posiomu systemu operacyjnego
55(generacja liczb losowych, stan systemu, itp.) i natywną obsługę
56procesów (współdzielona pamięć, potoki NT i gniazda uniksowe).
57
58Te cechy pozwalają na wykorzystanie Tomcata jako sewera www do
59zastosowań ogólnych, pozwalają na o wiele lepszą integrację z innymi
60natywnymi technologiami www i w ogólności pozwalają na traktowanie
61Javy jako zaawansowanej i kompletnej platformy www a nie tylko
62technologii backendowej.
63
64%package devel
65Summary: Header files for tcnative library
66Summary(pl.UTF-8): Pliki nagłówwkowe biblioteki tcnative
67Group: Development/Libraries
68Requires: %{name} = %{version}-%{release}
69
70%description devel
71Header files for tcnative library.
72
73%description devel -l pl.UTF-8
74Pliki nagłówkowe biblioteki tcnative.
75
76%package static
77Summary: Static tcnative library
78Summary(pl.UTF-8): Statyczna biblioteka tcnative
79Group: Development/Libraries
80Requires: %{name}-devel = %{version}-%{release}
81
82%description static
83Static tcnative library.
84
85%description static -l pl.UTF-8
86Statyczna biblioteka tcnative.
87
88%prep
89%setup -q -n %{name}-%{version}-src
90
91%build
92# build java part
93cd jni
94%ant clean jar
95
96# build native part
97cd native
98./buildconf --with-apr=%{_datadir}/apr
99%configure \
100 --with-java-home=%{java_home} \
101 --with-apr=/usr
102%{__make}
103
104%install
105rm -rf $RPM_BUILD_ROOT
106
107cd jni
108install -d $RPM_BUILD_ROOT/%{_javadir}
109install dist/tomcat-native-%{jarver}-dev.jar $RPM_BUILD_ROOT/%{_javadir}/tomcat-native-%{jarver}.jar
110ln -s tomcat-native-%{jarver}.jar $RPM_BUILD_ROOT/%{_javadir}/tomcat-native.jar
111
112cd native
113%{__make} install \
114 prefix=%{_prefix} \
115 DESTDIR=$RPM_BUILD_ROOT
116
117# Why Makefile doesn't do that?
118install -d $RPM_BUILD_ROOT/%{_includedir}
119install include/*.h $RPM_BUILD_ROOT/%{_includedir}
120
121%clean
122rm -rf $RPM_BUILD_ROOT
123
124%post -p /sbin/ldconfig
125%postun -p /sbin/ldconfig
126
127%files
128%defattr(644,root,root,755)
129%doc CHANGELOG.txt KEYS README.txt
130%{_javadir}/%{name}-%{jarver}.jar
131%{_javadir}/%{name}.jar
132%attr(755,root,root) %{_libdir}/libtcnative-1.so.*.*
133%attr(755,root,root) %ghost %{_libdir}/libtcnative-1.so.0
134%{_libdir}/libtcnative-1.so
135
136%files devel
137%defattr(644,root,root,755)
138%{_libdir}/libtcnative-1.la
139%{_pkgconfigdir}/tcnative-1.pc
140%{_includedir}/*.h
141
142%files static
143%defattr(644,root,root,755)
144%{_libdir}/libtcnative-1.a
This page took 0.056409 seconds and 4 git commands to generate.