]> git.pld-linux.org Git - packages/tomcat-native.git/blame_incremental - tomcat-native.spec
- rel 2
[packages/tomcat-native.git] / tomcat-native.spec
... / ...
CommitLineData
1
2%include /usr/lib/rpm/macros.java
3
4%define jarver 1.1.17
5
6Summary: Native Tomcat Connector based on APR
7Summary(pl.UTF-8): Natywny Connector Tomcata oparty o APR
8Name: tomcat-native
9Version: 1.1.20
10Release: 2
11License: Apache v2
12Group: Libraries
13Source0: http://www.apache.org/dist/tomcat/tomcat-connectors/native/%{version}/source/%{name}-%{version}-src.tar.gz
14# Source0-md5: fb2b9d073cb6575c2d0020eda266ca0c
15URL: http://tomcat.apache.org/native-doc
16BuildRequires: ant
17BuildRequires: apr-devel
18BuildRequires: autoconf
19BuildRequires: automake
20BuildRequires: java-sun
21BuildRequires: jpackage-utils
22BuildRequires: libtool
23BuildRequires: openssl-devel
24BuildRequires: rpm >= 4.4.9-56
25BuildRequires: rpm-javaprov
26BuildRequires: rpmbuild(macros) >= 1.300
27ExclusiveArch: i586 i686 pentium3 pentium4 athlon %{x8664}
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31Tomcat can use the Apache Portable Runtime to provide superior
32scalability, performance, and better integration with native server
33technologies. The Apache Portable Runtime is a highly portable library
34that is at the heart of Apache HTTP Server 2.x. APR has many uses,
35including access to advanced IO functionality (such as sendfile, epoll
36and OpenSSL), OS level functionality (random number generation, system
37status, etc), and native process handling (shared memory, NT pipes and
38Unix sockets).
39
40These features allows making Tomcat a general purpose webserver, will
41enable much better integration with other native web technologies, and
42overall make Java much more viable as a full fledged webserver
43platform rather than simply a backend focused technology.
44
45%description -l pl.UTF-8
46Tomcat może wykorzytać Apache Portable Runtime aby zapewnić najwyższą,
47saklowalność, wydajność i lepszą integrację z natywnymi technologiami
48serwerowymi.
49
50Apache portable Runtime jest wysoce przenośną biblioteką, która jest
51sercem serwera Apache HTTPD 2.x. APR ma wiele zestosowań, m. in.
52dostępd do zaawansowanych funkcjonalnośći IO (takich jak sendfile,
53epoll i OpenSSL), funkcjonalności posiomu systemu operacyjnego
54(generacja liczb losowych, stan systemu, itp.) i natywną obsługę
55procesów (współdzielona pamięć, potoki NT i gniazda uniksowe).
56
57Te cechy pozwalają na wykorzystanie Tomcata jako sewera www do
58zastosowań ogólnych, pozwalają na o wiele lepszą integrację z innymi
59natywnymi technologiami www i w ogólności pozwalają na traktowanie
60Javy jako zaawansowanej i kompletnej platformy www a nie tylko
61technologii backendowej.
62
63%package devel
64Summary: Header files for tcnative library
65Summary(pl.UTF-8): Pliki nagłówwkowe biblioteki tcnative
66Group: Development/Libraries
67Requires: %{name} = %{version}-%{release}
68
69%description devel
70Header files for tcnative library.
71
72%description devel -l pl.UTF-8
73Pliki nagłówkowe biblioteki tcnative.
74
75%package static
76Summary: Static tcnative library
77Summary(pl.UTF-8): Statyczna biblioteka tcnative
78Group: Development/Libraries
79Requires: %{name}-devel = %{version}-%{release}
80
81%description static
82Static tcnative library.
83
84%description static -l pl.UTF-8
85Statyczna biblioteka tcnative.
86
87%prep
88%setup -q -n %{name}-%{version}-src
89
90%build
91# build java part
92cd jni
93%ant clean jar
94
95# build native part
96cd native
97./buildconf --with-apr=%{_datadir}/apr
98%configure \
99 --with-java-home=%{java_home} \
100 --with-apr=/usr
101%{__make}
102
103%install
104rm -rf $RPM_BUILD_ROOT
105
106cd jni
107install -d $RPM_BUILD_ROOT/%{_javadir}
108install dist/tomcat-native-%{jarver}-dev.jar $RPM_BUILD_ROOT/%{_javadir}/tomcat-native-%{jarver}.jar
109ln -s tomcat-native-%{jarver}.jar $RPM_BUILD_ROOT/%{_javadir}/tomcat-native.jar
110
111cd native
112%{__make} install \
113 prefix=%{_prefix} \
114 DESTDIR=$RPM_BUILD_ROOT
115
116# Why Makefile doesn't do that?
117install -d $RPM_BUILD_ROOT/%{_includedir}
118install include/*.h $RPM_BUILD_ROOT/%{_includedir}
119
120%clean
121rm -rf $RPM_BUILD_ROOT
122
123%post -p /sbin/ldconfig
124%postun -p /sbin/ldconfig
125
126%files
127%defattr(644,root,root,755)
128%doc CHANGELOG.txt KEYS README.txt
129%{_javadir}/%{name}-%{jarver}.jar
130%{_javadir}/%{name}.jar
131%attr(755,root,root) %{_libdir}/libtcnative-1.so.*.*
132%attr(755,root,root) %ghost %{_libdir}/libtcnative-1.so.0
133%{_libdir}/libtcnative-1.so
134
135%files devel
136%defattr(644,root,root,755)
137%{_libdir}/libtcnative-1.la
138%{_pkgconfigdir}/tcnative-1.pc
139%{_includedir}/*.h
140
141%files static
142%defattr(644,root,root,755)
143%{_libdir}/libtcnative-1.a
This page took 0.08877 seconds and 4 git commands to generate.