]> git.pld-linux.org Git - packages/tomcat-native.git/blame - tomcat-native.spec
- rewritten almost from scratch.
[packages/tomcat-native.git] / tomcat-native.spec
CommitLineData
fd07ef08 1
2%if "%{pld_release}" == "ti"
3%bcond_without java_sun # build with gcj
4%else
5%bcond_with java_sun # build with java-sun
6%endif
7#
8%include /usr/lib/rpm/macros.java
9
c9ca93f2 10Summary: Native Tomcat Connector based on APR
11Summary(pl.UTF-8): Natywny Connector Tomcata oparty o APR
12Name: tomcat-native
13Version: 1.1.16
14Release: 0.1
fd07ef08 15License: Apache v2
c9ca93f2 16Group: Libraries
17Source0: http://www.apache.org/dist/tomcat/tomcat-connectors/native/%{version}/source/%{name}-%{version}-src.tar.gz
fd07ef08 18# Source0-md5: 2d27f8cf0d87b92b57b2758dad48ff2d
c9ca93f2 19URL: http://tomcat.apache.org/native-doc
fd07ef08 20BuildRequires: ant
21BuildRequires: apr-devel
22BuildRequires: autoconf
23BuildRequires: automake
24%{!?with_java_sun:BuildRequires: java-gcj-compat-devel}
25%{?with_java_sun:BuildRequires: java-sun}
26BuildRequires: jpackage-utils
27BuildRequires: libtool
c9ca93f2 28BuildRequires: openssl-devel
fd07ef08 29BuildRequires: rpm >= 4.4.9-56
30BuildRequires: rpm-javaprov
31BuildRequires: rpmbuild(macros) >= 1.300
c9ca93f2 32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
35Tomcat can use the Apache Portable Runtime to provide superior
36scalability, performance, and better integration with native server
37technologies. The Apache Portable Runtime is a highly portable library
38that is at the heart of Apache HTTP Server 2.x. APR has many uses,
39including access to advanced IO functionality (such as sendfile, epoll
40and OpenSSL), OS level functionality (random number generation, system
41status, etc), and native process handling (shared memory, NT pipes and
42Unix sockets).
43
44These features allows making Tomcat a general purpose webserver, will
45enable much better integration with other native web technologies, and
46overall make Java much more viable as a full fledged webserver
47platform rather than simply a backend focused technology.
48
49%description -l pl.UTF-8
c9ca93f2 50Tomcat może wykorzytać Apache Portable Runtime aby zapewnić
51najwyższą, saklowalność, wydajność i lepszą integrację z
52natywnymi technologiami serwerowymi.
53
54Apache portable Runtime jest wysoce przenośną biblioteką, która
55jest sercem serwera Apache HTTPD 2.x. APR ma wiele zestosowań, m. in.
56dostępd do zaawansowanych funkcjonalnośći IO (takich jak sendfile,
57epoll i OpenSSL), funkcjonalności posiomu systemu operacyjnego
58(generacja liczb losowych, stan systemu, itp.) i natywną obsługę
59procesów (współdzielona pamięć, potoki NT i gniazda uniksowe).
60
61Te cechy pozwalają na wykorzystanie Tomcata jako sewera www do
62zastosowań ogólnych, pozwalają na o wiele lepszą integrację z
63innymi natywnymi technologiami www i w ogólności pozwalają na
64traktowanie Javy jako zaawansowanej i kompletnej platformy www s nie
65tylko technologii backendowej.
66
67%package devel
68Summary: Header files for tcnative library
69Summary(pl.UTF-8): Pliki nagłówwkowe biblioteki tcnative
70Group: Development/Libraries
71Requires: %{name} = %{version}-%{release}
72
73%description devel
74Header files for tcnative library
75
76%description devel -l pl.UTF-8
fd07ef08 77Pliki nagłówkowe biblioteki tcnative
78
79%package static
80Summary: Static tcnative library
81Summary(pl.UTF-8): Statyczna biblioteka tcnative
82Group: Development/Libraries
83Requires: %{name}-devel = %{version}-%{release}
84
85%description static
86Static tcnative library.
87
88%description static -l pl.UTF-8
89Statyczna biblioteka tcnative.
c9ca93f2 90
91%prep
fd07ef08 92%setup -q -n %{name}-%{version}-src
c9ca93f2 93
94%build
fd07ef08 95# build java part
96cd jni
97%ant clean jar
c9ca93f2 98
fd07ef08 99# build native part
100cd native
101./buildconf --with-apr=%{_datadir}/apr
102%configure \
103 --with-java-home=%{java_home} \
104 --with-apr=/usr
c9ca93f2 105%{__make}
106
107%install
108rm -rf $RPM_BUILD_ROOT
c9ca93f2 109
fd07ef08 110cd jni
111install -d $RPM_BUILD_ROOT/%{_javadir}
112install dist/tomcat-native-1.0.0.jar $RPM_BUILD_ROOT/%{_javadir}/tomcat-native-1.0.0.jar
113ln -s tomcat-native-1.0.0.jar $RPM_BUILD_ROOT/%{_javadir}/tomcat-native.jar
114
115cd native
116%{__make} install \
117 prefix=%{_prefix} \
118 DESTDIR=$RPM_BUILD_ROOT
119
120# Why Makefile doesn't do that?
121install -d $RPM_BUILD_ROOT/%{_includedir}
122install include/*.h $RPM_BUILD_ROOT/%{_includedir}
c9ca93f2 123
124%clean
125rm -rf $RPM_BUILD_ROOT
126
fd07ef08 127%post -p /sbin/ldconfig
128%postun -p /sbin/ldconfig
129
c9ca93f2 130%files
131%defattr(644,root,root,755)
fd07ef08 132%doc CHANGELOG.txt KEYS
133%{_javadir}/%{name}-1.0.0.jar
134%{_javadir}/%{name}.jar
135%attr(755,root,root) %{_libdir}/libtcnative-1.so.0.1.16
136%attr(755,root,root) %ghost %{_libdir}/libtcnative-1.so.0
c9ca93f2 137
138%files devel
139%defattr(644,root,root,755)
fd07ef08 140%{_libdir}/libtcnative-1.la
141%{_libdir}/libtcnative-1.so
c9ca93f2 142%{_pkgconfigdir}/tcnative-1.pc
fd07ef08 143%{_includedir}/*.h
144
145%files static
146%defattr(644,root,root,755)
147%{_libdir}/libtcnative-1.a
This page took 0.073975 seconds and 4 git commands to generate.