]> git.pld-linux.org Git - packages/tomcat-native.git/blame - tomcat-native.spec
- EA: (like java_sun.spec)
[packages/tomcat-native.git] / tomcat-native.spec
CommitLineData
fd07ef08 1
fd07ef08 2%include /usr/lib/rpm/macros.java
3
c9ca93f2 4Summary: Native Tomcat Connector based on APR
5Summary(pl.UTF-8): Natywny Connector Tomcata oparty o APR
6Name: tomcat-native
7Version: 1.1.16
8Release: 0.1
fd07ef08 9License: Apache v2
c9ca93f2 10Group: Libraries
11Source0: http://www.apache.org/dist/tomcat/tomcat-connectors/native/%{version}/source/%{name}-%{version}-src.tar.gz
fd07ef08 12# Source0-md5: 2d27f8cf0d87b92b57b2758dad48ff2d
c9ca93f2 13URL: http://tomcat.apache.org/native-doc
fd07ef08 14BuildRequires: ant
15BuildRequires: apr-devel
16BuildRequires: autoconf
17BuildRequires: automake
ec14c88f 18BuildRequires: java-sun
fd07ef08 19BuildRequires: jpackage-utils
20BuildRequires: libtool
c9ca93f2 21BuildRequires: openssl-devel
fd07ef08 22BuildRequires: rpm >= 4.4.9-56
23BuildRequires: rpm-javaprov
24BuildRequires: rpmbuild(macros) >= 1.300
c5ae0c94 25ExclusiveArch: i586 i686 pentium3 pentium4 athlon %{x8664}
c9ca93f2 26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
29Tomcat can use the Apache Portable Runtime to provide superior
30scalability, performance, and better integration with native server
31technologies. The Apache Portable Runtime is a highly portable library
32that is at the heart of Apache HTTP Server 2.x. APR has many uses,
33including access to advanced IO functionality (such as sendfile, epoll
34and OpenSSL), OS level functionality (random number generation, system
35status, etc), and native process handling (shared memory, NT pipes and
36Unix sockets).
37
38These features allows making Tomcat a general purpose webserver, will
39enable much better integration with other native web technologies, and
40overall make Java much more viable as a full fledged webserver
41platform rather than simply a backend focused technology.
42
43%description -l pl.UTF-8
c9ca93f2 44Tomcat może wykorzytać Apache Portable Runtime aby zapewnić
45najwyższą, saklowalność, wydajność i lepszą integrację z
46natywnymi technologiami serwerowymi.
47
48Apache portable Runtime jest wysoce przenośną biblioteką, która
49jest sercem serwera Apache HTTPD 2.x. APR ma wiele zestosowań, m. in.
50dostępd do zaawansowanych funkcjonalnośći IO (takich jak sendfile,
51epoll i OpenSSL), funkcjonalności posiomu systemu operacyjnego
52(generacja liczb losowych, stan systemu, itp.) i natywną obsługę
53procesów (współdzielona pamięć, potoki NT i gniazda uniksowe).
54
55Te cechy pozwalają na wykorzystanie Tomcata jako sewera www do
56zastosowań ogólnych, pozwalają na o wiele lepszą integrację z
57innymi natywnymi technologiami www i w ogólności pozwalają na
58traktowanie Javy jako zaawansowanej i kompletnej platformy www s nie
59tylko technologii backendowej.
60
61%package devel
62Summary: Header files for tcnative library
63Summary(pl.UTF-8): Pliki nagłówwkowe biblioteki tcnative
64Group: Development/Libraries
65Requires: %{name} = %{version}-%{release}
66
67%description devel
68Header files for tcnative library
69
70%description devel -l pl.UTF-8
fd07ef08 71Pliki nagłówkowe biblioteki tcnative
72
73%package static
74Summary: Static tcnative library
75Summary(pl.UTF-8): Statyczna biblioteka tcnative
76Group: Development/Libraries
77Requires: %{name}-devel = %{version}-%{release}
78
79%description static
80Static tcnative library.
81
82%description static -l pl.UTF-8
83Statyczna biblioteka tcnative.
c9ca93f2 84
85%prep
fd07ef08 86%setup -q -n %{name}-%{version}-src
c9ca93f2 87
88%build
fd07ef08 89# build java part
90cd jni
91%ant clean jar
c9ca93f2 92
fd07ef08 93# build native part
94cd native
95./buildconf --with-apr=%{_datadir}/apr
96%configure \
97 --with-java-home=%{java_home} \
98 --with-apr=/usr
c9ca93f2 99%{__make}
100
101%install
102rm -rf $RPM_BUILD_ROOT
c9ca93f2 103
fd07ef08 104cd jni
105install -d $RPM_BUILD_ROOT/%{_javadir}
106install dist/tomcat-native-1.0.0.jar $RPM_BUILD_ROOT/%{_javadir}/tomcat-native-1.0.0.jar
107ln -s tomcat-native-1.0.0.jar $RPM_BUILD_ROOT/%{_javadir}/tomcat-native.jar
108
109cd native
110%{__make} install \
111 prefix=%{_prefix} \
112 DESTDIR=$RPM_BUILD_ROOT
113
114# Why Makefile doesn't do that?
115install -d $RPM_BUILD_ROOT/%{_includedir}
116install include/*.h $RPM_BUILD_ROOT/%{_includedir}
c9ca93f2 117
118%clean
119rm -rf $RPM_BUILD_ROOT
120
fd07ef08 121%post -p /sbin/ldconfig
122%postun -p /sbin/ldconfig
123
c9ca93f2 124%files
125%defattr(644,root,root,755)
fd07ef08 126%doc CHANGELOG.txt KEYS
127%{_javadir}/%{name}-1.0.0.jar
128%{_javadir}/%{name}.jar
129%attr(755,root,root) %{_libdir}/libtcnative-1.so.0.1.16
130%attr(755,root,root) %ghost %{_libdir}/libtcnative-1.so.0
c9ca93f2 131
132%files devel
133%defattr(644,root,root,755)
fd07ef08 134%{_libdir}/libtcnative-1.la
135%{_libdir}/libtcnative-1.so
c9ca93f2 136%{_pkgconfigdir}/tcnative-1.pc
fd07ef08 137%{_includedir}/*.h
138
139%files static
140%defattr(644,root,root,755)
141%{_libdir}/libtcnative-1.a
This page took 0.044639 seconds and 4 git commands to generate.