]> git.pld-linux.org Git - packages/tomcat-native.git/blame - tomcat-native.spec
- up to 1.2.10
[packages/tomcat-native.git] / tomcat-native.spec
CommitLineData
fd07ef08 1%include /usr/lib/rpm/macros.java
c9ca93f2 2Summary: Native Tomcat Connector based on APR
3Summary(pl.UTF-8): Natywny Connector Tomcata oparty o APR
4Name: tomcat-native
72b95cf8 5Version: 1.2.10
d5b2922e 6Release: 1
fd07ef08 7License: Apache v2
c9ca93f2 8Group: Libraries
9Source0: http://www.apache.org/dist/tomcat/tomcat-connectors/native/%{version}/source/%{name}-%{version}-src.tar.gz
72b95cf8 10# Source0-md5: 7529a2240f1405f206d2c47dce2f5e6d
103a5393 11URL: http://tomcat.apache.org/native-doc/
fd07ef08 12BuildRequires: ant
13BuildRequires: apr-devel
14BuildRequires: autoconf
15BuildRequires: automake
9d3aef56 16BuildRequires: jdk >= 1.7.0
fd07ef08 17BuildRequires: jpackage-utils
18BuildRequires: libtool
c9ca93f2 19BuildRequires: openssl-devel
fd07ef08 20BuildRequires: rpm >= 4.4.9-56
21BuildRequires: rpm-javaprov
22BuildRequires: rpmbuild(macros) >= 1.300
99a4b5c8 23BuildConflicts: java-gcj-compat
e90eba34 24Requires: nss
c9ca93f2 25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%description
28Tomcat can use the Apache Portable Runtime to provide superior
29scalability, performance, and better integration with native server
30technologies. The Apache Portable Runtime is a highly portable library
31that is at the heart of Apache HTTP Server 2.x. APR has many uses,
32including access to advanced IO functionality (such as sendfile, epoll
33and OpenSSL), OS level functionality (random number generation, system
34status, etc), and native process handling (shared memory, NT pipes and
35Unix sockets).
36
37These features allows making Tomcat a general purpose webserver, will
38enable much better integration with other native web technologies, and
39overall make Java much more viable as a full fledged webserver
40platform rather than simply a backend focused technology.
41
42%description -l pl.UTF-8
c80659b3 43Tomcat może wykorzytać Apache Portable Runtime aby zapewnić najwyższą,
e28843a8 44skalowalność, wydajność i lepszą integrację z natywnymi technologiami
c80659b3 45serwerowymi.
c9ca93f2 46
c80659b3 47Apache portable Runtime jest wysoce przenośną biblioteką, która jest
48sercem serwera Apache HTTPD 2.x. APR ma wiele zestosowań, m. in.
c9ca93f2 49dostępd do zaawansowanych funkcjonalnośći IO (takich jak sendfile,
50epoll i OpenSSL), funkcjonalności posiomu systemu operacyjnego
51(generacja liczb losowych, stan systemu, itp.) i natywną obsługę
52procesów (współdzielona pamięć, potoki NT i gniazda uniksowe).
53
54Te cechy pozwalają na wykorzystanie Tomcata jako sewera www do
c80659b3 55zastosowań ogólnych, pozwalają na o wiele lepszą integrację z innymi
56natywnymi technologiami www i w ogólności pozwalają na traktowanie
57Javy jako zaawansowanej i kompletnej platformy www a nie tylko
58technologii backendowej.
c9ca93f2 59
60%package devel
61Summary: Header files for tcnative library
62Summary(pl.UTF-8): Pliki nagłówwkowe biblioteki tcnative
63Group: Development/Libraries
64Requires: %{name} = %{version}-%{release}
65
66%description devel
c80659b3 67Header files for tcnative library.
c9ca93f2 68
69%description devel -l pl.UTF-8
c80659b3 70Pliki nagłówkowe biblioteki tcnative.
fd07ef08 71
72%package static
73Summary: Static tcnative library
74Summary(pl.UTF-8): Statyczna biblioteka tcnative
75Group: Development/Libraries
76Requires: %{name}-devel = %{version}-%{release}
77
78%description static
79Static tcnative library.
80
81%description static -l pl.UTF-8
82Statyczna biblioteka tcnative.
c9ca93f2 83
84%prep
fd07ef08 85%setup -q -n %{name}-%{version}-src
c9ca93f2 86
87%build
fd07ef08 88# build java part
5f1f37b5
ER
89%ant clean jar \
90 -Dcompile.source=1.7 \
91 -Dcompile.target=1.7 \
92 %{nil}
c9ca93f2 93
fd07ef08 94# build native part
95cd native
96./buildconf --with-apr=%{_datadir}/apr
97%configure \
98 --with-java-home=%{java_home} \
99 --with-apr=/usr
c9ca93f2 100%{__make}
101
102%install
103rm -rf $RPM_BUILD_ROOT
103a5393 104install -d $RPM_BUILD_ROOT%{_javadir}
a1f0c8af 105cp -p dist/tomcat-native-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/tomcat-native-%{version}.jar
103a5393 106ln -s tomcat-native-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/tomcat-native.jar
fd07ef08 107
108cd native
109%{__make} install \
110 prefix=%{_prefix} \
111 DESTDIR=$RPM_BUILD_ROOT
112
113# Why Makefile doesn't do that?
114install -d $RPM_BUILD_ROOT/%{_includedir}
103a5393 115cp -p include/*.h $RPM_BUILD_ROOT/%{_includedir}
c9ca93f2 116
117%clean
118rm -rf $RPM_BUILD_ROOT
119
fd07ef08 120%post -p /sbin/ldconfig
121%postun -p /sbin/ldconfig
122
c9ca93f2 123%files
124%defattr(644,root,root,755)
9d3aef56 125%doc CHANGELOG.txt README.txt
cc752fca 126%{_javadir}/%{name}-%{version}.jar
fd07ef08 127%{_javadir}/%{name}.jar
c80659b3 128%attr(755,root,root) %{_libdir}/libtcnative-1.so.*.*
fd07ef08 129%attr(755,root,root) %ghost %{_libdir}/libtcnative-1.so.0
105bb620 130%{_libdir}/libtcnative-1.so
c9ca93f2 131
132%files devel
133%defattr(644,root,root,755)
fd07ef08 134%{_libdir}/libtcnative-1.la
c9ca93f2 135%{_pkgconfigdir}/tcnative-1.pc
fd07ef08 136%{_includedir}/*.h
137
138%files static
139%defattr(644,root,root,755)
140%{_libdir}/libtcnative-1.a
This page took 0.055569 seconds and 4 git commands to generate.