]> git.pld-linux.org Git - packages/tomcat-native.git/blame - tomcat-native.spec
up to 1.1.29
[packages/tomcat-native.git] / tomcat-native.spec
CommitLineData
fd07ef08 1%include /usr/lib/rpm/macros.java
c9ca93f2 2Summary: Native Tomcat Connector based on APR
3Summary(pl.UTF-8): Natywny Connector Tomcata oparty o APR
4Name: tomcat-native
103a5393 5Version: 1.1.29
d5b2922e 6Release: 1
fd07ef08 7License: Apache v2
c9ca93f2 8Group: Libraries
9Source0: http://www.apache.org/dist/tomcat/tomcat-connectors/native/%{version}/source/%{name}-%{version}-src.tar.gz
103a5393
ER
10# Source0-md5: 98dd26555a600928238dd9f1d87b22da
11URL: http://tomcat.apache.org/native-doc/
fd07ef08 12BuildRequires: ant
13BuildRequires: apr-devel
14BuildRequires: autoconf
15BuildRequires: automake
9d3aef56 16BuildRequires: jdk >= 1.7.0
fd07ef08 17BuildRequires: jpackage-utils
18BuildRequires: libtool
c9ca93f2 19BuildRequires: openssl-devel
fd07ef08 20BuildRequires: rpm >= 4.4.9-56
21BuildRequires: rpm-javaprov
22BuildRequires: rpmbuild(macros) >= 1.300
99a4b5c8 23BuildConflicts: java-gcj-compat
c9ca93f2 24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27Tomcat can use the Apache Portable Runtime to provide superior
28scalability, performance, and better integration with native server
29technologies. The Apache Portable Runtime is a highly portable library
30that is at the heart of Apache HTTP Server 2.x. APR has many uses,
31including access to advanced IO functionality (such as sendfile, epoll
32and OpenSSL), OS level functionality (random number generation, system
33status, etc), and native process handling (shared memory, NT pipes and
34Unix sockets).
35
36These features allows making Tomcat a general purpose webserver, will
37enable much better integration with other native web technologies, and
38overall make Java much more viable as a full fledged webserver
39platform rather than simply a backend focused technology.
40
41%description -l pl.UTF-8
c80659b3 42Tomcat może wykorzytać Apache Portable Runtime aby zapewnić najwyższą,
43saklowalność, wydajność i lepszą integrację z natywnymi technologiami
44serwerowymi.
c9ca93f2 45
c80659b3 46Apache portable Runtime jest wysoce przenośną biblioteką, która jest
47sercem serwera Apache HTTPD 2.x. APR ma wiele zestosowań, m. in.
c9ca93f2 48dostępd do zaawansowanych funkcjonalnośći IO (takich jak sendfile,
49epoll i OpenSSL), funkcjonalności posiomu systemu operacyjnego
50(generacja liczb losowych, stan systemu, itp.) i natywną obsługę
51procesów (współdzielona pamięć, potoki NT i gniazda uniksowe).
52
53Te cechy pozwalają na wykorzystanie Tomcata jako sewera www do
c80659b3 54zastosowań ogólnych, pozwalają na o wiele lepszą integrację z innymi
55natywnymi technologiami www i w ogólności pozwalają na traktowanie
56Javy jako zaawansowanej i kompletnej platformy www a nie tylko
57technologii backendowej.
c9ca93f2 58
59%package devel
60Summary: Header files for tcnative library
61Summary(pl.UTF-8): Pliki nagłówwkowe biblioteki tcnative
62Group: Development/Libraries
63Requires: %{name} = %{version}-%{release}
64
65%description devel
c80659b3 66Header files for tcnative library.
c9ca93f2 67
68%description devel -l pl.UTF-8
c80659b3 69Pliki nagłówkowe biblioteki tcnative.
fd07ef08 70
71%package static
72Summary: Static tcnative library
73Summary(pl.UTF-8): Statyczna biblioteka tcnative
74Group: Development/Libraries
75Requires: %{name}-devel = %{version}-%{release}
76
77%description static
78Static tcnative library.
79
80%description static -l pl.UTF-8
81Statyczna biblioteka tcnative.
c9ca93f2 82
83%prep
fd07ef08 84%setup -q -n %{name}-%{version}-src
c9ca93f2 85
86%build
fd07ef08 87# build java part
88cd jni
89%ant clean jar
c9ca93f2 90
fd07ef08 91# build native part
92cd native
93./buildconf --with-apr=%{_datadir}/apr
94%configure \
95 --with-java-home=%{java_home} \
96 --with-apr=/usr
c9ca93f2 97%{__make}
98
99%install
100rm -rf $RPM_BUILD_ROOT
fd07ef08 101cd jni
103a5393
ER
102install -d $RPM_BUILD_ROOT%{_javadir}
103cp -p dist/tomcat-native-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/tomcat-native-%{version}.jar
104ln -s tomcat-native-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/tomcat-native.jar
fd07ef08 105
106cd native
107%{__make} install \
108 prefix=%{_prefix} \
109 DESTDIR=$RPM_BUILD_ROOT
110
111# Why Makefile doesn't do that?
112install -d $RPM_BUILD_ROOT/%{_includedir}
103a5393 113cp -p include/*.h $RPM_BUILD_ROOT/%{_includedir}
c9ca93f2 114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
fd07ef08 118%post -p /sbin/ldconfig
119%postun -p /sbin/ldconfig
120
c9ca93f2 121%files
122%defattr(644,root,root,755)
9d3aef56 123%doc CHANGELOG.txt README.txt
cc752fca 124%{_javadir}/%{name}-%{version}.jar
fd07ef08 125%{_javadir}/%{name}.jar
c80659b3 126%attr(755,root,root) %{_libdir}/libtcnative-1.so.*.*
fd07ef08 127%attr(755,root,root) %ghost %{_libdir}/libtcnative-1.so.0
105bb620 128%{_libdir}/libtcnative-1.so
c9ca93f2 129
130%files devel
131%defattr(644,root,root,755)
fd07ef08 132%{_libdir}/libtcnative-1.la
c9ca93f2 133%{_pkgconfigdir}/tcnative-1.pc
fd07ef08 134%{_includedir}/*.h
135
136%files static
137%defattr(644,root,root,755)
138%{_libdir}/libtcnative-1.a
This page took 0.060867 seconds and 4 git commands to generate.