]> git.pld-linux.org Git - packages/tomcat-native.git/blame - tomcat-native.spec
- Dropped EA, we have icedtea6 jdk on all archs
[packages/tomcat-native.git] / tomcat-native.spec
CommitLineData
fd07ef08 1
fd07ef08 2%include /usr/lib/rpm/macros.java
3
c80659b3 4%define jarver 1.1.17
5
c9ca93f2 6Summary: Native Tomcat Connector based on APR
7Summary(pl.UTF-8): Natywny Connector Tomcata oparty o APR
8Name: tomcat-native
a88aae74 9Version: 1.1.20
e97315c7 10Release: 2
fd07ef08 11License: Apache v2
c9ca93f2 12Group: Libraries
13Source0: http://www.apache.org/dist/tomcat/tomcat-connectors/native/%{version}/source/%{name}-%{version}-src.tar.gz
a88aae74 14# Source0-md5: fb2b9d073cb6575c2d0020eda266ca0c
c9ca93f2 15URL: http://tomcat.apache.org/native-doc
fd07ef08 16BuildRequires: ant
17BuildRequires: apr-devel
18BuildRequires: autoconf
19BuildRequires: automake
99a4b5c8 20BuildRequires: jdk
fd07ef08 21BuildRequires: jpackage-utils
22BuildRequires: libtool
c9ca93f2 23BuildRequires: openssl-devel
fd07ef08 24BuildRequires: rpm >= 4.4.9-56
25BuildRequires: rpm-javaprov
26BuildRequires: rpmbuild(macros) >= 1.300
99a4b5c8 27BuildConflicts: java-gcj-compat
c9ca93f2 28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31Tomcat can use the Apache Portable Runtime to provide superior
32scalability, performance, and better integration with native server
33technologies. The Apache Portable Runtime is a highly portable library
34that is at the heart of Apache HTTP Server 2.x. APR has many uses,
35including access to advanced IO functionality (such as sendfile, epoll
36and OpenSSL), OS level functionality (random number generation, system
37status, etc), and native process handling (shared memory, NT pipes and
38Unix sockets).
39
40These features allows making Tomcat a general purpose webserver, will
41enable much better integration with other native web technologies, and
42overall make Java much more viable as a full fledged webserver
43platform rather than simply a backend focused technology.
44
45%description -l pl.UTF-8
c80659b3 46Tomcat może wykorzytać Apache Portable Runtime aby zapewnić najwyższą,
47saklowalność, wydajność i lepszą integrację z natywnymi technologiami
48serwerowymi.
c9ca93f2 49
c80659b3 50Apache portable Runtime jest wysoce przenośną biblioteką, która jest
51sercem serwera Apache HTTPD 2.x. APR ma wiele zestosowań, m. in.
c9ca93f2 52dostępd do zaawansowanych funkcjonalnośći IO (takich jak sendfile,
53epoll i OpenSSL), funkcjonalności posiomu systemu operacyjnego
54(generacja liczb losowych, stan systemu, itp.) i natywną obsługę
55procesów (współdzielona pamięć, potoki NT i gniazda uniksowe).
56
57Te cechy pozwalają na wykorzystanie Tomcata jako sewera www do
c80659b3 58zastosowań ogólnych, pozwalają na o wiele lepszą integrację z innymi
59natywnymi technologiami www i w ogólności pozwalają na traktowanie
60Javy jako zaawansowanej i kompletnej platformy www a nie tylko
61technologii backendowej.
c9ca93f2 62
63%package devel
64Summary: Header files for tcnative library
65Summary(pl.UTF-8): Pliki nagłówwkowe biblioteki tcnative
66Group: Development/Libraries
67Requires: %{name} = %{version}-%{release}
68
69%description devel
c80659b3 70Header files for tcnative library.
c9ca93f2 71
72%description devel -l pl.UTF-8
c80659b3 73Pliki nagłówkowe biblioteki tcnative.
fd07ef08 74
75%package static
76Summary: Static tcnative library
77Summary(pl.UTF-8): Statyczna biblioteka tcnative
78Group: Development/Libraries
79Requires: %{name}-devel = %{version}-%{release}
80
81%description static
82Static tcnative library.
83
84%description static -l pl.UTF-8
85Statyczna biblioteka tcnative.
c9ca93f2 86
87%prep
fd07ef08 88%setup -q -n %{name}-%{version}-src
c9ca93f2 89
90%build
fd07ef08 91# build java part
92cd jni
93%ant clean jar
c9ca93f2 94
fd07ef08 95# build native part
96cd native
97./buildconf --with-apr=%{_datadir}/apr
98%configure \
99 --with-java-home=%{java_home} \
100 --with-apr=/usr
c9ca93f2 101%{__make}
102
103%install
104rm -rf $RPM_BUILD_ROOT
c9ca93f2 105
fd07ef08 106cd jni
107install -d $RPM_BUILD_ROOT/%{_javadir}
c80659b3 108install dist/tomcat-native-%{jarver}-dev.jar $RPM_BUILD_ROOT/%{_javadir}/tomcat-native-%{jarver}.jar
109ln -s tomcat-native-%{jarver}.jar $RPM_BUILD_ROOT/%{_javadir}/tomcat-native.jar
fd07ef08 110
111cd native
112%{__make} install \
113 prefix=%{_prefix} \
114 DESTDIR=$RPM_BUILD_ROOT
115
116# Why Makefile doesn't do that?
117install -d $RPM_BUILD_ROOT/%{_includedir}
118install include/*.h $RPM_BUILD_ROOT/%{_includedir}
c9ca93f2 119
120%clean
121rm -rf $RPM_BUILD_ROOT
122
fd07ef08 123%post -p /sbin/ldconfig
124%postun -p /sbin/ldconfig
125
c9ca93f2 126%files
127%defattr(644,root,root,755)
80e1a8f5 128%doc CHANGELOG.txt KEYS README.txt
c80659b3 129%{_javadir}/%{name}-%{jarver}.jar
fd07ef08 130%{_javadir}/%{name}.jar
c80659b3 131%attr(755,root,root) %{_libdir}/libtcnative-1.so.*.*
fd07ef08 132%attr(755,root,root) %ghost %{_libdir}/libtcnative-1.so.0
105bb620 133%{_libdir}/libtcnative-1.so
c9ca93f2 134
135%files devel
136%defattr(644,root,root,755)
fd07ef08 137%{_libdir}/libtcnative-1.la
c9ca93f2 138%{_pkgconfigdir}/tcnative-1.pc
fd07ef08 139%{_includedir}/*.h
140
141%files static
142%defattr(644,root,root,755)
143%{_libdir}/libtcnative-1.a
This page took 0.056245 seconds and 4 git commands to generate.