]> git.pld-linux.org Git - packages/tomcat-native.git/blame - tomcat-native.spec
Up to 1.2.31.
[packages/tomcat-native.git] / tomcat-native.spec
CommitLineData
c9ca93f2 1Summary: Native Tomcat Connector based on APR
2Summary(pl.UTF-8): Natywny Connector Tomcata oparty o APR
3Name: tomcat-native
ddf326b6
AM
4Version: 1.2.31
5Release: 1
fd07ef08 6License: Apache v2
c9ca93f2 7Group: Libraries
8Source0: http://www.apache.org/dist/tomcat/tomcat-connectors/native/%{version}/source/%{name}-%{version}-src.tar.gz
ddf326b6 9# Source0-md5: a6943e123b1eca0795e106af132df93d
103a5393 10URL: http://tomcat.apache.org/native-doc/
fd07ef08 11BuildRequires: ant
12BuildRequires: apr-devel
13BuildRequires: autoconf
14BuildRequires: automake
9d3aef56 15BuildRequires: jdk >= 1.7.0
fd07ef08 16BuildRequires: jpackage-utils
17BuildRequires: libtool
c9ca93f2 18BuildRequires: openssl-devel
fd07ef08 19BuildRequires: rpm >= 4.4.9-56
20BuildRequires: rpm-javaprov
21BuildRequires: rpmbuild(macros) >= 1.300
99a4b5c8 22BuildConflicts: java-gcj-compat
e90eba34 23Requires: nss
c9ca93f2 24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27Tomcat can use the Apache Portable Runtime to provide superior
28scalability, performance, and better integration with native server
29technologies. The Apache Portable Runtime is a highly portable library
30that is at the heart of Apache HTTP Server 2.x. APR has many uses,
31including access to advanced IO functionality (such as sendfile, epoll
32and OpenSSL), OS level functionality (random number generation, system
33status, etc), and native process handling (shared memory, NT pipes and
34Unix sockets).
35
36These features allows making Tomcat a general purpose webserver, will
37enable much better integration with other native web technologies, and
38overall make Java much more viable as a full fledged webserver
39platform rather than simply a backend focused technology.
40
41%description -l pl.UTF-8
c80659b3 42Tomcat może wykorzytać Apache Portable Runtime aby zapewnić najwyższą,
e28843a8 43skalowalność, wydajność i lepszą integrację z natywnymi technologiami
c80659b3 44serwerowymi.
c9ca93f2 45
c80659b3 46Apache portable Runtime jest wysoce przenośną biblioteką, która jest
47sercem serwera Apache HTTPD 2.x. APR ma wiele zestosowań, m. in.
c9ca93f2 48dostępd do zaawansowanych funkcjonalnośći IO (takich jak sendfile,
49epoll i OpenSSL), funkcjonalności posiomu systemu operacyjnego
50(generacja liczb losowych, stan systemu, itp.) i natywną obsługę
51procesów (współdzielona pamięć, potoki NT i gniazda uniksowe).
52
53Te cechy pozwalają na wykorzystanie Tomcata jako sewera www do
c80659b3 54zastosowań ogólnych, pozwalają na o wiele lepszą integrację z innymi
55natywnymi technologiami www i w ogólności pozwalają na traktowanie
56Javy jako zaawansowanej i kompletnej platformy www a nie tylko
57technologii backendowej.
c9ca93f2 58
59%package devel
60Summary: Header files for tcnative library
61Summary(pl.UTF-8): Pliki nagłówwkowe biblioteki tcnative
62Group: Development/Libraries
63Requires: %{name} = %{version}-%{release}
64
65%description devel
c80659b3 66Header files for tcnative library.
c9ca93f2 67
68%description devel -l pl.UTF-8
c80659b3 69Pliki nagłówkowe biblioteki tcnative.
fd07ef08 70
71%package static
72Summary: Static tcnative library
73Summary(pl.UTF-8): Statyczna biblioteka tcnative
74Group: Development/Libraries
75Requires: %{name}-devel = %{version}-%{release}
76
77%description static
78Static tcnative library.
79
80%description static -l pl.UTF-8
81Statyczna biblioteka tcnative.
c9ca93f2 82
83%prep
fd07ef08 84%setup -q -n %{name}-%{version}-src
c9ca93f2 85
86%build
fd07ef08 87# build java part
5f1f37b5
ER
88%ant clean jar \
89 -Dcompile.source=1.7 \
90 -Dcompile.target=1.7 \
91 %{nil}
c9ca93f2 92
fd07ef08 93# build native part
94cd native
95./buildconf --with-apr=%{_datadir}/apr
96%configure \
97 --with-java-home=%{java_home} \
98 --with-apr=/usr
c9ca93f2 99%{__make}
100
101%install
102rm -rf $RPM_BUILD_ROOT
103a5393 103install -d $RPM_BUILD_ROOT%{_javadir}
a1f0c8af 104cp -p dist/tomcat-native-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/tomcat-native-%{version}.jar
103a5393 105ln -s tomcat-native-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/tomcat-native.jar
fd07ef08 106
107cd native
108%{__make} install \
109 prefix=%{_prefix} \
110 DESTDIR=$RPM_BUILD_ROOT
111
112# Why Makefile doesn't do that?
113install -d $RPM_BUILD_ROOT/%{_includedir}
103a5393 114cp -p include/*.h $RPM_BUILD_ROOT/%{_includedir}
c9ca93f2 115
116%clean
117rm -rf $RPM_BUILD_ROOT
118
fd07ef08 119%post -p /sbin/ldconfig
120%postun -p /sbin/ldconfig
121
c9ca93f2 122%files
123%defattr(644,root,root,755)
9d3aef56 124%doc CHANGELOG.txt README.txt
cc752fca 125%{_javadir}/%{name}-%{version}.jar
fd07ef08 126%{_javadir}/%{name}.jar
c80659b3 127%attr(755,root,root) %{_libdir}/libtcnative-1.so.*.*
fd07ef08 128%attr(755,root,root) %ghost %{_libdir}/libtcnative-1.so.0
105bb620 129%{_libdir}/libtcnative-1.so
c9ca93f2 130
131%files devel
132%defattr(644,root,root,755)
fd07ef08 133%{_libdir}/libtcnative-1.la
fd07ef08 134%{_includedir}/*.h
135
136%files static
137%defattr(644,root,root,755)
138%{_libdir}/libtcnative-1.a
This page took 0.136714 seconds and 5 git commands to generate.