]> git.pld-linux.org Git - packages/tmux.git/blame - tmux.spec
Up to 3.4.
[packages/tmux.git] / tmux.spec
CommitLineData
21dfa491
ZU
1# TODO:
2# - vim doesn't detect filetype
73fd702d
JP
3#
4# Conditional build:
5%bcond_without systemd # without system integration
6
5724a193 7%define commit e809c2ec359b0fd6151cf33929244b7a7d637119
341bb9ad 8
0a168b43 9Summary: tmux - a terminal multiplexer
df1e8c4e 10Summary(hu.UTF-8): tmux egy terminál-sokszorozó
0a168b43 11Summary(pl.UTF-8): tmux - multiplekser terminali
df1e8c4e 12Name: tmux
83b52fa1
AM
13Version: 3.4
14Release: 1
c4f39c44 15License: ISC
df1e8c4e 16Group: Applications/Terminal
1a940cea 17#Source0Download: https://github.com/tmux/tmux/releases
83b52fa1
AM
18Source0: https://github.com/tmux/tmux/releases/download/%{version}/%{name}-%{version}.tar.gz
19# Source0-md5: f6e35f957f91af5bb07cb8449228f5cd
df1e8c4e 20Source1: %{name}-filedetect.vim
466bc6bc 21Source2: https://raw.githubusercontent.com/keith/tmux.vim/master/syntax/tmux.vim
101ede04 22# Source2-md5: cd1169a1757b515b5c57816d339c6f72
13f42450 23Source3: https://raw.githubusercontent.com/imomaliev/tmux-bash-completion/master/completions/tmux
7a54b8d0 24# Source3-md5: 6d65c0f42c74f61602a399d7bb04a85c
095bed52 25Source4: tmux@.service
a018f7c2 26URL: http://tmux.github.io/
05eab483 27BuildRequires: libevent-devel
ea24db7e 28BuildRequires: libutempter-devel
c4f39c44
JB
29BuildRequires: ncurses-devel >= 5
30BuildRequires: pkgconfig
1a940cea 31BuildRequires: rpmbuild(macros) >= 1.673
73fd702d 32%{?with_systemd:BuildRequires: systemd-devel}
df1e8c4e
ZU
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%description
36tmux is a terminal multiplexer: it enables a number of terminals (or
37windows), each running a separate program, to be created, accessed,
38and controlled from a single screen. tmux may be detached from a
39screen and continue running in the background, then later reattached.
40
41%description -l hu.UTF-8
42tmux egy terminál-sokszorozó: terminálok (vagy ablakok) sokaságát
43hozhatd létre, mindegyikben egy külön program fut, létrehozhatsz,
44csatlakozhatsz és irányíthatod egyetlen képernyőről. tmux
45lecsatlakozhat a képernyőről és folytathatja a futását a háttérben, és
46később újracsatlakozhatsz.
47
0a168b43
JB
48%description -l pl.UTF-8
49tmux to multiplekser terminali: pozwala na tworzenie wielu terminali
50(lub okien) z osobnymi programami, dostęp do nich i sterowanie z
51pojedynczego ekranu. tmux może być odłączony od ekranu i nadal działać
52w tle, a następnie ponownie podłączony.
53
df1e8c4e
ZU
54%package -n vim-syntax-tmux
55Summary: Vim syntax file to tmux config files
56Summary(hu.UTF-8): Vim syntax fájl a tmux konfigurációs fájljához
0a168b43 57Summary(pl.UTF-8): Plik składni Vima dla plików konfiguracyjnych tmuksa
df1e8c4e 58Group: Applications/Editors/Vim
0a168b43 59Requires: vim-rt
df1e8c4e
ZU
60
61%description -n vim-syntax-tmux
62Vim syntax file to tmux config files.
63
64%description -n vim-syntax-tmux -l hu.UTF-8
65Vim syntax fájl a tmux konfigurációs fájljához.
66
ee0f9a2f
ZU
67%package -n bash-completion-tmux
68Summary: Bash completion for tmux
0a168b43 69Summary(pl.UTF-8): Bashowe dopełnianie poleceń dla tmuksa
596f5bca 70Group: Applications/Shells
0a168b43 71Requires: %{name} = %{version}-%{release}
1a940cea 72Requires: bash-completion >= 2.0
ee0f9a2f
ZU
73
74%description -n bash-completion-tmux
75This package provides bash-completion for tmux.
76
0a168b43
JB
77%description -n bash-completion-tmux -l pl.UTF-8
78Ten pakiet dostarcza bashowe dopełnianie składni dla polecenia tmux.
79
df1e8c4e 80%prep
83b52fa1 81%setup -q
df1e8c4e
ZU
82
83%build
341bb9ad 84[ ! -x configure ] && ./autogen.sh
c4f39c44 85# note: on Linux use plain glibc functions instead of utf8proc
bdef13e9 86%configure \
73fd702d
JP
87 CPPFLAGS="%{rpmcppflags} -I/usr/include/ncursesw" \
88 %{__enable_disable systemd}
bdef13e9 89
27a56cc0 90%{__make}
df1e8c4e
ZU
91
92%install
93rm -rf $RPM_BUILD_ROOT
94
95%{__make} install \
96 DESTDIR=$RPM_BUILD_ROOT \
97 PREFIX=%{_prefix}
98
99install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/{ftdetect,syntax}
100install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/ftdetect/tmux.vim
466bc6bc 101install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
1a940cea 102install -d $RPM_BUILD_ROOT%{bash_compdir}
efc13735 103sed -e '1s,#!/usr/bin/env bash,#!/bin/bash,' %{SOURCE3} > $RPM_BUILD_ROOT%{bash_compdir}/%{name}
095bed52
JP
104install -d $RPM_BUILD_ROOT%{systemdunitdir}
105install %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}
df1e8c4e
ZU
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110%files
111%defattr(644,root,root,755)
13f42450 112%doc CHANGES COPYING README
0a168b43
JB
113%attr(755,root,root) %{_bindir}/tmux
114%{_mandir}/man1/tmux.1*
095bed52 115%{systemdunitdir}/tmux@.service
df1e8c4e
ZU
116
117%files -n vim-syntax-tmux
118%defattr(644,root,root,755)
119%{_datadir}/vim/vimfiles/ftdetect/tmux.vim
120%{_datadir}/vim/vimfiles/syntax/tmux.vim
ee0f9a2f
ZU
121
122%files -n bash-completion-tmux
123%defattr(644,root,root,755)
1a940cea 124%{bash_compdir}/%{name}
This page took 0.238119 seconds and 4 git commands to generate.