]> git.pld-linux.org Git - packages/tigervnc.git/commitdiff
- updated xserver patch auto/th/tigervnc-1.8.0-3
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 22 May 2018 13:33:23 +0000 (22:33 +0900)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 22 May 2018 13:33:23 +0000 (22:33 +0900)
- added xorg 1.20 support (patch from fedora)
- disabled dri3, does not build here
- rel 3

tigervnc-support-xorg120.patch [new file with mode: 0644]
tigervnc.spec
xserver.patch

diff --git a/tigervnc-support-xorg120.patch b/tigervnc-support-xorg120.patch
new file mode 100644 (file)
index 0000000..dcb50db
--- /dev/null
@@ -0,0 +1,58 @@
+diff --git a/unix/xserver/hw/vnc/xorg-version.h b/unix/xserver/hw/vnc/xorg-version.h
+index 9d1c0eb..79ff79a 100644
+--- a/unix/xserver/hw/vnc/xorg-version.h
++++ b/unix/xserver/hw/vnc/xorg-version.h
+@@ -52,8 +52,10 @@
+ #define XORG 118
+ #elif XORG_VERSION_CURRENT < ((1 * 10000000) + (19 * 100000) + (99 * 1000))
+ #define XORG 119
++#elif XORG_VERSION_CURRENT < ((1 * 10000000) + (20 * 100000) + (99 * 1000))
++#define XORG 120
+ #else
+-#error "X.Org newer than 1.19 is not supported"
++#error "X.Org newer than 1.20 is not supported"
+ #endif
+
+ #endif
+diff --git a/unix/xserver/hw/vnc/xvnc.c b/unix/xserver/hw/vnc/xvnc.c
+index 93d8af4..1517809 100644
+--- a/unix/xserver/hw/vnc/xvnc.c
++++ b/unix/xserver/hw/vnc/xvnc.c
+@@ -202,6 +202,7 @@ vfbBitsPerPixel(int depth)
+
+ static void vfbFreeFramebufferMemory(vfbFramebufferInfoPtr pfb);
+
++#if XORG < 120
+ #ifdef DPMSExtension
+     /* Why support DPMS? Because stupid modern desktop environments
+        such as Unity 2D on Ubuntu 11.10 crashes if DPMS is not
+@@ -219,6 +220,7 @@ Bool DPMSSupported(void)
+     return FALSE;
+ }
+ #endif
++#endif
+
+ #if XORG < 111
+ void ddxGiveUp()
+@@ -1491,6 +1491,12 @@ vfbCloseScreen(ScreenPtr pScreen)
+ #endif
+ }
+
++#if XORG >= 120
++static void vncDPMS(ScreenPtr pScreen, int level)
++{
++}
++#endif
++
+ static Bool
+ #if XORG < 113
+ vfbScreenInit(int index, ScreenPtr pScreen, int argc, char **argv)
+@@ -1661,6 +1667,9 @@ vfbScreenInit(ScreenPtr pScreen, int arg
+     if (!ret) return FALSE;
+ #endif
+
++#if XORG >= 120
++    pScreen->DPMS = vncDPMS;
++#endif
+
+   return TRUE;
index 1076eeac5948285f71ad0d70baca50708ba1279f..0cf1b2135a40aa0ae609f6004375f777bd376b72 100644 (file)
@@ -4,7 +4,7 @@ Summary:        A TigerVNC remote display system
 Summary(pl.UTF-8):     System zdalnego dostępu TigerVNC
 Name:          tigervnc
 Version:       1.8.0
-Release:       2
+Release:       3
 License:       GPL v2
 Group:         X11/Applications/Networking
 Source0:       https://github.com/TigerVNC/tigervnc/archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
@@ -17,6 +17,7 @@ Source5:      vncserver-service-generator
 Patch2:                %{name}-getmaster.patch
 Patch3:                %{name}-utilize-system-crypto-policies.patch
 Patch4:                %{name}-xstartup.patch
+Patch5:                tigervnc-support-xorg120.patch
 Patch100:      xserver.patch
 URL:           http://www.tigervnc.com/
 BuildRequires: ImageMagick
@@ -178,6 +179,7 @@ zdalny dostęp do pulpitu.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 cp -a %{_usrsrc}/xorg-xserver-server-%{_xserverver}/* unix/xserver
 cd unix/xserver
@@ -208,7 +210,7 @@ cd unix/xserver
        --disable-kdrive \
        --disable-dri \
        --enable-dri2 \
-       --enable-dri3 \
+       --disable-dri3 \
        --with-pic \
        --disable-static \
        --disable-wayland \
index 614f104a4d4d47137fa1e063647794fe119e20d1..54cad17e97f8ea147eaa0f6c4a5fafea23b73dba 100644 (file)
@@ -61,19 +61,14 @@ diff -up xserver/hw/Makefile.am.xserver116-rebased xserver/hw/Makefile.am
 diff -up xserver/mi/miinitext.c.xserver116-rebased xserver/mi/miinitext.c
 --- xserver/mi/miinitext.c.xserver116-rebased  2016-09-29 13:14:45.618441855 +0200
 +++ xserver/mi/miinitext.c     2016-09-29 13:14:45.631442006 +0200
-@@ -114,6 +114,10 @@ SOFTWARE.
- #include "micmap.h"
+@@ -114,8 +114,15 @@ SOFTWARE.
+ #include "os.h"
  #include "globals.h"
  
 +#ifdef TIGERVNC
 +extern void vncExtensionInit(INITARGS);
 +#endif
 +
- /* The following is only a small first step towards run-time
-  * configurable extensions.
-  */
-@@ -238,6 +242,9 @@ EnableDisableExtensionError(const char *
  /* List of built-in (statically linked) extensions */
  static const ExtensionModule staticExtensions[] = {
 +#ifdef TIGERVNC
This page took 0.252335 seconds and 4 git commands to generate.