]> git.pld-linux.org Git - packages/thunderbolt-software-user-space.git/blob - thunderbolt-software-user-space.spec
f1083f62c5fb7c04da407327732f401d6e4771fe
[packages/thunderbolt-software-user-space.git] / thunderbolt-software-user-space.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        Thunderbolt(TM) Linux Software
6 Summary(pl.UTF-8):      Oprogramowanie linuksowe do technologii Thunderbolt(TM)
7 Name:           thunderbolt-software-user-space
8 # use "0" until versioning is stabilized:
9 # - github/dell release is tagged by date
10 # - changelog says it's 16.2.59 release
11 # - individual component versions acc. to changelogs:
12 #   - daemon 16.2.57
13 #   - libtbtfwu 1.0.0 release 16.2.59
14 #   - tbtfwucli 0.0.2 release 16.2.59
15 Version:        0
16 %define subver  2017.01.19
17 Release:        0.%{subver}.2
18 License:        BSD
19 Group:          Libraries
20 # primary repository is https://github.com/01org/thunderbolt-software-user-space, but release exists only in dell repository
21 #Source0Download: https://github.com/dell/thunderbolt-software-user-space/releases
22 Source0:        https://github.com/dell/thunderbolt-software-user-space/archive/%{subver}/%{name}-%{subver}.tar.gz
23 # Source0-md5:  2876232d622eb83df0f8ec392826ab55
24 Patch0:         %{name}-glibc.patch
25 Patch1:         %{name}-dbus-macros.patch
26 Patch2:         %{name}-install.patch
27 Patch3:         %{name}-link.patch
28 URL:            https://01.org/thunderbolt-sw/
29 BuildRequires:  cmake >= 2.8.8
30 BuildRequires:  dbus-c++-devel >= 0.5.0
31 BuildRequires:  libnl-devel >= 1:3.2
32 BuildRequires:  libstdc++-devel >= 6:4.7
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 # hardcoded in ThunderboltService/Linux/{CMakeLists.txt,config/*.service}
36 %define         _libexecdir     /usr/lib
37
38 %description
39 Thunderbolt(TM) Linux Software.
40
41 %description -l pl.UTF-8
42 Oprogramowanie linuksowe do technologii Thunderbolt(TM).
43
44 %package -n thunderbolt-software-daemon
45 Summary:        Thunderbolt(TM) daemon
46 Summary(pl.UTF-8):      Demon Thunderbolt(TM)
47 Group:          Daemons
48
49 %description -n thunderbolt-software-daemon
50 Thunderbolt(TM) technology is a transformational high-speed, dual
51 protocol I/O that provides unmatched performance with up to 40Gbps
52 bi-directional transfer speeds. It provides flexibility and simplicity
53 by supporting both data (PCIe, USB3.1) and video (DisplayPort) on a
54 single cable connection that can daisy-chain up to six devices.
55
56 In addition, the Thunderbolt Networking mode allows a connection of
57 two computers through a Thunderbolt cable.
58
59 The Thunderbolt daemon (thunderboltd) is a user-space daemon that
60 implements 2 main functionalities:
61 1. Completing the Thunderbolt Networking implementation.
62 2. Implementing the host FW update functionality.
63
64 %description -n thunderbolt-software-daemon -l pl.UTF-8
65 Technologia Thunderbolt(TM) to szybkie, dwuprotokołowe operacje we/wy
66 zapewniające wyjątkową przepustowość do 40Gbps w obie strony. Zapewnia
67 elastyczność i prostotę, obsługując zarówno dane (PCIe, USB3.1), jak i
68 obraz (DisplayPort) na pojedynczym połączeniu kablowym, którym można
69 połączyć szeregowo do sześciu urządzeń.
70
71 Ponadto tryb sieciowy Thunderbolt pozwala na połączenie kablem dwóch
72 komputerów.
73
74 Demon Thunderbolt (thunderboltd) to demon przestrzeni użytkownika
75 zapewniający dwie funkcje:
76 1. Uzupełnienie implementacji Thunderbolt Networking.
77 2. Aktualizacje firmware'u hosta.
78
79 %package -n libtbtfwu
80 Summary:        Thunderbolt(TM) FW update library
81 Summary(pl.UTF-8):      Biblioteka do uaktualniania FW systemu Thunderbolt(TM)
82 Group:          Libraries
83
84 %description -n libtbtfwu
85 This library supplies simpler, safer and higher-level interface of the
86 FW update functionality supplied by Thunderbolt daemon. It currently
87 supports FW update for host controller only.
88
89 %description -n libtbtfwu -l pl.UTF-8
90 Ta biblioteka udostępnia prostszy, bezpieczniejszy interfejs wyższego
91 poziomu funkcji uaktualniania FW udostępnianej przez demona
92 Thunderbolt. Obecnie obsługuje uaktualnianie firmware'u tylko
93 kontrolera hosta.
94
95 %package -n libtbtfwu-devel
96 Summary:        Header files for libtbtfwu library
97 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libtbtfwu
98 Group:          Development/Libraries
99 Requires:       libtbtfwu = %{version}-%{release}
100
101 %description -n libtbtfwu-devel
102 Header files for libtbtfwu library.
103
104 %description -n libtbtfwu-devel -l pl.UTF-8
105 Pliki nagłówkowe biblioteki libtbtfwu.
106
107 %package -n libtbtfwu-static
108 Summary:        Static libtbtfwu library
109 Summary(pl.UTF-8):      Statyczna biblioteka libtbtfwu
110 Group:          Development/Libraries
111 Requires:       libtbtfwu-devel = %{version}-%{release}
112
113 %description -n libtbtfwu-static
114 Static libtbtfwu library.
115
116 %description -n libtbtfwu-static -l pl.UTF-8
117 Statyczna biblioteka libtbtfwu.
118
119 %package -n tbtfwucli
120 Summary:        Thunderbold(TM) FW update sample tool
121 Summary(pl.UTF-8):      Przykładowe narzędzie do uaktualniania FW systemu Thunderbolt(TM)
122 Group:          Applications/System
123 Requires:       libtbtfwu = %{version}-%{release}
124
125 %description -n tbtfwucli
126 This is a preliminary sample of a command line tool that uses the FW
127 update library. It implements a simple user interface for testing
128 current FW version of a Thunderbolt host controller, validating FW
129 image file compatibility with current controller and writing a new FW
130 image file to the controller flash.
131
132 %description -n tbtfwucli -l pl.UTF-8
133 Ten pakiet zawiera wczesne, przykładowe narzędzie linii poleceń
134 wykorzystujące bibliotekę do uaktualniania FW. Implementuje prosty
135 interfejs użytkownika do testowania aktualnej wersji FW kontrolera
136 hosta Thunderbolt, sprawdzanie zgodności pliku obrazu FW z aktualnym
137 kontrolerem oraz zapis nowego pliku obrazu FW do pamięci flash
138 kontrolera.
139
140 %prep
141 %setup -q -n %{name}-%{subver}
142 %patch0 -p1
143 %patch1 -p1
144 %patch2 -p1
145 %patch3 -p1
146
147 %build
148 TOPDIR=$(pwd)
149 install -d build-libtbtfwu
150 cd build-libtbtfwu
151 # CMakeFiles expect relative CMAKE_INSTALL_LIBDIR
152 %cmake ../fwupdate/libtbtfwu \
153         -DCMAKE_INSTALL_LIBDIR:PATH=%{_lib}
154 %{__make}
155 cd ..
156
157 install -d build-tbtfwucli
158 cd build-tbtfwucli
159 %cmake ../fwupdate/tbtfwucli \
160         -DTBT_LIBRARY="$TOPDIR/build-libtbtfwu/libtbtfwu.so"
161 %{__make}
162 cd ..
163
164 install -d build-daemon
165 cd build-daemon
166 %cmake ../ThunderboltService/Linux
167 %{__make}
168 cd ..
169
170 %install
171 rm -rf $RPM_BUILD_ROOT
172
173 %{__make} -C build-libtbtfwu install \
174         DESTDIR=$RPM_BUILD_ROOT
175
176 %{__make} -C build-tbtfwucli install \
177         DESTDIR=$RPM_BUILD_ROOT
178
179 %{__make} -C build-daemon install \
180         DESTDIR=$RPM_BUILD_ROOT
181
182 %clean
183 rm -rf $RPM_BUILD_ROOT
184
185 %post   -n libtbtfwu -p /sbin/ldconfig
186 %postun -n libtbtfwu -p /sbin/ldconfig
187
188 %files -n thunderbolt-software-daemon
189 %defattr(644,root,root,755)
190 %doc AUTHORS.daemon COPYING.daemon ChangeLog.daemon README README.daemon
191 %dir %{_libexecdir}/thunderbolt
192 %attr(755,root,root) %{_libexecdir}/thunderbolt/thunderboltd
193 %{_datadir}/dbus-1/system-services/com.Intel.Thunderbolt.service
194 %{systemdunitdir}/thunderbolt.service
195 /etc/dbus-1/system.d/thunderbolt.conf
196 /etc/udev/rules.d/10-thunderbolt.rules
197
198 %files -n libtbtfwu
199 %defattr(644,root,root,755)
200 %doc AUTHORS.libtbtfwu COPYING.libtbtfwu ChangeLog.libtbtfwu README.libtbtfwu
201 %attr(755,root,root) %{_libdir}/libtbtfwu.so.*.*.*
202 %attr(755,root,root) %ghost %{_libdir}/libtbtfwu.so.1
203
204 %files -n libtbtfwu-devel
205 %defattr(644,root,root,755)
206 %attr(755,root,root) %{_libdir}/libtbtfwu.so
207 %{_includedir}/tbt
208 %{_pkgconfigdir}/libtbtfwu.pc
209
210 %files -n libtbtfwu-static
211 %defattr(644,root,root,755)
212 %{_libdir}/libtbtfwu.a
213
214 %files -n tbtfwucli
215 %defattr(644,root,root,755)
216 %doc AUTHORS.tbtfwucli COPYING.tbtfwucli ChangeLog.tbtfwucli README.tbtfwucli
217 %attr(755,root,root) %{_bindir}/tbtfwucli
This page took 0.069546 seconds and 2 git commands to generate.