]> git.pld-linux.org Git - packages/thunderbird.git/commitdiff
- fix building with libvpx 1.4.x
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 23 May 2015 20:14:18 +0000 (22:14 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 23 May 2015 20:14:18 +0000 (22:14 +0200)
- rel 2

icedove.spec
libvpx2.patch [new file with mode: 0644]

index 86170191e68f46a2505b89eaf71c36548f7d2262..eb170fe7da125940d7010ae3638a28a7773abb27 100644 (file)
@@ -28,7 +28,7 @@ Summary:      Icedove - email client
 Summary(pl.UTF-8):     Icedove - klient poczty
 Name:          icedove
 Version:       31.5.0
-Release:       1
+Release:       2
 License:       MPL v2.0
 Group:         X11/Applications/Mail
 Source0:       http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
@@ -39,16 +39,17 @@ Source3:    %{name}-rm_nonfree.sh
 Source4:       %{name}.desktop
 Source5:       %{name}.sh
 Patch0:                %{name}-branding.patch
-Patch3:                %{name}-fonts.patch
-Patch6:                %{name}-prefs.patch
-Patch7:                system-mozldap.patch
-Patch8:                %{name}-makefile.patch
-Patch10:       %{name}-extensiondir.patch
-Patch12:       no-subshell.patch
+Patch1:                %{name}-fonts.patch
+Patch2:                %{name}-prefs.patch
+Patch3:                system-mozldap.patch
+Patch4:                %{name}-makefile.patch
+Patch5:                %{name}-extensiondir.patch
+Patch6:                no-subshell.patch
 # Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
-Patch13:       system-virtualenv.patch
-Patch15:       enable-addons.patch
-Patch16:       bump-nss-req.patch
+Patch7:                system-virtualenv.patch
+Patch8:                enable-addons.patch
+Patch9:                bump-nss-req.patch
+Patch10:       libvpx2.patch
 URL:           http://www.pld-linux.org/Packages/Icedove
 BuildRequires: GConf2-devel >= 1.2.1
 BuildRequires: alsa-lib-devel
@@ -155,15 +156,16 @@ funkcjonalność kalendarza.
 cd mozilla
 /bin/sh %{SOURCE3}
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
 %patch3 -p1
+%patch4 -p2
+%patch5 -p2
 %patch6 -p1
 %patch7 -p1
-%patch8 -p2
-%patch10 -p2
-%patch12 -p1
-%patch13 -p1
-%patch15 -p1
-%patch16 -p2
+%patch8 -p1
+%patch9 -p2
+%patch10 -p1
 
 %build
 cd mozilla
diff --git a/libvpx2.patch b/libvpx2.patch
new file mode 100644 (file)
index 0000000..85a1a2d
--- /dev/null
@@ -0,0 +1,74 @@
+--- comm-release/mozilla/media/webrtc/trunk/webrtc/modules/video_coding/codecs/vp8/vp8_impl.cc~        2014-06-13 02:45:44.000000000 +0200
++++ comm-release/mozilla/media/webrtc/trunk/webrtc/modules/video_coding/codecs/vp8/vp8_impl.cc 2015-05-23 22:04:53.241382776 +0200
+@@ -180,7 +180,7 @@
+   // Creating a wrapper to the image - setting image data to NULL. Actual
+   // pointer will be set in encode. Setting align to 1, as it is meaningless
+   // (actual memory is not allocated).
+-  raw_ = vpx_img_wrap(NULL, IMG_FMT_I420, codec_.width, codec_.height,
++  raw_ = vpx_img_wrap(NULL, VPX_IMG_FMT_I420, codec_.width, codec_.height,
+                       1, NULL);
+   // populate encoder configuration with default values
+   if (vpx_codec_enc_config_default(vpx_codec_vp8_cx(), config_, 0)) {
+@@ -349,9 +349,9 @@
+   }
+   // Image in vpx_image_t format.
+   // Input image is const. VP8's raw image is not defined as const.
+-  raw_->planes[PLANE_Y] = const_cast<uint8_t*>(input_image.buffer(kYPlane));
+-  raw_->planes[PLANE_U] = const_cast<uint8_t*>(input_image.buffer(kUPlane));
+-  raw_->planes[PLANE_V] = const_cast<uint8_t*>(input_image.buffer(kVPlane));
++  raw_->planes[VPX_PLANE_Y] = const_cast<uint8_t*>(input_image.buffer(kYPlane));
++  raw_->planes[VPX_PLANE_U] = const_cast<uint8_t*>(input_image.buffer(kUPlane));
++  raw_->planes[VPX_PLANE_V] = const_cast<uint8_t*>(input_image.buffer(kVPlane));
+   // TODO(mikhal): Stride should be set in initialization.
+   raw_->stride[VPX_PLANE_Y] = input_image.stride(kYPlane);
+   raw_->stride[VPX_PLANE_U] = input_image.stride(kUPlane);
+--- mozilla/mozilla/content/media/encoder/VP8TrackEncoder.cpp~ 2015-02-25 19:21:17.000000000 +0100
++++ mozilla/mozilla/content/media/encoder/VP8TrackEncoder.cpp  2015-05-23 22:11:33.299057650 +0200
+@@ -84,7 +84,7 @@
+   // Creating a wrapper to the image - setting image data to NULL. Actual
+   // pointer will be set in encode. Setting align to 1, as it is meaningless
+   // (actual memory is not allocated).
+-  vpx_img_wrap(mVPXImageWrapper, IMG_FMT_I420,
++  vpx_img_wrap(mVPXImageWrapper, VPX_IMG_FMT_I420,
+                mFrameWidth, mFrameHeight, 1, nullptr);
+   config.g_w = mFrameWidth;
+@@ -239,9 +239,9 @@
+   uint8_t *cb = mMuteFrame.Elements() + yPlaneSize;
+   uint8_t *cr = mMuteFrame.Elements() + yPlaneSize + uvPlaneSize;
+-  mVPXImageWrapper->planes[PLANE_Y] = y;
+-  mVPXImageWrapper->planes[PLANE_U] = cb;
+-  mVPXImageWrapper->planes[PLANE_V] = cr;
++  mVPXImageWrapper->planes[VPX_PLANE_Y] = y;
++  mVPXImageWrapper->planes[VPX_PLANE_U] = cb;
++  mVPXImageWrapper->planes[VPX_PLANE_V] = cr;
+   mVPXImageWrapper->stride[VPX_PLANE_Y] = mFrameWidth;
+   mVPXImageWrapper->stride[VPX_PLANE_U] = halfWidth;
+   mVPXImageWrapper->stride[VPX_PLANE_V] = halfWidth;
+@@ -297,9 +297,9 @@
+     const PlanarYCbCrImage::Data *data = yuv->GetData();
+     if (isYUV420(data) && !data->mCbSkip) { // 420 planar
+-      mVPXImageWrapper->planes[PLANE_Y] = data->mYChannel;
+-      mVPXImageWrapper->planes[PLANE_U] = data->mCbChannel;
+-      mVPXImageWrapper->planes[PLANE_V] = data->mCrChannel;
++      mVPXImageWrapper->planes[VPX_PLANE_Y] = data->mYChannel;
++      mVPXImageWrapper->planes[VPX_PLANE_U] = data->mCbChannel;
++      mVPXImageWrapper->planes[VPX_PLANE_V] = data->mCrChannel;
+       mVPXImageWrapper->stride[VPX_PLANE_Y] = data->mYStride;
+       mVPXImageWrapper->stride[VPX_PLANE_U] = data->mCbCrStride;
+       mVPXImageWrapper->stride[VPX_PLANE_V] = data->mCbCrStride;
+@@ -355,9 +355,9 @@
+         return NS_ERROR_NOT_IMPLEMENTED;
+       }
+-      mVPXImageWrapper->planes[PLANE_Y] = y;
+-      mVPXImageWrapper->planes[PLANE_U] = cb;
+-      mVPXImageWrapper->planes[PLANE_V] = cr;
++      mVPXImageWrapper->planes[VPX_PLANE_Y] = y;
++      mVPXImageWrapper->planes[VPX_PLANE_U] = cb;
++      mVPXImageWrapper->planes[VPX_PLANE_V] = cr;
+       mVPXImageWrapper->stride[VPX_PLANE_Y] = mFrameWidth;
+       mVPXImageWrapper->stride[VPX_PLANE_U] = halfWidth;
+       mVPXImageWrapper->stride[VPX_PLANE_V] = halfWidth;
This page took 0.388853 seconds and 4 git commands to generate.