]> git.pld-linux.org Git - packages/thunderbird.git/commitdiff
- updated to 24.2.0
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 14 Dec 2013 15:23:26 +0000 (16:23 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 14 Dec 2013 15:23:26 +0000 (16:23 +0100)
enable-addons.patch [new file with mode: 0644]
gyp-slashism.patch
icedove-branding.patch
icedove-extensiondir.patch
icedove.spec
system-mozldap.patch
system-virtualenv.patch

diff --git a/enable-addons.patch b/enable-addons.patch
new file mode 100644 (file)
index 0000000..daff8d1
--- /dev/null
@@ -0,0 +1,46 @@
+--- comm-release/mail/app/profile/all-thunderbird.js.old       2011-11-21 11:20:08.000000000 +0100
++++ comm-release/mail/app/profile/all-thunderbird.js   2011-12-14 12:40:24.074179826 +0100
+@@ -138,7 +138,7 @@ pref("extensions.update.autoUpdateDefaul
+ // Disable add-ons installed into the shared user and shared system areas by
+ // default. This does not include the application directory. See the SCOPE
+ // constants in AddonManager.jsm for values to use here
+-pref("extensions.autoDisableScopes", 15);
++pref("extensions.autoDisableScopes", 0);
+ // Preferences for AMO integration
+ pref("extensions.getAddons.cache.enabled", true);
+--- comm-release/mozilla/toolkit/mozapps/extensions/XPIProvider.jsm.addons     2011-11-21 11:28:32.000000000 +0100
++++ comm-release/mozilla/toolkit/mozapps/extensions/XPIProvider.jsm    2011-12-14 12:43:42.461184351 +0100
+@@ -1591,8 +1591,8 @@ var XPIProvider = {
+       this.showUpgradeUI();
+       flushCaches = true;
+     }
+-    else if (aAppChanged === undefined) {
+-      // For new profiles we will never need to show the add-on selection UI
++    else {
++      // For all profiles we will never need to show the add-on selection UI
+       Services.prefs.setBoolPref(PREF_SHOWN_SELECTION_UI, true);
+     }
+--- comm-release/suite/browser/browser-prefs.js~       2013-11-06 19:54:38.789734061 +0100
++++ comm-release/suite/browser/browser-prefs.js        2013-11-06 20:55:33.765611935 +0100
+@@ -616,7 +616,7 @@
+ // Disable add-ons installed into the shared user and shared system areas by
+ // default. This does not include the application directory. See the SCOPE
+ // constants in AddonManager.jsm for values to use here.
+-pref("extensions.autoDisableScopes", 15);
++pref("extensions.autoDisableScopes", 0);
+ // Preferences for AMO integration
+ pref("extensions.getAddons.cache.enabled", true);  // also toggles personalized recommendations
+--- comm-release/mozilla/browser/app/profile/firefox.js~       2013-10-29 02:20:40.000000000 +0100
++++ comm-release/mozilla/browser/app/profile/firefox.js        2013-11-06 20:56:58.633092070 +0100
+@@ -62,7 +62,7 @@
+ // Disable add-ons that are not installed by the user in all scopes by default.
+ // See the SCOPE constants in AddonManager.jsm for values to use here.
+-pref("extensions.autoDisableScopes", 15);
++pref("extensions.autoDisableScopes", 0);
+ // Dictionary download preference
+ pref("browser.dictionaries.download.url", "https://addons.mozilla.org/%LOCALE%/firefox/dictionaries/");
index ccab4568fc026ed9f3407dcd2ff22f75d9c9ffd4..51000118b008bd8637d1851a1a1d075a064acad3 100644 (file)
      if self.WriteTargetMakefile(output_file, rel_path, qualified_target, spec, build_file, subdepth):
          # If WriteTargetMakefile returns True, then this is a useful target
        dirs.append(rel_path)
-@@ -376,7 +382,7 @@
-     WriteMakefile(output_file, data, build_file, depth, top,
-                   # we set srcdir up one directory, since the subdir
-                   # doesn't actually exist in the source directory
--                  swapslashes(os.path.join(top, self.relative_srcdir, os.path.split(rel_path)[0])),
-+                  swapslashes(append_relative(append_relative(top, self.relative_srcdir), os.path.split(rel_path)[0])),
-                   self.relative_srcdir)
-     return True
 @@ -399,7 +405,7 @@
    # The relative path from objdir to gyp_file_dir
    srcdir = gyp.common.RelativePath(gyp_file_dir, objdir)
index a5262c45a2b40575b369ae394c08edd9b44d6574..d4386c233ae6a5fb6a041e3a3a93c6a34a64c16a 100644 (file)
  
  // Enables some extra Extension System Logging (can reduce performance) 
  pref("extensions.logging.enabled", false); 
-@@ -190,7 +190,7 @@
- pref("extensions.update.interval", 86400);  // Check for updates to Extensions and 
-                                             // Themes every day
--pref("extensions.getMoreThemesURL", "https://addons.mozilla.org/%LOCALE%/%APP%/themes/");
-+pref("extensions.getMoreThemesURL", "https://addons.mozilla.org/%LOCALE%/thunderbird/themes/");
- pref("extensions.dss.enabled", false);          // Dynamic Skin Switching                                               
- pref("extensions.dss.switchPending", false);    // Non-dynamic switch pending after next
 @@ -391,7 +391,7 @@
  
  pref("spellchecker.dictionary", "");
index 836c0b5341ec152aae3b995c5cf42992a6282125..7ffbebde4534bdc6f13a681001d78a4d7a3f7118 100644 (file)
@@ -1,24 +1,25 @@
 --- icedove-3.1.2/mozilla/mozilla/toolkit/xre/nsXREDirProvider.cpp~    2010-08-03 02:28:31.000000000 +0300
 +++ icedove-3.1.2/mozilla/mozilla/toolkit/xre/nsXREDirProvider.cpp     2010-08-17 15:46:17.972676534 +0300
 @@ -328,7 +328,7 @@
- #if defined(XP_UNIX) && !defined(XP_MACOSX)
-   else if (!strcmp(aProperty, XRE_SYS_SHARE_EXTENSION_PARENT_DIR)) {
- #ifdef ENABLE_SYSTEM_EXTENSION_DIRS
+ #if defined(__OpenBSD__) || defined(__FreeBSD__)
+     static const char *const sysLExtDir = "/usr/local/share/mozilla/extensions";
+ #else
 -    static const char *const sysLExtDir = "/usr/share/mozilla/extensions";
 +    static const char *const sysLExtDir = "/usr/share/icedove/extensions";
+ #endif
      return NS_NewNativeLocalFile(nsDependentCString(sysLExtDir),
-                                  false, (nsILocalFile**)(nsIFile**) aFile);
- #else
-@@ -1129,9 +1129,9 @@
+                                  false, aFile);
+@@ -1129,11 +1129,11 @@
  #elif defined(XP_UNIX)
-   static const char *const sysSExtDir =
+   static const char *const sysSExtDir = 
  #ifdef HAVE_USR_LIB64_DIR
 -    "/usr/lib64/mozilla/extensions";
 +    "/usr/lib64/icedove/extensions";
+ #elif defined(__OpenBSD__) || defined(__FreeBSD__)
+     "/usr/local/lib/mozilla/extensions";
  #else
 -    "/usr/lib/mozilla/extensions";
 +    "/usr/lib/icedove/extensions";
  #endif
-
    rv = NS_NewNativeLocalFile(nsDependentCString(sysSExtDir), false,
-  rv = NS_NewNativeLocalFile(nsDependentCString(sysSExtDir), PR_FALSE,
index 82db0fbbcdad4abb07d5994875e42901a1271d00..eebbbb9959328294d134c51118255209b442de02 100644 (file)
@@ -4,26 +4,20 @@
 #
 # Conditional builds
 %bcond_without enigmail        # don't build enigmail - GPG/PGP support
-%bcond_without gnomeui         # disable gnomeui support
-%bcond_without gnome           # alias for gnomeui
 %bcond_without ldap            # disable e-mail address lookups in LDAP directories
 %bcond_without lightning       # disable Sunbird/Lightning calendar
 %bcond_with    xulrunner       # system xulrunner
 %bcond_with    crashreporter   # report crashes to crash-stats.mozilla.com
 
-%if %{without gnome}
-%undefine      with_gnomeui
-%endif
-
 %if 0%{?_enable_debug_packages} != 1
 %undefine      crashreporter
 %endif
 
-%define                enigmail_ver    1.5.1
+%define                enigmail_ver    1.6
 %define                nspr_ver        4.9.3
-%define                nss_ver         3.14.1
+%define                nss_ver         3.15.3.1
 
-%define                xulrunner_ver   2:17.0
+%define                xulrunner_ver   2:24.0
 
 %if %{without xulrunner}
 # The actual sqlite version (see RHBZ#480989):
 Summary:       Icedove - email client
 Summary(pl.UTF-8):     Icedove - klient poczty
 Name:          icedove
-Version:       17.0.8
-Release:       2
+Version:       24.2.0
+Release:       0.3
 License:       MPL 1.1 or GPL v2+ or LGPL v2.1+
 Group:         X11/Applications/Mail
 Source0:       http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
-# Source0-md5: e4aee8852e94e455930bf482aecdbcd4
+# Source0-md5: 53d457a8ff97a305d975c20d1bebff04
 Source1:       http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
-# Source1-md5: 3e71f84ed2c11471282412ebe4f5eb2d
+# Source1-md5: 4a2bbcb020bdb282a660fda8c70d5608
 Source2:       %{name}-branding.tar.bz2
-# Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
+# Source2-md5: d8e6897870bf288fdf264c0e9ef85f7d
 Source3:       %{name}-rm_nonfree.sh
 Source4:       %{name}.desktop
 Source5:       %{name}.sh
 Patch0:                %{name}-branding.patch
 Patch1:                %{name}-enigmail-shared.patch
 Patch3:                %{name}-fonts.patch
-Patch4:                %{name}-install.patch
-Patch5:                %{name}-hunspell.patch
 Patch6:                %{name}-prefs.patch
 Patch7:                system-mozldap.patch
 Patch8:                %{name}-makefile.patch
-Patch9:                system-cairo.patch
 Patch10:       %{name}-extensiondir.patch
 Patch11:       crashreporter.patch
 Patch12:       no-subshell.patch
 # Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
 Patch13:       system-virtualenv.patch
 Patch14:       gyp-slashism.patch
+Patch15:       enable-addons.patch
 URL:           http://www.pld-linux.org/Packages/Icedove
 BuildRequires: GConf2-devel >= 1.2.1
 BuildRequires: alsa-lib-devel
@@ -70,12 +62,12 @@ BuildRequires:      cairo-devel >= 1.10
 BuildRequires: dbus-glib-devel >= 0.60
 BuildRequires: freetype-devel >= 1:2.1.8
 BuildRequires: glib2-devel >= 2.0
+BuildRequires: gstreamer0.10-devel
+BuildRequires: gstreamer0.10-plugins-base-devel
 BuildRequires: gtk+2-devel >= 2:2.10.0
 BuildRequires: hunspell-devel
 BuildRequires: libIDL-devel >= 0.8.0
-%{?with_gnomeui:BuildRequires: libgnome-devel >= 2.0}
-%{?with_gnomeui:BuildRequires: libgnome-keyring-devel}
-%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
+BuildRequires: libevent-devel
 BuildRequires: libiw-devel
 # requires libjpeg-turbo implementing at least libjpeg 6b API
 BuildRequires: libjpeg-devel >= 6b
@@ -83,15 +75,18 @@ BuildRequires:      libjpeg-turbo-devel
 BuildRequires: libnotify-devel >= 0.4
 BuildRequires: libpng-devel >= 1.4.1
 BuildRequires: libstdc++-devel
+BuildRequires: mozldap-devel
 BuildRequires: nspr-devel >= 1:%{nspr_ver}
 BuildRequires: nss-devel >= 1:%{nss_ver}
 BuildRequires: pango-devel >= 1:1.14.0
 BuildRequires: perl-base >= 1:5.6
+BuildRequires: python-virtualenv
 BuildRequires: pkgconfig
 BuildRequires: python >= 1:2.5
 BuildRequires: sed >= 4.0
 BuildRequires: sqlite3-devel >= 3.7.4
 BuildRequires: startup-notification-devel >= 0.8
+BuildRequires: libvpx-devel >= 1.0.0
 BuildRequires: xorg-lib-libXext-devel
 BuildRequires: xorg-lib-libXinerama-devel
 BuildRequires: xorg-lib-libXt-devel
@@ -99,7 +94,6 @@ BuildRequires:        yasm
 BuildRequires: zip
 %if %{with xulrunner}
 BuildRequires: xulrunner-devel >= %{xulrunner_ver}
-BuildRequires: xulrunner-devel < 2:18
 %else
 Requires:      myspell-common
 Requires:      nspr >= 1:%{nspr_ver}
@@ -190,7 +184,7 @@ Główne możliwości:
 
 %prep
 %setup -qc
-mv comm-esr17 mozilla
+mv comm-esr24 mozilla
 %setup -q -T -D -a2
 cd mozilla
 %{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
@@ -198,16 +192,18 @@ cd mozilla
 %patch0 -p1
 %{?with_enigmail:%patch1 -p1}
 %patch3 -p1
-%patch4 -p1
 %patch6 -p1
 %patch7 -p1
 %patch8 -p2
-%patch9 -p1
 %patch10 -p2
-%patch11 -p2
+#patch11 -p2
 %patch12 -p1
 %patch13 -p1
 %patch14 -p1
+%patch15 -p1
+
+# the entire check in that configure is so wrong, it's simpler to just workaround it here temporarily
+%{__sed} -i -e 's|min_nss_version=3.15.3.1|min_nss_version=3.15.3|' mozilla/configure
 
 %build
 cd mozilla
@@ -259,11 +255,7 @@ ac_add_options --enable-tests
 ac_add_options --disable-tests
 %endif
 ac_add_options --enable-gio
-%if %{with gnomeui}
-ac_add_options --enable-gnomeui
-%else
 ac_add_options --disable-gnomeui
-%endif
 ac_add_options --disable-gnomevfs
 %if %{with ldap}
 ac_add_options --enable-ldap
@@ -283,35 +275,31 @@ ac_add_options --enable-calendar
 %else
 ac_add_options --disable-calendar
 %endif
+ac_add_options --disable-elf-dynstr-gc
 ac_add_options --disable-installer
+ac_add_options --disable-javaxpcom
 ac_add_options --disable-updater
-ac_add_options --disable-xprint
-ac_add_options --disable-permissions
-ac_add_options --disable-pref-extensions
-ac_add_options --enable-canvas
 ac_add_options --enable-crypto
-ac_add_options --enable-mathml
+ac_add_options --enable-libxul
 ac_add_options --enable-pango
-ac_add_options --enable-reorder
+ac_add_options --enable-shared-js
 ac_add_options --enable-startup-notification
-ac_add_options --enable-svg
 ac_add_options --enable-system-cairo
 ac_add_options --enable-system-hunspell
 ac_add_options --enable-system-sqlite
-ac_add_options --enable-xft
 ac_add_options --enable-application=mail
-ac_add_options --enable-default-toolkit=cairo-gtk2
-ac_add_options --enable-xinerama
 ac_add_options --with-distribution-id=org.pld-linux
 ac_add_options --with-branding=icedove/branding
 %if %{with xulrunner}
-ac_add_options --enable-shared-js
-ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
 ac_add_options --with-system-libxul
+ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
 %endif
 ac_add_options --with-pthreads
 ac_add_options --with-system-bz2
+ac_add_options --with-system-ffi
 ac_add_options --with-system-jpeg
+ac_add_options --with-system-libevent
+ac_add_options --with-system-libvpx
 ac_add_options --with-system-nspr
 ac_add_options --with-system-nss
 ac_add_options --with-system-png
@@ -321,9 +309,13 @@ ac_add_options --disable-profilesharing
 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
 EOF
 
+mkdir -p %{objdir}/config
+ln -s %{topdir}/mozilla/config/*.mk %{objdir}/config
+
 %{__make} -j1 -f client.mk build \
        STRIP="/bin/true" \
        MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
+       installdir=%{_libdir}/%{name} \
        XLIBS="-lX11 -lXt" \
        CC="%{__cc}" \
        CXX="%{__cxx}"
@@ -336,12 +328,12 @@ EOF
 %if %{with enigmail}
 cd mailnews/extensions/enigmail
 ./makemake -r -o %{objdir}
-%{__make} -C %{objdir}/mailnews/extensions/enigmail \
+%{__make} -j1 -C %{objdir}/mailnews/extensions/enigmail \
        STRIP="/bin/true" \
        CC="%{__cc}" \
        CXX="%{__cxx}"
 
-%{__make} -C %{objdir}/mailnews/extensions/enigmail xpi \
+%{__make} -j1 -C %{objdir}/mailnews/extensions/enigmail xpi \
        STRIP="/bin/true" \
        CC="%{__cc}" \
        CXX="%{__cxx}"
@@ -354,9 +346,14 @@ install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_
 cd %{objdir}
 %{__make} -C mail/installer stage-package \
        DESTDIR=$RPM_BUILD_ROOT \
-       MOZ_PKG_DIR=%{_libdir}/%{name} \
+       installdir=%{_libdir}/%{name} \
        PKG_SKIP_STRIP=1
 
+%{__make} -C icedove/branding install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+cp -a mozilla/dist/icedove/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
 %if %{with xulrunner}
 # needed to find mozilla runtime
 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
@@ -372,25 +369,12 @@ cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $R
 %endif
 
 # copy manually lightning files, somewhy they are not installed by make
-cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
-       mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
+cp -a mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
        $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
 
 # move arch independant ones to datadir
-mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
-mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
-mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
-mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
-ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
-ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
-ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
-ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
-%if %{without xulrunner}
-mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
-ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
-%endif
 
 # dir for arch independant extensions besides arch dependant extensions
 # see mozilla/xpcom/build/nsXULAppAPI.h
@@ -400,8 +384,6 @@ install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
 %if %{without xulrunner}
 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
-%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
-ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
 %endif
 
 %{__sed} -e "s|%MOZAPPDIR%|%{_libdir}/%{name}|" \
@@ -412,8 +394,17 @@ ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
 
-cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
+# install icons and desktop file
 cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
+for i in 16 32 48 64 128 256; do
+       install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps
+       cp -a %{topdir}/mozilla/icedove/branding/icedove${i}.png \
+               $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps/icedove.png
+done
+install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps
+cp -a %{topdir}/mozilla/icedove/branding/icedove.svg $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps/icedove.svg
+
+cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
 
 # files created by regxpcom -register in post
 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
@@ -437,7 +428,6 @@ install -d $ext_dir/{chrome,components,defaults/preferences,modules}
 cd mozilla/dist/bin
 cp -rfLp chrome/enigmail.jar $ext_dir/chrome
 cp -rfLp components/enig* $ext_dir/components
-cp -rfLp components/libenigmime.so $ext_dir/components
 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
 cp -rfLp modules/{commonFuncs,enigmailCommon,keyManagement,pipeConsole,subprocess}.jsm $ext_dir/modules
 cp -rfLp modules/{subprocess_worker_unix,subprocess_worker_win}.js $ext_dir/modules
@@ -446,15 +436,9 @@ cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_di
 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
 %endif
 
-# never package these. always remove
-# nss
-%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
-# nspr
-%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
 # mozldap
-%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
-# testpilot quiz
-%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/tbtestpilot@labs.mozilla.com.xpi
+%{__sed} -i '/lib\(ldap\|ldif\|prldap\)60.so/d' $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap}60.so
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -484,21 +468,19 @@ exit 0
 %{_libdir}/%{name}/blocklist.xml
 %{_libdir}/%{name}/chrome.manifest
 %dir %{_libdir}/%{name}/components
-%{_libdir}/%{name}/components/*.js
-%{_libdir}/%{name}/components/*.xpt
 %{_libdir}/%{name}/components/components.manifest
-%{_libdir}/%{name}/components/interfaces.manifest
 %attr(755,root,root) %{_libdir}/%{name}/*.sh
 %attr(755,root,root) %{_libdir}/%{name}/*-bin
 %attr(755,root,root) %{_libdir}/%{name}/icedove
 %attr(755,root,root) %{_libdir}/%{name}/register
+%{_libdir}/%{name}/omni.ja
 %if %{without xulrunner}
 %{_libdir}/%{name}/dependentlibs.list
 %{_libdir}/%{name}/platform.ini
-%{_libdir}/%{name}/greprefs.js
+#%{_libdir}/%{name}/greprefs.js
 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
-%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
+%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
@@ -508,38 +490,20 @@ exit 0
 %{_libdir}/%{name}/chrome
 %{_libdir}/%{name}/defaults
 %{_libdir}/%{name}/isp
-%{_libdir}/%{name}/modules
+#%{_libdir}/%{name}/modules
 %{_libdir}/%{name}/searchplugins
 %if %{with xulrunner}
 %{_libdir}/%{name}/xulrunner
 %else
 %{_libdir}/%{name}/dictionaries
-%{_libdir}/%{name}/hyphenation
-%{_libdir}/%{name}/res
 %endif
 
 %{_pixmapsdir}/icedove.png
 %{_desktopdir}/icedove.desktop
 
 %dir %{_datadir}/%{name}
-%{_datadir}/%{name}/chrome
-%{_datadir}/%{name}/defaults
 %{_datadir}/%{name}/extensions
-%{_datadir}/%{name}/isp
-%{_datadir}/%{name}/modules
-%if %{with enigmail}
-%exclude %{_datadir}/%{name}/modules/commonFuncs.jsm
-%exclude %{_datadir}/%{name}/modules/enigmailCommon.jsm
-%exclude %{_datadir}/%{name}/modules/keyManagement.jsm
-%exclude %{_datadir}/%{name}/modules/pipeConsole.jsm
-%exclude %{_datadir}/%{name}/modules/subprocess.jsm
-%exclude %{_datadir}/%{name}/modules/subprocess_worker_unix.js
-%exclude %{_datadir}/%{name}/modules/subprocess_worker_win.js
-%endif
 %{_datadir}/%{name}/searchplugins
-%if %{without xulrunner}
-%{_datadir}/%{name}/res
-%endif
 
 %if %{with crashreporter}
 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
@@ -554,6 +518,8 @@ exit 0
 %ghost %{_libdir}/%{name}/components/compreg.dat
 %ghost %{_libdir}/%{name}/components/xpti.dat
 
+%{_iconsdir}/hicolor/*/apps/icedove.*
+
 %if %{with lightning}
 %files addon-lightning
 %defattr(644,root,root,755)
@@ -571,7 +537,6 @@ exit 0
 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
-%{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
 %endif
 
 %if %{with enigmail}
@@ -583,7 +548,6 @@ exit 0
 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
-%attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules
index 74a57b3fe2c0a8be2e82632e6b5dcfc86f3af818..3fe1c4e3cc996b2abe8339cdf2bd039e5e90bbdc 100644 (file)
@@ -1,8 +1,8 @@
 --- mozilla/configure.in.orig  2010-06-23 19:43:07.000000000 +0200
 +++ mozilla/configure.in       2010-07-06 11:14:54.350499449 +0200
-@@ -5032,6 +5032,13 @@
-     MOZ_LDAP_XPCOM=,
-     MOZ_LDAP_XPCOM=1)
+@@ -134,6 +134,13 @@
+   AC_MSG_RESULT([no])
+ fi
  
 +dnl system LDAP Support
 +dnl ========================================================
  dnl ========================================================
  dnl = Trademarked Branding 
  dnl ========================================================
-@@ -7612,7 +7619,7 @@
+--- mozilla/mail/configure.in.orig     2010-06-23 19:43:07.000000000 +0200
++++ mozilla/mail/configure.in  2010-07-06 11:14:54.350499449 +0200
+@@ -59,7 +59,12 @@
+     MOZ_LDAP_XPCOM=,
+     MOZ_LDAP_XPCOM=1)
+-if test "$MOZ_LDAP_XPCOM"; then
++if test "$MOZ_LDAP_DIR" ; then
++    LDAP_CFLAGS=$(pkg-config --cflags mozldap)
++    LDAP_LIBS=$(pkg-config --libs mozldap)
++    LDAP_COMPONENT=mozldap
++    LDAP_MODULE="MODULE(nsLDAPProtocolModule)"
++elif test "$MOZ_LDAP_XPCOM"; then
+     MOZ_ARG_ENABLE_BOOL(incomplete-toolkit-ldap-autocomplete,
+     [  --enable-incomplete-toolkit-ldap-autocomplete Builds a JavaScript component that implements an LDAP autocomplete component using the toolkit interfaces rather than the C++ component using the obsolete XPFE interfaces. ],
+         MOZ_INCOMPLETE_TOOLKIT_LDAP_AUTOCOMPLETE=1,
+@@ -118,7 +130,7 @@
  
- # if we're building the LDAP XPCOM component, we need to build 
- # the c-sdk first.  
+ # if we're building the LDAP XPCOM component, we need to build
+ # the c-sdk first.
 -if test -n "$COMPILE_ENVIRONMENT" -a -n "$MOZ_LDAP_XPCOM"; then
 +if test -n "$COMPILE_ENVIRONMENT" -a -n "$MOZ_LDAP_XPCOM" -a -z "$MOZ_LDAP_DIR"; then
-     # these subdirs may not yet have been created in the build tree.
-     # don't use the "-p" switch to mkdir, since not all platforms have it
-     if test ! -d "directory/c-sdk/ldap"; then
+     # Save configure args so we can restore them after configuring LDAP.
+     _save_ac_configure_args="$ac_configure_args"
+     ac_configure_args="$_SUBDIR_CONFIG_ARGS"
index a69cd1a28f7a10c860756adc5130bced67a80432..a2d150ff8ac26a4d3defa301da506f462b755971 100644 (file)
@@ -1,24 +1,12 @@
-Restore --system-site-packages when system virtualenv gets 1.7 upgrade
-
---- xulrunner-15.0/mozilla/configure.in~       2012-08-29 11:06:34.517985819 +0200
-+++ xulrunner-15.0/mozilla/configure.in        2012-08-29 11:23:47.234616054 +0200
-@@ -9069,7 +9069,7 @@
- AC_MSG_RESULT([Creating Python virtualenv])
- rm -rf _virtualenv
- mkdir -p _virtualenv
--MACOSX_DEPLOYMENT_TARGET= PYTHONDONTWRITEBYTECODE= $PYTHON $_topsrcdir/python/virtualenv/virtualenv.py --system-site-packages ./_virtualenv
-+MACOSX_DEPLOYMENT_TARGET= PYTHONDONTWRITEBYTECODE= /usr/bin/virtualenv ./_virtualenv
- case "$host_os" in
- mingw*)
-     PYTHON=`pwd`/_virtualenv/Scripts/python.exe
---- xulrunner-15.0/mozilla/configure~  2012-08-29 11:25:28.121279162 +0200
-+++ xulrunner-15.0/mozilla/configure   2012-08-29 11:27:27.981274936 +0200
-@@ -25468,7 +25468,7 @@
- echo "$ac_t""Creating Python virtualenv" 1>&6
- rm -rf _virtualenv
- mkdir -p _virtualenv
--MACOSX_DEPLOYMENT_TARGET= PYTHONDONTWRITEBYTECODE= $PYTHON $_topsrcdir/python/virtualenv/virtualenv.py --system-site-packages ./_virtualenv
-+MACOSX_DEPLOYMENT_TARGET= PYTHONDONTWRITEBYTECODE= /usr/bin/virtualenv ./_virtualenv
- case "$host_os" in
- mingw*)
-     PYTHON=`pwd`/_virtualenv/Scripts/python.exe
+--- xulrunner-21.0/mozilla/build/virtualenv/populate_virtualenv.py~    2013-05-11 21:19:23.000000000 +0200
++++ xulrunner-21.0/mozilla/build/virtualenv/populate_virtualenv.py     2013-05-14 22:51:32.136719267 +0200
+@@ -37,8 +37,7 @@
+     @property
+     def virtualenv_script_path(self):
+         """Path to virtualenv's own populator script."""
+-        return os.path.join(self.topsrcdir, 'python', 'virtualenv',
+-            'virtualenv.py')
++        return '/usr/bin/virtualenv'
+     @property
+     def python_path(self):
This page took 0.057393 seconds and 4 git commands to generate.