]> git.pld-linux.org Git - packages/thunderbird.git/commitdiff
add build fix for wayland 1.20 from firefox
authorJan Palus <atler@pld-linux.org>
Sat, 18 Dec 2021 13:37:48 +0000 (14:37 +0100)
committerJan Palus <atler@pld-linux.org>
Sat, 18 Dec 2021 13:37:48 +0000 (14:37 +0100)
thunderbird.spec
wayland-1.20.patch [new file with mode: 0644]

index 8cea6b35661bf6aa19e6bd1d1c009d5835efc1d1..dc0464c34d9bcb2e31c747bfdd8a5bfab08aa10c 100644 (file)
@@ -183,6 +183,7 @@ Patch1:             no-subshell.patch
 Patch2:                enable-addons.patch
 Patch3:                %{name}-system-virtualenv.patch
 Patch4:                glibc-2.34.patch
 Patch2:                enable-addons.patch
 Patch3:                %{name}-system-virtualenv.patch
 Patch4:                glibc-2.34.patch
+Patch5:                wayland-1.20.patch
 URL:           http://www.mozilla.org/projects/thunderbird/
 BuildRequires: alsa-lib-devel
 BuildRequires: autoconf2_13 >= 2.13
 URL:           http://www.mozilla.org/projects/thunderbird/
 BuildRequires: alsa-lib-devel
 BuildRequires: autoconf2_13 >= 2.13
@@ -1352,6 +1353,7 @@ unpack() {
 %patch2 -p0
 %patch3 -p2
 %patch4 -p1
 %patch2 -p0
 %patch3 -p2
 %patch4 -p1
+%patch5 -p1
 
 %build
 cp -p %{_datadir}/automake/config.* build/autoconf
 
 %build
 cp -p %{_datadir}/automake/config.* build/autoconf
diff --git a/wayland-1.20.patch b/wayland-1.20.patch
new file mode 100644 (file)
index 0000000..610c335
--- /dev/null
@@ -0,0 +1,32 @@
+
+# HG changeset patch
+# User Kevin Daudt <kdaudt@alpinelinux.org>
+# Date 1639316328 0
+# Node ID f7e2cf808d303d04b1b92dc825621b2fdba5559b
+# Parent  ce23c0066bacde4cef8dac8e5e8e42df6cac4bff
+Bug 1745560 - Add missing stub for wl_proxy_marshal_flags, r=stransky
+
+Firefox fails to build against wayland 1.20 because this symbol is missing
+
+Differential Revision: https://phabricator.services.mozilla.com/D133583
+
+diff --git a/widget/gtk/mozwayland/mozwayland.c b/widget/gtk/mozwayland/mozwayland.c
+--- a/widget/gtk/mozwayland/mozwayland.c
++++ b/widget/gtk/mozwayland/mozwayland.c
+@@ -195,8 +195,15 @@ MOZ_EXPORT void wl_list_insert(struct wl
+ MOZ_EXPORT void wl_list_remove(struct wl_list* elm) {}
+ MOZ_EXPORT int wl_list_length(const struct wl_list* list) { return -1; }
+ MOZ_EXPORT int wl_list_empty(const struct wl_list* list) { return -1; }
+ MOZ_EXPORT void wl_list_insert_list(struct wl_list* list,
+                                     struct wl_list* other) {}
++
++MOZ_EXPORT struct wl_proxy* wl_proxy_marshal_flags(
++    struct wl_proxy* proxy, uint32_t opcode,
++    const struct wl_interface* interface, uint32_t version, uint32_t flags,
++    ...) {
++  return NULL;
++}
+
This page took 0.041749 seconds and 4 git commands to generate.