]> git.pld-linux.org Git - packages/thunderbird.git/commitdiff
- up to 52.0.1, still crashes
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 20 Apr 2017 07:03:17 +0000 (09:03 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Thu, 20 Apr 2017 07:03:17 +0000 (09:03 +0200)
enable-addons.patch
mozilla-1269171-badalloc.patch [deleted file]
prefs.patch
thunderbird.spec

index 9b18db8a4d06cacbe34e65a2dc54f341f414a4aa..8b4bee817672a09be8165b74273db74a94b13e1e 100644 (file)
@@ -9,22 +9,6 @@
  
  // Preferences for AMO integration
  pref("extensions.getAddons.cache.enabled", true);
---- comm-release/mozilla/toolkit/mozapps/extensions/internal/XPIProvider.jsm.addons    2011-11-21 11:28:32.000000000 +0100
-+++ comm-release/mozilla/toolkit/mozapps/extensions/internal/XPIProvider.jsm   2011-12-14 12:43:42.461184351 +0100
-@@ -2102,11 +2102,9 @@ var XPIProvider = {
-       AddonManagerPrivate.markProviderSafe(this);
--      if (aAppChanged === undefined) {
--        // For new profiles we will never need to show the add-on selection UI
-+        // For all profiles we will never need to show the add-on selection UI
-         Services.prefs.setBoolPref(PREF_SHOWN_SELECTION_UI, true);
--      }
--      else if (aAppChanged && !this.allAppGlobal &&
-+      if (aAppChanged && !this.allAppGlobal &&
-                Preferences.get(PREF_EM_SHOW_MISMATCH_UI, true)) {
-         if (!Preferences.get(PREF_SHOWN_SELECTION_UI, false)) {
-           // Flip a flag to indicate that we interrupted startup with an interactive prompt
 --- comm-release/suite/browser/browser-prefs.js~       2013-11-06 19:54:38.789734061 +0100
 +++ comm-release/suite/browser/browser-prefs.js        2013-11-06 20:55:33.765611935 +0100
 @@ -616,7 +616,7 @@
diff --git a/mozilla-1269171-badalloc.patch b/mozilla-1269171-badalloc.patch
deleted file mode 100644 (file)
index 150a3d7..0000000
+++ /dev/null
@@ -1,212 +0,0 @@
-From: Jens Lody <fedora@jenslody.de>
-Date: Thu, 16 Feb 2017 09:31:56 +0100
-Subject: Backport of fix for mozilla-bug 1269171, needed for gcc7.
-
-diff --git a/mozilla/config/gcc-stl-wrapper.template.h b/mozilla/config/gcc-stl-wrapper.template.h
---- a/mozilla/config/gcc-stl-wrapper.template.h
-+++ b/mozilla/config/gcc-stl-wrapper.template.h
-@@ -17,25 +17,6 @@
- // Silence "warning: #include_next is a GCC extension"
- #pragma GCC system_header
--// mozalloc.h wants <new>; break the cycle by always explicitly
--// including <new> here.  NB: this is a tad sneaky.  Sez the gcc docs:
--//
--//    `#include_next' does not distinguish between <file> and "file"
--//    inclusion, nor does it check that the file you specify has the
--//    same name as the current file. It simply looks for the file
--//    named, starting with the directory in the search path after the
--//    one where the current file was found.
--#include_next <new>
--
--// See if we're in code that can use mozalloc.  NB: this duplicates
--// code in nscore.h because nscore.h pulls in prtypes.h, and chromium
--// can't build with that being included before base/basictypes.h.
--#if !defined(XPCOM_GLUE) && !defined(NS_NO_XPCOM) && !defined(MOZ_NO_MOZALLOC)
--#  include "mozilla/mozalloc.h"
--#else
--#  error "STL code can only be used with infallible ::operator new()"
--#endif
--
- #if defined(DEBUG) && !defined(_GLIBCXX_DEBUG)
- // Enable checked iterators and other goodies
- //
-@@ -46,10 +27,34 @@
- //  # define _GLIBCXX_DEBUG 1
- #endif
-+// Don't include mozalloc for cstdlib. See bug 1245076.
-+#ifndef moz_dont_include_mozalloc_for_cstdlib
-+#  define moz_dont_include_mozalloc_for_cstdlib
-+#endif
-+
-+// Include mozalloc after the STL header and all other headers it includes
-+// have been preprocessed.
-+#if !defined(MOZ_INCLUDE_MOZALLOC_H) && \
-+    !defined(moz_dont_include_mozalloc_for_${HEADER})
-+#  define MOZ_INCLUDE_MOZALLOC_H
-+#  define MOZ_INCLUDE_MOZALLOC_H_FROM_${HEADER}
-+#endif
-+
- #pragma GCC visibility push(default)
- #include_next <${HEADER}>
- #pragma GCC visibility pop
-+#ifdef MOZ_INCLUDE_MOZALLOC_H_FROM_${HEADER}
-+// See if we're in code that can use mozalloc.  NB: this duplicates
-+// code in nscore.h because nscore.h pulls in prtypes.h, and chromium
-+// can't build with that being included before base/basictypes.h.
-+#  if !defined(XPCOM_GLUE) && !defined(NS_NO_XPCOM) && !defined(MOZ_NO_MOZALLOC)
-+#    include "mozilla/mozalloc.h"
-+#  else
-+#    error "STL code can only be used with infallible ::operator new()"
-+#  endif
-+#endif
-+
- // gcc calls a __throw_*() function from bits/functexcept.h when it
- // wants to "throw an exception".  functexcept exists nominally to
- // support -fno-exceptions, but since we'll always use the system
---- a/mozilla/config/make-stl-wrappers.py
-+++ b/mozilla/config/make-stl-wrappers.py
-@@ -25,28 +25,26 @@ def header_path(header, compiler):
- def is_comment(line):
-     return re.match(r'\s*#.*', line)
- def main(outdir, compiler, template_file, header_list_file):
-     if not os.path.isdir(outdir):
-         os.mkdir(outdir)
-     template = open(template_file, 'r').read()
--    path_to_new = header_path('new', compiler)
-     for header in open(header_list_file, 'r'):
-         header = header.rstrip()
-         if 0 == len(header) or is_comment(header):
-             continue
-         path = header_path(header, compiler)
-         with FileAvoidWrite(os.path.join(outdir, header)) as f:
-             f.write(string.Template(template).substitute(HEADER=header,
--                                                         HEADER_PATH=path,
--                                                         NEW_HEADER_PATH=path_to_new))
-+                                                         HEADER_PATH=path))
- if __name__ == '__main__':
-     if 5 != len(sys.argv):
-         print("""Usage:
-   python {0} OUT_DIR ('msvc'|'gcc') TEMPLATE_FILE HEADER_LIST_FILE
- """.format(sys.argv[0]), file=sys.stderr)
-         sys.exit(1)
-diff --git a/mozilla/config/msvc-stl-wrapper.template.h b/mozilla/config/msvc-stl-wrapper.template.h
---- a/mozilla/config/msvc-stl-wrapper.template.h
-+++ b/mozilla/config/msvc-stl-wrapper.template.h
-@@ -3,45 +3,33 @@
-  */
- /* This Source Code Form is subject to the terms of the Mozilla Public
-  * License, v. 2.0. If a copy of the MPL was not distributed with this
-  * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
- #ifndef mozilla_${HEADER}_h
- #define mozilla_${HEADER}_h
--#ifndef MOZ_HAVE_INCLUDED_ALLOC
--#define MOZ_HAVE_INCLUDED_ALLOC
--
- #if _HAS_EXCEPTIONS
- #  error "STL code can only be used with -fno-exceptions"
- #endif
-+// Include mozalloc after the STL header and all other headers it includes
-+// have been preprocessed.
-+#if !defined(MOZ_INCLUDE_MOZALLOC_H)
-+#  define MOZ_INCLUDE_MOZALLOC_H
-+#  define MOZ_INCLUDE_MOZALLOC_H_FROM_${HEADER}
-+#endif
-+
- // Code built with !_HAS_EXCEPTIONS calls std::_Throw(), but the win2k
- // CRT doesn't export std::_Throw().  So we define it.
- #ifndef mozilla_Throw_h
- #  include "mozilla/throw_msvc.h"
- #endif
--// Code might include <new> before other wrapped headers, but <new>
--// includes <exception> and so we want to wrap it.  But mozalloc.h
--// wants <new> also, so we break the cycle by always explicitly
--// including <new> here.
--#include <${NEW_HEADER_PATH}>
--
--// See if we're in code that can use mozalloc.  NB: this duplicates
--// code in nscore.h because nscore.h pulls in prtypes.h, and chromium
--// can't build with that being included before base/basictypes.h.
--#if !defined(XPCOM_GLUE) && !defined(NS_NO_XPCOM) && !defined(MOZ_NO_MOZALLOC)
--#  include "mozilla/mozalloc.h"
--#else
--#  error "STL code can only be used with infallible ::operator new()"
--#endif
--#endif /* MOZ_HAVE_INCLUDED_ALLOC */
--
- #ifdef _DEBUG
- // From
- //   http://msdn.microsoft.com/en-us/library/aa985982%28VS.80%29.aspx
- // and
- //   http://msdn.microsoft.com/en-us/library/aa985965%28VS.80%29.aspx
- // there appear to be two types of STL container checking.  The
- // former is enabled by -D_DEBUG (which is implied by -MDd or -MTd), and
- // looks to be full generation/mutation checked iterators as done by
-@@ -70,9 +58,20 @@
- //        but that's OK because we're not throwing them.
- #pragma warning( push )
- #pragma warning( disable : 4275 4530 )
- #include <${HEADER_PATH}>
- #pragma warning( pop )
-+#ifdef MOZ_INCLUDE_MOZALLOC_H_FROM_${HEADER}
-+// See if we're in code that can use mozalloc.  NB: this duplicates
-+// code in nscore.h because nscore.h pulls in prtypes.h, and chromium
-+// can't build with that being included before base/basictypes.h.
-+#  if !defined(XPCOM_GLUE) && !defined(NS_NO_XPCOM) && !defined(MOZ_NO_MOZALLOC)
-+#    include "mozilla/mozalloc.h"
-+#  else
-+#    error "STL code can only be used with infallible ::operator new()"
-+#  endif
-+#endif
-+
- #endif  // if mozilla_${HEADER}_h
-diff --git a/mozilla/memory/mozalloc/mozalloc.h b/mozilla/memory/mozalloc/mozalloc.h
---- a/mozilla/memory/mozalloc/mozalloc.h
-+++ b/mozilla/memory/mozalloc/mozalloc.h
-@@ -7,20 +7,27 @@
- #ifndef mozilla_mozalloc_h
- #define mozilla_mozalloc_h
- /*
-  * https://bugzilla.mozilla.org/show_bug.cgi?id=427099
-  */
--#include <stdlib.h>
--#include <string.h>
- #if defined(__cplusplus)
- #  include <new>
-+// Since libstdc++ 6, including the C headers (e.g. stdlib.h) instead of the
-+// corresponding C++ header (e.g. cstdlib) can cause confusion in C++ code
-+// using things defined there. Specifically, with stdlib.h, the use of abs()
-+// in gfx/graphite2/src/inc/UtfCodec.h somehow ends up picking the wrong abs()
-+#  include <cstdlib>
-+#  include <cstring>
-+#else
-+#  include <stdlib.h>
-+#  include <string.h>
- #endif
- #if defined(__cplusplus)
- #include "mozilla/fallible.h"
- #include "mozilla/TemplateLib.h"
- #endif
- #include "mozilla/Attributes.h"
- #include "mozilla/Types.h"
-
-
index 61c8a4b390001526ec315e8764c93ec2f32c3e3a..417e1214df20bd21b7e277f1b8e15f3933dc1341 100644 (file)
@@ -1,14 +1,14 @@
 --- mozilla.orig/mail/app/profile/all-thunderbird.js   2008-06-23 14:04:11.000000000 +0200
 +++ mozilla/mail/app/profile/all-thunderbird.js        2008-06-24 13:22:48.000000000 +0200
 @@ -78,7 +78,7 @@
- // This preference turns on app.update.mode and allows automatic download and
- // install to take place. We use a separate boolean toggle for this to make     
- // the UI easier to construct.
+ // If set to true, the Update Service will automatically download updates when
+ // app updates are enabled per the app.update.enabled preference and if the user
+ // can apply updates.
 -pref("app.update.auto", true);
 +pref("app.update.auto", false);
  
- // Defines how the Application Update Service notifies the user about updates:
- //
+ // If set to true, the Update Service will present no UI for any event.
+ pref("app.update.silent", false);
 @@ -373,7 +373,7 @@
  pref("alerts.totalOpenTime", 3000);
  
index 334db1e1a7a221eca6e27466aa5868229ae02017..e285b21bb9f0d6dfd5237a6f53ea0488cab58cea 100644 (file)
@@ -1,8 +1,9 @@
 # TODO:
 # - build with system mozldap
+# - fix startup crash "TypeError: a is null"
 #
 # Conditional builds
-%bcond_with    gtk3            # GTK+ 3.x instead of 2.x
+%bcond_without gtk3            # GTK+ 3.x instead of 2.x
 %bcond_without ldap            # disable e-mail address lookups in LDAP directories
 %bcond_without lightning       # disable Sunbird/Lightning calendar
 %bcond_with    crashreporter   # report crashes to crash-stats.mozilla.com
 Summary:       Thunderbird - email client
 Summary(pl.UTF-8):     Thunderbird - klient poczty
 Name:          thunderbird
-Version:       45.8.0
+Version:       52.0.1
 Release:       0.1
 License:       MPL v2.0
 Group:         X11/Applications/Mail
 Source0:       http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/%{name}-%{version}.source.tar.xz
-# Source0-md5: 4e04b1618273f946f00f8ea547578895
+# Source0-md5: e66a1f513258a515089eed70a7d2a509
 Source1:       %{name}.desktop
 Source2:       %{name}.sh
 Patch0:                prefs.patch
 Patch1:                no-subshell.patch
 Patch2:                enable-addons.patch
-Patch3:                mozilla-1269171-badalloc.patch
-Patch4:                mozilla-1245783.patch
+Patch3:                mozilla-1245783.patch
 URL:           http://www.mozilla.org/projects/thunderbird/
 BuildRequires: GConf2-devel >= 1.2.1
 BuildRequires: alsa-lib-devel
@@ -135,7 +135,6 @@ funkcjonalność kalendarza.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
 
 %build
 cat << EOF > .mozconfig
@@ -147,18 +146,6 @@ export MOZ_DEBUG_SYMBOLS=1
 
 # Options for 'configure' (same as command-line options).
 ac_add_options --prefix=%{_prefix}
-ac_add_options --exec-prefix=%{_exec_prefix}
-ac_add_options --bindir=%{_bindir}
-ac_add_options --sbindir=%{_sbindir}
-ac_add_options --sysconfdir=%{_sysconfdir}
-ac_add_options --datadir=%{_datadir}
-ac_add_options --includedir=%{_includedir}
-ac_add_options --libdir=%{_libdir}
-ac_add_options --libexecdir=%{_libexecdir}
-ac_add_options --localstatedir=%{_localstatedir}
-ac_add_options --sharedstatedir=%{_sharedstatedir}
-ac_add_options --mandir=%{_mandir}
-ac_add_options --infodir=%{_infodir}
 %if %{?debug:1}0
 ac_add_options --disable-optimize
 ac_add_options --enable-debug
@@ -170,9 +157,10 @@ ac_add_options --disable-debug
 ac_add_options --enable-optimize="%{rpmcflags} -Os"
 %endif
 ac_add_options --disable-strip
-ac_add_options --disable-strip-libs
+ac_add_options --disable-install-strip
 %if %{with tests}
 ac_add_options --enable-tests
+ac_add_options --enable-mochitest
 %else
 ac_add_options --disable-tests
 %endif
@@ -189,36 +177,26 @@ ac_add_options --disable-crashreporter
 #ac_add_options --disable-elf-dynstr-gc
 #ac_add_options --disable-elf-hack
 ac_add_options --disable-gnomeui
-ac_add_options --disable-gnomevfs
-ac_add_options --disable-installer
-ac_add_options --disable-javaxpcom
-ac_add_options --disable-profilesharing
 ac_add_options --disable-updater
-ac_add_options --disable-xterm-updates
 ac_add_options --enable-application=mail
-ac_add_options --enable-crypto
 ac_add_options --enable-default-toolkit=%{?with_gtk3:cairo-gtk3}%{!?with_gtk3:cairo-gtk2}
 ac_add_options --enable-gio
 %if %{with ldap}
 ac_add_options --enable-ldap
-ac_add_options --with-system-ldap
 %else
 ac_add_options --disable-ldap
 %endif
-ac_add_options --enable-libxul
-ac_add_options --enable-pango
-ac_add_options --enable-postscript
 %{?with_shared_js:ac_add_options --enable-shared-js}
-ac_add_options --enable-single-profile
 ac_add_options --enable-startup-notification
 ac_add_options --enable-system-cairo
+ac_add_options --enable-system-ffi
 ac_add_options --enable-system-hunspell
 ac_add_options --enable-system-sqlite
+ac_add_options --enable-url-classifier
 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
 ac_add_options --with-distribution-id=org.pld-linux
 ac_add_options --with-pthreads
 ac_add_options --with-system-bz2
-ac_add_options --with-system-ffi
 ac_add_options --with%{!?with_system_icu:out}-system-icu
 ac_add_options --with-system-jpeg
 ac_add_options --with-system-libevent
@@ -227,18 +205,15 @@ ac_add_options --with-system-nspr
 ac_add_options --with-system-nss
 ac_add_options --with-system-png
 ac_add_options --with-system-zlib
+ac_add_options --with-x
 EOF
 
 mkdir -p %{objdir}/config
 ln -sf %{topdir}/mozilla/config/*.mk %{objdir}/config
 
 %{__make} -j1 -f client.mk build \
-       STRIP="/bin/true" \
-       MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
-       installdir=%{_libdir}/%{name} \
-       XLIBS="-lX11 -lXt" \
-       CC="%{__cc}" \
-       CXX="%{__cxx}"
+       AUTOCONF=/usr/bin/autoconf2_13 \
+       MOZ_MAKE_FLAGS="%{_smp_mflags}"
 
 %if %{with crashreporter}
 # create debuginfo for crash-stats.mozilla.com
@@ -332,6 +307,7 @@ rm -rf $HOME
 %endif
 %attr(755,root,root) %{_libdir}/%{name}/liblgpllibs.so
 %{?with_shared_js:%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so}
+%attr(755,root,root) %{_libdir}/%{name}/libmozsandbox.so
 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
 %attr(755,root,root) %{_libdir}/%{name}/*.sh
 %attr(755,root,root) %{_libdir}/%{name}/*-bin
@@ -343,6 +319,10 @@ rm -rf $HOME
 %{_libdir}/%{name}/dependentlibs.list
 %{_libdir}/%{name}/omni.ja
 %{_libdir}/%{name}/platform.ini
+%{!?with_system_icu:%{_libdir}/%{name}/icudt58l.dat}
+
+%dir %{_libdir}/%{name}/fonts
+%{_libdir}/%{name}/fonts/EmojiOneMozilla.ttf
 
 %if %{with crashreporter}
 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
@@ -381,7 +361,6 @@ rm -rf $HOME
 %{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
 %{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
 %dir %{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
-%attr(755,root,root) %{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
 %{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
 %{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*manifest
 %{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
This page took 0.701276 seconds and 4 git commands to generate.