]> git.pld-linux.org Git - packages/thunderbird.git/blobdiff - thunderbird.spec
disable clang and gold by default
[packages/thunderbird.git] / thunderbird.spec
index aac514829812aaafcfd5c56e4fe4fd40ca8cc47e..d0d3da6665aecd587d2b8de7fffb18bc667f16e3 100644 (file)
@@ -4,15 +4,17 @@
 #
 # Conditional builds
 %bcond_with    tests           # enable tests (whatever they check)
-%bcond_without gtk3            # GTK+ 3.x instead of 2.x
 %bcond_without ldap            # disable e-mail address lookups in LDAP directories
 %bcond_without lightning       # disable Sunbird/Lightning calendar
 %bcond_without official        # official Thunderbird branding
 %bcond_with    crashreporter   # report crashes to crash-stats.mozilla.com
+%bcond_with    gold            # use gold instead of default linker
 # - disabled shared_js - https://bugzilla.mozilla.org/show_bug.cgi?id=1039964
 %bcond_with    shared_js       # shared libmozjs library [broken]
-%bcond_with    system_icu      # build with system ICU (disabled due to crashes with system icu 58.2)
-%bcond_without clang           # build using Clang/LLVM
+%bcond_without system_icu      # build without system ICU
+%bcond_with    system_cairo    # build with system cairo (not supported in 60.0)
+%bcond_with    system_libvpx   # build with system libvpx (60.7.0 does not build with libvpx 1.8)
+%bcond_with    clang           # build using Clang/LLVM
 
 # UPDATING TRANSLATIONS:
 %if 0
@@ -23,12 +25,14 @@ U=http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/$V/linux-i686
 curl -s $U | sed -ne 's,.*href="\([^"]\+\)/".*,'"$U"'xpi/\1.xpi,p'
 %endif
 
+%define                _enable_debug_packages  0
+
 %if 0%{?_enable_debug_packages} != 1
 %undefine      crashreporter
 %endif
 
-%define                nspr_ver        4.13.1
-%define                nss_ver         3.28.6
+%define                nspr_ver        4.21
+%define                nss_ver         3.44.1
 
 # The actual sqlite version (see RHBZ#480989):
 %define                sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
@@ -36,157 +40,160 @@ curl -s $U | sed -ne 's,.*href="\([^"]\+\)/".*,'"$U"'xpi/\1.xpi,p'
 Summary:       Thunderbird - email client
 Summary(pl.UTF-8):     Thunderbird - klient poczty
 Name:          thunderbird
-Version:       52.6.0
+Version:       68.0
 Release:       1
 License:       MPL v2.0
 Group:         X11/Applications/Mail
 Source0:       http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/%{name}-%{version}.source.tar.xz
-# Source0-md5: ce4496f157050a711745c44acdd04385
+# Source0-md5: 79fbff6edded2fce28026c617dec805c
 Source1:       %{name}.desktop
 Source2:       %{name}.sh
 Source100:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/ar.xpi
-# Source100-md5:       06600d37da07057129a72a318af256bb
+# Source100-md5:       d5e114116a5e36856f3353f153d7bc61
 Source101:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/ast.xpi
-# Source101-md5:       6508c9a8bb1f8369f82982ad8aec0997
+# Source101-md5:       2b2ac31bfb2e429f64323f35e62baf8f
 Source102:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/be.xpi
-# Source102-md5:       d7120daebd9f539c3b3b93e6dba6d02b
+# Source102-md5:       ddf45714aa4b4f31aa396c3860b2228f
 Source103:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/bg.xpi
-# Source103-md5:       bc86df506dbb11cac5adf5b758bee226
-Source104:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/bn-BD.xpi
-# Source104-md5:       8baefd18101b7f158e35c9d4ce613812
-Source105:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/br.xpi
-# Source105-md5:       314e5c9b642dd92877e2a1120ebba043
-Source106:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/ca.xpi
-# Source106-md5:       737f6b09b06715ea4383b37c2b85d372
-Source107:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/cs.xpi
-# Source107-md5:       f38a3aebca64ae290759552e29fcf7b8
+# Source103-md5:       c20fc99646e5ef9f0c766d86b9da1adb
+Source104:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/br.xpi
+# Source104-md5:       d7ce37e52ea831a4e123f970e4b3d266
+Source105:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/ca.xpi
+# Source105-md5:       c57d00bfcad2db63acd5f04b3aa5394e
+Source106:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/cs.xpi
+# Source106-md5:       60ffd65ac5ccb8289adfb517a1a62dca
+Source107:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/cy.xpi
+# Source107-md5:       b352ccb56b4d8eefe53ca9db54ade441
 Source108:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/da.xpi
-# Source108-md5:       83fb7c791c691c7717595d1ce4a329bd
+# Source108-md5:       b2580d68bc3696c93becb7f580896df1
 Source109:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/de.xpi
-# Source109-md5:       4946aed812494e506a80008cb9b2ceeb
+# Source109-md5:       c6554eb16f9fba7cdcfcedc5d541b6f5
 Source110:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/dsb.xpi
-# Source110-md5:       4d8ca3e62bd4c514198aa7643ce017b6
+# Source110-md5:       4ac6ee426e196b3226368413179a8e6c
 Source111:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/el.xpi
-# Source111-md5:       de6e95d04bb9c65e20d2a16bc4dd923a
+# Source111-md5:       dd31d910010462670a49a946993f5a82
 Source112:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/en-GB.xpi
-# Source112-md5:       02163fef0884ef93ac43f2489f985636
+# Source112-md5:       3ba76b86401665573f7feb53bec585cc
 Source113:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/en-US.xpi
-# Source113-md5:       6dbc1c3ff365e66ffe1a9a9e450c6b22
+# Source113-md5:       afc3399baafd6dd40280146762b7e215
 Source114:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/es-AR.xpi
-# Source114-md5:       8bfd19aa7c6ca9115d3fee4ff81720b7
+# Source114-md5:       24f9ce861b8bede5feb33aab47d84ce4
 Source115:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/es-ES.xpi
-# Source115-md5:       a8dc704f4f45a7f57d8d622b7bf89460
+# Source115-md5:       4eacbc0393b84e2eb3817c0c6ced62b4
 Source116:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/et.xpi
-# Source116-md5:       438de4867285dac14c282c9ccb83adff
+# Source116-md5:       70074fc2361424d42b51e422f8a74ae2
 Source117:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/eu.xpi
-# Source117-md5:       c6bbba94f23d7f9ae41345b5032a9bc1
+# Source117-md5:       303a3c31980e3d2a88787553cdb04280
 Source118:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/fi.xpi
-# Source118-md5:       9ccaa6906ee949d66f4928de3075c64f
+# Source118-md5:       ccddfdfa45aa87421c9e729fe771f510
 Source119:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/fr.xpi
-# Source119-md5:       f149ec6a042e73aafa015dc820e4cffe
+# Source119-md5:       140d6f3befda4f227756304317f3e279
 Source120:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/fy-NL.xpi
-# Source120-md5:       3ccb2c391f92f675a30b8a65ee18f10c
+# Source120-md5:       c656b1c21c64435bfbca05e2c4d462a0
 Source121:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/ga-IE.xpi
-# Source121-md5:       c397b8df59e3edf1b2d86d3c70cf8cd1
+# Source121-md5:       84deed1b3170bc89cf928650da717feb
 Source122:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/gd.xpi
-# Source122-md5:       bc0af2b71bf2dea8fc09c98d2bf56e14
+# Source122-md5:       7321c9f9fcd844ff4954f4e87b303bd7
 Source123:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/gl.xpi
-# Source123-md5:       51aad58dc3be09bc99f39e4827460f7f
+# Source123-md5:       77475473005736d8a4782ffe7303067a
 Source124:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/he.xpi
-# Source124-md5:       48c4f8bfe70f2ead19ac20eeb46d35d0
+# Source124-md5:       65cc42ea29a8decab59a053a4727217e
 Source125:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/hr.xpi
-# Source125-md5:       ce1732a112a3506d6dc74c39870fe1e3
+# Source125-md5:       51f62444887a5e30804ed38b69c7acff
 Source126:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/hsb.xpi
-# Source126-md5:       08f3ce4e5a96de674aa5d9c2b54faef3
+# Source126-md5:       f1370c44368e674977135a79c379c798
 Source127:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/hu.xpi
-# Source127-md5:       1e6c1fb9e304915f34580d0ffa4f80d1
+# Source127-md5:       fe8b2c7631f8dd7a21504eb685ff7531
 Source128:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/hy-AM.xpi
-# Source128-md5:       682dafbc3279e3722b31e9c80b48360d
+# Source128-md5:       2d662e9d1f7e041da00010f156cdf768
 Source129:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/id.xpi
-# Source129-md5:       e7de4a0799cc720404d2ccc1f0290e69
+# Source129-md5:       b13d1286a490e1116ed7980e85d5a099
 Source130:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/is.xpi
-# Source130-md5:       eb39e1d52be63c45fc002bbaecbb7128
+# Source130-md5:       8be73084b5812588158986735f71a3f3
 Source131:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/it.xpi
-# Source131-md5:       425180b824d7c6fa7800b85e6948cc2e
+# Source131-md5:       e8513a35d4d7bbcaabbfd78da24db72a
 Source132:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/ja.xpi
-# Source132-md5:       42a578947f29693737b9216b4bf817fd
+# Source132-md5:       0d64b38da764674fbb18396dc991d332
 Source133:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/kab.xpi
-# Source133-md5:       a99bd5b0d5052787118f6276dcaca3c5
-Source134:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/ko.xpi
-# Source134-md5:       99daf7c39acb128e129fe4b303d3bf73
-Source135:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/lt.xpi
-# Source135-md5:       6eac5a75b06c9c22f86f4dd6cade0ae5
-Source136:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/nb-NO.xpi
-# Source136-md5:       299ca065184306bb39242fa9128873b2
-Source137:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/nl.xpi
-# Source137-md5:       1ef63f5b65d630f1f23d9b574b46f2f7
-Source138:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/nn-NO.xpi
-# Source138-md5:       ff532343ec10b9086c9cc2f520123e73
-Source139:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/pa-IN.xpi
-# Source139-md5:       c3189015eec9aa38ffbbf680551c1f66
-Source140:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/pl.xpi
-# Source140-md5:       43fab613e4a78b4b00d1a9e9ab474ebe
-Source141:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/pt-BR.xpi
-# Source141-md5:       5d91f3580f067149dc3a8c53c46efcdd
-Source142:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/pt-PT.xpi
-# Source142-md5:       0493fc311baeda9ec641e73a1c344b97
-Source143:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/rm.xpi
-# Source143-md5:       0e40317d0af75b43593a6494f322a31a
-Source144:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/ro.xpi
-# Source144-md5:       65df8fc26d3e58845b9cbff7d7c04238
-Source145:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/ru.xpi
-# Source145-md5:       c190305d5c5634f36592c7a4bdf22a36
-Source146:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/si.xpi
-# Source146-md5:       0cda0817450da703005b26286a1d5f32
-Source147:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/sk.xpi
-# Source147-md5:       23e0f6ccfb8890814684211925b353fb
-Source148:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/sl.xpi
-# Source148-md5:       bdba2737ee4167a2ebf4d0fabcae4173
-Source149:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/sq.xpi
-# Source149-md5:       f9c8941cc5097c986982506ebd42d57b
-Source150:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/sr.xpi
-# Source150-md5:       2b03f11fe3f6d46511b4c9a2a10c28cb
-Source151:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/sv-SE.xpi
-# Source151-md5:       78ecda4c5ea0c9c218f2433328d83010
-Source152:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/ta-LK.xpi
-# Source152-md5:       1800200dee917c7fb2edda5a658dcd6e
+# Source133-md5:       b2d1d5dd6a2be6e021f73003da3044a4
+Source134:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/kk.xpi
+# Source134-md5:       962a95cfcb93aa72cc46d37b8d24d853
+Source135:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/ko.xpi
+# Source135-md5:       9da478aee2b85aa1af91d4adde523860
+Source136:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/lt.xpi
+# Source136-md5:       d53cadbd712b26134b333a2c2540c0a3
+Source137:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/ms.xpi
+# Source137-md5:       ec17a19acd79bdf956d3f0df67c8d381
+Source138:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/nb-NO.xpi
+# Source138-md5:       ff43e00a84325083b1eab08744e0c473
+Source139:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/nl.xpi
+# Source139-md5:       a5d721f6b688d57074dd39ef95e2a6cf
+Source140:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/nn-NO.xpi
+# Source140-md5:       acfcb526762615d5cb7570b49b147537
+Source141:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/pl.xpi
+# Source141-md5:       0564c146722bae34ad39efd801eff587
+Source142:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/pt-BR.xpi
+# Source142-md5:       72a8bc3dbda72559437efc12caecb8e8
+Source143:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/pt-PT.xpi
+# Source143-md5:       8f09353c5b9e69f995b6737862979dec
+Source144:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/rm.xpi
+# Source144-md5:       3c7e21574546f6bc11f6cfaac4416893
+Source145:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/ro.xpi
+# Source145-md5:       ee7293b221c8d32d76bae90b87734561
+Source146:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/ru.xpi
+# Source146-md5:       7357452581604895bae66088fa3ef54e
+Source147:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/si.xpi
+# Source147-md5:       5e12bef0bc2a742a22ca6b8babb13fa5
+Source148:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/sk.xpi
+# Source148-md5:       67cdb3d53d79af83a5fa19b8467f67a4
+Source149:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/sl.xpi
+# Source149-md5:       72f988b4997bef2c8aa1a13b3968ba60
+Source150:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/sq.xpi
+# Source150-md5:       fba648aacaf1f623262d2d2ae7b67553
+Source151:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/sr.xpi
+# Source151-md5:       80a3e322da3c9359483347c9469ddd67
+Source152:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/sv-SE.xpi
+# Source152-md5:       ef7617e052a45d2864dd9bebc22c74ad
 Source153:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/tr.xpi
-# Source153-md5:       c1da2eee99dde25ea64015d21d228aa6
+# Source153-md5:       2d239b6eb141d30d6f60b603459a8e6a
 Source154:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/uk.xpi
-# Source154-md5:       134d14867b53d63cbeba61e22d552277
+# Source154-md5:       3c16e9c798c6289855daad0c28568fe0
 Source155:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/vi.xpi
-# Source155-md5:       76c32f2bbc77c154c5ecd0d1e26560d7
+# Source155-md5:       d6552117e8bf0da91d32af77d278da50
 Source156:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/zh-CN.xpi
-# Source156-md5:       be28f993853d7aca1a9bd20966791dda
+# Source156-md5:       b3fde48e00cb3c7a4ce2e59e5afc4fde
 Source157:     http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/linux-i686/xpi/zh-TW.xpi
-# Source157-md5:       c06f71a185c05f409520bb5aa4e1284e
+# Source157-md5:       dadb95754415a28ad5e5a7818e2edb5d
 Patch0:                prefs.patch
 Patch1:                no-subshell.patch
 Patch2:                enable-addons.patch
+Patch3:                format.patch
 URL:           http://www.mozilla.org/projects/thunderbird/
 BuildRequires: alsa-lib-devel
 BuildRequires: autoconf2_13 >= 2.13
+%{?with_gold:BuildRequires:    binutils >= 3:2.20.51.0.7}
 BuildRequires: bzip2-devel
-BuildRequires: cairo-devel >= 1.10
+%{?with_system_cairo:BuildRequires:    cairo-devel >= 1.10.2-5}
+BuildRequires: cargo
 %{?with_clang:BuildRequires:   clang}
+BuildRequires: clang-devel
 BuildRequires: dbus-glib-devel >= 0.60
 BuildRequires: fontconfig-devel >= 2.7.0
 BuildRequires: freetype-devel >= 1:2.1.8
 BuildRequires: glib2-devel >= 1:2.22
-%{!?with_gtk3:BuildRequires:   gtk+2-devel >= 2:2.18.0}
-%{?with_gtk3:BuildRequires:    gtk+3-devel >= 3.4.0}
-BuildRequires: hunspell-devel
+BuildRequires: gtk+3-devel >= 3.4.0
 BuildRequires: libatomic-devel
 BuildRequires: libevent-devel
 BuildRequires: libffi-devel > 3.0.9
-%{?with_system_icu:BuildRequires:      libicu-devel >= 58.1}
+%{?with_system_icu:BuildRequires:      libicu-devel >= 63.1}
 BuildRequires: libiw-devel
 # requires libjpeg-turbo implementing at least libjpeg 6b API
 BuildRequires: libjpeg-devel >= 6b
 BuildRequires: libjpeg-turbo-devel
 BuildRequires: libpng-devel >= 2:1.6.25
 BuildRequires: libstdc++-devel
-BuildRequires: libvpx-devel >= 1.5.0
+%{?with_system_libvpx:BuildRequires:   libvpx-devel >= 1.5.0}
+BuildRequires: llvm-devel
 BuildRequires: mozldap-devel
 BuildRequires: nspr-devel >= 1:%{nspr_ver}
 BuildRequires: nss-devel >= 1:%{nss_ver}
@@ -196,8 +203,10 @@ BuildRequires:     pixman-devel >= 0.19.2
 BuildRequires: pkgconfig
 BuildRequires: python >= 1:2.7
 BuildRequires: python-virtualenv
+BuildRequires: rust >= 1.34.0
+BuildRequires: rust-cbindgen >= 0.8.2
 BuildRequires: sed >= 4.0
-BuildRequires: sqlite3-devel >= 3.17.0
+BuildRequires: sqlite3-devel >= 3.28.0
 BuildRequires: startup-notification-devel >= 0.8
 BuildRequires: virtualenv
 BuildRequires: xorg-lib-libX11-devel
@@ -212,12 +221,12 @@ BuildRequires:    yasm >= 1.0.1
 BuildRequires: zip
 BuildRequires: zlib-devel >= 1.2.3
 Requires(post):        mktemp >= 1.5-18
+%{?with_system_cairo:Requires: cairo >= 1.10.2-5}
 Requires:      dbus-glib >= 0.60
 Requires:      glib2 >= 1:2.22
-%{!?with_gtk3:Requires:        gtk+2 >= 2:2.18.0}
-%{?with_gtk3:Requires: gtk+3 >= 3.4.0}
+Requires:      gtk+3 >= 3.4.0
 Requires:      libpng >= 2:1.6.25
-Requires:      libvpx >= 1.5.0
+%{?with_system_libvpx:Requires:        libvpx >= 1.5.0}
 Requires:      myspell-common
 Requires:      nspr >= 1:%{nspr_ver}
 Requires:      nss >= 1:%{nss_ver}
@@ -382,6 +391,20 @@ Catalan resources for Thunderbird.
 %description lang-ca -l pl.UTF-8
 Katalońskie pliki językowe dla Thunderbirda.
 
+%package lang-cy
+Summary:       Welsh resources for Thunderbird
+Summary(pl.UTF-8):     Walijskie pliki językowe dla Thunderbirda
+Group:         I18n
+Requires:      thunderbird >= %{version}
+Provides:      thunderbird-lang-resources = %{version}
+BuildArch:     noarch
+
+%description lang-cy
+Welsh resources for Thunderbird.
+
+%description lang-cy -l pl.UTF-8
+Walijskie pliki językowe dla Thunderbirda.
+
 %package lang-cs
 Summary:       Czech resources for Thunderbird
 Summary(pl.UTF-8):     Czeskie pliki językowe dla Thunderbirda
@@ -808,6 +831,20 @@ Kabyle resources for Thunderbird.
 %description lang-kab -l pl.UTF-8
 Kabylskie pliki językowe dla Thunderbirda.
 
+%package lang-kk
+Summary:       Kazakh resources for Thunderbird
+Summary(pl.UTF-8):     Kazachskie pliki językowe dla Thunderbirda
+Group:         I18n
+Requires:      thunderbird >= %{version}
+Provides:      thunderbird-lang-resources = %{version}
+BuildArch:     noarch
+
+%description lang-kk
+Kazakh resources for Thunderbird.
+
+%description lang-kk -l pl.UTF-8
+Kazachskie pliki językowe dla Thunderbirda.
+
 %package lang-ko
 Summary:       Korean resources for Thunderbird
 Summary(pl.UTF-8):     Koreańskie pliki językowe dla Thunderbirda
@@ -840,6 +877,20 @@ Lithuanian resources for Thunderbird.
 %description lang-lt -l pl.UTF-8
 Litewskie pliki językowe dla Thunderbirda.
 
+%package lang-ms
+Summary:       Malay resources for Thunderbird
+Summary(pl.UTF-8):     Malajskie pliki językowe dla Thunderbirda
+Group:         I18n
+Requires:      thunderbird >= %{version}
+Provides:      thunderbird-lang-resources = %{version}
+BuildArch:     noarch
+
+%description lang-ms
+Malay resources for Thunderbird.
+
+%description lang-ms -l pl.UTF-8
+Malajskie pliki językowe dla Thunderbirda.
+
 %package lang-nb
 Summary:       Norwegian Bokmaal resources for Thunderbird
 Summary(pl.UTF-8):     Norweskie (bokmaal) pliki językowe dla Thunderbirda
@@ -1202,10 +1253,14 @@ unpack() {
 %setup -q %(seq -f '-a %g' 100 157 | xargs)
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
+%patch2 -p0
+%patch3 -p1
 
 %build
-cat << EOF > .mozconfig
+cp -p %{_datadir}/automake/config.* build/autoconf
+
+cat << 'EOF' > .mozconfig
+. $topsrcdir/browser/config/mozconfig
 mk_add_options MOZ_OBJDIR=%{objdir}
 
 %if %{with clang}
@@ -1215,14 +1270,25 @@ export CXX="clang++"
 export CC="%{__cc}"
 export CXX="%{__cxx}"
 %endif
+%ifarch %{ix86}
+export CFLAGS="%{rpmcflags} -D_FILE_OFFSET_BITS=64 -g0"
+export CXXFLAGS="%{rpmcxxflags} -D_FILE_OFFSET_BITS=64 -g0"
+export MOZ_DEBUG_FLAGS=" "
+export LLVM_USE_SPLIT_DWARF=1
+export LLVM_PARALLEL_LINK_JOBS=1
+export MOZ_LINK_FLAGS="-Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
+export RUSTFLAGS="-Cdebuginfo=0"
+%else
 export CFLAGS="%{rpmcflags} -D_FILE_OFFSET_BITS=64"
 export CXXFLAGS="%{rpmcxxflags} -D_FILE_OFFSET_BITS=64"
+%endif
 
 %if %{with crashreporter}
 export MOZ_DEBUG_SYMBOLS=1
 %endif
 
 # Options for 'configure' (same as command-line options).
+ac_add_options --host=%{_target_platform}
 ac_add_options --prefix=%{_prefix}
 %if %{?debug:1}0
 ac_add_options --disable-optimize
@@ -1232,13 +1298,11 @@ ac_add_options --enable-debugger-info-modules
 ac_add_options --enable-crash-on-assert
 %else
 ac_add_options --disable-debug
-ac_add_options --enable-optimize="%{rpmcflags}"
 %endif
 ac_add_options --disable-strip
 ac_add_options --disable-install-strip
 %if %{with tests}
 ac_add_options --enable-tests
-ac_add_options --enable-mochitest
 %else
 ac_add_options --disable-tests
 %endif
@@ -1252,51 +1316,42 @@ ac_add_options --enable-crashreporter
 %else
 ac_add_options --disable-crashreporter
 %endif
-#ac_add_options --disable-elf-hack
+ac_add_options --disable-elf-hack
 ac_add_options --disable-gconf
-ac_add_options --disable-gnomeui
 ac_add_options --disable-necko-wifi
 ac_add_options --disable-updater
 ac_add_options --enable-alsa
-ac_add_options --enable-application=mail
+ac_add_options --enable-application=comm/mail
 ac_add_options --enable-chrome-format=omni
-ac_add_options --enable-default-toolkit=%{?with_gtk3:cairo-gtk3}%{!?with_gtk3:cairo-gtk2}
-ac_add_options --enable-gio
+ac_add_options --enable-default-toolkit=cairo-gtk3
 %if %{with ldap}
 ac_add_options --enable-ldap
 %else
 ac_add_options --disable-ldap
 %endif
 %{?with_official:ac_add_options --enable-official-branding}
+%{?with_gold:ac_add_options --enable-linker=gold}
 ac_add_options --enable-readline
 %{?with_shared_js:ac_add_options --enable-shared-js}
 ac_add_options --enable-startup-notification
-ac_add_options --enable-system-cairo
+%{?with_system_cairo:ac_add_options --enable-system-cairo}
 ac_add_options --enable-system-ffi
-ac_add_options --enable-system-hunspell
 ac_add_options --enable-system-sqlite
-ac_add_options --enable-url-classifier
-ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
 ac_add_options --with-distribution-id=org.pld-linux
-ac_add_options --with-pthreads
 ac_add_options --with-system-bz2
 ac_add_options --with%{!?with_system_icu:out}-system-icu
 ac_add_options --with-system-jpeg
 ac_add_options --with-system-libevent
-ac_add_options --with-system-libvpx
+ac_add_options --with%{!?with_system_libvpx:out}-system-libvpx
 ac_add_options --with-system-nspr
 ac_add_options --with-system-nss
 ac_add_options --with-system-png
 ac_add_options --with-system-zlib
-ac_add_options --with-x
 EOF
 
-mkdir -p %{objdir}/config
-ln -sf %{topdir}/mozilla/config/*.mk %{objdir}/config
+%{!?with_clang:export MOZ_MAKE_FLAGS="-j1"}
 
-%{__make} -j1 -f client.mk build \
-       AUTOCONF=/usr/bin/autoconf2_13 \
-       MOZ_MAKE_FLAGS="%{_smp_mflags}"
+AUTOCONF=/usr/bin/autoconf2_13 ./mach build
 
 %if %{with crashreporter}
 # create debuginfo for crash-stats.mozilla.com
@@ -1305,10 +1360,10 @@ ln -sf %{topdir}/mozilla/config/*.mk %{objdir}/config
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name}/plugins,%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
+install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name}/{extensions,plugins},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
 
 cd %{objdir}
-%{__make} -C mail/installer stage-package \
+%{__make} -C comm/mail/installer stage-package \
        DESTDIR=$RPM_BUILD_ROOT \
        installdir=%{_libdir}/%{name} \
        PKG_SKIP_STRIP=1
@@ -1328,11 +1383,6 @@ cp -a dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD
 cp -p dist/thunderbird/chrome/icons/default/default48.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
 
-# use system dict
-%{__rm} -rv $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
-ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
-ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
-
 # move arch independant ones to datadir
 %{__mv} $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
 %{__mv} $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
@@ -1367,9 +1417,6 @@ if [ -d %{_libdir}/%{name}/extensions ] && [ ! -L %{_libdir}/%{name}/extensions
        fi
        mv -v %{_libdir}/%{name}/extensions %{_datadir}/%{name}/extensions
 fi
-if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
-       mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
-fi
 for d in chrome defaults icons isp modules res; do
        if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
                install -d %{_datadir}/%{name}
@@ -1398,29 +1445,33 @@ rm -rf $HOME
 %dir %{_libdir}/%{name}
 %dir %{_libdir}/%{name}/plugins
 
-%if %{with gtk3}
 %dir %{_libdir}/%{name}/gtk2
 %attr(755,root,root) %{_libdir}/%{name}/gtk2/libmozgtk.so
 %attr(755,root,root) %{_libdir}/%{name}/libmozgtk.so
-%endif
 %attr(755,root,root) %{_libdir}/%{name}/liblgpllibs.so
 %{?with_shared_js:%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so}
 %attr(755,root,root) %{_libdir}/%{name}/libmozsandbox.so
+%attr(755,root,root) %{_libdir}/%{name}/libmozwayland.so
 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
-%attr(755,root,root) %{_libdir}/%{name}/*.sh
 %attr(755,root,root) %{_libdir}/%{name}/*-bin
+%attr(755,root,root) %{_libdir}/%{name}/pingsender
 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
+%attr(755,root,root) %{_libdir}/%{name}/precomplete
 %attr(755,root,root) %{_libdir}/%{name}/thunderbird
 
 %{_libdir}/%{name}/application.ini
 %{_libdir}/%{name}/blocklist.xml
+%{_libdir}/%{name}/chrome.manifest
 %{_libdir}/%{name}/dependentlibs.list
 %{_libdir}/%{name}/omni.ja
 %{_libdir}/%{name}/platform.ini
 %{!?with_system_icu:%{_libdir}/%{name}/icudt58l.dat}
 
+%dir %{_libdir}/%{name}/features
+%{_libdir}/%{name}/features/wetransfer@extensions.thunderbird.net.xpi
+
 %dir %{_libdir}/%{name}/fonts
-%{_libdir}/%{name}/fonts/EmojiOneMozilla.ttf
+%{_libdir}/%{name}/fonts/TwemojiMozilla.ttf
 
 %if %{with crashreporter}
 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
@@ -1434,9 +1485,7 @@ rm -rf $HOME
 # symlinks
 %{_libdir}/%{name}/chrome
 %{_libdir}/%{name}/defaults
-%{_libdir}/%{name}/dictionaries
 %{_libdir}/%{name}/extensions
-%{_libdir}/%{name}/hyphenation
 %{_libdir}/%{name}/isp
 
 %{_pixmapsdir}/*.png
@@ -1447,26 +1496,10 @@ rm -rf $HOME
 %{_datadir}/%{name}/defaults
 %{_datadir}/%{name}/isp
 
-%dir %{_datadir}/%{name}/extensions
-%{_datadir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}.xpi
-
 %if %{with lightning}
 %files addon-lightning
 %defattr(644,root,root,755)
-%dir %{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
-%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/app.ini
-%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.jar
-%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
-%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
-%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
-%dir %{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
-%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
-%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*manifest
-%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
-%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
-%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
-%dir %{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones
-%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones/zones.json
+%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}.xpi
 %endif
 
 %files lang-ar
@@ -1485,10 +1518,6 @@ rm -rf $HOME
 %defattr(644,root,root,755)
 %{_datadir}/%{name}/extensions/langpack-bg@thunderbird.mozilla.org.xpi
 
-%files lang-bn
-%defattr(644,root,root,755)
-%{_datadir}/%{name}/extensions/langpack-bn-BD@thunderbird.mozilla.org.xpi
-
 %files lang-br
 %defattr(644,root,root,755)
 %{_datadir}/%{name}/extensions/langpack-br@thunderbird.mozilla.org.xpi
@@ -1501,6 +1530,10 @@ rm -rf $HOME
 %defattr(644,root,root,755)
 %{_datadir}/%{name}/extensions/langpack-cs@thunderbird.mozilla.org.xpi
 
+%files lang-cy
+%defattr(644,root,root,755)
+%{_datadir}/%{name}/extensions/langpack-cy@thunderbird.mozilla.org.xpi
+
 %files lang-da
 %defattr(644,root,root,755)
 %{_datadir}/%{name}/extensions/langpack-da@thunderbird.mozilla.org.xpi
@@ -1605,6 +1638,10 @@ rm -rf $HOME
 %defattr(644,root,root,755)
 %{_datadir}/%{name}/extensions/langpack-kab@thunderbird.mozilla.org.xpi
 
+%files lang-kk
+%defattr(644,root,root,755)
+%{_datadir}/%{name}/extensions/langpack-kk@thunderbird.mozilla.org.xpi
+
 %files lang-ko
 %defattr(644,root,root,755)
 %{_datadir}/%{name}/extensions/langpack-ko@thunderbird.mozilla.org.xpi
@@ -1613,6 +1650,10 @@ rm -rf $HOME
 %defattr(644,root,root,755)
 %{_datadir}/%{name}/extensions/langpack-lt@thunderbird.mozilla.org.xpi
 
+%files lang-ms
+%defattr(644,root,root,755)
+%{_datadir}/%{name}/extensions/langpack-ms@thunderbird.mozilla.org.xpi
+
 %files lang-nb
 %defattr(644,root,root,755)
 %{_datadir}/%{name}/extensions/langpack-nb-NO@thunderbird.mozilla.org.xpi
@@ -1625,10 +1666,6 @@ rm -rf $HOME
 %defattr(644,root,root,755)
 %{_datadir}/%{name}/extensions/langpack-nn-NO@thunderbird.mozilla.org.xpi
 
-%files lang-pa
-%defattr(644,root,root,755)
-%{_datadir}/%{name}/extensions/langpack-pa-IN@thunderbird.mozilla.org.xpi
-
 %files lang-pl
 %defattr(644,root,root,755)
 %{_datadir}/%{name}/extensions/langpack-pl@thunderbird.mozilla.org.xpi
@@ -1677,10 +1714,6 @@ rm -rf $HOME
 %defattr(644,root,root,755)
 %{_datadir}/%{name}/extensions/langpack-sv-SE@thunderbird.mozilla.org.xpi
 
-%files lang-ta_LK
-%defattr(644,root,root,755)
-%{_datadir}/%{name}/extensions/langpack-ta-LK@thunderbird.mozilla.org.xpi
-
 %files lang-tr
 %defattr(644,root,root,755)
 %{_datadir}/%{name}/extensions/langpack-tr@thunderbird.mozilla.org.xpi
This page took 0.0825 seconds and 4 git commands to generate.