]> git.pld-linux.org Git - packages/thunderbird.git/blobdiff - thunderbird.spec
disable clang and gold by default
[packages/thunderbird.git] / thunderbird.spec
index 339c4f2ed1398880b52737fb39f813bf9715aadd..d0d3da6665aecd587d2b8de7fffb18bc667f16e3 100644 (file)
@@ -8,13 +8,13 @@
 %bcond_without lightning       # disable Sunbird/Lightning calendar
 %bcond_without official        # official Thunderbird branding
 %bcond_with    crashreporter   # report crashes to crash-stats.mozilla.com
-%bcond_without gold            # use default linker instead of gold
+%bcond_with    gold            # use gold instead of default linker
 # - disabled shared_js - https://bugzilla.mozilla.org/show_bug.cgi?id=1039964
 %bcond_with    shared_js       # shared libmozjs library [broken]
 %bcond_without system_icu      # build without system ICU
 %bcond_with    system_cairo    # build with system cairo (not supported in 60.0)
 %bcond_with    system_libvpx   # build with system libvpx (60.7.0 does not build with libvpx 1.8)
-%bcond_without clang           # build using Clang/LLVM
+%bcond_with    clang           # build using Clang/LLVM
 
 # UPDATING TRANSLATIONS:
 %if 0
@@ -25,6 +25,8 @@ U=http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/$V/linux-i686
 curl -s $U | sed -ne 's,.*href="\([^"]\+\)/".*,'"$U"'xpi/\1.xpi,p'
 %endif
 
+%define                _enable_debug_packages  0
+
 %if 0%{?_enable_debug_packages} != 1
 %undefine      crashreporter
 %endif
@@ -165,6 +167,7 @@ Source157:  http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{ve
 Patch0:                prefs.patch
 Patch1:                no-subshell.patch
 Patch2:                enable-addons.patch
+Patch3:                format.patch
 URL:           http://www.mozilla.org/projects/thunderbird/
 BuildRequires: alsa-lib-devel
 BuildRequires: autoconf2_13 >= 2.13
@@ -1251,6 +1254,7 @@ unpack() {
 %patch0 -p1
 %patch1 -p1
 %patch2 -p0
+%patch3 -p1
 
 %build
 cp -p %{_datadir}/automake/config.* build/autoconf
@@ -1266,8 +1270,18 @@ export CXX="clang++"
 export CC="%{__cc}"
 export CXX="%{__cxx}"
 %endif
+%ifarch %{ix86}
+export CFLAGS="%{rpmcflags} -D_FILE_OFFSET_BITS=64 -g0"
+export CXXFLAGS="%{rpmcxxflags} -D_FILE_OFFSET_BITS=64 -g0"
+export MOZ_DEBUG_FLAGS=" "
+export LLVM_USE_SPLIT_DWARF=1
+export LLVM_PARALLEL_LINK_JOBS=1
+export MOZ_LINK_FLAGS="-Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
+export RUSTFLAGS="-Cdebuginfo=0"
+%else
 export CFLAGS="%{rpmcflags} -D_FILE_OFFSET_BITS=64"
 export CXXFLAGS="%{rpmcxxflags} -D_FILE_OFFSET_BITS=64"
+%endif
 
 %if %{with crashreporter}
 export MOZ_DEBUG_SYMBOLS=1
@@ -1302,7 +1316,7 @@ ac_add_options --enable-crashreporter
 %else
 ac_add_options --disable-crashreporter
 %endif
-#ac_add_options --disable-elf-hack
+ac_add_options --disable-elf-hack
 ac_add_options --disable-gconf
 ac_add_options --disable-necko-wifi
 ac_add_options --disable-updater
@@ -1335,7 +1349,7 @@ ac_add_options --with-system-png
 ac_add_options --with-system-zlib
 EOF
 
-export MOZ_MAKE_FLAGS="-j1"
+%{!?with_clang:export MOZ_MAKE_FLAGS="-j1"}
 
 AUTOCONF=/usr/bin/autoconf2_13 ./mach build
 
This page took 0.058551 seconds and 4 git commands to generate.