]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- added R: gnupg to -addons-enigmail
[packages/thunderbird.git] / icedove.spec
1 #
2 # TODO:
3 # - CHECK all features of enigmail
4 # - separate spec for enigmail
5 # - update or remove -myspell.patch
6 # - package unpackaged files
7 # - update branding patch!!!
8 #
9 # Conditional builds
10 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
11 %bcond_without  gnomeui         # disable gnomeui support
12 %bcond_without  gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
13 %bcond_without  gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
14 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
15 #
16 %if %{without gnome}
17 %undefine       with_gnomeui
18 %undefine       with_gnomevfs
19 %endif
20 %define         enigmail_ver            1.0.0
21
22 Summary:        Icedove - email client
23 Summary(pl.UTF-8):      Icedove - klient poczty
24 Name:           icedove
25 Version:        3.0
26 Release:        0.2
27 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
28 Group:          Applications/Networking
29 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
30 # Source0-md5:  9a564ac2489b1b0f9348dc298b913f6c
31 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
32 # Source1-md5:  e3a6d379f1a72ac023751bdde2de750a
33 Source2:        %{name}-branding.tar.bz2
34 # Source2-md5:  e775b8cb658de32f30b403bc9b7950bf
35 Source3:        %{name}-rm_nonfree.sh
36 Source4:        %{name}.desktop
37 Source5:        %{name}.sh
38 Source6:        %{name}-enigmail.manifest
39 Patch0:         %{name}-branding.patch
40 Patch1:         %{name}-enigmail-shared.patch
41 Patch2:         %{name}-gcc.patch
42 Patch3:         %{name}-fonts.patch
43 Patch4:         %{name}-install.patch
44 Patch5:         %{name}-myspell.patch
45 Patch6:         %{name}-prefs.patch
46 Patch7:         %{name}-breakpad.patch
47 URL:            http://www.pld-linux.org/Packages/Icedove
48 %{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
49 BuildRequires:  automake
50 BuildRequires:  freetype-devel >= 1:2.1.8
51 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
52 BuildRequires:  gtk+2-devel >= 1:2.0.0
53 BuildRequires:  libIDL-devel >= 0.8.0
54 %{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
55 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
56 BuildRequires:  libjpeg-devel >= 6b
57 BuildRequires:  libpng-devel >= 1.2.0
58 BuildRequires:  libstdc++-devel
59 BuildRequires:  myspell-devel
60 BuildRequires:  nspr-devel >= 1:4.8
61 BuildRequires:  nss-devel >= 1:3.12.0
62 BuildRequires:  pango-devel >= 1:1.1.0
63 BuildRequires:  sed >= 4.0
64 BuildRequires:  xorg-lib-libXext-devel
65 BuildRequires:  xorg-lib-libXft-devel >= 2.1
66 BuildRequires:  xorg-lib-libXinerama-devel
67 BuildRequires:  xorg-lib-libXp-devel
68 BuildRequires:  xorg-lib-libXt-devel
69 Requires:       myspell-common
70 Requires:       nspr >= 1:4.6.1
71 Requires:       nss >= 1:3.11.3
72 Obsoletes:      mozilla-thunderbird
73 Obsoletes:      mozilla-thunderbird-dictionary-en-US
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
77
78 # iceweasel/icedove/iceape provide their own versions
79 %define         _noautoreqdep           libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so libxpistub.so
80 %define         _noautoprovfiles        %{_libdir}/%{name}/components
81 # we don't want these to satisfy xulrunner-devel
82 %define         _noautoprov             libgtkembedmoz.so libldap50.so libmozjs.so libprldap50.so libssldap50.so libxpcom.so libxul.so
83 # and as we don't provide them, don't require either
84 %define         _noautoreq              libgtkembedmoz.so libldap50.so libmozjs.so libprldap50.so libssldap50.so libxpcom.so libxul.so
85
86 %description
87 Icedove is an open-source,fast and portable email client.
88
89 %description -l pl.UTF-8
90 Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
91
92 %package addon-enigmail
93 Summary:        Extension for the authentication and encryption features provided by GnuPG
94 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
95 License:        MPL/LGPL
96 Group:          Applications/Networking
97 URL:            http://enigmail.mozdev.org/
98 Requires:       %{name} = %{version}-%{release}
99 Requires:   gnupg
100 Obsoletes:      mozilla-thunderbird-addon-enigmail
101
102 %description addon-enigmail
103 Enigmail is an extension to the Icedove mail client which allows users
104 to access the authentication and encryption features provided by
105 GnuPG.
106
107 Main Features:
108 - Encrypt/sign mail when sending, decrypt/authenticate received mail
109 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
110 - Per-Account based encryption and signing defaults
111 - Per-Recipient rules for automated key selection, and
112   enabling/disabling encryption and signing
113 - OpenPGP key management interface
114
115 %description addon-enigmail -l pl.UTF-8
116 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
117 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
118 przez GnuPG.
119
120 Główne możliwości:
121 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
122   odszyfrowywanie/uwierzytelnianie poczty odebranej
123 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
124 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
125 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
126   podpisywania dla każdego adresata
127 - interfejs do zarządzania kluczami OpenPGP
128
129 %prep
130 %setup -q -c -a2
131 cd comm-1.9.1
132 %{?with_enigmail:tar xvfz %{SOURCE1} -C mailnews/extensions}
133 /bin/sh %{SOURCE3}
134 %patch0 -p1
135 %{?with_enigmail:%patch1 -p1}
136 %patch2 -p1
137 %patch3 -p1
138 %patch4 -p1
139 #%patch5 -p1
140 %patch6 -p0
141 %patch7 -p1
142
143 %build
144 cd comm-1.9.1
145 export CFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
146 export CXXFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
147
148 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
149 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
150 cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
151
152 cat << 'EOF' > .mozconfig
153 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
154
155 # Options for 'configure' (same as command-line options).
156 ac_add_options --prefix=%{_prefix}
157 ac_add_options --exec-prefix=%{_exec_prefix}
158 ac_add_options --bindir=%{_bindir}
159 ac_add_options --sbindir=%{_sbindir}
160 ac_add_options --sysconfdir=%{_sysconfdir}
161 ac_add_options --datadir=%{_datadir}
162 ac_add_options --includedir=%{_includedir}
163 ac_add_options --libdir=%{_libdir}
164 ac_add_options --libexecdir=%{_libexecdir}
165 ac_add_options --localstatedir=%{_localstatedir}
166 ac_add_options --sharedstatedir=%{_sharedstatedir}
167 ac_add_options --mandir=%{_mandir}
168 ac_add_options --infodir=%{_infodir}
169 %if %{?debug:1}0
170 ac_add_options --disable-optimize
171 ac_add_options --enable-debug
172 ac_add_options --enable-debug-modules
173 ac_add_options --enable-debugger-info-modules
174 ac_add_options --enable-crash-on-assert
175 %else
176 ac_add_options --disable-debug
177 ac_add_options --disable-debug-modules
178 ac_add_options --disable-logging
179 ac_add_options --enable-optimize="%{rpmcflags} -Os"
180 %endif
181 %if %{with tests}
182 ac_add_options --enable-tests
183 %else
184 ac_add_options --disable-tests
185 %endif
186 %if %{with gnomeui}
187 ac_add_options --enable-gnomeui
188 %else
189 ac_add_options --disable-gnomeui
190 %endif
191 %if %{with gnomevfs}
192 ac_add_options --enable-gnomevfs
193 %else
194 ac_add_options --disable-gnomevfs
195 %endif
196 %if %{with ldap}
197 ac_add_options --enable-ldap
198 %else
199 ac_add_options --disable-ldap
200 %endif
201 ac_add_options --disable-crashreporter
202 ac_add_options --disable-updater
203 ac_add_options --disable-xterm-updates
204 ac_add_options --enable-ldap
205 ac_add_options --enable-postscript
206 ac_add_options --enable-startup-notification
207 ac_add_options --enable-calendar
208 ac_add_options --disable-installer
209 ac_add_options --disable-jsd
210 ac_add_options --disable-xprint
211 ac_add_options --disable-permissions
212 ac_add_options --disable-pref-extensions
213 ac_add_options --enable-canvas
214 ac_add_options --enable-crypto
215 ac_add_options --enable-default-toolkit="gtk2"
216 ac_add_options --enable-mathml
217 ac_add_options --enable-optimize="%{rpmcflags}"
218 ac_add_options --enable-pango
219 ac_add_options --enable-reorder
220 ac_add_options --enable-static
221 ac_add_options --disable-strip
222 ac_add_options --disable-strip-libs
223 ac_add_options --enable-system-cairo
224 ac_add_options --enable-system-myspell
225 ac_add_options --enable-svg
226 ac_add_options --enable-xft
227 ac_add_options --enable-application=mail
228 ac_add_options --enable-default-toolkit=cairo-gtk2
229 ac_add_options --enable-xinerama
230 ac_add_options --with-system-jpeg
231 ac_add_options --with-system-nspr
232 ac_add_options --with-system-nss
233 ac_add_options --with-system-png
234 ac_add_options --with-system-zlib
235 ac_add_options --with-pthreads
236 ac_add_options --enable-single-profile
237 ac_add_options --disable-profilesharing
238 ac_add_options --with-distribution-id=org.pld-linux
239 #ac_add_options --with-branding=icedove/branding
240 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
241 EOF
242
243 %{__make} -j1 -f client.mk build \
244     STRIP="/bin/true" \
245     CC="%{__cc}" \
246         CXX="%{__cxx}"
247
248 %if %{with enigmail}
249 cd mailnews/extensions/enigmail
250 ./makemake -r 
251 %{__make} -C ../../../obj-%{_target_cpu}/mailnews/extensions/enigmail \
252     STRIP="/bin/true" \
253     CC="%{__cc}" \
254     CXX="%{__cxx}"
255 %endif
256
257 %install
258 rm -rf $RPM_BUILD_ROOT
259 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_pixmapsdir},%{_desktopdir}} \
260                $RPM_BUILD_ROOT%{_datadir}/%{name}
261 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}
262
263 cd comm-1.9.1
264 %{__make} -C obj-%{_target_cpu}/mail/installer stage-package \
265         DESTDIR=$RPM_BUILD_ROOT \
266         MOZ_PKG_APPDIR=%{_libdir}/%{name} \
267         PKG_SKIP_STRIP=1
268
269 # move arch independant ones to datadir
270 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
271 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
272 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
273 #mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
274 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
275 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
276 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
277 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
278 ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
279 #ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
280 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
281 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
282
283 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
284 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
285
286 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
287 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
288 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
289
290 install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
291
292 %if %{with enigmail}
293 _enig_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
294 install -d $_enig_dir/chrome
295 install -d $_enig_dir/components
296 install -d $_enig_dir/defaults/preferences
297 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail.jar $_enig_dir/chrome
298 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/enig* $_enig_dir/components
299 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/libenigmime.so $_enig_dir/components
300 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/ipc.xpt $_enig_dir/components
301 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults/preferences/enigmail.js $_enig_dir/defaults/preferences
302 cp -f mailnews/extensions/enigmail/package/install.rdf $_enig_dir
303 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults/preferences
304 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-en-US.jar
305 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-skin.jar
306 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmime.jar
307 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/components/enig*
308 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/libenigmime.so
309 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/ipc.xpt
310 cp -f %{SOURCE6} $_enig_dir/chrome.manifest
311 #cp -f icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/icedove.png
312 %endif
313
314 # win32 stuff
315 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/dirver
316
317 %clean
318 rm -rf $RPM_BUILD_ROOT
319
320 %pretrans
321 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
322         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
323 fi
324 for d in chrome defaults greprefs icons isp res; do
325         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
326                 install -d %{_datadir}/%{name}
327                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
328         fi
329 done
330 exit 0
331
332 %files
333 %defattr(644,root,root,755)
334 %attr(755,root,root) %{_bindir}/icedove
335 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
336 %attr(755,root,root) %{_bindir}/thunderbird
337 %dir %{_libdir}/%{name}
338 %{_libdir}/%{name}/*.ini
339 %dir %{_libdir}/%{name}/components
340 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
341 %{_libdir}/%{name}/components/*.js
342 %{_libdir}/%{name}/components/*.xpt
343 %attr(755,root,root) %{_libdir}/%{name}/*.so
344 %attr(755,root,root) %{_libdir}/%{name}/*.sh
345 %attr(755,root,root) %{_libdir}/%{name}/*-bin
346 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
347 #%attr(755,root,root) %{_libdir}/%{name}/reg*
348 %attr(755,root,root) %{_libdir}/%{name}/icedove
349 %{_libdir}/%{name}/*.txt
350 #%attr(755,root,root) %{_libdir}/%{name}/x*
351
352 # symlinks
353 %{_libdir}/%{name}/chrome
354 %{_libdir}/%{name}/defaults
355 %{_libdir}/%{name}/dictionaries
356 %{_libdir}/%{name}/greprefs
357 #%{_libdir}/%{name}/icons
358 %{_libdir}/%{name}/isp
359 %{_libdir}/%{name}/res
360
361 %{_libdir}/%{name}/dependentlibs.list
362 #%{_libdir}/%{name}/updater
363 #%{_libdir}/%{name}/update.locale
364 #%{_pixmapsdir}/*.png
365 %{_desktopdir}/*.desktop
366
367 %dir %{_datadir}/%{name}
368 %{_datadir}/%{name}/chrome
369 %{_datadir}/%{name}/defaults
370 %{_datadir}/%{name}/greprefs
371 #%{_datadir}/%{name}/icons
372 %{_datadir}/%{name}/isp
373 %{_datadir}/%{name}/res
374
375 %dir %{_libdir}/%{name}/modules
376 %{_libdir}/%{name}/modules/*.js*
377 %dir %{_libdir}/%{name}/modules/activity
378 %{_libdir}/%{name}/modules/activity/*.js
379 %dir %{_libdir}/%{name}/modules/gloda
380 %{_libdir}/%{name}/modules/gloda/*.js
381
382 %dir %{_libdir}/%{name}/extensions
383 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
384
385 %if %{with enigmail}
386 %files addon-enigmail
387 %defattr(644,root,root,755)
388 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
389 %endif
This page took 0.076394 seconds and 4 git commands to generate.