]> git.pld-linux.org Git - packages/thunderbird.git/blob - icedove.spec
- avoid subdirs
[packages/thunderbird.git] / icedove.spec
1 # TODO:
2 # - separate spec for enigmail
3 # - fix icedove (building) and installing nss/nspr libs!
4 # - build with system mozldap
5 #
6 # Conditional builds
7 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
8 %bcond_without  gnomeui         # disable gnomeui support
9 %bcond_without  gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
10 %bcond_without  gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
11 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
12 %bcond_without  lightning       # disable sunbird calendar
13 %bcond_with             xulrunner       # build with xulrunner
14 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
15
16 %if %{without gnome}
17 %undefine       with_gnomeui
18 %undefine       with_gnomevfs
19 %endif
20
21 %if %{?_enable_debug_packages} != 1
22 %undefine       crashreporter
23 %endif
24
25 %define         enigmail_ver            1.1.2
26
27 %if %{without xulrunner}
28 # The actual sqlite version (see RHBZ#480989):
29 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
30 %endif
31
32 Summary:        Icedove - email client
33 Summary(pl.UTF-8):      Icedove - klient poczty
34 Name:           icedove
35 Version:        3.1.3
36 Release:        1
37 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
38 Group:          X11/Applications/Networking
39 Source0:        http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
40 # Source0-md5:  46332e1d9a658f6e31797035107b1a8d
41 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
42 # Source1-md5:  7d329d5e8afbbb28214ca1995beb09c9
43 Source2:        %{name}-branding.tar.bz2
44 # Source2-md5:  85fdf877e2f1bc41329d8086ef5cf0f1
45 Source3:        %{name}-rm_nonfree.sh
46 Source4:        %{name}.desktop
47 Source5:        %{name}.sh
48 Patch0:         %{name}-branding.patch
49 Patch1:         %{name}-enigmail-shared.patch
50 Patch2:         %{name}-gcc.patch
51 Patch3:         %{name}-fonts.patch
52 Patch4:         %{name}-install.patch
53 Patch5:         %{name}-hunspell.patch
54 Patch6:         %{name}-prefs.patch
55 Patch7:         system-mozldap.patch
56 Patch8:         %{name}-makefile.patch
57 Patch9:         %{name}-libpng.patch
58 Patch10:        %{name}-extensiondir.patch
59 Patch11:        crashreporter.patch
60 Patch12:        no-subshell.patch
61 URL:            http://www.pld-linux.org/Packages/Icedove
62 %{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
63 BuildRequires:  alsa-lib-devel
64 BuildRequires:  automake
65 BuildRequires:  bzip2-devel
66 BuildRequires:  freetype-devel >= 1:2.1.8
67 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
68 BuildRequires:  gtk+2-devel >= 1:2.0.0
69 BuildRequires:  hunspell-devel
70 BuildRequires:  libIDL-devel >= 0.8.0
71 %{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
72 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
73 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
74 BuildRequires:  libiw-devel
75 BuildRequires:  libjpeg-devel >= 6b
76 BuildRequires:  libnotify-devel >= 0.4
77 BuildRequires:  libpng-devel >= 1.2.0
78 BuildRequires:  libstdc++-devel
79 BuildRequires:  nspr-devel >= 1:4.8
80 BuildRequires:  nss-devel >= 1:3.12.0
81 BuildRequires:  pango-devel >= 1:1.1.0
82 BuildRequires:  pkgconfig
83 BuildRequires:  sed >= 4.0
84 BuildRequires:  sqlite3-devel >= 3.7.2-2
85 BuildRequires:  startup-notification-devel >= 0.8
86 BuildRequires:  xorg-lib-libXext-devel
87 BuildRequires:  xorg-lib-libXinerama-devel
88 BuildRequires:  xorg-lib-libXt-devel
89 BuildRequires:  zip
90 %if %{with xulrunner}
91 %else
92 Requires:       myspell-common
93 Requires:       nspr >= 1:4.6.1
94 Requires:       nss >= 1:3.11.3
95 Requires:       sqlite3 >= %{sqlite_build_version}
96 %endif
97 Obsoletes:      mozilla-thunderbird
98 Obsoletes:      mozilla-thunderbird-dictionary-en-US
99 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
101 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
102
103 # iceweasel/icedove/iceape provide their own versions
104 %define         _noautoreqdep           libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
105 %define         _noautoprovfiles        %{_libdir}/%{name}/components
106 # we don't want these to satisfy xulrunner-devel
107 %define         _noautoprov             libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
108 # and as we don't provide them, don't require either
109 %define         _noautoreq              libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
110
111 %define         topdir          %{_builddir}/%{name}-%{version}
112 %define         objdir          %{topdir}/obj-%{_target_cpu}
113
114 %description
115 Icedove is an open-source,fast and portable email client.
116
117 %description -l pl.UTF-8
118 Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
119
120 %package addon-lightning
121 Summary:        An integrated calendar for Icedove
122 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Icedove
123 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
124 Group:          Applications/Networking
125 Requires:       %{name} = %{version}-%{release}
126
127 %description addon-lightning
128 Lightning is an calendar extension to Icedove email client.
129
130 %description addon-lightning -l pl.UTF-8
131 Lightning to rozszerzenie do klienta poczty Icedove dodające
132 funkcjonalność kalendarza.
133
134 %package addon-enigmail
135 Summary:        Extension for the authentication and encryption features provided by GnuPG
136 Summary(pl.UTF-8):      Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
137 License:        MPL/LGPL
138 Group:          Applications/Networking
139 URL:            http://enigmail.mozdev.org/
140 Requires:       %{name} = %{version}-%{release}
141 Requires:       gnupg
142 Obsoletes:      mozilla-thunderbird-addon-enigmail
143
144 %description addon-enigmail
145 Enigmail is an extension to the Icedove mail client which allows users
146 to access the authentication and encryption features provided by
147 GnuPG.
148
149 Main Features:
150 - Encrypt/sign mail when sending, decrypt/authenticate received mail
151 - Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
152 - Per-Account based encryption and signing defaults
153 - Per-Recipient rules for automated key selection, and
154   enabling/disabling encryption and signing
155 - OpenPGP key management interface
156
157 %description addon-enigmail -l pl.UTF-8
158 Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
159 użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
160 przez GnuPG.
161
162 Główne możliwości:
163 - szyfrowanie/podpisywanie poczty przy wysyłaniu,
164   odszyfrowywanie/uwierzytelnianie poczty odebranej
165 - obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
166 - ustawienia domyślne szyfrowania i podpisywania dla każdego konta
167 - reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
168   podpisywania dla każdego adresata
169 - interfejs do zarządzania kluczami OpenPGP
170
171 %prep
172 %setup -qc
173 mv -f comm-1.9.2 mozilla
174 %setup -q -T -D -a2
175 cd mozilla
176 %{?with_enigmail:tar xvfz %{SOURCE1} -C mailnews/extensions}
177 /bin/sh %{SOURCE3}
178 %patch0 -p1
179 %{?with_enigmail:%patch1 -p1}
180 %patch2 -p1
181 %patch3 -p1
182 %patch4 -p1
183 %patch5 -p1
184 %patch6 -p1
185 %patch7 -p1
186 %patch8 -p0
187 %patch9 -p0
188 %patch10 -p2
189 %patch11 -p2
190 %patch12 -p1
191
192 %build
193 cd mozilla
194 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
195 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
196 cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
197
198 install -d libxul-sdk
199 ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
200
201 cat << EOF > .mozconfig
202 mk_add_options MOZ_OBJDIR=%{objdir}
203
204 export CFLAGS="%{rpmcflags}"
205 export CXXFLAGS="%{rpmcflags}"
206
207 %if %{with crashreporter}
208 export MOZ_DEBUG_SYMBOLS=1
209 %endif
210
211 # Options for 'configure' (same as command-line options).
212 ac_add_options --prefix=%{_prefix}
213 ac_add_options --exec-prefix=%{_exec_prefix}
214 ac_add_options --bindir=%{_bindir}
215 ac_add_options --sbindir=%{_sbindir}
216 ac_add_options --sysconfdir=%{_sysconfdir}
217 ac_add_options --datadir=%{_datadir}
218 ac_add_options --includedir=%{_includedir}
219 ac_add_options --libdir=%{_libdir}
220 ac_add_options --libexecdir=%{_libexecdir}
221 ac_add_options --localstatedir=%{_localstatedir}
222 ac_add_options --sharedstatedir=%{_sharedstatedir}
223 ac_add_options --mandir=%{_mandir}
224 ac_add_options --infodir=%{_infodir}
225 %if %{?debug:1}0
226 ac_add_options --disable-optimize
227 ac_add_options --enable-debug
228 ac_add_options --enable-debug-modules
229 ac_add_options --enable-debugger-info-modules
230 ac_add_options --enable-crash-on-assert
231 %else
232 ac_add_options --disable-debug
233 ac_add_options --disable-debug-modules
234 ac_add_options --disable-logging
235 ac_add_options --enable-optimize="%{rpmcflags} -Os"
236 %endif
237 ac_add_options --disable-strip
238 ac_add_options --disable-strip-libs
239 %if %{with tests}
240 ac_add_options --enable-tests
241 %else
242 ac_add_options --disable-tests
243 %endif
244 %if %{with gnomeui}
245 ac_add_options --enable-gnomeui
246 %else
247 ac_add_options --disable-gnomeui
248 %endif
249 %if %{with gnomevfs}
250 ac_add_options --enable-gnomevfs
251 %else
252 ac_add_options --disable-gnomevfs
253 %endif
254 %if %{with ldap}
255 ac_add_options --enable-ldap
256 ac_add_options --with-system-ldap
257 %else
258 ac_add_options --disable-ldap
259 %endif
260 %if %{with crashreporter}
261 ac_add_options --enable-crashreporter
262 %else
263 ac_add_options --disable-crashreporter
264 %endif
265 ac_add_options --disable-xterm-updates
266 ac_add_options --enable-postscript
267 %if %{with lightning}
268 ac_add_options --enable-calendar
269 %else
270 ac_add_options --disable-calendar
271 %endif
272 ac_add_options --disable-installer
273 ac_add_options --disable-jsd
274 ac_add_options --disable-updater
275 ac_add_options --disable-xprint
276 ac_add_options --disable-permissions
277 ac_add_options --disable-pref-extensions
278 ac_add_options --enable-canvas
279 ac_add_options --enable-crypto
280 ac_add_options --enable-mathml
281 ac_add_options --enable-pango
282 ac_add_options --enable-reorder
283 ac_add_options --enable-startup-notification
284 ac_add_options --enable-svg
285 ac_add_options --enable-system-cairo
286 ac_add_options --enable-system-hunspell
287 ac_add_options --enable-system-sqlite
288 ac_add_options --enable-xft
289 ac_add_options --enable-application=mail
290 ac_add_options --enable-default-toolkit=cairo-gtk2
291 ac_add_options --enable-xinerama
292 ac_add_options --with-distribution-id=org.pld-linux
293 ac_add_options --with-branding=icedove/branding
294 %if %{with xulrunner}
295 ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk
296 ac_add_options --enable-shared
297 %else
298 ac_add_options --enable-static
299 %endif
300 ac_add_options --with-pthreads
301 ac_add_options --with-system-bz2
302 ac_add_options --with-system-jpeg
303 ac_add_options --with-system-nspr
304 ac_add_options --with-system-nss
305 ac_add_options --with-system-png
306 ac_add_options --with-system-zlib
307 ac_add_options --enable-single-profile
308 ac_add_options --disable-profilesharing
309 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
310 EOF
311
312 %{__make} -j1 -f client.mk build \
313         STRIP="/bin/true" \
314         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
315         CC="%{__cc}" \
316         CXX="%{__cxx}"
317
318 %if %{with crashreporter}
319 # create debuginfo for crash-stats.mozilla.com
320 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
321 %endif
322
323 %if %{with enigmail}
324 cd mailnews/extensions/enigmail
325 ./makemake -r -o %{objdir}
326 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
327         STRIP="/bin/true" \
328         CC="%{__cc}" \
329         CXX="%{__cxx}"
330 %endif
331
332 %install
333 rm -rf $RPM_BUILD_ROOT
334 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
335
336 cd %{objdir}
337 %{__make} -C mail/installer stage-package \
338         DESTDIR=$RPM_BUILD_ROOT \
339         MOZ_PKG_APPDIR=%{_libdir}/%{name} \
340         PKG_SKIP_STRIP=1
341
342 # Enable crash reporter for Firefox application
343 %if %{with crashreporter}
344 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
345
346 # Add debuginfo for crash-stats.mozilla.com
347 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
348 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
349 %endif
350
351 # copy manually lightning files, somewhy they are not installed by make
352 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
353         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
354         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
355
356 # move arch independant ones to datadir
357 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
358 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
359 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
360 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
361 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
362 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
363 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
364 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
365 ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
366 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
367 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
368 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
369
370 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
371 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
372
373 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
374 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
375 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
376
377 cp -a %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
378 cp -a %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
379
380 # files created by regxpcom -register
381 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
382 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
383
384 %if %{with enigmail}
385 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
386 install -d $ext_dir/{chrome,components,defaults/preferences}
387 cd mozilla/dist/bin
388 cp -rfLp chrome/enigmail.jar $ext_dir/chrome
389 cp -rfLp chrome/enigmime.jar $ext_dir/chrome
390 cp -rfLp components/enig* $ext_dir/components
391 cp -rfLp components/libenigmime.so $ext_dir/components
392 cp -rfLp components/libipc.so $ext_dir/components
393 cp -rfLp components/ipc.xpt $ext_dir/components
394 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
395 cd -
396 cp -a %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
397 cp -a %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
398 %endif
399
400 # remove unecessary stuff
401 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
402 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
403 rm $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
404
405 # never package these
406 # nss
407 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
408 # nspr
409 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
410 # mozldap
411 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
412
413 %clean
414 rm -rf $RPM_BUILD_ROOT
415
416 %pretrans
417 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
418         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
419 fi
420 for d in chrome defaults greprefs icons isp modules res; do
421         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
422                 install -d %{_datadir}/%{name}
423                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
424         fi
425 done
426 exit 0
427
428 %files
429 %defattr(644,root,root,755)
430 %attr(755,root,root) %{_bindir}/icedove
431 %attr(755,root,root) %{_bindir}/mozilla-thunderbird
432 %attr(755,root,root) %{_bindir}/thunderbird
433 %dir %{_libdir}/%{name}
434 %{_libdir}/%{name}/application.ini
435 %{_libdir}/%{name}/platform.ini
436 %dir %{_libdir}/%{name}/components
437 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
438 %{_libdir}/%{name}/components/*.js
439 %{_libdir}/%{name}/components/*.xpt
440 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
441 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
442 %attr(755,root,root) %{_libdir}/%{name}/libxpcom_core.so
443 %attr(755,root,root) %{_libdir}/%{name}/*.sh
444 %attr(755,root,root) %{_libdir}/%{name}/*-bin
445 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
446 %attr(755,root,root) %{_libdir}/%{name}/icedove
447
448 # symlinks
449 %{_libdir}/%{name}/chrome
450 %{_libdir}/%{name}/defaults
451 %{_libdir}/%{name}/dictionaries
452 %{_libdir}/%{name}/greprefs
453 %{_libdir}/%{name}/isp
454 %{_libdir}/%{name}/modules
455 %{_libdir}/%{name}/res
456
457 %{_pixmapsdir}/*.png
458 %{_desktopdir}/*.desktop
459
460 %dir %{_datadir}/%{name}
461 %{_datadir}/%{name}/chrome
462 %{_datadir}/%{name}/defaults
463 %{_datadir}/%{name}/greprefs
464 %{_datadir}/%{name}/isp
465 %{_datadir}/%{name}/modules
466 %{_datadir}/%{name}/res
467
468 %if %{with crashreporter}
469 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
470 %{_libdir}/%{name}/crashreporter.ini
471 %{_libdir}/%{name}/Throbber-small.gif
472 %endif
473
474 %dir %{_libdir}/%{name}/extensions
475 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
476
477 # files created by regxpcom -register
478 %ghost %{_libdir}/%{name}/components/compreg.dat
479 %ghost %{_libdir}/%{name}/components/xpti.dat
480
481 %if %{with lightning}
482 %files addon-lightning
483 %defattr(644,root,root,755)
484 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
485 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
486 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
487 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
488 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
489 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
490 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
491 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
492 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
493 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
494 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
495 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
496
497 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
498 %endif
499
500 %if %{with enigmail}
501 %files addon-enigmail
502 %defattr(644,root,root,755)
503 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
504 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
505 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
506 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
507 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
508 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
509 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
510 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
511 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
512 %endif
This page took 0.062322 seconds and 4 git commands to generate.