]> git.pld-linux.org Git - packages/thunderbird.git/blame_incremental - icedove.spec
- cleanup
[packages/thunderbird.git] / icedove.spec
... / ...
CommitLineData
1#
2# TODO:
3# - CHECK all features of enigmail
4# - separate spec for enigmail
5# - update or remove -myspell.patch
6# - package unpackaged files
7# - update branding patch!!!
8#
9# Conditional builds
10%bcond_without enigmail # don't build enigmail - GPG/PGP support
11%bcond_without gnomeui # disable gnomeui support
12%bcond_without gnomevfs # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
13%bcond_without gnome # disable all GNOME components (gnome+gnomeui+gnomevfs)
14%bcond_without ldap # disable e-mail address lookups in LDAP directories
15#
16%if %{without gnome}
17%undefine with_gnomeui
18%undefine with_gnomevfs
19%endif
20%define enigmail_ver 1.0.0
21
22Summary: Icedove - email client
23Summary(pl.UTF-8): Icedove - klient poczty
24Name: icedove
25Version: 3.0
26Release: 0.2
27License: MPL 1.1 or GPL v2+ or LGPL v2.1+
28Group: Applications/Networking
29Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
30# Source0-md5: 9a564ac2489b1b0f9348dc298b913f6c
31Source1: http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
32# Source1-md5: e3a6d379f1a72ac023751bdde2de750a
33Source2: %{name}-branding.tar.bz2
34# Source2-md5: e775b8cb658de32f30b403bc9b7950bf
35Source3: %{name}-rm_nonfree.sh
36Source4: %{name}.desktop
37Source5: %{name}.sh
38Source6: %{name}-enigmail.manifest
39Patch0: %{name}-branding.patch
40Patch1: %{name}-enigmail-shared.patch
41Patch2: %{name}-gcc.patch
42Patch3: %{name}-fonts.patch
43Patch4: %{name}-install.patch
44Patch5: %{name}-myspell.patch
45Patch6: %{name}-prefs.patch
46Patch7: %{name}-breakpad.patch
47URL: http://www.pld-linux.org/Packages/Icedove
48%{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
49BuildRequires: automake
50BuildRequires: freetype-devel >= 1:2.1.8
51%{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
52BuildRequires: gtk+2-devel >= 1:2.0.0
53BuildRequires: libIDL-devel >= 0.8.0
54%{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
55%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
56BuildRequires: libjpeg-devel >= 6b
57BuildRequires: libpng-devel >= 1.2.0
58BuildRequires: libstdc++-devel
59BuildRequires: myspell-devel
60BuildRequires: nspr-devel >= 1:4.8
61BuildRequires: nss-devel >= 1:3.12.0
62BuildRequires: pango-devel >= 1:1.1.0
63BuildRequires: sed >= 4.0
64BuildRequires: xorg-lib-libXext-devel
65BuildRequires: xorg-lib-libXft-devel >= 2.1
66BuildRequires: xorg-lib-libXinerama-devel
67BuildRequires: xorg-lib-libXp-devel
68BuildRequires: xorg-lib-libXt-devel
69Requires: myspell-common
70Requires: nspr >= 1:4.6.1
71Requires: nss >= 1:3.11.3
72Obsoletes: mozilla-thunderbird
73Obsoletes: mozilla-thunderbird-dictionary-en-US
74BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
77
78# iceweasel/icedove/iceape provide their own versions
79%define _noautoreqdep libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so libxpistub.so
80%define _noautoprovfiles %{_libdir}/%{name}/components
81# we don't want these to satisfy xulrunner-devel
82%define _noautoprov libgtkembedmoz.so libldap50.so libmozjs.so libprldap50.so libssldap50.so libxpcom.so libxul.so
83# and as we don't provide them, don't require either
84%define _noautoreq libgtkembedmoz.so libldap50.so libmozjs.so libprldap50.so libssldap50.so libxpcom.so libxul.so
85
86%description
87Icedove is an open-source,fast and portable email client.
88
89%description -l pl.UTF-8
90Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
91
92%package addon-enigmail
93Summary: Extension for the authentication and encryption features provided by GnuPG
94Summary(pl.UTF-8): Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
95License: MPL/LGPL
96Group: Applications/Networking
97URL: http://enigmail.mozdev.org/
98Requires: %{name} = %{version}-%{release}
99Obsoletes: mozilla-thunderbird-addon-enigmail
100
101%description addon-enigmail
102Enigmail is an extension to the Icedove mail client which allows users
103to access the authentication and encryption features provided by
104GnuPG.
105
106Main Features:
107- Encrypt/sign mail when sending, decrypt/authenticate received mail
108- Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
109- Per-Account based encryption and signing defaults
110- Per-Recipient rules for automated key selection, and
111 enabling/disabling encryption and signing
112- OpenPGP key management interface
113
114%description addon-enigmail -l pl.UTF-8
115Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
116użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
117przez GnuPG.
118
119Główne możliwości:
120- szyfrowanie/podpisywanie poczty przy wysyłaniu,
121 odszyfrowywanie/uwierzytelnianie poczty odebranej
122- obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
123- ustawienia domyślne szyfrowania i podpisywania dla każdego konta
124- reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
125 podpisywania dla każdego adresata
126- interfejs do zarządzania kluczami OpenPGP
127
128%prep
129%setup -q -c -a2
130cd comm-1.9.1
131%{?with_enigmail:tar xvfz %{SOURCE1} -C mailnews/extensions}
132/bin/sh %{SOURCE3}
133%patch0 -p1
134%{?with_enigmail:%patch1 -p1}
135%patch2 -p1
136%patch3 -p1
137%patch4 -p1
138#%patch5 -p1
139%patch6 -p0
140%patch7 -p1
141
142%build
143cd comm-1.9.1
144export CFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
145export CXXFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
146
147cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
148cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
149cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
150
151cat << 'EOF' > .mozconfig
152
153mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
154
155ac_add_options --prefix=%{_prefix}
156ac_add_options --exec-prefix=%{_exec_prefix}
157ac_add_options --bindir=%{_bindir}
158ac_add_options --sbindir=%{_sbindir}
159ac_add_options --sysconfdir=%{_sysconfdir}
160ac_add_options --datadir=%{_datadir}
161ac_add_options --includedir=%{_includedir}
162ac_add_options --libdir=%{_libdir}
163ac_add_options --libexecdir=%{_libexecdir}
164ac_add_options --localstatedir=%{_localstatedir}
165ac_add_options --sharedstatedir=%{_sharedstatedir}
166ac_add_options --mandir=%{_mandir}
167ac_add_options --infodir=%{_infodir}
168%if %{?debug:1}0
169ac_add_options --enable-debug
170ac_add_options --enable-debug-modules
171%else
172ac_add_options --disable-debug
173ac_add_options --disable-debug-modules
174%endif
175%if %{with tests}
176ac_add_options --enable-tests
177%else
178ac_add_options --disable-tests
179%endif
180%if %{with gnomeui}
181ac_add_options --enable-gnomeui
182%else
183ac_add_options --disable-gnomeui
184%endif
185%if %{with gnomevfs}
186ac_add_options --enable-gnomevfs
187%else
188ac_add_options --disable-gnomevfs
189%endif
190%if %{with ldap}
191ac_add_options --enable-ldap
192%else
193ac_add_options --disable-ldap
194%endif
195ac_add_options --enable-calendar
196ac_add_options --disable-installer
197ac_add_options --disable-jsd
198ac_add_options --disable-xprint
199ac_add_options --disable-permissions
200ac_add_options --disable-pref-extensions
201ac_add_options --enable-canvas
202ac_add_options --enable-crypto
203ac_add_options --enable-default-toolkit="gtk2"
204ac_add_options --enable-mathml
205ac_add_options --enable-optimize="%{rpmcflags}"
206ac_add_options --enable-pango
207ac_add_options --enable-reorder
208ac_add_options --enable-static
209ac_add_options --disable-strip
210ac_add_options --disable-strip-libs
211ac_add_options --enable-system-cairo
212ac_add_options --enable-system-myspell
213ac_add_options --enable-svg
214ac_add_options --enable-xft
215ac_add_options --enable-application=mail
216ac_add_options --enable-default-toolkit=cairo-gtk2
217ac_add_options --enable-xinerama
218ac_add_options --with-system-jpeg
219ac_add_options --with-system-nspr
220ac_add_options --with-system-nss
221ac_add_options --with-system-png
222ac_add_options --with-system-zlib
223ac_add_options --with-pthreads
224ac_add_options --enable-single-profile
225ac_add_options --disable-profilesharing
226ac_add_options --with-distribution-id=org.pld-linux
227#ac_add_options --with-branding=icedove/branding
228ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
229EOF
230
231%{__make} -j1 -f client.mk build \
232 CC="%{__cc}" \
233 CXX="%{__cxx}"
234
235%if %{with enigmail}
236 cd mailnews/extensions/enigmail
237 ./makemake -r
238 %{__make} -C ../../../obj-%{_target_cpu}/mailnews/extensions/enigmail
239%endif
240
241%install
242rm -rf $RPM_BUILD_ROOT
243install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_pixmapsdir},%{_desktopdir}} \
244 $RPM_BUILD_ROOT%{_datadir}/%{name}
245install -d $RPM_BUILD_ROOT%{_libdir}/%{name}
246
247cd comm-1.9.1
248%{__make} -C obj-%{_target_cpu}/mail/installer stage-package \
249 DESTDIR=$RPM_BUILD_ROOT \
250 MOZ_PKG_APPDIR=%{_libdir}/%{name} \
251 PKG_SKIP_STRIP=1
252
253# move arch independant ones to datadir
254mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
255mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
256mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
257mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
258mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
259mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
260ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
261ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
262ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
263ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
264ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
265ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
266
267rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
268ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
269
270%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
271ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
272ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
273
274install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
275
276%if %{with enigmail}
277_enig_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
278install -d $_enig_dir/chrome
279install -d $_enig_dir/components
280install -d $_enig_dir/defaults/preferences
281mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail.jar $_enig_dir/chrome
282#mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-skin-seamonkey.jar $_enig_dir/chrome
283mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/enig* $_enig_dir/components
284mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/libenigmime.so $_enig_dir/components
285#mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/libipc.so $_enig_dir/components
286mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/ipc.xpt $_enig_dir/components
287mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults/preferences/enigmail.js $_enig_dir/defaults/preferences
288cp -f mailnews/extensions/enigmail/package/install.rdf $_enig_dir
289rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults/preferences
290rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-en-US.jar
291rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-skin.jar
292rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmime.jar
293rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/components/enig*
294rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/libenigmime.so
295rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/ipc.xpt
296cp -f %{SOURCE6} $_enig_dir/chrome.manifest
297#cp -f icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/icedove.png
298%endif
299
300# win32 stuff
301rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/dirver
302
303%clean
304rm -rf $RPM_BUILD_ROOT
305
306%pretrans
307if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
308 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
309fi
310for d in chrome defaults greprefs icons isp res; do
311 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
312 install -d %{_datadir}/%{name}
313 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
314 fi
315done
316exit 0
317
318%files
319%defattr(644,root,root,755)
320%attr(755,root,root) %{_bindir}/icedove
321%attr(755,root,root) %{_bindir}/mozilla-thunderbird
322%attr(755,root,root) %{_bindir}/thunderbird
323%dir %{_libdir}/%{name}
324%{_libdir}/%{name}/*.ini
325%dir %{_libdir}/%{name}/components
326%attr(755,root,root) %{_libdir}/%{name}/components/*.so
327%{_libdir}/%{name}/components/*.js
328%{_libdir}/%{name}/components/*.xpt
329%attr(755,root,root) %{_libdir}/%{name}/*.so
330%attr(755,root,root) %{_libdir}/%{name}/*.sh
331%attr(755,root,root) %{_libdir}/%{name}/*-bin
332%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
333#%attr(755,root,root) %{_libdir}/%{name}/reg*
334%attr(755,root,root) %{_libdir}/%{name}/icedove
335%{_libdir}/%{name}/*.txt
336#%attr(755,root,root) %{_libdir}/%{name}/x*
337
338# symlinks
339%{_libdir}/%{name}/chrome
340%{_libdir}/%{name}/defaults
341%{_libdir}/%{name}/dictionaries
342%{_libdir}/%{name}/greprefs
343%{_libdir}/%{name}/icons
344%{_libdir}/%{name}/isp
345%{_libdir}/%{name}/res
346
347%{_libdir}/%{name}/dependentlibs.list
348%{_libdir}/%{name}/updater
349%{_libdir}/%{name}/update.locale
350#%{_pixmapsdir}/*.png
351%{_desktopdir}/*.desktop
352
353%dir %{_datadir}/%{name}
354%{_datadir}/%{name}/chrome
355%{_datadir}/%{name}/defaults
356%{_datadir}/%{name}/greprefs
357%{_datadir}/%{name}/icons
358%{_datadir}/%{name}/isp
359%{_datadir}/%{name}/res
360
361%dir %{_libdir}/%{name}/modules
362%{_libdir}/%{name}/modules/*.js*
363%dir %{_libdir}/%{name}/modules/activity
364%{_libdir}/%{name}/modules/activity/*.js
365%dir %{_libdir}/%{name}/modules/gloda
366%{_libdir}/%{name}/modules/gloda/*.js
367
368%dir %{_libdir}/%{name}/extensions
369%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
370
371%if %{with enigmail}
372%files addon-enigmail
373%defattr(644,root,root,755)
374%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
375%endif
This page took 0.053211 seconds and 4 git commands to generate.