]> git.pld-linux.org Git - packages/thunderbird.git/blame_incremental - icedove.spec
- fix building with freetype 2.6
[packages/thunderbird.git] / icedove.spec
... / ...
CommitLineData
1# TODO:
2# - build with system mozldap
3#
4# Conditional builds
5%bcond_with gtk3 # GTK+ 3.x instead of 2.x
6%bcond_without ldap # disable e-mail address lookups in LDAP directories
7%bcond_without lightning # disable Sunbird/Lightning calendar
8%bcond_with xulrunner # system xulrunner
9%bcond_with crashreporter # report crashes to crash-stats.mozilla.com
10# - disabled shared_js - https://bugzilla.mozilla.org/show_bug.cgi?id=1039964
11%bcond_with shared_js # shared libmozjs library [broken]
12
13%if 0%{?_enable_debug_packages} != 1
14%undefine crashreporter
15%endif
16
17%define nspr_ver 4.10.6
18%define nss_ver 3.17.0
19
20%define xulrunner_ver 2:31.3.0
21
22%if %{without xulrunner}
23# The actual sqlite version (see RHBZ#480989):
24%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
25%endif
26
27Summary: Icedove - email client
28Summary(pl.UTF-8): Icedove - klient poczty
29Name: icedove
30Version: 31.7.0
31Release: 1
32License: MPL v2.0
33Group: X11/Applications/Mail
34Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
35# Source0-md5: dcf14a6d4aaba2f695a1ec30c296e356
36Source2: %{name}-branding.tar.xz
37# Source2-md5: 85992ebd22e36ba69743b06b4c53fb2a
38Source3: %{name}-rm_nonfree.sh
39Source4: %{name}.desktop
40Source5: %{name}.sh
41Patch0: %{name}-branding.patch
42Patch1: %{name}-fonts.patch
43Patch2: %{name}-prefs.patch
44Patch3: system-mozldap.patch
45Patch4: %{name}-makefile.patch
46Patch5: %{name}-extensiondir.patch
47Patch6: no-subshell.patch
48# Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
49Patch7: system-virtualenv.patch
50Patch8: enable-addons.patch
51Patch9: bump-nss-req.patch
52Patch10: libvpx2.patch
53Patch11: freetype-2.6.patch
54URL: http://www.pld-linux.org/Packages/Icedove
55BuildRequires: GConf2-devel >= 1.2.1
56BuildRequires: alsa-lib-devel
57BuildRequires: automake
58BuildRequires: bzip2-devel
59BuildRequires: cairo-devel >= 1.10
60BuildRequires: dbus-glib-devel >= 0.60
61BuildRequires: freetype-devel >= 1:2.1.8
62BuildRequires: glib2-devel >= 1:2.20
63BuildRequires: gstreamer0.10-devel
64BuildRequires: gstreamer0.10-plugins-base-devel
65%{!?with_gtk3:BuildRequires: gtk+2-devel >= 2:2.14}
66%{?with_gtk3:BuildRequires: gtk+3-devel >= 3.0.0}
67BuildRequires: hunspell-devel
68BuildRequires: libIDL-devel >= 0.8.0
69BuildRequires: libevent-devel
70BuildRequires: libicu-devel >= 50.1
71BuildRequires: libiw-devel
72# requires libjpeg-turbo implementing at least libjpeg 6b API
73BuildRequires: libjpeg-devel >= 6b
74BuildRequires: libjpeg-turbo-devel
75BuildRequires: libpng-devel >= 1.4.1
76BuildRequires: libstdc++-devel
77BuildRequires: mozldap-devel
78BuildRequires: nspr-devel >= 1:%{nspr_ver}
79BuildRequires: nss-devel >= 1:%{nss_ver}
80BuildRequires: pango-devel >= 1:1.22.0
81BuildRequires: perl-base >= 1:5.6
82BuildRequires: python-virtualenv
83BuildRequires: pkgconfig
84BuildRequires: python >= 1:2.5
85BuildRequires: sed >= 4.0
86BuildRequires: sqlite3-devel >= 3.8.4.2
87BuildRequires: startup-notification-devel >= 0.8
88BuildRequires: libvpx-devel >= 1.3.0
89BuildRequires: xorg-lib-libXext-devel
90BuildRequires: xorg-lib-libXinerama-devel
91BuildRequires: xorg-lib-libXt-devel
92BuildRequires: yasm
93BuildRequires: zip
94%if %{with xulrunner}
95BuildRequires: xulrunner-devel >= %{xulrunner_ver}
96BuildRequires: xulrunner-devel < 2:32
97%else
98Requires: glib2 >= 1:2.20
99%{!?with_gtk3:Requires: gtk+2 >= 2:2.14}
100%{?with_gtk3:Requires: gtk+3 >= 3.0.0}
101Requires: libvpx >= 1.3.0
102Requires: myspell-common
103Requires: nspr >= 1:%{nspr_ver}
104Requires: nss >= 1:%{nss_ver}
105Requires: pango >= 1:1.22.0
106Requires: sqlite3 >= %{sqlite_build_version}
107%endif
108Requires(post): mktemp >= 1.5-18
109%if %{with xulrunner}
110%requires_eq_to xulrunner xulrunner-devel
111%endif
112Requires: libjpeg-turbo
113Obsoletes: mozilla-thunderbird
114Obsoletes: mozilla-thunderbird-dictionary-en-US
115Conflicts: icedove-lang-resources < %{version}
116BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
117
118%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
119
120# iceweasel/icedove/iceape provide their own versions
121%define _noautoprovfiles %{_libdir}/%{name}/components
122%if %{without xulrunner}
123# we don't want these to satisfy packages depending on xulrunner
124%define _noautoprov libmozalloc.so libmozjs.so libxul.so
125# and as we don't provide them, don't require either
126%define _noautoreq libmozalloc.so libmozjs.so libxul.so
127%endif
128
129%define topdir %{_builddir}/%{name}-%{version}
130%define objdir %{topdir}/obj-%{_target_cpu}
131
132%description
133Icedove is an open-source, fast and portable email client.
134
135%description -l pl.UTF-8
136Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
137poczty.
138
139%package addon-lightning
140Summary: An integrated calendar for Icedove
141Summary(pl.UTF-8): Zintegrowany kalendarz dla Icedove
142License: MPL 1.1 or GPL v2+ or LGPL v2.1+
143Group: Applications/Networking
144Requires: %{name} = %{version}-%{release}
145
146%description addon-lightning
147Lightning is an calendar extension to Icedove email client.
148
149%description addon-lightning -l pl.UTF-8
150Lightning to rozszerzenie do klienta poczty Icedove dodające
151funkcjonalność kalendarza.
152
153%prep
154%setup -qc
155%{__mv} comm-esr31 mozilla
156%setup -q -T -D -a2
157cd mozilla
158/bin/sh %{SOURCE3}
159%patch0 -p1
160%patch1 -p1
161%patch2 -p1
162%patch3 -p1
163%patch4 -p2
164%patch5 -p2
165%patch6 -p1
166%patch7 -p1
167%patch8 -p1
168%patch9 -p2
169%patch10 -p1
170%patch11 -p1
171
172%build
173cd mozilla
174cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
175cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
176cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
177
178cat << EOF > .mozconfig
179mk_add_options MOZ_OBJDIR=%{objdir}
180
181export CFLAGS="%{rpmcflags}"
182export CXXFLAGS="%{rpmcflags}"
183
184%if %{with crashreporter}
185export MOZ_DEBUG_SYMBOLS=1
186%endif
187
188# Options for 'configure' (same as command-line options).
189ac_add_options --prefix=%{_prefix}
190ac_add_options --exec-prefix=%{_exec_prefix}
191ac_add_options --bindir=%{_bindir}
192ac_add_options --sbindir=%{_sbindir}
193ac_add_options --sysconfdir=%{_sysconfdir}
194ac_add_options --datadir=%{_datadir}
195ac_add_options --includedir=%{_includedir}
196ac_add_options --libdir=%{_libdir}
197ac_add_options --libexecdir=%{_libexecdir}
198ac_add_options --localstatedir=%{_localstatedir}
199ac_add_options --sharedstatedir=%{_sharedstatedir}
200ac_add_options --mandir=%{_mandir}
201ac_add_options --infodir=%{_infodir}
202%if %{?debug:1}0
203ac_add_options --disable-optimize
204ac_add_options --enable-debug
205ac_add_options --enable-debug-modules
206ac_add_options --enable-debugger-info-modules
207ac_add_options --enable-crash-on-assert
208%else
209ac_add_options --disable-debug
210ac_add_options --disable-debug-modules
211ac_add_options --disable-logging
212ac_add_options --enable-optimize="%{rpmcflags} -Os"
213%endif
214ac_add_options --disable-strip
215ac_add_options --disable-strip-libs
216%if %{with tests}
217ac_add_options --enable-tests
218%else
219ac_add_options --disable-tests
220%endif
221%if %{with lightning}
222ac_add_options --enable-calendar
223%else
224ac_add_options --disable-calendar
225%endif
226%if %{with crashreporter}
227ac_add_options --enable-crashreporter
228%else
229ac_add_options --disable-crashreporter
230%endif
231ac_add_options --disable-elf-dynstr-gc
232ac_add_options --disable-gnomeui
233ac_add_options --disable-gnomevfs
234ac_add_options --disable-installer
235ac_add_options --disable-javaxpcom
236ac_add_options --disable-profilesharing
237ac_add_options --disable-updater
238ac_add_options --disable-xterm-updates
239ac_add_options --enable-application=mail
240ac_add_options --enable-crypto
241ac_add_options --enable-default-toolkit=%{?with_gtk3:cairo-gtk3}%{!?with_gtk3:cairo-gtk2}
242ac_add_options --enable-gio
243%if %{with ldap}
244ac_add_options --enable-ldap
245ac_add_options --with-system-ldap
246%else
247ac_add_options --disable-ldap
248%endif
249ac_add_options --enable-libxul
250ac_add_options --enable-pango
251ac_add_options --enable-postscript
252%{?with_shared_js:ac_add_options --enable-shared-js}
253ac_add_options --enable-single-profile
254ac_add_options --enable-startup-notification
255ac_add_options --enable-system-cairo
256ac_add_options --enable-system-hunspell
257ac_add_options --enable-system-sqlite
258ac_add_options --with-branding=icedove/branding
259ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
260ac_add_options --with-distribution-id=org.pld-linux
261%if %{with xulrunner}
262ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
263ac_add_options --with-system-libxul
264%endif
265ac_add_options --with-pthreads
266ac_add_options --with-system-bz2
267ac_add_options --with-system-ffi
268ac_add_options --with-system-icu
269ac_add_options --with-system-jpeg
270ac_add_options --with-system-libevent
271ac_add_options --with-system-libvpx
272ac_add_options --with-system-nspr
273ac_add_options --with-system-nss
274ac_add_options --with-system-png
275ac_add_options --with-system-zlib
276EOF
277
278mkdir -p %{objdir}/config
279ln -s %{topdir}/mozilla/config/*.mk %{objdir}/config
280
281%{__make} -j1 -f client.mk build \
282 STRIP="/bin/true" \
283 MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
284 installdir=%{_libdir}/%{name} \
285 XLIBS="-lX11 -lXt" \
286 CC="%{__cc}" \
287 CXX="%{__cxx}"
288
289%if %{with crashreporter}
290# create debuginfo for crash-stats.mozilla.com
291%{__make} -j1 -C obj-%{_target_cpu} buildsymbols
292%endif
293
294%install
295rm -rf $RPM_BUILD_ROOT
296install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
297
298cd %{objdir}
299%{__make} -C mail/installer stage-package \
300 DESTDIR=$RPM_BUILD_ROOT \
301 installdir=%{_libdir}/%{name} \
302 PKG_SKIP_STRIP=1
303
304%{__make} -C icedove/branding install \
305 DESTDIR=$RPM_BUILD_ROOT
306
307cp -a mozilla/dist/icedove/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
308
309%if %{with xulrunner}
310# needed to find mozilla runtime
311ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
312%endif
313
314# Enable crash reporter for Thunderbird application
315%if %{with crashreporter}
316%{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
317
318# Add debuginfo for crash-stats.mozilla.com
319install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
320cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
321%endif
322
323# copy manually lightning files, somewhy they are not installed by make
324cp -a mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
325 $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
326
327# move arch independant ones to datadir
328mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
329ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
330
331# dir for arch independant extensions besides arch dependant extensions
332# see mozilla/xpcom/build/nsXULAppAPI.h
333# XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
334install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
335
336%if %{without xulrunner}
337%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
338ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
339%endif
340
341%{__sed} -e "s|%MOZAPPDIR%|%{_libdir}/%{name}|" \
342 -e "s|%MOZ_APP_DISPLAYNAME%|Icedove|" \
343 %{topdir}/mozilla/mozilla/build/unix/mozilla.in > $RPM_BUILD_ROOT%{_libdir}/%{name}/icedove
344
345%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
346ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
347ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
348
349# install icons and desktop file
350cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
351for i in 16 32 48 64 128 256; do
352 install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps
353 cp -a %{topdir}/mozilla/icedove/branding/icedove${i}.png \
354 $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps/icedove.png
355done
356install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps
357cp -a %{topdir}/mozilla/icedove/branding/icedove.svg $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps/icedove.svg
358
359cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
360
361# files created by regxpcom -register in post
362touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
363touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
364cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
365#!/bin/sh
366umask 022
367# make temporary HOME, as it attempts to touch files in $HOME/.mozilla
368# dangerous if you run this with sudo with keep_env += HOME
369# also TMPDIR could be pointing to sudo user's homedir so we reset that too.
370t=$(mktemp -d)
371%{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
372TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
373rm -rf $t
374EOF
375chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
376
377# mozldap
378%{__sed} -i '/lib\(ldap\|ldif\|prldap\)60.so/d' $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
379%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap}60.so
380
381%clean
382rm -rf $RPM_BUILD_ROOT
383
384%pretrans
385if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
386 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
387fi
388for d in chrome defaults icons isp modules res searchplugins; do
389 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
390 install -d %{_datadir}/%{name}
391 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
392 fi
393done
394exit 0
395
396%post
397%{_libdir}/%{name}/register || :
398
399%files
400%defattr(644,root,root,755)
401%attr(755,root,root) %{_bindir}/icedove
402%attr(755,root,root) %{_bindir}/mozilla-thunderbird
403%attr(755,root,root) %{_bindir}/thunderbird
404%dir %{_libdir}/%{name}
405%{_libdir}/%{name}/application.ini
406%{_libdir}/%{name}/blocklist.xml
407%{_libdir}/%{name}/chrome.manifest
408%dir %{_libdir}/%{name}/components
409%{_libdir}/%{name}/components/components.manifest
410%attr(755,root,root) %{_libdir}/%{name}/*.sh
411%attr(755,root,root) %{_libdir}/%{name}/*-bin
412%attr(755,root,root) %{_libdir}/%{name}/icedove
413%attr(755,root,root) %{_libdir}/%{name}/register
414%{_libdir}/%{name}/omni.ja
415%if %{without xulrunner}
416%{_libdir}/%{name}/dependentlibs.list
417%{_libdir}/%{name}/platform.ini
418%attr(755,root,root) %{_libdir}/%{name}/components/*.so
419%attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
420%{?with_shared_js:%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so}
421%attr(755,root,root) %{_libdir}/%{name}/libxul.so
422%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
423%attr(755,root,root) %{_libdir}/%{name}/plugin-container
424%endif
425
426# symlinks
427%{_libdir}/%{name}/chrome
428%{_libdir}/%{name}/defaults
429%{_libdir}/%{name}/isp
430%{_libdir}/%{name}/searchplugins
431%if %{with xulrunner}
432%{_libdir}/%{name}/xulrunner
433%else
434%{_libdir}/%{name}/dictionaries
435%endif
436
437%{_pixmapsdir}/icedove.png
438%{_desktopdir}/icedove.desktop
439
440%dir %{_datadir}/%{name}
441%{_datadir}/%{name}/extensions
442%{_datadir}/%{name}/searchplugins
443
444%if %{with crashreporter}
445%attr(755,root,root) %{_libdir}/%{name}/crashreporter
446%{_libdir}/%{name}/crashreporter.ini
447%{_libdir}/%{name}/Throbber-small.gif
448%endif
449
450%dir %{_libdir}/%{name}/extensions
451%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
452
453# files created by regxpcom -register
454%ghost %{_libdir}/%{name}/components/compreg.dat
455%ghost %{_libdir}/%{name}/components/xpti.dat
456
457%{_iconsdir}/hicolor/*/apps/icedove.*
458
459%if %{with lightning}
460%files addon-lightning
461%defattr(644,root,root,755)
462%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
463%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
464%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
465%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
466%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
467%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
468%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
469%attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
470%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
471%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
472%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
473%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
474%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
475%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
476%endif
This page took 0.038921 seconds and 4 git commands to generate.