]> git.pld-linux.org Git - packages/thunderbird.git/blame_incremental - icedove.spec
- s/Thunderbird/Icedove in Lightning extension
[packages/thunderbird.git] / icedove.spec
... / ...
CommitLineData
1#
2# TODO:
3# - CHECK all features of enigmail
4# - separate spec for enigmail
5# - remove -myspell.patch
6# - package unpackaged files
7# - fix hunspell and enable
8#
9# Conditional builds
10%bcond_without enigmail # don't build enigmail - GPG/PGP support
11%bcond_without gnomeui # disable gnomeui support
12%bcond_without gnomevfs # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
13%bcond_without gnome # disable all GNOME components (gnome+gnomeui+gnomevfs)
14%bcond_without ldap # disable e-mail address lookups in LDAP directories
15%bcond_without lightning # disable sunbird calendar
16#
17%if %{without gnome}
18%undefine with_gnomeui
19%undefine with_gnomevfs
20%endif
21%define enigmail_ver 1.0.0
22
23Summary: Icedove - email client
24Summary(pl.UTF-8): Icedove - klient poczty
25Name: icedove
26Version: 3.0.1
27Release: 0.3
28License: MPL 1.1 or GPL v2+ or LGPL v2.1+
29Group: Applications/Networking
30Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
31# Source0-md5: f004aa5ddf2a30b5df96e06df416b0c9
32Source1: http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
33# Source1-md5: e3a6d379f1a72ac023751bdde2de750a
34Source2: %{name}-branding.tar.bz2
35# Source2-md5: ef52c044e026ee65762893e97f421b1b
36Source3: %{name}-rm_nonfree.sh
37Source4: %{name}.desktop
38Source5: %{name}.sh
39Source6: %{name}-enigmail.manifest
40Patch0: %{name}-branding.patch
41Patch1: %{name}-enigmail-shared.patch
42Patch2: %{name}-gcc.patch
43Patch3: %{name}-fonts.patch
44Patch4: %{name}-install.patch
45Patch5: %{name}-myspell.patch
46Patch6: %{name}-prefs.patch
47Patch7: %{name}-breakpad.patch
48Patch8: %{name}-libpng.patch
49Patch9: %{name}-condstore.patch
50URL: http://www.pld-linux.org/Packages/Icedove
51%{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
52BuildRequires: automake
53BuildRequires: freetype-devel >= 1:2.1.8
54%{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
55BuildRequires: gtk+2-devel >= 1:2.0.0
56#BuildRequires: hunspell-devel
57BuildRequires: libIDL-devel >= 0.8.0
58%{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
59%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
60BuildRequires: libjpeg-devel >= 6b
61BuildRequires: libpng-devel >= 1.2.0
62BuildRequires: libstdc++-devel
63BuildRequires: nspr-devel >= 1:4.8
64BuildRequires: nss-devel >= 1:3.12.0
65BuildRequires: pango-devel >= 1:1.1.0
66BuildRequires: pkgconfig
67BuildRequires: sed >= 4.0
68BuildRequires: startup-notification-devel >= 0.8
69BuildRequires: xorg-lib-libXext-devel
70BuildRequires: xorg-lib-libXinerama-devel
71BuildRequires: xorg-lib-libXt-devel
72BuildRequires: zip
73Requires: myspell-common
74Requires: nspr >= 1:4.6.1
75Requires: nss >= 1:3.11.3
76Obsoletes: mozilla-thunderbird
77Obsoletes: mozilla-thunderbird-dictionary-en-US
78BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
81
82# iceweasel/icedove/iceape provide their own versions
83%define _noautoreqdep libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so libxpistub.so
84%define _noautoprovfiles %{_libdir}/%{name}/components
85# we don't want these to satisfy xulrunner-devel
86%define _noautoprov libgtkembedmoz.so libldap50.so libmozjs.so libprldap50.so libssldap50.so libxpcom.so libxul.so
87# and as we don't provide them, don't require either
88%define _noautoreq libgtkembedmoz.so libldap50.so libmozjs.so libprldap50.so libssldap50.so libxpcom.so libxul.so
89
90%description
91Icedove is an open-source,fast and portable email client.
92
93%description -l pl.UTF-8
94Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
95
96%package addon-enigmail
97Summary: Extension for the authentication and encryption features provided by GnuPG
98Summary(pl.UTF-8): Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
99License: MPL/LGPL
100Group: Applications/Networking
101URL: http://enigmail.mozdev.org/
102Requires: %{name} = %{version}-%{release}
103Requires: gnupg
104Obsoletes: mozilla-thunderbird-addon-enigmail
105
106%description addon-enigmail
107Enigmail is an extension to the Icedove mail client which allows users
108to access the authentication and encryption features provided by
109GnuPG.
110
111Main Features:
112- Encrypt/sign mail when sending, decrypt/authenticate received mail
113- Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
114- Per-Account based encryption and signing defaults
115- Per-Recipient rules for automated key selection, and
116 enabling/disabling encryption and signing
117- OpenPGP key management interface
118
119%description addon-enigmail -l pl.UTF-8
120Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
121użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
122przez GnuPG.
123
124Główne możliwości:
125- szyfrowanie/podpisywanie poczty przy wysyłaniu,
126 odszyfrowywanie/uwierzytelnianie poczty odebranej
127- obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
128- ustawienia domyślne szyfrowania i podpisywania dla każdego konta
129- reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
130 podpisywania dla każdego adresata
131- interfejs do zarządzania kluczami OpenPGP
132
133%prep
134%setup -qc
135mv -f comm-1.9.1 mozilla
136%setup -q -T -D -a2
137cd mozilla
138%{?with_enigmail:tar xvfz %{SOURCE1} -C mailnews/extensions}
139/bin/sh %{SOURCE3}
140%patch0 -p1
141%{?with_enigmail:%patch1 -p1}
142%patch2 -p1
143%patch3 -p1
144%patch4 -p1
145#%patch5 -p1
146%patch6 -p1
147%patch7 -p1
148%patch8 -p1
149%patch9 -p1
150
151%build
152cd mozilla
153export CFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
154export CXXFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
155
156cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
157cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
158cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
159
160cat << 'EOF' > .mozconfig
161mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
162
163# Options for 'configure' (same as command-line options).
164ac_add_options --prefix=%{_prefix}
165ac_add_options --exec-prefix=%{_exec_prefix}
166ac_add_options --bindir=%{_bindir}
167ac_add_options --sbindir=%{_sbindir}
168ac_add_options --sysconfdir=%{_sysconfdir}
169ac_add_options --datadir=%{_datadir}
170ac_add_options --includedir=%{_includedir}
171ac_add_options --libdir=%{_libdir}
172ac_add_options --libexecdir=%{_libexecdir}
173ac_add_options --localstatedir=%{_localstatedir}
174ac_add_options --sharedstatedir=%{_sharedstatedir}
175ac_add_options --mandir=%{_mandir}
176ac_add_options --infodir=%{_infodir}
177%if %{?debug:1}0
178ac_add_options --disable-optimize
179ac_add_options --enable-debug
180ac_add_options --enable-debug-modules
181ac_add_options --enable-debugger-info-modules
182ac_add_options --enable-crash-on-assert
183%else
184ac_add_options --disable-debug
185ac_add_options --disable-debug-modules
186ac_add_options --disable-logging
187ac_add_options --enable-optimize="%{rpmcflags} -Os"
188%endif
189%if %{with tests}
190ac_add_options --enable-tests
191%else
192ac_add_options --disable-tests
193%endif
194%if %{with gnomeui}
195ac_add_options --enable-gnomeui
196%else
197ac_add_options --disable-gnomeui
198%endif
199%if %{with gnomevfs}
200ac_add_options --enable-gnomevfs
201%else
202ac_add_options --disable-gnomevfs
203%endif
204%if %{with ldap}
205ac_add_options --enable-ldap
206%else
207ac_add_options --disable-ldap
208%endif
209ac_add_options --disable-crashreporter
210ac_add_options --disable-updater
211ac_add_options --disable-xterm-updates
212ac_add_options --enable-ldap
213ac_add_options --enable-postscript
214ac_add_options --enable-startup-notification
215%if %{with lightning}
216ac_add_options --enable-calendar
217%else
218ac_add_options --disable-calendar
219%endif
220ac_add_options --disable-installer
221ac_add_options --disable-jsd
222ac_add_options --disable-xprint
223ac_add_options --disable-permissions
224ac_add_options --disable-pref-extensions
225ac_add_options --enable-canvas
226ac_add_options --enable-crypto
227ac_add_options --enable-default-toolkit="gtk2"
228ac_add_options --enable-mathml
229ac_add_options --enable-optimize="%{rpmcflags}"
230ac_add_options --enable-pango
231ac_add_options --enable-reorder
232ac_add_options --enable-static
233ac_add_options --disable-strip
234ac_add_options --disable-strip-libs
235ac_add_options --enable-system-cairo
236#ac_add_options --enable-system-hunspell
237ac_add_options --enable-svg
238ac_add_options --enable-xft
239ac_add_options --enable-application=mail
240ac_add_options --enable-default-toolkit=cairo-gtk2
241ac_add_options --enable-xinerama
242ac_add_options --with-system-jpeg
243ac_add_options --with-system-nspr
244ac_add_options --with-system-nss
245ac_add_options --with-system-png
246ac_add_options --with-system-zlib
247ac_add_options --with-pthreads
248ac_add_options --enable-single-profile
249ac_add_options --disable-profilesharing
250ac_add_options --with-distribution-id=org.pld-linux
251ac_add_options --with-branding=icedove/branding
252ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
253EOF
254
255%{__make} -j1 -f client.mk build \
256 STRIP="/bin/true" \
257 CC="%{__cc}" \
258 CXX="%{__cxx}"
259
260%if %{with enigmail}
261cd mailnews/extensions/enigmail
262./makemake -r
263%{__make} -C ../../../obj-%{_target_cpu}/mailnews/extensions/enigmail \
264 STRIP="/bin/true" \
265 CC="%{__cc}" \
266 CXX="%{__cxx}"
267%endif
268
269%install
270rm -rf $RPM_BUILD_ROOT
271install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_pixmapsdir},%{_desktopdir}} \
272 $RPM_BUILD_ROOT%{_datadir}/%{name}
273install -d $RPM_BUILD_ROOT%{_libdir}/%{name}
274
275cd mozilla
276%{__make} -C obj-%{_target_cpu}/mail/installer stage-package \
277 DESTDIR=$RPM_BUILD_ROOT \
278 MOZ_PKG_APPDIR=%{_libdir}/%{name} \
279 PKG_SKIP_STRIP=1
280
281# move arch independant ones to datadir
282mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
283mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
284mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
285#mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
286mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
287mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
288ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
289ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
290ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
291#ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
292ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
293ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
294
295rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
296ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
297
298%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
299ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
300ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
301
302install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
303
304%if %{with enigmail}
305_enig_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
306install -d $_enig_dir/chrome
307install -d $_enig_dir/components
308install -d $_enig_dir/defaults/preferences
309mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail.jar $_enig_dir/chrome
310mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/enig* $_enig_dir/components
311mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/libenigmime.so $_enig_dir/components
312mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/ipc.xpt $_enig_dir/components
313mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults/preferences/enigmail.js $_enig_dir/defaults/preferences
314cp -f mailnews/extensions/enigmail/package/install.rdf $_enig_dir
315rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults/preferences
316rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-en-US.jar
317rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-skin.jar
318rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmime.jar
319rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/components/enig*
320rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/libenigmime.so
321rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/ipc.xpt
322cp -f %{SOURCE6} $_enig_dir/chrome.manifest
323cp -f icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/icedove.png
324%endif
325
326# win32 stuff
327rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/dirver
328
329%clean
330rm -rf $RPM_BUILD_ROOT
331
332%pretrans
333if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
334 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
335fi
336for d in chrome defaults greprefs icons isp res; do
337 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
338 install -d %{_datadir}/%{name}
339 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
340 fi
341done
342exit 0
343
344%files
345%defattr(644,root,root,755)
346%attr(755,root,root) %{_bindir}/icedove
347%attr(755,root,root) %{_bindir}/mozilla-thunderbird
348%attr(755,root,root) %{_bindir}/thunderbird
349%dir %{_libdir}/%{name}
350%{_libdir}/%{name}/*.ini
351%dir %{_libdir}/%{name}/components
352%attr(755,root,root) %{_libdir}/%{name}/components/*.so
353%{_libdir}/%{name}/components/*.js
354%{_libdir}/%{name}/components/*.xpt
355%attr(755,root,root) %{_libdir}/%{name}/*.so
356%attr(755,root,root) %{_libdir}/%{name}/*.sh
357%attr(755,root,root) %{_libdir}/%{name}/*-bin
358%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
359#%attr(755,root,root) %{_libdir}/%{name}/reg*
360%attr(755,root,root) %{_libdir}/%{name}/icedove
361%{_libdir}/%{name}/*.txt
362#%attr(755,root,root) %{_libdir}/%{name}/x*
363
364# symlinks
365%{_libdir}/%{name}/chrome
366%{_libdir}/%{name}/defaults
367%{_libdir}/%{name}/dictionaries
368%{_libdir}/%{name}/greprefs
369#%{_libdir}/%{name}/icons
370%{_libdir}/%{name}/isp
371%{_libdir}/%{name}/res
372
373%{_libdir}/%{name}/dependentlibs.list
374#%{_libdir}/%{name}/updater
375#%{_libdir}/%{name}/update.locale
376#%{_pixmapsdir}/*.png
377%{_desktopdir}/*.desktop
378
379%dir %{_datadir}/%{name}
380%{_datadir}/%{name}/chrome
381%{_datadir}/%{name}/defaults
382%{_datadir}/%{name}/greprefs
383#%{_datadir}/%{name}/icons
384%{_datadir}/%{name}/isp
385%{_datadir}/%{name}/res
386
387%dir %{_libdir}/%{name}/modules
388%{_libdir}/%{name}/modules/*.js*
389%dir %{_libdir}/%{name}/modules/activity
390%{_libdir}/%{name}/modules/activity/*.js
391%dir %{_libdir}/%{name}/modules/gloda
392%{_libdir}/%{name}/modules/gloda/*.js
393
394%dir %{_libdir}/%{name}/extensions
395%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
396%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
397
398%if %{with enigmail}
399%files addon-enigmail
400%defattr(644,root,root,755)
401%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
402%endif
This page took 0.08627 seconds and 4 git commands to generate.