]> git.pld-linux.org Git - packages/thunderbird.git/blame_incremental - icedove.spec
- up to 3.0.3
[packages/thunderbird.git] / icedove.spec
... / ...
CommitLineData
1#
2# TODO:
3# - separate spec for enigmail
4#
5# Conditional builds
6%bcond_without enigmail # don't build enigmail - GPG/PGP support
7%bcond_without gnomeui # disable gnomeui support
8%bcond_without gnomevfs # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
9%bcond_without gnome # disable all GNOME components (gnome+gnomeui+gnomevfs)
10%bcond_without ldap # disable e-mail address lookups in LDAP directories
11%bcond_without lightning # disable sunbird calendar
12#
13%if %{without gnome}
14%undefine with_gnomeui
15%undefine with_gnomevfs
16%endif
17%define enigmail_ver 1.0.1
18
19Summary: Icedove - email client
20Summary(pl.UTF-8): Icedove - klient poczty
21Name: icedove
22Version: 3.0.3
23Release: 1
24License: MPL 1.1 or GPL v2+ or LGPL v2.1+
25Group: Applications/Networking
26Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
27# Source0-md5: 89e759fd7a6ab0f1cb0d089d9c89f3ee
28Source1: http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
29# Source1-md5: 508ca9ab0396afb49e82eda88014924b
30Source2: %{name}-branding.tar.bz2
31# Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
32Source3: %{name}-rm_nonfree.sh
33Source4: %{name}.desktop
34Source5: %{name}.sh
35Source6: %{name}-enigmail.manifest
36Patch0: %{name}-branding.patch
37Patch1: %{name}-enigmail-shared.patch
38Patch2: %{name}-gcc.patch
39Patch3: %{name}-fonts.patch
40Patch4: %{name}-install.patch
41Patch5: %{name}-hunspell.patch
42Patch6: %{name}-prefs.patch
43Patch7: %{name}-libpng.patch
44URL: http://www.pld-linux.org/Packages/Icedove
45%{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
46BuildRequires: automake
47BuildRequires: freetype-devel >= 1:2.1.8
48%{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
49BuildRequires: gtk+2-devel >= 1:2.0.0
50BuildRequires: hunspell-devel
51BuildRequires: libIDL-devel >= 0.8.0
52%{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
53%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
54BuildRequires: libjpeg-devel >= 6b
55BuildRequires: libpng-devel >= 1.2.0
56BuildRequires: libstdc++-devel
57BuildRequires: nspr-devel >= 1:4.8
58BuildRequires: nss-devel >= 1:3.12.0
59BuildRequires: pango-devel >= 1:1.1.0
60BuildRequires: pkgconfig
61BuildRequires: sed >= 4.0
62BuildRequires: startup-notification-devel >= 0.8
63BuildRequires: xorg-lib-libXext-devel
64BuildRequires: xorg-lib-libXinerama-devel
65BuildRequires: xorg-lib-libXt-devel
66BuildRequires: zip
67Requires: myspell-common
68Requires: nspr >= 1:4.6.1
69Requires: nss >= 1:3.11.3
70Obsoletes: mozilla-thunderbird
71Obsoletes: mozilla-thunderbird-dictionary-en-US
72BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
75
76# iceweasel/icedove/iceape provide their own versions
77%define _noautoreqdep libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so libxpistub.so
78%define _noautoprovfiles %{_libdir}/%{name}/components
79# we don't want these to satisfy xulrunner-devel
80%define _noautoprov libgtkembedmoz.so libldap50.so libmozjs.so libprldap50.so libssldap50.so libxpcom.so libxul.so
81# and as we don't provide them, don't require either
82%define _noautoreq libgtkembedmoz.so libldap50.so libmozjs.so libprldap50.so libssldap50.so libxpcom.so libxul.so
83
84%description
85Icedove is an open-source,fast and portable email client.
86
87%description -l pl.UTF-8
88Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
89
90%package addon-lightning
91Summary: An integrated calendar for Icedove
92Summary(pl.UTF-8): Zintegrowany kalendarz dla Icedove
93License: MPL 1.1 or GPL v2+ or LGPL v2.1+
94Group: Applications/Networking
95Requires: %{name} = %{version}-%{release}
96
97%description addon-lightning
98Lightning is an calendar extension to Icedove email client.
99
100%description addon-lightning -l pl.UTF-8
101Lightning to rozszerzenie do klienta poczty Icedove dodające
102funkcjonalność kalendarza.
103
104%package addon-enigmail
105Summary: Extension for the authentication and encryption features provided by GnuPG
106Summary(pl.UTF-8): Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
107License: MPL/LGPL
108Group: Applications/Networking
109URL: http://enigmail.mozdev.org/
110Requires: %{name} = %{version}-%{release}
111Requires: gnupg
112Obsoletes: mozilla-thunderbird-addon-enigmail
113
114%description addon-enigmail
115Enigmail is an extension to the Icedove mail client which allows users
116to access the authentication and encryption features provided by
117GnuPG.
118
119Main Features:
120- Encrypt/sign mail when sending, decrypt/authenticate received mail
121- Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
122- Per-Account based encryption and signing defaults
123- Per-Recipient rules for automated key selection, and
124 enabling/disabling encryption and signing
125- OpenPGP key management interface
126
127%description addon-enigmail -l pl.UTF-8
128Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
129użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
130przez GnuPG.
131
132Główne możliwości:
133- szyfrowanie/podpisywanie poczty przy wysyłaniu,
134 odszyfrowywanie/uwierzytelnianie poczty odebranej
135- obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
136- ustawienia domyślne szyfrowania i podpisywania dla każdego konta
137- reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
138 podpisywania dla każdego adresata
139- interfejs do zarządzania kluczami OpenPGP
140
141%prep
142%setup -qc
143mv -f comm-1.9.1 mozilla
144%setup -q -T -D -a2
145cd mozilla
146%{?with_enigmail:tar xvfz %{SOURCE1} -C mailnews/extensions}
147/bin/sh %{SOURCE3}
148%patch0 -p1
149%{?with_enigmail:%patch1 -p1}
150%patch2 -p1
151%patch3 -p1
152%patch4 -p1
153%patch5 -p1
154%patch6 -p1
155%patch7 -p1
156
157%build
158cd mozilla
159export CFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
160export CXXFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
161
162cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
163cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
164cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
165
166cat << 'EOF' > .mozconfig
167mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
168
169# Options for 'configure' (same as command-line options).
170ac_add_options --prefix=%{_prefix}
171ac_add_options --exec-prefix=%{_exec_prefix}
172ac_add_options --bindir=%{_bindir}
173ac_add_options --sbindir=%{_sbindir}
174ac_add_options --sysconfdir=%{_sysconfdir}
175ac_add_options --datadir=%{_datadir}
176ac_add_options --includedir=%{_includedir}
177ac_add_options --libdir=%{_libdir}
178ac_add_options --libexecdir=%{_libexecdir}
179ac_add_options --localstatedir=%{_localstatedir}
180ac_add_options --sharedstatedir=%{_sharedstatedir}
181ac_add_options --mandir=%{_mandir}
182ac_add_options --infodir=%{_infodir}
183%if %{?debug:1}0
184ac_add_options --disable-optimize
185ac_add_options --enable-debug
186ac_add_options --enable-debug-modules
187ac_add_options --enable-debugger-info-modules
188ac_add_options --enable-crash-on-assert
189%else
190ac_add_options --disable-debug
191ac_add_options --disable-debug-modules
192ac_add_options --disable-logging
193ac_add_options --enable-optimize="%{rpmcflags} -Os"
194%endif
195%if %{with tests}
196ac_add_options --enable-tests
197%else
198ac_add_options --disable-tests
199%endif
200%if %{with gnomeui}
201ac_add_options --enable-gnomeui
202%else
203ac_add_options --disable-gnomeui
204%endif
205%if %{with gnomevfs}
206ac_add_options --enable-gnomevfs
207%else
208ac_add_options --disable-gnomevfs
209%endif
210%if %{with ldap}
211ac_add_options --enable-ldap
212%else
213ac_add_options --disable-ldap
214%endif
215ac_add_options --disable-crashreporter
216ac_add_options --disable-updater
217ac_add_options --disable-xterm-updates
218ac_add_options --enable-ldap
219ac_add_options --enable-postscript
220ac_add_options --enable-startup-notification
221%if %{with lightning}
222ac_add_options --enable-calendar
223%else
224ac_add_options --disable-calendar
225%endif
226ac_add_options --disable-installer
227ac_add_options --disable-jsd
228ac_add_options --disable-xprint
229ac_add_options --disable-permissions
230ac_add_options --disable-pref-extensions
231ac_add_options --enable-canvas
232ac_add_options --enable-crypto
233ac_add_options --enable-default-toolkit="gtk2"
234ac_add_options --enable-mathml
235ac_add_options --enable-optimize="%{rpmcflags}"
236ac_add_options --enable-pango
237ac_add_options --enable-reorder
238ac_add_options --enable-static
239ac_add_options --disable-strip
240ac_add_options --disable-strip-libs
241ac_add_options --enable-system-cairo
242ac_add_options --enable-system-hunspell
243ac_add_options --enable-svg
244ac_add_options --enable-xft
245ac_add_options --enable-application=mail
246ac_add_options --enable-default-toolkit=cairo-gtk2
247ac_add_options --enable-xinerama
248ac_add_options --with-system-jpeg
249ac_add_options --with-system-nspr
250ac_add_options --with-system-nss
251ac_add_options --with-system-png
252ac_add_options --with-system-zlib
253ac_add_options --with-pthreads
254ac_add_options --enable-single-profile
255ac_add_options --disable-profilesharing
256ac_add_options --with-distribution-id=org.pld-linux
257ac_add_options --with-branding=icedove/branding
258ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
259EOF
260
261%{__make} -j1 -f client.mk build \
262 STRIP="/bin/true" \
263 CC="%{__cc}" \
264 CXX="%{__cxx}"
265
266%if %{with enigmail}
267cd mailnews/extensions/enigmail
268./makemake -r
269%{__make} -C ../../../obj-%{_target_cpu}/mailnews/extensions/enigmail \
270 STRIP="/bin/true" \
271 CC="%{__cc}" \
272 CXX="%{__cxx}"
273%endif
274
275%install
276rm -rf $RPM_BUILD_ROOT
277install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_pixmapsdir},%{_desktopdir}} \
278 $RPM_BUILD_ROOT%{_datadir}/%{name}
279install -d $RPM_BUILD_ROOT%{_libdir}/%{name}
280
281cd mozilla
282%{__make} -C obj-%{_target_cpu}/mail/installer stage-package \
283 DESTDIR=$RPM_BUILD_ROOT \
284 MOZ_PKG_APPDIR=%{_libdir}/%{name} \
285 PKG_SKIP_STRIP=1
286
287# move arch independant ones to datadir
288mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
289mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
290mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
291mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
292mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
293ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
294ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
295ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
296ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
297ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
298
299rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
300ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
301
302%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
303ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
304ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
305
306install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
307
308%if %{with enigmail}
309_enig_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
310install -d $_enig_dir/chrome
311install -d $_enig_dir/components
312install -d $_enig_dir/defaults/preferences
313mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail.jar $_enig_dir/chrome
314mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/enig* $_enig_dir/components
315mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/libenigmime.so $_enig_dir/components
316mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/ipc.xpt $_enig_dir/components
317mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults/preferences/enigmail.js $_enig_dir/defaults/preferences
318cp -f mailnews/extensions/enigmail/package/install.rdf $_enig_dir
319rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults/preferences
320rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-en-US.jar
321rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-skin.jar
322rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmime.jar
323rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/components/enig*
324rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/libenigmime.so
325rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/ipc.xpt
326cp -f %{SOURCE6} $_enig_dir/chrome.manifest
327cp -f icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/icedove.png
328%endif
329
330# win32 stuff
331rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/dirver
332
333%clean
334rm -rf $RPM_BUILD_ROOT
335
336%pretrans
337if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
338 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
339fi
340for d in chrome defaults greprefs icons isp res; do
341 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
342 install -d %{_datadir}/%{name}
343 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
344 fi
345done
346exit 0
347
348%files
349%defattr(644,root,root,755)
350%attr(755,root,root) %{_bindir}/icedove
351%attr(755,root,root) %{_bindir}/mozilla-thunderbird
352%attr(755,root,root) %{_bindir}/thunderbird
353%dir %{_libdir}/%{name}
354%{_libdir}/%{name}/*.ini
355%dir %{_libdir}/%{name}/components
356%attr(755,root,root) %{_libdir}/%{name}/components/*.so
357%{_libdir}/%{name}/components/*.js
358%{_libdir}/%{name}/components/*.xpt
359%attr(755,root,root) %{_libdir}/%{name}/*.so
360%attr(755,root,root) %{_libdir}/%{name}/*.sh
361%attr(755,root,root) %{_libdir}/%{name}/*-bin
362%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
363%attr(755,root,root) %{_libdir}/%{name}/icedove
364
365# symlinks
366%{_libdir}/%{name}/chrome
367%{_libdir}/%{name}/defaults
368%{_libdir}/%{name}/dictionaries
369%{_libdir}/%{name}/greprefs
370%{_libdir}/%{name}/isp
371%{_libdir}/%{name}/res
372
373%{_libdir}/%{name}/dependentlibs.list
374%{_pixmapsdir}/*.png
375%{_desktopdir}/*.desktop
376
377%dir %{_datadir}/%{name}
378%{_datadir}/%{name}/chrome
379%{_datadir}/%{name}/defaults
380%{_datadir}/%{name}/greprefs
381%{_datadir}/%{name}/isp
382%{_datadir}/%{name}/res
383
384%dir %{_libdir}/%{name}/modules
385%{_libdir}/%{name}/modules/*.js*
386%dir %{_libdir}/%{name}/modules/activity
387%{_libdir}/%{name}/modules/activity/*.js
388%dir %{_libdir}/%{name}/modules/gloda
389%{_libdir}/%{name}/modules/gloda/*.js
390
391%dir %{_libdir}/%{name}/extensions
392%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
393
394%if %{with lightning}
395%files addon-lightning
396%defattr(644,root,root,755)
397%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
398%{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
399%endif
400
401%if %{with enigmail}
402%files addon-enigmail
403%defattr(644,root,root,755)
404%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
405%endif
This page took 0.0348 seconds and 4 git commands to generate.