]> git.pld-linux.org Git - packages/thrift.git/commitdiff
- few debian patches
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 27 Sep 2018 13:48:25 +0000 (15:48 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 27 Sep 2018 13:48:25 +0000 (15:48 +0200)
no_bundler_use.patch [new file with mode: 0644]
no_grunt.patch [new file with mode: 0644]
no_pom.patch [new file with mode: 0644]
thrift.spec

diff --git a/no_bundler_use.patch b/no_bundler_use.patch
new file mode 100644 (file)
index 0000000..26b1ab3
--- /dev/null
@@ -0,0 +1,121 @@
+Description: do not use bundler as per Ruby policy
+ .
+Author: Laszlo Boszormenyi (GCS) <gcs@debian.org>
+Bug-Debian: https://bugs.debian.org/804668
+
+---
+The information above should follow the Patch Tagging Guidelines, please
+checkout http://dep.debian.net/deps/dep3/ to learn about the format. Here
+are templates for supplementary fields that you might want to add:
+
+Origin: <vendor|upstream|other>, <url of original patch>
+Bug: <url in upstream bugtracker>
+Bug-Debian: https://bugs.debian.org/<bugnumber>
+Bug-Ubuntu: https://launchpad.net/bugs/<bugnumber>
+Forwarded: <no|not-needed|url proving that it has been forwarded>
+Reviewed-By: <name and email of someone who approved the patch>
+Last-Update: <YYYY-MM-DD>
+
+--- thrift-0.9.3.orig/lib/rb/Makefile.am
++++ thrift-0.9.3/lib/rb/Makefile.am
+@@ -22,19 +22,23 @@ DESTDIR ?= /
+ if HAVE_BUNDLER
+ all-local:
+-      $(BUNDLER) install
+-      $(BUNDLER) exec rake build_ext
++      echo Do not use bundler for all-local
++#     $(BUNDLER) install
++#     $(BUNDLER) exec rake build_ext
+ install-exec-hook:
+-      $(BUNDLER) exec rake install
++      echo Do not use bundler for install-exec-hook
++#     $(BUNDLER) exec rake install
+ clean-local:
+-      $(BUNDLER) install
+-      $(BUNDLER) exec rake clean
++      echo Do not use bundler for clean-local
++#     $(BUNDLER) install
++#     $(BUNDLER) exec rake clean
+ check-local: all
+-      $(BUNDLER) install
+-      $(BUNDLER) exec rake
++      echo Do not use bundler for check-local
++#     $(BUNDLER) install
++#     $(BUNDLER) exec rake
+ endif
+--- thrift-0.9.3.orig/lib/rb/Makefile.in
++++ thrift-0.9.3/lib/rb/Makefile.in
+@@ -605,19 +605,19 @@ uninstall-am:
+ DESTDIR ?= /
+ @HAVE_BUNDLER_TRUE@all-local:
+-@HAVE_BUNDLER_TRUE@   $(BUNDLER) install
+-@HAVE_BUNDLER_TRUE@   $(BUNDLER) exec rake build_ext
++@HAVE_BUNDLER_TRUE@   echo No $(BUNDLER) install
++@HAVE_BUNDLER_TRUE@   echo No $(BUNDLER) exec rake build_ext
+ @HAVE_BUNDLER_TRUE@install-exec-hook:
+-@HAVE_BUNDLER_TRUE@   $(BUNDLER) exec rake install
++@HAVE_BUNDLER_TRUE@   echo No $(BUNDLER) exec rake install
+ @HAVE_BUNDLER_TRUE@clean-local:
+-@HAVE_BUNDLER_TRUE@   $(BUNDLER) install
+-@HAVE_BUNDLER_TRUE@   $(BUNDLER) exec rake clean
++@HAVE_BUNDLER_TRUE@   echo No $(BUNDLER) install
++@HAVE_BUNDLER_TRUE@   echo No $(BUNDLER) exec rake clean
+ @HAVE_BUNDLER_TRUE@check-local: all
+-@HAVE_BUNDLER_TRUE@   $(BUNDLER) install
+-@HAVE_BUNDLER_TRUE@   $(BUNDLER) exec rake
++@HAVE_BUNDLER_TRUE@   echo No $(BUNDLER) install
++@HAVE_BUNDLER_TRUE@   echo No $(BUNDLER) exec rake
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+--- thrift-0.9.3.orig/test/rb/Makefile
++++ thrift-0.9.3/test/rb/Makefile
+@@ -591,8 +591,9 @@ stubs: $(THRIFT) ../ThriftTest.thrift ..
+ precross: stubs
+ check: stubs
+-      $(BUNDLER) install
+-      $(BUNDLER) exec $(RUBY) -I. test_suite.rb
++      echo Do not use bundler for check
++#     $(BUNDLER) install
++#     $(BUNDLER) exec $(RUBY) -I. test_suite.rb
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+--- thrift-0.9.3.orig/test/rb/Makefile.am
++++ thrift-0.9.3/test/rb/Makefile.am
+@@ -27,7 +27,8 @@ precross: stubs
+ check: stubs
+ if HAVE_BUNDLER
+-      $(BUNDLER) install
+-      $(BUNDLER) exec $(RUBY) -I. test_suite.rb
++      echo Do not use bundler for check
++#     $(BUNDLER) install
++#     $(BUNDLER) exec $(RUBY) -I. test_suite.rb
+ endif
+--- thrift-0.9.3.orig/test/rb/Makefile.in
++++ thrift-0.9.3/test/rb/Makefile.in
+@@ -591,8 +591,9 @@ stubs: $(THRIFT) ../ThriftTest.thrift ..
+ precross: stubs
+ check: stubs
+-@HAVE_BUNDLER_TRUE@   $(BUNDLER) install
+-@HAVE_BUNDLER_TRUE@   $(BUNDLER) exec $(RUBY) -I. test_suite.rb
++@HAVE_BUNDLER_TRUE@   echo Do not use bundler for check
++@HAVE_BUNDLER_TRUE@   #$(BUNDLER) install
++@HAVE_BUNDLER_TRUE@   #$(BUNDLER) exec $(RUBY) -I. test_suite.rb
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/no_grunt.patch b/no_grunt.patch
new file mode 100644 (file)
index 0000000..e1d62a8
--- /dev/null
@@ -0,0 +1,10 @@
+--- thrift-0.11.0/configure.ac~        2017-12-03 20:11:35.000000000 +0100
++++ thrift-0.11.0/configure.ac 2018-09-27 15:33:08.540297485 +0200
+@@ -269,7 +269,6 @@ AX_THRIFT_LIB(nodejs, [Nodejs], yes)
+ have_nodejs=no
+ if test "$with_nodejs" = "yes"; then
+   AC_PATH_PROGS([NODEJS], [nodejs node])
+-  AC_PATH_PROG([NPM], [npm])
+   if test "x$NODEJS" != "x" -a "x$NPM" != "x"; then
+     have_nodejs="yes"
+   fi
diff --git a/no_pom.patch b/no_pom.patch
new file mode 100644 (file)
index 0000000..5b98780
--- /dev/null
@@ -0,0 +1,18 @@
+Description: no need for ANT Maven task
+ Just disable its download.
+Author: Laszlo Boszormenyi (GCS) <gcs@debian.org>
+
+---
+
+--- thrift-0.9.2.orig/lib/java/build.xml
++++ thrift-0.9.2/lib/java/build.xml
+@@ -295,7 +295,9 @@
+   </target>
+   <target name="mvn.ant.tasks.download" depends="setup.init,mvn.ant.tasks.check,proxy" unless="mvn.ant.tasks.found">
++<!--
+     <get src="${mvn.ant.task.url}/${mvn.ant.task.jar}" dest="${build.tools.dir}/${mvn.ant.task.jar}" usetimestamp="true"/>
++-->
+   </target>
+   <target name="mvn.ant.tasks.check">
index c235ba13bc4b982f8d79c58d3e7a286429f4112d..ab49898f6eca6c6706036ffdcb1a0dc1cfe3fa87 100644 (file)
@@ -61,8 +61,9 @@ License:      Apache v2.0
 Group:         Development/Libraries
 Source0:       http://www.apache.org/dist/thrift/%{version}/%{name}-%{version}.tar.gz
 # Source0-md5: 0be59730ebce071eceaf6bfdb8d3a20e
-Patch0:                %{name}-Werror_strlcpy_fix.patch
-Patch1:                %{name}-cpp_link_fix.patch
+Patch0:                no_bundler_use.patch
+Patch1:                no_grunt.patch
+Patch2:                no_pom.patch
 URL:           http://thrift.apache.org/
 BuildRequires: autoconf
 BuildRequires: automake >= 1:1.13
@@ -218,8 +219,9 @@ Interfejs thrift dla Perla.
 
 %prep
 %setup -q
-#%patch0 -p1
-#%patch1 -p1
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
 
 %build
 %{__aclocal} -I aclocal
This page took 0.137 seconds and 4 git commands to generate.