]> git.pld-linux.org Git - packages/tf.git/commitdiff
- fix build with pcre 8.30 auto/th/tf-50b8-4
authorArtur Frysiak <artur@frysiak.net>
Wed, 28 Mar 2012 14:20:52 +0000 (14:20 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- rel. 4

Changed files:
    pcre.patch -> 1.1
    tf.spec -> 1.38

pcre.patch [new file with mode: 0644]
tf.spec

diff --git a/pcre.patch b/pcre.patch
new file mode 100644 (file)
index 0000000..416f14d
--- /dev/null
@@ -0,0 +1,34 @@
+--- tf-50b8/src/pattern.h.wiget        2012-03-28 14:25:55.720865901 +0200
++++ tf-50b8/src/pattern.h      2012-03-28 14:26:14.157532261 +0200
+@@ -10,7 +10,7 @@
+ #ifndef PATTERN_H
+ #define PATTERN_H
+-#include "pcre-2.08/pcre.h"
++#include <pcre.h>
+ typedef struct RegInfo {
+     pcre *re;
+--- tf-50b8/src/pattern.c.wiget        2012-03-28 15:55:13.910312594 +0200
++++ tf-50b8/src/pattern.c      2012-03-28 15:56:16.456978228 +0200
+@@ -151,7 +151,7 @@ static RegInfo *tf_reg_compile_fl(const
+           emsg ? emsg : "unknown error");
+       goto tf_reg_compile_error;
+     }
+-    n = pcre_info(ri->re, NULL, NULL);
++    pcre_fullinfo(ri->re, NULL, PCRE_INFO_CAPTURECOUNT, &n);
+     if (n < 0) goto tf_reg_compile_error;
+     ri->ovecsize = 3 * (n + 1);
+     ri->ovector = dmalloc(NULL, sizeof(int) * ri->ovecsize, file, line);
+--- tf-50b8/src/macro.c.wiget  2012-03-28 13:44:42.280320322 +0200
++++ tf-50b8/src/macro.c        2012-03-28 15:56:32.813644628 +0200
+@@ -893,7 +893,8 @@ static int complete_macro(Macro *spec, u
+     }
+     spec->attr &= ~F_NONE;
+     if (spec->nsubattr) {
+-      int n = pcre_info(spec->trig.ri->re, NULL, NULL);
++      int n;
++      pcre_fullinfo(spec->trig.ri->re, NULL, PCRE_INFO_CAPTURECOUNT, &n);
+       for (i = 0; i < spec->nsubattr; i++) {
+           spec->subattr[i].attr &= ~F_NONE;
+           if (spec->subattr[i].subexp > n) {
diff --git a/tf.spec b/tf.spec
index 102a8928f69c1fb7de21c70f3cd3f4c58a9bd924..cd7d8eede640d3e12cdc75ddf470a00f79ef5b11 100644 (file)
--- a/tf.spec
+++ b/tf.spec
@@ -6,7 +6,7 @@ Summary:        tf - TinyFugue - text-mode MUD client
 Summary(pl.UTF-8):     tf - TinyFugue - tekstowy klient do MUD-ów
 Name:          tf
 Version:       50b8
-Release:       3
+Release:       4
 License:       GPL
 Group:         Applications/Games
 Source0:       http://dl.sourceforge.net/tinyfugue/%{name}-%{version}.tar.gz
@@ -15,6 +15,7 @@ Source1:      http://dl.sourceforge.net/tinyfugue/%{name}-%{doc_ver}-help.tar.gz
 # Source1-md5: 26eb64b2f811c8143e9c08654d26d138
 Source2:       http://www.ingwar.eu.org/downloads/%{name}.syntax.gz
 # Source2-md5: 398aa4c28e83fb2ce688eade24c5fc88
+Patch0:                pcre.patch
 URL:           http://sourceforge.net/projects/tinyfugue/
 BuildRequires: autoconf
 BuildRequires: ncurses-devel
@@ -50,6 +51,8 @@ Pliki pomocy w HTML.
 %setup -q
 tar xzPf %{SOURCE1}
 cp %{SOURCE2} .
+%patch0 -p1
+
 %build
 %{__autoconf}
 %configure
This page took 0.050938 seconds and 4 git commands to generate.