]> git.pld-linux.org Git - packages/texlive.git/commitdiff
- fix constants narrowing error on C++11
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 6 Dec 2017 09:56:19 +0000 (10:56 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 6 Dec 2017 09:56:19 +0000 (10:56 +0100)
cxx11.patch [new file with mode: 0644]
texlive.spec

diff --git a/cxx11.patch b/cxx11.patch
new file mode 100644 (file)
index 0000000..67fc946
--- /dev/null
@@ -0,0 +1,11 @@
+--- texlive-20080816-source/libs/icu-xetex/tools/genuca/genuca.cpp.orig        2008-03-04 14:26:36.000000000 +0100
++++ texlive-20080816-source/libs/icu-xetex/tools/genuca/genuca.cpp     2017-12-06 08:54:13.824347675 +0100
+@@ -882,7 +882,7 @@
+ struct {
+       UChar32 start;
+       UChar32 end;
+-      int32_t value;
++      uint32_t value;
+     } ranges[] =
+     {
+ #if 0
index 9b7603f5aaa7ea8293b55ab83d10da9f544c0338..d1ec5ca5250e428f8cb4a57da0bd65374066b03b 100644 (file)
@@ -95,6 +95,7 @@ Patch12:      %{name}-system-libpng.patch
 Patch13:       %{name}-system-zzip.patch
 Patch14:       %{name}-system-zlib.patch
 Patch15:       %{name}-xetex-zlib.patch
+Patch16:       cxx11.patch
 URL:           http://www.tug.org/texlive/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -6438,6 +6439,7 @@ lzma -dc %{SOURCE0} | tar xf - -C ..
 %patch13 -p1
 %patch14 -p1
 %patch15 -p1
+%patch16 -p1
 
 CURDIR=$(pwd)
 cd utils/xindy/make-rules/alphabets
This page took 0.114024 seconds and 4 git commands to generate.