]> git.pld-linux.org Git - packages/texlive.git/blobdiff - texlive.spec
- process all and then fail
[packages/texlive.git] / texlive.spec
index 09e694cadb18c823831fc3ea52b6fc1a8beb9c5d..71e9e841ecf8e98661d154174184cdb333e4c41d 100644 (file)
@@ -6013,6 +6013,7 @@ rm -rf $RPM_BUILD_ROOT%{_datadir}/xindy
 rm -rf $RPM_BUILD_ROOT%{_datadir}/doc
 
 # Create format files
+failed=""
 for format in \
        aleph \
        csplain \
@@ -6043,9 +6044,16 @@ for format in \
 #  %else
        out=$(fmtutil --fmtdir $RPM_BUILD_ROOT%{fmtdir} --byfmt=${format})
        echo $out
-       [ -z $out ] && echo "fmtutil for format ${format} failed. Likely ${format}.ini file missing..." && exit 1
+       if [ -z $out ]; then
+               failed="$failed ${format}"
+       fi
 #  %endif
 done
+if [ -n "$failed" ]; then
+       echo "fmtutil formats failed: ${failed}. Missing format_name.ini files?" >&1
+       exit 1
+fi
+
 %if %{with bootstrap}
 touch $RPM_BUILD_ROOT%{fmtdir}/xetex/xelatex.fmt
 %endif
This page took 0.293224 seconds and 4 git commands to generate.