]> git.pld-linux.org Git - packages/tepl.git/blob - tepl.spec
- up to 2.99.2; introduces amtk library, no vapi in this version
[packages/tepl.git] / tepl.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        Tepl - Text editor product line
6 Summary(pl.UTF-8):      Tepl (Text editor product line) - linia produkcyjna edytorów
7 Name:           tepl
8 Version:        2.99.2
9 Release:        1
10 License:        LGPL v2.1+
11 Group:          Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/tepl/2.99/%{name}-%{version}.tar.xz
13 # Source0-md5:  2340f04086fdd565925c97da0f880ffa
14 URL:            https://wiki.gnome.org/Projects/Tepl
15 BuildRequires:  autoconf >= 2.64
16 BuildRequires:  automake >= 1:1.14
17 BuildRequires:  gettext-tools >= 0.19.4
18 BuildRequires:  glib2-devel >= 1:2.52
19 BuildRequires:  gobject-introspection-devel >= 1.42.0
20 BuildRequires:  gtk+3-devel >= 3.20
21 BuildRequires:  gtk-doc >= 1.25
22 BuildRequires:  gtksourceview3-devel >= 3.22
23 BuildRequires:  libtool >= 2:2.2.6
24 BuildRequires:  libxml2-devel >= 1:2.5
25 BuildRequires:  pkgconfig
26 BuildRequires:  uchardet-devel
27 #BuildRequires: vala
28 Requires:       glib2 >= 1:2.52
29 Requires:       gtk+3 >= 3.20
30 Requires:       gtksourceview3 >= 3.22
31 Requires:       libxml2 >= 1:2.5
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Tepl is a library that eases the development of GtkSourceView-based
36 text editors and IDEs.
37
38 Tepl was previously named Gtef (GTK+ text editor framework). The
39 project has been renamed in June 2017 to have a more beautiful name.
40
41 %description -l pl.UTF-8
42 Tepl to biblioteka ułatawiająca tworzenie edytorów tekstu i IDE
43 opartych na GtkSourceView.
44
45 Tepl wcześniej nazywał się Gtef (GTK+ text editor framework - skielet
46 edytorów tekstu GTK+); nazwa została zmieniona w czerwcu 2017 na
47 ładniej brzmiącą.
48
49 %package devel
50 Summary:        Header files for Tepl library
51 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Tepl
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       glib2-devel >= 1:2.52
55 Requires:       gtk+3-devel >= 3.20
56 Requires:       gtksourceview3-devel >= 3.22
57 Requires:       libxml2-devel >= 1:2.5
58 Requires:       uchardet-devel
59 # temporary? no vapi in 2.99.2
60 Obsoletes:      vala-tepl < 2.99.2
61
62 %description devel
63 Header files for Tepl library.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe biblioteki Tepl.
67
68 %package static
69 Summary:        Static Tepl library
70 Summary(pl.UTF-8):      Statyczna biblioteka Tepl
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 Static Tepl library.
76
77 %description static -l pl.UTF-8
78 Statyczna biblioteka Tepl.
79
80 %package -n vala-tepl
81 Summary:        Vala API for Tepl library
82 Summary(pl.UTF-8):      API języka Vala do biblioteki Tepl
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85 Requires:       vala
86
87 %description -n vala-tepl
88 Vala API for Tepl library.
89
90 %description -n vala-tepl -l pl.UTF-8
91 API języka Vala do biblioteki Tepl.
92
93 %package apidocs
94 Summary:        API documentation for Tepl library
95 Summary(pl.UTF-8):      Dokumentacja API biblioteki Tepl
96 Group:          Documentation
97 %if "%{_rpmversion}" >= "5"
98 BuildArch:      noarch
99 %endif
100
101 %description apidocs
102 API documentation for Tepl library.
103
104 %description apidocs -l pl.UTF-8
105 Dokumentacja API biblioteki Tepl.
106
107 %prep
108 %setup -q
109
110 %build
111 # rebuild ac/am/lt for as-needed to work
112 %{__libtoolize}
113 %{__aclocal} -I m4
114 %{__autoconf}
115 %{__autoheader}
116 %{__automake}
117 %configure \
118         --disable-silent-rules \
119         %{?with_static_libs:--enable-static} \
120         --with-html-dir=%{_gtkdocdir}
121 %{__make}
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125
126 %{__make} install \
127         DESTDIR=$RPM_BUILD_ROOT
128
129 # obsoleted by pkg-config
130 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
131
132 %find_lang tepl-3
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post   -p /sbin/ldconfig
138 %postun -p /sbin/ldconfig
139
140 %files -f tepl-3.lang
141 %defattr(644,root,root,755)
142 %doc AUTHORS NEWS README
143 %attr(755,root,root) %{_libdir}/libamtk-3.so.*.*.*
144 %attr(755,root,root) %ghost %{_libdir}/libamtk-3.so.0
145 %attr(755,root,root) %{_libdir}/libtepl-3.so.*.*.*
146 %attr(755,root,root) %ghost %{_libdir}/libtepl-3.so.0
147 %{_libdir}/girepository-1.0/Amtk-3.typelib
148 %{_libdir}/girepository-1.0/Tepl-3.typelib
149
150 %files devel
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_libdir}/libamtk-3.so
153 %attr(755,root,root) %{_libdir}/libtepl-3.so
154 %{_includedir}/amtk-3
155 %{_includedir}/tepl-3
156 %{_datadir}/gir-1.0/Amtk-3.gir
157 %{_datadir}/gir-1.0/Tepl-3.gir
158 %{_pkgconfigdir}/amtk-3.pc
159 %{_pkgconfigdir}/tepl-3.pc
160
161 %if %{with static_libs}
162 %files static
163 %defattr(644,root,root,755)
164 %{_libdir}/libamtk-3.a
165 %{_libdir}/libtepl-3.a
166 %endif
167
168 %if 0
169 %files -n vala-tepl
170 %defattr(644,root,root,755)
171 %{_datadir}/vala/vapi/tepl-3.deps
172 %{_datadir}/vala/vapi/tepl-3.vapi
173 %endif
174
175 %files apidocs
176 %defattr(644,root,root,755)
177 %{_gtkdocdir}/tepl-3.0
This page took 0.044824 seconds and 4 git commands to generate.