]> git.pld-linux.org Git - packages/tepl.git/blob - tepl.spec
- updated to 5.0.0 (new soname and API version)
[packages/tepl.git] / tepl.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation
4 %bcond_without  static_libs     # static library
5 #
6 Summary:        Tepl - Text editor product line
7 Summary(pl.UTF-8):      Tepl (Text editor product line) - linia produkcyjna edytorów
8 Name:           tepl
9 Version:        5.0.0
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/tepl/5.0/%{name}-%{version}.tar.xz
14 # Source0-md5:  c31271dd4b039b02676f82b2a853ad2c
15 URL:            https://wiki.gnome.org/Projects/Tepl
16 BuildRequires:  amtk-devel >= 5.0
17 BuildRequires:  gettext-tools >= 0.19.6
18 BuildRequires:  glib2-devel >= 1:2.64
19 BuildRequires:  gobject-introspection-devel >= 1.42.0
20 BuildRequires:  gtk+3-devel >= 3.22
21 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.25}
22 BuildRequires:  gtksourceview4-devel >= 4.0
23 BuildRequires:  libicu-devel
24 BuildRequires:  libxml2-devel >= 1:2.5
25 BuildRequires:  meson >= 0.53
26 BuildRequires:  ninja >= 1.5
27 BuildRequires:  pkgconfig
28 BuildRequires:  rpmbuild(macros) >= 1.736
29 #BuildRequires: vala
30 Requires:       glib2 >= 1:2.64
31 Requires:       gtk+3 >= 3.22
32 Requires:       gtksourceview4 >= 4.0
33 Requires:       libxml2 >= 1:2.5
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Tepl is a library that eases the development of GtkSourceView-based
38 text editors and IDEs.
39
40 Tepl was previously named Gtef (GTK+ text editor framework). The
41 project has been renamed in June 2017 to have a more beautiful name.
42
43 %description -l pl.UTF-8
44 Tepl to biblioteka ułatawiająca tworzenie edytorów tekstu i IDE
45 opartych na GtkSourceView.
46
47 Tepl wcześniej nazywał się Gtef (GTK+ text editor framework - skielet
48 edytorów tekstu GTK+); nazwa została zmieniona w czerwcu 2017 na
49 ładniej brzmiącą.
50
51 %package devel
52 Summary:        Header files for Tepl library
53 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Tepl
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       amtk-devel >= 5.0
57 Requires:       glib2-devel >= 1:2.64
58 Requires:       gtk+3-devel >= 3.22
59 Requires:       gtksourceview4-devel >= 4.0
60 Requires:       libicu-devel
61 Requires:       libxml2-devel >= 1:2.5
62 # temporary? no vapi in 2.99.2
63 Obsoletes:      vala-tepl < 2.99.2
64
65 %description devel
66 Header files for Tepl library.
67
68 %description devel -l pl.UTF-8
69 Pliki nagłówkowe biblioteki Tepl.
70
71 %package static
72 Summary:        Static Tepl library
73 Summary(pl.UTF-8):      Statyczna biblioteka Tepl
74 Group:          Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76
77 %description static
78 Static Tepl library.
79
80 %description static -l pl.UTF-8
81 Statyczna biblioteka Tepl.
82
83 %package -n vala-tepl
84 Summary:        Vala API for Tepl library
85 Summary(pl.UTF-8):      API języka Vala do biblioteki Tepl
86 Group:          Development/Libraries
87 Requires:       %{name}-devel = %{version}-%{release}
88 Requires:       vala
89 %if "%{_rpmversion}" >= "4.6"
90 BuildArch:      noarch
91 %endif
92
93 %description -n vala-tepl
94 Vala API for Tepl library.
95
96 %description -n vala-tepl -l pl.UTF-8
97 API języka Vala do biblioteki Tepl.
98
99 %package apidocs
100 Summary:        API documentation for Tepl library
101 Summary(pl.UTF-8):      Dokumentacja API biblioteki Tepl
102 Group:          Documentation
103 %if "%{_rpmversion}" >= "4.6"
104 BuildArch:      noarch
105 %endif
106
107 %description apidocs
108 API documentation for Tepl library.
109
110 %description apidocs -l pl.UTF-8
111 Dokumentacja API biblioteki Tepl.
112
113 %prep
114 %setup -q
115
116 %build
117 %meson build \
118         %{!?with_static_libs:--default-library=shared} \
119         %{?with_apidocs:-Dgtk_doc=true}
120
121 %ninja_build -C build
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125
126 %ninja_install -C build
127
128 %find_lang tepl-5
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   -p /sbin/ldconfig
134 %postun -p /sbin/ldconfig
135
136 %files -f tepl-5.lang
137 %defattr(644,root,root,755)
138 %doc AUTHORS NEWS README
139 %attr(755,root,root) %{_libdir}/libtepl-5.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libtepl-5.so.0
141 %{_libdir}/girepository-1.0/Tepl-5.typelib
142
143 %files devel
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_libdir}/libtepl-5.so
146 %{_includedir}/tepl-5
147 %{_datadir}/gir-1.0/Tepl-5.gir
148 %{_pkgconfigdir}/tepl-5.pc
149
150 %if %{with static_libs}
151 %files static
152 %defattr(644,root,root,755)
153 %{_libdir}/libtepl-5.a
154 %endif
155
156 %if 0
157 %files -n vala-tepl
158 %defattr(644,root,root,755)
159 %{_datadir}/vala/vapi/tepl-5.deps
160 %{_datadir}/vala/vapi/tepl-5.vapi
161 %endif
162
163 %if %{with apidocs}
164 %files apidocs
165 %defattr(644,root,root,755)
166 %{_gtkdocdir}/tepl-5
167 %endif
This page took 0.053001 seconds and 4 git commands to generate.