]> git.pld-linux.org Git - packages/tepl.git/blob - tepl.spec
- unconditional noarch subpackages
[packages/tepl.git] / tepl.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation
4 %bcond_without  static_libs     # static library
5 #
6 Summary:        Tepl - Text editor product line
7 Summary(pl.UTF-8):      Tepl (Text editor product line) - linia produkcyjna edytorów
8 Name:           tepl
9 Version:        5.0.1
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Libraries
13 Source0:        https://download.gnome.org/sources/tepl/5.0/%{name}-%{version}.tar.xz
14 # Source0-md5:  5b6b9e022de87ed804266d9edb0e0ff4
15 URL:            https://wiki.gnome.org/Projects/Tepl
16 BuildRequires:  amtk-devel >= 5.0
17 BuildRequires:  gettext-tools >= 0.19.6
18 BuildRequires:  glib2-devel >= 1:2.64
19 BuildRequires:  gobject-introspection-devel >= 1.42.0
20 BuildRequires:  gtk+3-devel >= 3.22
21 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.25}
22 BuildRequires:  gtksourceview4-devel >= 4.0
23 BuildRequires:  libicu-devel
24 BuildRequires:  libxml2-devel >= 1:2.5
25 BuildRequires:  meson >= 0.53
26 BuildRequires:  ninja >= 1.5
27 BuildRequires:  pkgconfig
28 BuildRequires:  rpmbuild(macros) >= 1.752
29 #BuildRequires: vala
30 Requires:       glib2 >= 1:2.64
31 Requires:       gtk+3 >= 3.22
32 Requires:       gtksourceview4 >= 4.0
33 Requires:       libxml2 >= 1:2.5
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Tepl is a library that eases the development of GtkSourceView-based
38 text editors and IDEs.
39
40 Tepl was previously named Gtef (GTK+ text editor framework). The
41 project has been renamed in June 2017 to have a more beautiful name.
42
43 %description -l pl.UTF-8
44 Tepl to biblioteka ułatawiająca tworzenie edytorów tekstu i IDE
45 opartych na GtkSourceView.
46
47 Tepl wcześniej nazywał się Gtef (GTK+ text editor framework - skielet
48 edytorów tekstu GTK+); nazwa została zmieniona w czerwcu 2017 na
49 ładniej brzmiącą.
50
51 %package devel
52 Summary:        Header files for Tepl library
53 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Tepl
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       amtk-devel >= 5.0
57 Requires:       glib2-devel >= 1:2.64
58 Requires:       gtk+3-devel >= 3.22
59 Requires:       gtksourceview4-devel >= 4.0
60 Requires:       libicu-devel
61 Requires:       libxml2-devel >= 1:2.5
62 # temporary? no vapi in 2.99.2
63 Obsoletes:      vala-tepl < 2.99.2
64
65 %description devel
66 Header files for Tepl library.
67
68 %description devel -l pl.UTF-8
69 Pliki nagłówkowe biblioteki Tepl.
70
71 %package static
72 Summary:        Static Tepl library
73 Summary(pl.UTF-8):      Statyczna biblioteka Tepl
74 Group:          Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76
77 %description static
78 Static Tepl library.
79
80 %description static -l pl.UTF-8
81 Statyczna biblioteka Tepl.
82
83 %package -n vala-tepl
84 Summary:        Vala API for Tepl library
85 Summary(pl.UTF-8):      API języka Vala do biblioteki Tepl
86 Group:          Development/Libraries
87 Requires:       %{name}-devel = %{version}-%{release}
88 Requires:       vala
89 BuildArch:      noarch
90
91 %description -n vala-tepl
92 Vala API for Tepl library.
93
94 %description -n vala-tepl -l pl.UTF-8
95 API języka Vala do biblioteki Tepl.
96
97 %package apidocs
98 Summary:        API documentation for Tepl library
99 Summary(pl.UTF-8):      Dokumentacja API biblioteki Tepl
100 Group:          Documentation
101 BuildArch:      noarch
102
103 %description apidocs
104 API documentation for Tepl library.
105
106 %description apidocs -l pl.UTF-8
107 Dokumentacja API biblioteki Tepl.
108
109 %prep
110 %setup -q
111
112 %build
113 %meson build \
114         %{!?with_static_libs:--default-library=shared} \
115         %{?with_apidocs:-Dgtk_doc=true}
116
117 %ninja_build -C build
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %ninja_install -C build
123
124 %find_lang tepl-5
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %files -f tepl-5.lang
133 %defattr(644,root,root,755)
134 %doc AUTHORS NEWS README
135 %attr(755,root,root) %{_libdir}/libtepl-5.so.*.*.*
136 %attr(755,root,root) %ghost %{_libdir}/libtepl-5.so.0
137 %{_libdir}/girepository-1.0/Tepl-5.typelib
138
139 %files devel
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_libdir}/libtepl-5.so
142 %{_includedir}/tepl-5
143 %{_datadir}/gir-1.0/Tepl-5.gir
144 %{_pkgconfigdir}/tepl-5.pc
145
146 %if %{with static_libs}
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/libtepl-5.a
150 %endif
151
152 %if 0
153 %files -n vala-tepl
154 %defattr(644,root,root,755)
155 %{_datadir}/vala/vapi/tepl-5.deps
156 %{_datadir}/vala/vapi/tepl-5.vapi
157 %endif
158
159 %if %{with apidocs}
160 %files apidocs
161 %defattr(644,root,root,755)
162 %{_gtkdocdir}/tepl-5
163 %endif
This page took 0.065583 seconds and 4 git commands to generate.