]> git.pld-linux.org Git - packages/tepl.git/blob - tepl.spec
e3f154b77febc9981abfe821091b6ec919b5244a
[packages/tepl.git] / tepl.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        Tepl - Text editor product line
6 Summary(pl.UTF-8):      Tepl (Text editor product line) - linia produkcyjna edytorów
7 Name:           tepl
8 Version:        4.4.0
9 Release:        1
10 License:        LGPL v2.1+
11 Group:          Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/tepl/4.4/%{name}-%{version}.tar.xz
13 # Source0-md5:  013ee8aae178f75cc74e05fac70786b3
14 URL:            https://wiki.gnome.org/Projects/Tepl
15 BuildRequires:  amtk-devel >= 5.0
16 BuildRequires:  autoconf >= 2.64
17 BuildRequires:  automake >= 1:1.14
18 BuildRequires:  gettext-tools >= 0.19.6
19 BuildRequires:  glib2-devel >= 1:2.52
20 BuildRequires:  gobject-introspection-devel >= 1.42.0
21 BuildRequires:  gtk+3-devel >= 3.22
22 BuildRequires:  gtk-doc >= 1.25
23 BuildRequires:  gtksourceview4-devel >= 4.0
24 BuildRequires:  libtool >= 2:2.2.6
25 BuildRequires:  libxml2-devel >= 1:2.5
26 BuildRequires:  pkgconfig
27 BuildRequires:  uchardet-devel
28 #BuildRequires: vala
29 Requires:       glib2 >= 1:2.52
30 Requires:       gtk+3 >= 3.22
31 Requires:       gtksourceview4 >= 4.0
32 Requires:       libxml2 >= 1:2.5
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Tepl is a library that eases the development of GtkSourceView-based
37 text editors and IDEs.
38
39 Tepl was previously named Gtef (GTK+ text editor framework). The
40 project has been renamed in June 2017 to have a more beautiful name.
41
42 %description -l pl.UTF-8
43 Tepl to biblioteka ułatawiająca tworzenie edytorów tekstu i IDE
44 opartych na GtkSourceView.
45
46 Tepl wcześniej nazywał się Gtef (GTK+ text editor framework - skielet
47 edytorów tekstu GTK+); nazwa została zmieniona w czerwcu 2017 na
48 ładniej brzmiącą.
49
50 %package devel
51 Summary:        Header files for Tepl library
52 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Tepl
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55 Requires:       amtk-devel >= 5.0
56 Requires:       glib2-devel >= 1:2.52
57 Requires:       gtk+3-devel >= 3.22
58 Requires:       gtksourceview4-devel >= 4.0
59 Requires:       libxml2-devel >= 1:2.5
60 Requires:       uchardet-devel
61 # temporary? no vapi in 2.99.2
62 Obsoletes:      vala-tepl < 2.99.2
63
64 %description devel
65 Header files for Tepl library.
66
67 %description devel -l pl.UTF-8
68 Pliki nagłówkowe biblioteki Tepl.
69
70 %package static
71 Summary:        Static Tepl library
72 Summary(pl.UTF-8):      Statyczna biblioteka Tepl
73 Group:          Development/Libraries
74 Requires:       %{name}-devel = %{version}-%{release}
75
76 %description static
77 Static Tepl library.
78
79 %description static -l pl.UTF-8
80 Statyczna biblioteka Tepl.
81
82 %package -n vala-tepl
83 Summary:        Vala API for Tepl library
84 Summary(pl.UTF-8):      API języka Vala do biblioteki Tepl
85 Group:          Development/Libraries
86 Requires:       %{name}-devel = %{version}-%{release}
87 Requires:       vala
88
89 %description -n vala-tepl
90 Vala API for Tepl library.
91
92 %description -n vala-tepl -l pl.UTF-8
93 API języka Vala do biblioteki Tepl.
94
95 %package apidocs
96 Summary:        API documentation for Tepl library
97 Summary(pl.UTF-8):      Dokumentacja API biblioteki Tepl
98 Group:          Documentation
99 %if "%{_rpmversion}" >= "5"
100 BuildArch:      noarch
101 %endif
102
103 %description apidocs
104 API documentation for Tepl library.
105
106 %description apidocs -l pl.UTF-8
107 Dokumentacja API biblioteki Tepl.
108
109 %prep
110 %setup -q
111
112 %build
113 # rebuild ac/am/lt for as-needed to work
114 %{__libtoolize}
115 %{__aclocal} -I m4
116 %{__autoconf}
117 %{__autoheader}
118 %{__automake}
119 %configure \
120         --disable-silent-rules \
121         %{?with_static_libs:--enable-static} \
122         --with-html-dir=%{_gtkdocdir}
123 %{__make}
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 # obsoleted by pkg-config
132 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
133
134 %find_lang tepl-4
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post   -p /sbin/ldconfig
140 %postun -p /sbin/ldconfig
141
142 %files -f tepl-4.lang
143 %defattr(644,root,root,755)
144 %doc AUTHORS NEWS README
145 %attr(755,root,root) %{_libdir}/libtepl-4.so.*.*.*
146 %attr(755,root,root) %ghost %{_libdir}/libtepl-4.so.0
147 %{_libdir}/girepository-1.0/Tepl-4.typelib
148
149 %files devel
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_libdir}/libtepl-4.so
152 %{_includedir}/tepl-4
153 %{_datadir}/gir-1.0/Tepl-4.gir
154 %{_pkgconfigdir}/tepl-4.pc
155
156 %if %{with static_libs}
157 %files static
158 %defattr(644,root,root,755)
159 %{_libdir}/libtepl-4.a
160 %endif
161
162 %if 0
163 %files -n vala-tepl
164 %defattr(644,root,root,755)
165 %{_datadir}/vala/vapi/tepl-4.deps
166 %{_datadir}/vala/vapi/tepl-4.vapi
167 %endif
168
169 %files apidocs
170 %defattr(644,root,root,755)
171 %{_gtkdocdir}/tepl-4.0
This page took 0.070905 seconds and 2 git commands to generate.