]> git.pld-linux.org Git - packages/tepl.git/blob - tepl.spec
844c180cca13fb3c3e0e6923051f24e441d5608f
[packages/tepl.git] / tepl.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        Tepl - Text editor product line
6 Summary(pl.UTF-8):      Tepl (Text editor product line) - linia produkcyjna edytorów
7 Name:           tepl
8 Version:        2.99.1
9 Release:        1
10 License:        LGPL v2.1+
11 Group:          Libraries
12 Source0:        http://ftp.acc.umu.se/pub/GNOME/sources/tepl/2.99/%{name}-%{version}.tar.xz
13 # Source0-md5:  42b00cf84cbfed6a40dc0011c42da588
14 URL:            https://wiki.gnome.org/Projects/Tepl
15 BuildRequires:  autoconf >= 2.64
16 BuildRequires:  automake >= 1:1.14
17 BuildRequires:  gettext-tools >= 0.19.4
18 BuildRequires:  glib2-devel >= 1:2.52
19 BuildRequires:  gobject-introspection-devel >= 1.42.0
20 BuildRequires:  gtk+3-devel >= 3.20
21 BuildRequires:  gtk-doc >= 1.25
22 BuildRequires:  gtksourceview3-devel >= 3.22
23 BuildRequires:  libtool >= 2:2.2.6
24 BuildRequires:  libxml2-devel >= 1:2.5
25 BuildRequires:  pkgconfig
26 BuildRequires:  uchardet-devel
27 BuildRequires:  vala
28 Requires:       glib2 >= 1:2.52
29 Requires:       gtk+3 >= 3.20
30 Requires:       gtksourceview3 >= 3.22
31 Requires:       libxml2 >= 1:2.5
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Tepl is a library that eases the development of GtkSourceView-based
36 text editors and IDEs.
37
38 Tepl was previously named Gtef (GTK+ text editor framework). The
39 project has been renamed in June 2017 to have a more beautiful name.
40
41 %description -l pl.UTF-8
42 Tepl to biblioteka ułatawiająca tworzenie edytorów tekstu i IDE
43 opartych na GtkSourceView.
44
45 Tepl wcześniej nazywał się Gtef (GTK+ text editor framework - skielet
46 edytorów tekstu GTK+); nazwa została zmieniona w czerwcu 2017 na
47 ładniej brzmiącą.
48
49 %package devel
50 Summary:        Header files for Tepl library
51 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Tepl
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       glib2-devel >= 1:2.52
55 Requires:       gtk+3-devel >= 3.20
56 Requires:       gtksourceview3-devel >= 3.22
57 Requires:       libxml2-devel >= 1:2.5
58 Requires:       uchardet-devel
59
60 %description devel
61 Header files for Tepl library.
62
63 %description devel -l pl.UTF-8
64 Pliki nagłówkowe biblioteki Tepl.
65
66 %package static
67 Summary:        Static Tepl library
68 Summary(pl.UTF-8):      Statyczna biblioteka Tepl
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71
72 %description static
73 Static Tepl library.
74
75 %description static -l pl.UTF-8
76 Statyczna biblioteka Tepl.
77
78 %package -n vala-tepl
79 Summary:        Vala API for Tepl library
80 Summary(pl.UTF-8):      API języka Vala do biblioteki Tepl
81 Group:          Development/Libraries
82 Requires:       %{name}-devel = %{version}-%{release}
83 Requires:       vala
84
85 %description -n vala-tepl
86 Vala API for Tepl library.
87
88 %description -n vala-tepl -l pl.UTF-8
89 API języka Vala do biblioteki Tepl.
90
91 %package apidocs
92 Summary:        API documentation for Tepl library
93 Summary(pl.UTF-8):      Dokumentacja API biblioteki Tepl
94 Group:          Documentation
95 %if "%{_rpmversion}" >= "5"
96 BuildArch:      noarch
97 %endif
98
99 %description apidocs
100 API documentation for Tepl library.
101
102 %description apidocs -l pl.UTF-8
103 Dokumentacja API biblioteki Tepl.
104
105 %prep
106 %setup -q
107
108 %build
109 # rebuild ac/am/lt for as-needed to work
110 %{__libtoolize}
111 %{__aclocal} -I m4
112 %{__autoconf}
113 %{__autoheader}
114 %{__automake}
115 %configure \
116         --disable-silent-rules \
117         %{?with_static_libs:--enable-static} \
118         --with-html-dir=%{_gtkdocdir}
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 # obsoleted by pkg-config
128 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libtepl-3.la
129
130 %find_lang tepl-3
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post   -p /sbin/ldconfig
136 %postun -p /sbin/ldconfig
137
138 %files -f tepl-3.lang
139 %defattr(644,root,root,755)
140 %doc AUTHORS NEWS README
141 %attr(755,root,root) %{_libdir}/libtepl-3.so.*.*.*
142 %attr(755,root,root) %ghost %{_libdir}/libtepl-3.so.0
143 %{_libdir}/girepository-1.0/Tepl-3.typelib
144
145 %files devel
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_libdir}/libtepl-3.so
148 %{_includedir}/tepl-3
149 %{_datadir}/gir-1.0/Tepl-3.gir
150 %{_pkgconfigdir}/tepl-3.pc
151
152 %if %{with static_libs}
153 %files static
154 %defattr(644,root,root,755)
155 %{_libdir}/libtepl-3.a
156 %endif
157
158 %files -n vala-tepl
159 %defattr(644,root,root,755)
160 %{_datadir}/vala/vapi/tepl-3.deps
161 %{_datadir}/vala/vapi/tepl-3.vapi
162
163 %files apidocs
164 %defattr(644,root,root,755)
165 %{_gtkdocdir}/tepl-3.0
This page took 0.096019 seconds and 2 git commands to generate.