]> git.pld-linux.org Git - packages/tepl.git/blame_incremental - tepl.spec
icu rebuild
[packages/tepl.git] / tepl.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without apidocs # API documentation
4%bcond_without static_libs # static library
5#
6Summary: Tepl - Text editor product line
7Summary(pl.UTF-8): Tepl (Text editor product line) - linia produkcyjna edytorów
8Name: tepl
9Version: 6.00.0
10Release: 2
11License: LGPL v2.1+
12Group: Libraries
13Source0: https://download.gnome.org/sources/tepl/6.00/%{name}-%{version}.tar.xz
14# Source0-md5: 08248e527cc87a4bf7300c04d1babcb9
15URL: https://wiki.gnome.org/Projects/Tepl
16BuildRequires: amtk-devel >= 5.0
17BuildRequires: gettext-tools >= 0.19.6
18BuildRequires: glib2-devel >= 1:2.64
19BuildRequires: gobject-introspection-devel >= 1.42.0
20BuildRequires: gtk+3-devel >= 3.22
21%{?with_apidocs:BuildRequires: gtk-doc >= 1.25}
22BuildRequires: gtksourceview4-devel >= 4.0
23BuildRequires: libicu-devel
24BuildRequires: libxml2-devel >= 1:2.5
25BuildRequires: meson >= 0.53
26BuildRequires: ninja >= 1.5
27BuildRequires: pkgconfig
28BuildRequires: rpm-build >= 4.6
29BuildRequires: rpmbuild(macros) >= 1.752
30#BuildRequires: vala
31Requires: glib2 >= 1:2.64
32Requires: gtk+3 >= 3.22
33Requires: gtksourceview4 >= 4.0
34Requires: libxml2 >= 1:2.5
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
38Tepl is a library that eases the development of GtkSourceView-based
39text editors and IDEs.
40
41Tepl was previously named Gtef (GTK+ text editor framework). The
42project has been renamed in June 2017 to have a more beautiful name.
43
44%description -l pl.UTF-8
45Tepl to biblioteka ułatawiająca tworzenie edytorów tekstu i IDE
46opartych na GtkSourceView.
47
48Tepl wcześniej nazywał się Gtef (GTK+ text editor framework - skielet
49edytorów tekstu GTK+); nazwa została zmieniona w czerwcu 2017 na
50ładniej brzmiącą.
51
52%package devel
53Summary: Header files for Tepl library
54Summary(pl.UTF-8): Pliki nagłówkowe biblioteki Tepl
55Group: Development/Libraries
56Requires: %{name} = %{version}-%{release}
57Requires: amtk-devel >= 5.0
58Requires: glib2-devel >= 1:2.64
59Requires: gtk+3-devel >= 3.22
60Requires: gtksourceview4-devel >= 4.0
61Requires: libicu-devel
62Requires: libxml2-devel >= 1:2.5
63# temporary? no vapi in 2.99.2
64Obsoletes: vala-tepl < 2.99.2
65
66%description devel
67Header files for Tepl library.
68
69%description devel -l pl.UTF-8
70Pliki nagłówkowe biblioteki Tepl.
71
72%package static
73Summary: Static Tepl library
74Summary(pl.UTF-8): Statyczna biblioteka Tepl
75Group: Development/Libraries
76Requires: %{name}-devel = %{version}-%{release}
77
78%description static
79Static Tepl library.
80
81%description static -l pl.UTF-8
82Statyczna biblioteka Tepl.
83
84%package -n vala-tepl
85Summary: Vala API for Tepl library
86Summary(pl.UTF-8): API języka Vala do biblioteki Tepl
87Group: Development/Libraries
88Requires: %{name}-devel = %{version}-%{release}
89Requires: vala
90BuildArch: noarch
91
92%description -n vala-tepl
93Vala API for Tepl library.
94
95%description -n vala-tepl -l pl.UTF-8
96API języka Vala do biblioteki Tepl.
97
98%package apidocs
99Summary: API documentation for Tepl library
100Summary(pl.UTF-8): Dokumentacja API biblioteki Tepl
101Group: Documentation
102BuildArch: noarch
103
104%description apidocs
105API documentation for Tepl library.
106
107%description apidocs -l pl.UTF-8
108Dokumentacja API biblioteki Tepl.
109
110%prep
111%setup -q
112
113%build
114%meson build \
115 %{!?with_static_libs:--default-library=shared} \
116 %{?with_apidocs:-Dgtk_doc=true}
117
118%ninja_build -C build
119
120%install
121rm -rf $RPM_BUILD_ROOT
122
123%ninja_install -C build
124
125%find_lang tepl-6
126
127%clean
128rm -rf $RPM_BUILD_ROOT
129
130%post -p /sbin/ldconfig
131%postun -p /sbin/ldconfig
132
133%files -f tepl-6.lang
134%defattr(644,root,root,755)
135%doc NEWS README.md
136%attr(755,root,root) %{_libdir}/libtepl-6.so.*.*.*
137%attr(755,root,root) %ghost %{_libdir}/libtepl-6.so.0
138%{_libdir}/girepository-1.0/Tepl-6.typelib
139
140%files devel
141%defattr(644,root,root,755)
142%attr(755,root,root) %{_libdir}/libtepl-6.so
143%{_includedir}/tepl-6
144%{_datadir}/gir-1.0/Tepl-6.gir
145%{_pkgconfigdir}/tepl-6.pc
146
147%if %{with static_libs}
148%files static
149%defattr(644,root,root,755)
150%{_libdir}/libtepl-6.a
151%endif
152
153%if 0
154%files -n vala-tepl
155%defattr(644,root,root,755)
156%{_datadir}/vala/vapi/tepl-6.deps
157%{_datadir}/vala/vapi/tepl-6.vapi
158%endif
159
160%if %{with apidocs}
161%files apidocs
162%defattr(644,root,root,755)
163%{_gtkdocdir}/tepl-6
164%endif
This page took 0.050304 seconds and 4 git commands to generate.