]> git.pld-linux.org Git - packages/telepathy-qt4.git/commitdiff
- up to 0.8.0
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 28 Jul 2012 14:52:25 +0000 (16:52 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 28 Jul 2012 14:52:25 +0000 (16:52 +0200)
telepathy-qt4-build.patch [new file with mode: 0644]
telepathy-qt4.spec

diff --git a/telepathy-qt4-build.patch b/telepathy-qt4-build.patch
new file mode 100644 (file)
index 0000000..4277aed
--- /dev/null
@@ -0,0 +1,43 @@
+--- telepathy-qt4-0.8.0/TelepathyQt4/client-registrar.cpp~     2011-11-10 20:52:11.000000000 +0100
++++ telepathy-qt4-0.8.0/TelepathyQt4/client-registrar.cpp      2012-07-28 16:37:36.795988827 +0200
+@@ -20,6 +20,8 @@
+  * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA  02110-1301  USA
+  */
++#include <inttypes.h>
++
+ #include <TelepathyQt4/ClientRegistrar>
+ #include "TelepathyQt4/client-registrar-internal.h"
+--- telepathy-qt4-0.8.0/TelepathyQt4/stream-tube-server.cpp~   2011-11-10 20:52:11.000000000 +0100
++++ telepathy-qt4-0.8.0/TelepathyQt4/stream-tube-server.cpp    2012-07-28 16:39:34.525627400 +0200
+@@ -20,6 +20,8 @@
+  * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA  02110-1301  USA
+  */
++#include <inttypes.h>
++
+ #include <TelepathyQt4/StreamTubeServer>
+ #include "TelepathyQt4/stream-tube-server-internal.h"
+--- telepathy-qt4-0.8.0/TelepathyQt4/stream-tube-client.cpp~   2011-11-10 20:52:11.000000000 +0100
++++ telepathy-qt4-0.8.0/TelepathyQt4/stream-tube-client.cpp    2012-07-28 16:39:57.932884930 +0200
+@@ -20,6 +20,8 @@
+  * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA  02110-1301  USA
+  */
++#include <inttypes.h>
++
+ #include <TelepathyQt4/StreamTubeClient>
+ #include "TelepathyQt4/stream-tube-client-internal.h"
+--- telepathy-qt4-0.8.0/TelepathyQt4/Farsight/CMakeLists.txt~  2011-11-10 20:52:11.000000000 +0100
++++ telepathy-qt4-0.8.0/TelepathyQt4/Farsight/CMakeLists.txt   2012-07-28 16:46:07.879664825 +0200
+@@ -29,6 +29,7 @@
+         ${QT_QTDBUS_LIBRARY}
+         ${QT_QTCORE_LIBRARY}
+         ${TELEPATHY_FARSIGHT_LIBRARIES}
++        ${TELEPATHY_GLIB_LIBRARIES}
+         ${GSTREAMER_INTERFACE_LIBRARY}
+         telepathy-qt4)
index be80e853e765c90c008284ee3885c5b1d6b3ced4..dd6a936d99bb141b75981c749900794062b81e62 100644 (file)
@@ -1,21 +1,23 @@
 
-%define                qt_ver          4.6.0
+%define                qt_ver          4.8.2
 
 Summary:       Telepathy Qt4
 Summary(pl.UTF-8):     Telepathy Qt4
 Name:          telepathy-qt4
-Version:       0.2.1
-Release:       3
+Version:       0.8.0
+Release:       1
 License:       LGPL v2.1
 Group:         X11/Applications
 Source0:       http://telepathy.freedesktop.org/releases/telepathy-qt4/%{name}-%{version}.tar.gz
-# Source0-md5: 9eaaa055eb2503e5a362bd183f344ac7
+# Source0-md5: b93f03f063d784855d83e1b3c79a1cc5
+Patch0:                %{name}-build.patch
 URL:           http://telepathy.freedesktop.org/wiki/Telepathy-Qt4
 BuildRequires: QtCore-devel >= %{qt_ver}
 BuildRequires: QtDBus-devel >= %{qt_ver}
 BuildRequires: QtGui-devel >= %{qt_ver}
 BuildRequires: QtNetwork-devel >= %{qt_ver}
 BuildRequires: QtTest-devel >= %{qt_ver}
+BuildRequires: cmake
 BuildRequires: pkgconfig
 BuildRequires: python-dbus
 BuildRequires: python-devel
@@ -43,30 +45,23 @@ Header files for telepathy-qt4 library.
 %description devel -l pl.UTF-8
 Pliki nagłówkowe biblioteki telepathy-qt4
 
-%package static
-Summary:       Static telepathy-qt4 library
-Summary(pl.UTF-8):     Statyczna biblioteka telepathy-qt4
-Group:         Development/Libraries
-Requires:      %{name} = %{version}-%{release}
-
-%description static
-Static telepathy-qt4 library.
-
-%description static -l pl.UTF-8
-Statyczna biblioteka telepathy-qt4.
-
 %prep
 %setup -q
+%patch0 -p1
 
 %build
-%configure
+install -d build
+cd build
+%cmake \
+        ../
+
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
+%{__make} -C build install \
+        DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -87,13 +82,6 @@ rm -rf $RPM_BUILD_ROOT
 %doc doc/html
 %attr(755,root,root) %{_libdir}/libtelepathy-qt4.so
 %attr(755,root,root) %{_libdir}/libtelepathy-qt4-farsight.so
-%{_libdir}/libtelepathy-qt4.la
-%{_libdir}/libtelepathy-qt4-farsight.la
 %{_includedir}/telepathy-1.0
 %{_pkgconfigdir}/TelepathyQt4.pc
 %{_pkgconfigdir}/TelepathyQt4Farsight.pc
-
-%files static
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libtelepathy-qt4.a
-%attr(755,root,root) %{_libdir}/libtelepathy-qt4-farsight.a
This page took 0.093327 seconds and 4 git commands to generate.