]> git.pld-linux.org Git - packages/telepathy-qt4.git/blobdiff - telepathy-qt4-build.patch
- rel 4; fix build with new farstream
[packages/telepathy-qt4.git] / telepathy-qt4-build.patch
index 4277aedce73c9a65e0a07502d9b0069a85fd999d..c139166457bc74fddcef8da1b00dbd2649780034 100644 (file)
@@ -1,43 +1,27 @@
---- telepathy-qt4-0.8.0/TelepathyQt4/client-registrar.cpp~     2011-11-10 20:52:11.000000000 +0100
-+++ telepathy-qt4-0.8.0/TelepathyQt4/client-registrar.cpp      2012-07-28 16:37:36.795988827 +0200
-@@ -20,6 +20,8 @@
-  * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA  02110-1301  USA
-  */
-+#include <inttypes.h>
-+
- #include <TelepathyQt4/ClientRegistrar>
- #include "TelepathyQt4/client-registrar-internal.h"
---- telepathy-qt4-0.8.0/TelepathyQt4/stream-tube-server.cpp~   2011-11-10 20:52:11.000000000 +0100
-+++ telepathy-qt4-0.8.0/TelepathyQt4/stream-tube-server.cpp    2012-07-28 16:39:34.525627400 +0200
-@@ -20,6 +20,8 @@
-  * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA  02110-1301  USA
-  */
-+#include <inttypes.h>
-+
- #include <TelepathyQt4/StreamTubeServer>
- #include "TelepathyQt4/stream-tube-server-internal.h"
---- telepathy-qt4-0.8.0/TelepathyQt4/stream-tube-client.cpp~   2011-11-10 20:52:11.000000000 +0100
-+++ telepathy-qt4-0.8.0/TelepathyQt4/stream-tube-client.cpp    2012-07-28 16:39:57.932884930 +0200
-@@ -20,6 +20,8 @@
-  * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA  02110-1301  USA
-  */
-+#include <inttypes.h>
-+
- #include <TelepathyQt4/StreamTubeClient>
- #include "TelepathyQt4/stream-tube-client-internal.h"
---- telepathy-qt4-0.8.0/TelepathyQt4/Farsight/CMakeLists.txt~  2011-11-10 20:52:11.000000000 +0100
-+++ telepathy-qt4-0.8.0/TelepathyQt4/Farsight/CMakeLists.txt   2012-07-28 16:46:07.879664825 +0200
-@@ -29,6 +29,7 @@
-         ${QT_QTDBUS_LIBRARY}
-         ${QT_QTCORE_LIBRARY}
-         ${TELEPATHY_FARSIGHT_LIBRARIES}
-+        ${TELEPATHY_GLIB_LIBRARIES}
-         ${GSTREAMER_INTERFACE_LIBRARY}
-         telepathy-qt4)
+--- telepathy-qt-0.9.3/cmake/modules/FindFarstream.cmake~      2012-07-13 19:40:23.000000000 +0200
++++ telepathy-qt-0.9.3/cmake/modules/FindFarstream.cmake       2012-10-07 23:19:44.818427437 +0200
+@@ -23,9 +23,9 @@
+     # in the find_path() and find_library() calls
+     find_package(PkgConfig)
+     if (FARSTREAM_MIN_VERSION)
+-        PKG_CHECK_MODULES(PC_FARSTREAM farstream-0.1>=${FARSTREAM_MIN_VERSION})
++        PKG_CHECK_MODULES(PC_FARSTREAM farstream-0.2>=${FARSTREAM_MIN_VERSION})
+     else (FARSTREAM_MIN_VERSION)
+-        PKG_CHECK_MODULES(PC_FARSTREAM farstream-0.1)
++        PKG_CHECK_MODULES(PC_FARSTREAM farstream-0.2)
+     endif (FARSTREAM_MIN_VERSION)
+     set(FARSTREAM_DEFINITIONS ${PC_FARSTREAM_CFLAGS_OTHER})
+ endif (NOT WIN32)
+@@ -34,10 +34,10 @@
+    PATHS
+    ${PC_FARSTREAM_INCLUDEDIR}
+    ${PC_FARSTREAM_INCLUDE_DIRS}
+-   PATH_SUFFIXES farstream-0.1
++   PATH_SUFFIXES farstream-0.2
+    )
  
+-find_library(FARSTREAM_LIBRARIES NAMES farstream-0.1
++find_library(FARSTREAM_LIBRARIES NAMES farstream-0.2
+    PATHS
+    ${PC_FARSTREAM_LIBDIR}
+    ${PC_FARSTREAM_LIBRARY_DIRS}
This page took 0.670864 seconds and 4 git commands to generate.