]> git.pld-linux.org Git - packages/systemd.git/commitdiff
- up to 235; build system uses meson now auto/th/systemd-235-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 21 Oct 2017 15:40:43 +0000 (17:40 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 21 Oct 2017 15:40:43 +0000 (17:40 +0200)
cryptsetup-fix-infinite-timeout-6486.patch [deleted file]
initrd-fstab-generator.patch [deleted file]
optional-tmp-on-tmpfs.patch
systemd-configfs.patch
systemd-path.patch [deleted file]
systemd.spec
target-pld.patch
udevadm-in-sbin.patch
uids_gids.patch

diff --git a/cryptsetup-fix-infinite-timeout-6486.patch b/cryptsetup-fix-infinite-timeout-6486.patch
deleted file mode 100644 (file)
index 860d816..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-From c64c6a8b259abfbff5ce202d5d5982b120cf928f Mon Sep 17 00:00:00 2001
-From: Andrew Soutar <andrew@andrewsoutar.com>
-Date: Mon, 31 Jul 2017 02:19:16 -0400
-Subject: [PATCH] cryptsetup: fix infinite timeout (#6486)
-
-0004f698d causes `arg_timeout` to be infinity instead of 0 when timeout=0. The
-logic here now matches this change.
-
-Fixes #6381
-
-(cherry picked from commit 0864d311766498563331f486909a0d950ba7de87)
----
- src/cryptsetup/cryptsetup.c | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/src/cryptsetup/cryptsetup.c b/src/cryptsetup/cryptsetup.c
-index 3b4c086162..08ed7e53ba 100644
---- a/src/cryptsetup/cryptsetup.c
-+++ b/src/cryptsetup/cryptsetup.c
-@@ -56,7 +56,7 @@ static bool arg_tcrypt_veracrypt = false;
- static char **arg_tcrypt_keyfiles = NULL;
- static uint64_t arg_offset = 0;
- static uint64_t arg_skip = 0;
--static usec_t arg_timeout = 0;
-+static usec_t arg_timeout = USEC_INFINITY;
- /* Options Debian's crypttab knows we don't:
-@@ -670,10 +670,10 @@ int main(int argc, char *argv[]) {
-                 if (arg_discards)
-                         flags |= CRYPT_ACTIVATE_ALLOW_DISCARDS;
--                if (arg_timeout > 0)
--                        until = now(CLOCK_MONOTONIC) + arg_timeout;
--                else
-+                if (arg_timeout == USEC_INFINITY)
-                         until = 0;
-+                else
-+                        until = now(CLOCK_MONOTONIC) + arg_timeout;
-                 arg_key_size = (arg_key_size > 0 ? arg_key_size : (256 / 8));
diff --git a/initrd-fstab-generator.patch b/initrd-fstab-generator.patch
deleted file mode 100644 (file)
index 45b2fed..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-From c7b2630c9154722e2295f3dbfbb19f3305676ecf Mon Sep 17 00:00:00 2001
-From: Harald Hoyer <harald@redhat.com>
-Date: Thu, 20 Jul 2017 13:38:46 +0200
-Subject: [PATCH] call chase_symlinks without the /sysroot prefix
-
-In case fstab-generator is called in the initrd, chase_symlinks()
-returns with a canonical path "/sysroot/sysroot/<mountpoint>", if the
-"/sysroot" prefix is present in the path.
-
-This patch skips the "/sysroot" prefix for the chase_symlinks() call,
-because "/sysroot" is already the root directory and chase_symlinks()
-prepends the root directory in the canonical path returned.
----
- src/fstab-generator/fstab-generator.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/fstab-generator/fstab-generator.c b/src/fstab-generator/fstab-generator.c
-index ea5ceb39ca..8fc4c8d179 100644
---- a/src/fstab-generator/fstab-generator.c
-+++ b/src/fstab-generator/fstab-generator.c
-@@ -526,7 +526,7 @@ static int parse_fstab(bool initrd) {
-                         continue;
-                 }
--                where = initrd ? strappend("/sysroot/", me->mnt_dir) : strdup(me->mnt_dir);
-+                where = strdup(me->mnt_dir);
-                 if (!where)
-                         return log_oom();
index 9f0eee083f66253100002432f3f8945ee103444f..32d674ad26e6239dc73cfabfe988c83073360f0f 100644 (file)
@@ -1,5 +1,5 @@
---- a/units/tmp.mount.m4~      2016-11-03 18:16:42.000000000 +0100
-+++ b/units/tmp.mount.m4       2016-11-12 20:03:29.998410581 +0100
+--- systemd-235/units/tmp.mount~       2017-10-06 10:18:04.000000000 +0200
++++ systemd-235/units/tmp.mount        2017-10-21 15:22:24.201178987 +0200
 @@ -20,3 +20,6 @@ What=tmpfs
  Where=/tmp
  Type=tmpfs
index 27642566bce95edc6498920d60b72ac309d2ad18..1769b9746291eecd4c88f0a04d4586a7ae0a671a 100644 (file)
@@ -1,22 +1,15 @@
-diff -durN -x '*.orig' systemd-208.orig/Makefile.am systemd-208/Makefile.am
---- systemd-208.orig/Makefile.am       2014-01-10 10:21:40.000000000 +0100
-+++ systemd-208/Makefile.am    2014-01-10 10:22:33.000000000 +0100
-@@ -411,6 +411,7 @@
-       units/syslog.socket \
-       units/dev-hugepages.mount \
-       units/dev-mqueue.mount \
-+      units/sys-kernel-config.service \
-       units/sys-kernel-config.mount \
-       units/sys-kernel-debug.mount \
-       units/sys-fs-fuse-connections.mount \
-@@ -4435,7 +4436,6 @@
- SYSINIT_TARGET_WANTS += \
-       dev-hugepages.mount \
-       dev-mqueue.mount \
--      sys-kernel-config.mount \
-       sys-kernel-debug.mount \
-       sys-fs-fuse-connections.mount \
-       systemd-sysctl.service \
+--- systemd-235/units/meson.build.org  2017-10-21 15:20:03.280741248 +0200
++++ systemd-235/units/meson.build      2017-10-21 15:20:23.741288778 +0200
+@@ -68,8 +68,9 @@ units = [
+         ['swap.target',                         ''],
+         ['sys-fs-fuse-connections.mount',       '',
+          'sysinit.target.wants/'],
+         ['sys-kernel-config.mount',             '',
+          'sysinit.target.wants/'],
++        ['sys-kernel-config.service',           ''],
+         ['sys-kernel-debug.mount',              '',
+          'sysinit.target.wants/'],
+         ['sysinit.target',                      ''],
 diff -durN -x '*.orig' systemd-208.orig/units/sys-kernel-config.mount systemd-208/units/sys-kernel-config.mount
 --- systemd-208.orig/units/sys-kernel-config.mount     2013-08-13 22:02:52.000000000 +0200
 +++ systemd-208/units/sys-kernel-config.mount  2014-01-10 10:22:04.000000000 +0100
diff --git a/systemd-path.patch b/systemd-path.patch
deleted file mode 100644 (file)
index c12436e..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
---- systemd-234/configure.ac~  2017-07-12 16:01:10.000000000 +0200
-+++ systemd-234/configure.ac   2017-08-07 22:12:59.531024573 +0200
-@@ -95,19 +95,19 @@
- AC_PATH_PROG([M4], [m4])
--AC_PATH_PROG([QUOTAON], [quotaon], [/usr/sbin/quotaon], [$PATH:/usr/sbin:/sbin])
--AC_PATH_PROG([QUOTACHECK], [quotacheck], [/usr/sbin/quotacheck], [$PATH:/usr/sbin:/sbin])
-+AC_PATH_PROG([QUOTAON], [quotaon], [/sbin/quotaon], [$PATH:/usr/sbin:/sbin])
-+AC_PATH_PROG([QUOTACHECK], [quotacheck], [/sbin/quotacheck], [$PATH:/usr/sbin:/sbin])
--AC_PATH_PROG([KILL], [kill], [/usr/bin/kill], [$PATH:/usr/sbin:/sbin])
-+AC_PATH_PROG([KILL], [kill], [/bin/kill], [$PATH:/usr/sbin:/sbin])
--AC_PATH_PROG([KMOD], [kmod], [/usr/bin/kmod], [$PATH:/usr/sbin:/sbin])
-+AC_PATH_PROG([KMOD], [kmod], [/sbin/kmod], [$PATH:/usr/sbin:/sbin])
- AC_PATH_PROG([KEXEC], [kexec], [/usr/sbin/kexec], [$PATH:/usr/sbin:/sbin])
--AC_PATH_PROG([SULOGIN], [sulogin], [/usr/sbin/sulogin], [$PATH:/usr/sbin:/sbin])
-+AC_PATH_PROG([SULOGIN], [sulogin], [/sbin/sulogin], [$PATH:/usr/sbin:/sbin])
--AC_PATH_PROG([MOUNT_PATH], [mount], [/usr/bin/mount], [$PATH:/usr/sbin:/sbin])
--AC_PATH_PROG([UMOUNT_PATH], [umount], [/usr/bin/umount], [$PATH:/usr/sbin:/sbin])
-+AC_PATH_PROG([MOUNT_PATH], [mount], [/bin/mount], [$PATH:/usr/sbin:/sbin])
-+AC_PATH_PROG([UMOUNT_PATH], [umount], [/bin/umount], [$PATH:/usr/sbin:/sbin])
- AS_IF([! ln --relative --help > /dev/null 2>&1], [AC_MSG_ERROR([*** ln doesn't support --relative ***])])
index 27b46e2e4945d08feb2d5210849b7acddf9432f8..4e26c4eb479a5dc2018da954617220703949d76f 100644 (file)
@@ -25,13 +25,13 @@ Summary:    A System and Service Manager
 Summary(pl.UTF-8):     systemd - zarządca systemu i usług dla Linuksa
 Name:          systemd
 # Verify ChangeLog and NEWS when updating (since there are incompatible/breaking changes very often)
-Version:       234
-Release:       3
+Version:       235
+Release:       1
 Epoch:         1
 License:       GPL v2+ (udev), LGPL v2.1+ (the rest)
 Group:         Base
 Source0:       https://github.com/systemd/systemd/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 2d8f6ebded3462ac0d1a6275e54db561
+# Source0-md5: d53a925f1ca5b2e124de0a8aa65d0db2
 Source1:       %{name}-sysv-convert
 Source2:       %{name}_booted.c
 Source3:       network.service
@@ -64,7 +64,7 @@ Patch3:               tmpfiles-not-fatal.patch
 Patch4:                udev-ploop-rules.patch
 Patch5:                udevadm-in-sbin.patch
 Patch6:                net-rename-revert.patch
-Patch7:                %{name}-lz4.patch
+
 Patch8:                proc-hidepid.patch
 Patch9:                %{name}-configfs.patch
 Patch10:       pld-boot_efi_mount.patch
@@ -73,14 +73,9 @@ Patch12:     uids_gids.patch
 Patch13:       sysctl.patch
 Patch14:       pld-pam-%{name}-user.patch
 Patch15:       %{name}-seccomp_disable_on_i386.patch
-Patch16:       %{name}-path.patch
-Patch17:       cryptsetup-fix-infinite-timeout-6486.patch
-Patch18:       initrd-fstab-generator.patch
 URL:           http://www.freedesktop.org/wiki/Software/systemd
 BuildRequires: acl-devel
 %{?with_audit:BuildRequires:   audit-libs-devel}
-BuildRequires: autoconf >= 2.64
-BuildRequires: automake >= 1:1.11
 BuildRequires: binutils >= 3:2.22.52.0.1-2
 BuildRequires: bzip2-devel
 # ln --relative
@@ -114,12 +109,13 @@ BuildRequires:    libtool >= 2:2.2
 BuildRequires: libxslt-progs
 BuildRequires: lz4-devel >= r125
 BuildRequires: m4
+BuildRequires: meson
 %{?with_pam:BuildRequires:     pam-devel >= 1.1.2}
 BuildRequires: pkgconfig >= 0.9.0
 BuildRequires: python3
 BuildRequires: python3-lxml
 %{?with_qrencode:BuildRequires:        qrencode-devel}
-BuildRequires: rpmbuild(macros) >= 1.719
+BuildRequires: rpmbuild(macros) >= 1.727
 BuildRequires: sed >= 4.0
 %{?with_tests:BuildRequires:   systemd}
 BuildRequires: usbutils >= 0.82
@@ -278,7 +274,7 @@ Conflicts:  xl2tpd < 1.3.0-2
 # end of tmpfiles conflicts
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _sbindir        /sbin
+%define                _rootsbindir    /sbin
 %define                _libexecdir     %{_prefix}/lib
 
 %description
@@ -632,7 +628,7 @@ Uzupełnianie parametrów w zsh dla poleceń udev.
 %patch5 -p1
 # rejected upstream (do not disable!)
 %patch6 -p1
-%patch7 -p1
+
 %patch8 -p1
 %patch9 -p1
 %patch10 -p1
@@ -641,82 +637,76 @@ Uzupełnianie parametrów w zsh dla poleceń udev.
 %patch13 -p1
 %patch14 -p1
 %patch15 -p1
-%patch16 -p1
-%patch17 -p1
-%patch18 -p1
 
 cp -p %{SOURCE2} src/systemd_booted.c
 
 %build
-%{__intltoolize}
-%{__libtoolize}
-%{__aclocal} -I m4
-%{__autoconf}
-%{__autoheader}
-%{__automake}
-
-%configure \
-       QUOTAON=/sbin/quotaon \
-       QUOTACHECK=/sbin/quotacheck \
-       SETCAP=/sbin/setcap \
-       KILL=/bin/kill \
-       KMOD=/sbin/kmod \
-       KEXEC=/sbin/kexec \
-       MOUNT=/bin/mount \
-       UMOUNT=/bin/umount \
-       SULOGIN=/sbin/sulogin \
-%if "%{?configure_cache}" == "1"
-       --cache-file=%{?configure_cache_file}%{!?configure_cache_file:configure}.cache \
-%endif
-       %{?debug:--enable-debug} \
-       %{__enable_disable audit} \
-       %{__enable_disable cryptsetup libcryptsetup} \
-       %{__enable_disable efi gnuefi} \
-       %{__enable_disable pam} \
-       %{__enable_disable selinux} \
-       %{__enable_disable microhttpd} \
-       %{__enable_disable qrencode} \
-       --disable-silent-rules \
-       --enable-lz4 \
-       --enable-split-usr \
-       --with-kbd-loadkeys=/usr/bin/loadkeys \
-       --with-kbd-setfont=/bin/setfont \
-       --with-ntp-servers='0.pool.ntp.org 1.pool.ntp.org 2.pool.ntp.org 3.pool.ntp.org' \
-       --with-rc-local-script-path-start=/etc/rc.d/rc.local \
-       --with-rc-local-script-path-stop=/sbin/halt.local \
-       --with-rootprefix="" \
-       --with-rootlibdir=/%{_lib} \
-       --with-sysvinit-path=/etc/rc.d/init.d \
-       --with-sysvrcnd-path=/etc/rc.d \
-       --without-kill-user-processes
-
-%{__make}
-
-./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd
-
-%{?with_tests:%{__make} check}
+%meson build \
+       -Daudit=%{__true_false audit} \
+       -Ddefault-kill-user-processes=false \
+       %{?debug:--buildtype=debug} \
+       -Defi=%{__true_false efi} \
+       -Dhalt-local=/sbin/halt.local \
+       -Dkexec-path=/sbin/kexec \
+       -Dkill-path=/bin/kill \
+       -Dkmod-path=/sbin/kmod \
+       -Dlibcryptsetup=%{__true_false cryptsetup} \
+       -Dloadkeys-path=/usr/bin/loadkeys \
+       -Dlz4=true \
+       -Dmicrohttpd=%{__true_false microhttpd} \
+       -Dmount-path=/bin/mount \
+       -Dntp-servers='0.pool.ntp.org 1.pool.ntp.org 2.pool.ntp.org 3.pool.ntp.org' \
+       -Dpam=%{__true_false pam} \
+       -Dqrencode=%{__true_false qrencode} \
+       -Dquotacheck=true \
+       -Dquotacheck-path=/sbin/quotacheck \
+       -Dquotaon-path=/sbin/quotaon \
+       -Drc-local=/etc/rc.d/rc.local \
+       -Drootlibdir=/%{_lib} \
+       -Drootprefix="" \
+       -Drootsbindir=%{_rootsbindir} \
+       -Dselinux=%{__true_false selinux} \
+       -Dsetfont-path=/bin/setfont \
+       -Dsplit-usr=true \
+       -Dsulogin-path=/sbin/sulogin \
+       -Dsysvinit-path=/etc/rc.d/init.d \
+       -Dsysvrcnd-path=/etc/rc.d \
+       -Dumount-path=/bin/umount
+
+%meson_build -C build
+
+%{__cc} %{rpmcppflags} %{rpmcflags} -o build/systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd
+
+%{?with_tests:%meson_test -C build}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT/var/lib/{%{name}/{catalog,coredump},machines} \
-       $RPM_BUILD_ROOT{%{_sysconfdir}/{modprobe.d,systemd/system-preset},%{_sbindir}}
+       $RPM_BUILD_ROOT{%{_sysconfdir}/{modprobe.d,systemd/system-preset},%{_rootsbindir}}
 install -d $RPM_BUILD_ROOT%{systemduserunitdir}/sockets.target.wants
+install -d $RPM_BUILD_ROOT%{systemdunitdir}/final.target.wants
 
-%{__make} -j1 install \
-       DESTDIR=$RPM_BUILD_ROOT
+%meson_install -C build
 
 touch $RPM_BUILD_ROOT/var/lib/%{name}/random-seed
 
-./libtool --mode=install install -p -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
+install -p -m755 build/systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
+
+# target-pld.patch supplements
+rm $RPM_BUILD_ROOT%{systemdunitdir}/sysinit.target.wants/sys-kernel-config.mount
+ln -s %{systemdunitdir}/prefdm.service $RPM_BUILD_ROOT%{systemdunitdir}/graphical.target.wants/display-manager.service
+ln -s prefdm.service $RPM_BUILD_ROOT%{systemdunitdir}/display-manager.service
+ln -s rescue.service $RPM_BUILD_ROOT%{systemdunitdir}/single.service
+ln -s %{systemdunitdir}/halt-local.service $RPM_BUILD_ROOT%{systemdunitdir}/final.target.wants/halt-local.service
+ln -s %{systemdunitdir}/rc-local.service $RPM_BUILD_ROOT%{systemdunitdir}/multi-user.target.wants/rc-local.service
 
 # compatibility symlinks to udevd binary
 mv $RPM_BUILD_ROOT/lib/{systemd/systemd-,udev/}udevd
 ln -s /lib/udev/udevd $RPM_BUILD_ROOT/lib/systemd/systemd-udevd
-ln -s /lib/udev/udevd $RPM_BUILD_ROOT%{_sbindir}/udevd
+ln -s /lib/udev/udevd $RPM_BUILD_ROOT%{_rootsbindir}/udevd
 
 # compat symlinks for "/ merged into /usr" programs
-mv $RPM_BUILD_ROOT/{,s}bin/udevadm
-ln -s %{_sbindir}/udevadm $RPM_BUILD_ROOT/bin
+ln -s %{_rootsbindir}/udevadm $RPM_BUILD_ROOT/bin
 ln -s /lib/udev $RPM_BUILD_ROOT%{_prefix}/lib
 
 # install custom udev rules from pld package
@@ -733,7 +723,7 @@ cp -a %{SOURCE103} $RPM_BUILD_ROOT%{_sysconfdir}/udev/links.conf
 
 # install udev executables (scripts, helpers, etc.)
 install -p %{SOURCE110} $RPM_BUILD_ROOT/lib/udev/net_helper
-install -p %{SOURCE111} $RPM_BUILD_ROOT%{_sbindir}/start_udev
+install -p %{SOURCE111} $RPM_BUILD_ROOT%{_rootsbindir}/start_udev
 
 # install misc udev stuff
 cp -a %{SOURCE120} $RPM_BUILD_ROOT%{_sysconfdir}/modprobe.d/udev_blacklist.conf
@@ -837,9 +827,6 @@ install -d $RPM_BUILD_ROOT/var/log
 :> $RPM_BUILD_ROOT/var/log/wtmp
 
 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
-%{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la \
-       $RPM_BUILD_ROOT/lib/systemd/*.la \
-       $RPM_BUILD_ROOT/%{_lib}/*.la
 
 %find_lang %{name}
 
@@ -1106,7 +1093,9 @@ fi
 %dir %{_sysconfdir}/systemd/system/sysinit.target.wants
 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/getty.target.wants/getty@tty1.service
 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/multi-user.target.wants/machines.target
+%{?with_cryptsetup:%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/multi-user.target.wants/remote-cryptsetup.target}
 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/multi-user.target.wants/remote-fs.target
+
 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/sysinit.target.wants/systemd-timesyncd.service
 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/systemd-user
 /etc/xdg/systemd
@@ -1253,9 +1242,6 @@ fi
 %{_libexecdir}/tmpfiles.d/systemd.conf
 %{_libexecdir}/tmpfiles.d/systemd-nologin.conf
 %{_libexecdir}/tmpfiles.d/systemd-nspawn.conf
-%if %{with microhttpd}
-%{_libexecdir}/tmpfiles.d/systemd-remote.conf
-%endif
 %{_libexecdir}/tmpfiles.d/tmp.conf
 %{_libexecdir}/tmpfiles.d/var.conf
 %{_libexecdir}/tmpfiles.d/x11.conf
@@ -1471,7 +1457,6 @@ fi
 %dir %{_libexecdir}/systemd/user
 %{_libexecdir}/systemd/user/basic.target
 %{_libexecdir}/systemd/user/bluetooth.target
-%{_libexecdir}/systemd/user/busnames.target
 %{_libexecdir}/systemd/user/default.target
 %{_libexecdir}/systemd/user/exit.target
 %{_libexecdir}/systemd/user/paths.target
@@ -1503,15 +1488,6 @@ fi
 %{systemdunitdir}/dev-hugepages.mount
 %{systemdunitdir}/dev-mqueue.mount
 %{systemdunitdir}/initrd-root-device.target
-%{systemdunitdir}/org.freedesktop.hostname1.busname
-%{systemdunitdir}/org.freedesktop.import1.busname
-%{systemdunitdir}/org.freedesktop.locale1.busname
-%{systemdunitdir}/org.freedesktop.login1.busname
-%{systemdunitdir}/org.freedesktop.machine1.busname
-%{systemdunitdir}/org.freedesktop.network1.busname
-%{systemdunitdir}/org.freedesktop.resolve1.busname
-%{systemdunitdir}/org.freedesktop.systemd1.busname
-%{systemdunitdir}/org.freedesktop.timedate1.busname
 %{systemdunitdir}/proc-sys-fs-binfmt_misc.automount
 %{systemdunitdir}/proc-sys-fs-binfmt_misc.mount
 %{systemdunitdir}/sockets.target.wants/systemd-coredump.socket
@@ -1630,7 +1606,6 @@ fi
 %{systemdunitdir}/systemd-udevd-kernel.socket
 %{systemdunitdir}/basic.target
 %{systemdunitdir}/bluetooth.target
-%{systemdunitdir}/busnames.target
 %{?with_cryptsetup:%{systemdunitdir}/cryptsetup-pre.target}
 %{?with_cryptsetup:%{systemdunitdir}/cryptsetup.target}
 %{systemdunitdir}/ctrl-alt-del.target
@@ -1639,6 +1614,7 @@ fi
 %{systemdunitdir}/exit.target
 %{systemdunitdir}/final.target
 %{systemdunitdir}/getty.target
+%{systemdunitdir}/getty-pre.target
 %{systemdunitdir}/graphical.target
 %{systemdunitdir}/halt.target
 %{systemdunitdir}/hibernate.target
@@ -1663,6 +1639,10 @@ fi
 %{systemdunitdir}/reboot.target
 %{systemdunitdir}/remote-fs-pre.target
 %{systemdunitdir}/remote-fs.target
+%if %{with cryptsetup}
+%{systemdunitdir}/remote-cryptsetup-pre.target
+%{systemdunitdir}/remote-cryptsetup.target
+%endif
 %{systemdunitdir}/rescue.target
 %{systemdunitdir}/rpcbind.target
 %{systemdunitdir}/runlevel0.target
@@ -1688,7 +1668,6 @@ fi
 %{systemdunitdir}/umount.target
 %{systemdunitdir}/systemd-tmpfiles-clean.timer
 %dir %{systemdunitdir}/basic.target.wants
-%dir %{systemdunitdir}/busnames.target.wants
 %dir %{systemdunitdir}/dbus.target.wants
 %dir %{systemdunitdir}/final.target.wants
 %dir %{systemdunitdir}/graphical.target.wants
@@ -1709,15 +1688,6 @@ fi
 %dir %{systemdunitdir}/sysinit.target.wants
 %dir %{systemdunitdir}/syslog.target.wants
 %dir %{systemdunitdir}/timers.target.wants
-%{systemdunitdir}/busnames.target.wants/org.freedesktop.hostname1.busname
-%{systemdunitdir}/busnames.target.wants/org.freedesktop.import1.busname
-%{systemdunitdir}/busnames.target.wants/org.freedesktop.locale1.busname
-%{systemdunitdir}/busnames.target.wants/org.freedesktop.login1.busname
-%{systemdunitdir}/busnames.target.wants/org.freedesktop.machine1.busname
-%{systemdunitdir}/busnames.target.wants/org.freedesktop.network1.busname
-%{systemdunitdir}/busnames.target.wants/org.freedesktop.resolve1.busname
-%{systemdunitdir}/busnames.target.wants/org.freedesktop.systemd1.busname
-%{systemdunitdir}/busnames.target.wants/org.freedesktop.timedate1.busname
 %{systemdunitdir}/final.target.wants/halt-local.service
 %{systemdunitdir}/graphical.target.wants/display-manager.service
 %{systemdunitdir}/graphical.target.wants/systemd-update-utmp-runlevel.service
@@ -1989,13 +1959,14 @@ fi
 /lib/udev/hwdb.d/60-evdev.hwdb
 /lib/udev/hwdb.d/60-keyboard.hwdb
 /lib/udev/hwdb.d/60-sensor.hwdb
+/lib/udev/hwdb.d/70-joystick.hwdb
 /lib/udev/hwdb.d/70-mouse.hwdb
 /lib/udev/hwdb.d/70-pointingstick.hwdb
 /lib/udev/hwdb.d/70-touchpad.hwdb
 
-%attr(755,root,root) %{_sbindir}/start_udev
-%attr(755,root,root) %{_sbindir}/udevd
-%attr(755,root,root) %{_sbindir}/udevadm
+%attr(755,root,root) %{_rootsbindir}/start_udev
+%attr(755,root,root) %{_rootsbindir}/udevd
+%attr(755,root,root) %{_rootsbindir}/udevadm
 %attr(755,root,root) /bin/systemd-hwdb
 %attr(755,root,root) /bin/udevadm
 
index d072379df9ebc738cddc22f892b1a1eeff559def..784c3409d7535b8f716bb75da4ba8bf578deba32 100644 (file)
@@ -1,51 +1,4 @@
-diff -dur -x '*~' -x '*.orig' systemd-208.orig/Makefile.am systemd-208/Makefile.am
---- systemd-208.orig/Makefile.am       2013-10-02 04:57:09.000000000 +0200
-+++ systemd-208/Makefile.am    2014-01-09 15:15:41.000000000 +0100
-@@ -211,6 +211,8 @@
- TIMERS_TARGET_WANTS =
- USER_SOCKETS_TARGET_WANTS =
- USER_BUSNAMES_TARGET_WANTS =
-+FINAL_TARGET_WANTS =
-+GRAPHICAL_TARGET_WANTS =
- SYSTEM_UNIT_ALIASES =
- USER_UNIT_ALIASES =
-@@ -230,6 +232,8 @@
-       what="$(SLICES_TARGET_WANTS)" && wants=slices.target && $(add-wants)
-       what="$(USER_SOCKETS_TARGET_WANTS)" && wants=sockets.target && dir=$(userunitdir) && $(add-wants)
-       what="$(USER_BUSNAMES_TARGET_WANTS)" && wants=busnames.target && dir=$(userunitdir) && $(add-wants)
-+      what="$(FINAL_TARGET_WANTS)" && wants=final.target && dir=$(systemunitdir) && $(add-wants)
-+      what="$(GRAPHICAL_TARGET_WANTS)" && wants=graphical.target && dir=$(systemunitdir) && $(add-wants)
- define add-wants
-       [ -z "$$what" ] || ( \
-@@ -4001,8 +4005,15 @@
-       $(systemdstatedir)
- MULTI_USER_TARGET_WANTS += \
-+      rc-local.service \
-       systemd-logind.service
-+FINAL_TARGET_WANTS += \
-+      halt-local.service
-+
-+GRAPHICAL_TARGET_WANTS += \
-+      display-manager.service
-+
- SYSTEM_UNIT_ALIASES += \
-       systemd-logind.service dbus-org.freedesktop.login1.service
-@@ -4493,6 +4504,10 @@
- uninstall-hook: $(UNINSTALL_DATA_HOOKS) $(UNINSTALL_EXEC_HOOKS)
- install-data-hook: $(INSTALL_DATA_HOOKS)
-+      ( cd $(DESTDIR)$(systemunitdir) && \
-+              rm -f display-manager.service single.service && \
-+              $(LN_S) prefdm.service display-manager.service && \
-+              $(LN_S) rescue.service single.service )
- distclean-local: $(DISTCLEAN_LOCAL_HOOKS)
+; rest of target-pld.patch logic in systemd.spec
 diff -dur -x '*~' -x '*.orig' systemd-208.orig/src/core/hostname-setup.c systemd-208/src/core/hostname-setup.c
 --- systemd-208.orig/src/core/hostname-setup.c 2013-08-13 22:02:46.000000000 +0200
 +++ systemd-208/src/core/hostname-setup.c      2014-01-09 15:15:41.000000000 +0100
index 75a6fcd5d9f8b45a05337d1fa6030f649990ab34..d97fd539da4097d3285b7c81b0d70700151e21fa 100644 (file)
@@ -1,13 +1,30 @@
---- systemd-183/Makefile.am~   2012-05-30 14:28:53.647009365 +0200
-+++ systemd-183/Makefile.am    2012-05-30 14:35:41.593661644 +0200
-@@ -3817,6 +3817,7 @@
-        '|rootlibexecdir=$(rootlibexecdir)|' \
-        '|rootbindir=$(rootbindir)|' \
-        '|bindir=$(bindir)|' \
-+       '|sbindir=$(sbindir)|' \
-        '|SYSTEMCTL=$(rootbindir)/systemctl|' \
-        '|SYSTEMD_NOTIFY=$(rootbindir)/systemd-notify|' \
-        '|pkgsysconfdir=$(pkgsysconfdir)|' \
+--- systemd-235/meson.build~   2017-10-06 10:18:04.000000000 +0200
++++ systemd-235/meson.build    2017-10-21 15:12:47.202404998 +0200
+@@ -67,6 +67,7 @@ datadir = join_paths(prefixdir, get_opti
+ localstatedir = join_paths('/', get_option('localstatedir'))
+ rootbindir = join_paths(rootprefixdir, 'bin')
++rootsbindir = join_paths(rootprefixdir, 'sbin')
+ rootlibexecdir = join_paths(rootprefixdir, 'lib/systemd')
+ rootlibdir = get_option('rootlibdir')
+@@ -200,6 +201,7 @@ substs.set('includedir',
+ substs.set('pkgsysconfdir',                                   pkgsysconfdir)
+ substs.set('bindir',                                          bindir)
+ substs.set('rootbindir',                                      rootbindir)
++substs.set('rootsbindir',                                     rootsbindir)
+ substs.set('rootlibexecdir',                                  rootlibexecdir)
+ substs.set('systemunitdir',                                   systemunitdir)
+ substs.set('userunitdir',                                     userunitdir)
+@@ -2164,7 +2166,7 @@ exe = executable('udevadm',
+                                  libblkid],
+                  install_rpath : udev_rpath,
+                  install : true,
+-                 install_dir : rootbindir)
++                 install_dir : rootsbindir)
+ public_programs += [exe]
+ executable('systemd-shutdown',
 --- systemd-183/units/systemd-udev-trigger.service.in~ 2012-05-21 15:14:51.642981269 +0200
 +++ systemd-183/units/systemd-udev-trigger.service.in  2012-05-30 13:55:20.229509590 +0200
 @@ -17,4 +17,4 @@
@@ -15,7 +32,7 @@
  Type=oneshot
  RemainAfterExit=yes
 -ExecStart=@rootbindir@/udevadm trigger --type=subsystems --action=add ; @rootbindir@/udevadm trigger --type=devices --action=add
-+ExecStart=@sbindir@/udevadm trigger --type=subsystems --action=add ; @sbindir@/udevadm trigger --type=devices --action=add
++ExecStart=@rootsbindir@/udevadm trigger --type=subsystems --action=add ; @rootsbindir@/udevadm trigger --type=devices --action=add
 --- systemd-183/units/systemd-udev-settle.service.in~  2012-05-30 13:43:34.886201138 +0200
 +++ systemd-183/units/systemd-udev-settle.service.in   2012-05-30 13:55:44.546175399 +0200
 @@ -29,4 +29,4 @@
@@ -23,7 +40,7 @@
  TimeoutSec=180
  RemainAfterExit=yes
 -ExecStart=@rootbindir@/udevadm settle
-+ExecStart=@sbindir@/udevadm settle
++ExecStart=@rootsbindir@/udevadm settle
 --- systemd-199/units/initrd-udevadm-cleanup-db.service.in~    2013-03-11 18:01:33.616138706 +0100
 +++ systemd-199/units/initrd-udevadm-cleanup-db.service.in     2013-03-26 19:09:54.525625477 +0100
 @@ -15,4 +15,4 @@
@@ -31,4 +48,4 @@
  [Service]
  Type=oneshot
 -ExecStart=-@rootbindir@/udevadm info --cleanup-db
-+ExecStart=-@sbindir@/udevadm info --cleanup-db
++ExecStart=-@rootsbindir@/udevadm info --cleanup-db
index f55a8c385ff32d0f0d71f64f93a962c0421c5af9..27313f77b553944bc628ac0d81bfe9ab9c452fd6 100644 (file)
  # Default group for normal users
 -g users   -     -            -
 +g users   1000  -            -
---- a/sysusers.d/systemd-remote.conf.m4~       2016-11-03 18:16:42.000000000 +0100
-+++ b/sysusers.d/systemd-remote.conf.m4        2016-11-12 20:07:22.838061991 +0100
-@@ -6,9 +6,9 @@
+--- systemd-235/sysusers.d/systemd-remote.conf.m4~     2017-10-06 10:18:04.000000000 +0200
++++ systemd-235/sysusers.d/systemd-remote.conf.m4      2017-10-21 15:26:33.951199376 +0200
+@@ -6,8 +6,8 @@
  #  (at your option) any later version.
  
  m4_ifdef(`HAVE_MICROHTTPD',
--u systemd-journal-gateway - "systemd Journal Gateway"
 -u systemd-journal-remote  - "systemd Journal Remote"
-+u systemd-journal-gateway 287 "systemd Journal Gateway"
 +u systemd-journal-remote  319 "systemd Journal Remote"
  )m4_dnl
  m4_ifdef(`HAVE_LIBCURL',
 -u systemd-journal-upload  - "systemd Journal Upload"
 +u systemd-journal-upload  320 "systemd Journal Upload"
  )m4_dnl
---- a/sysusers.d/systemd.conf.m4~      2016-11-03 18:16:42.000000000 +0100
-+++ b/sysusers.d/systemd.conf.m4       2016-11-12 20:08:23.103080854 +0100
+--- systemd-235/sysusers.d/systemd.conf.m4~    2017-10-06 10:18:04.000000000 +0200
++++ systemd-235/sysusers.d/systemd.conf.m4     2017-10-21 15:27:49.116545700 +0200
 @@ -5,16 +5,16 @@
  #  the Free Software Foundation; either version 2.1 of the License, or
  #  (at your option) any later version.
@@ -68,7 +66,7 @@
 -u systemd-network   - "systemd Network Management"
 +u systemd-network   316 "systemd Network Management"
  )m4_dnl
- m4_ifdef(`ENABLE_RESOLVED',
+ m4_ifdef(`ENABLE_RESOLVE',
 -u systemd-resolve   - "systemd Resolver"
 +u systemd-resolve   317 "systemd Resolver"
  )m4_dnl
This page took 0.07243 seconds and 4 git commands to generate.