]> git.pld-linux.org Git - packages/systemd.git/commitdiff
fix build with recent meson versions
authorJan Palus <atler@pld-linux.org>
Sun, 18 Nov 2018 22:03:33 +0000 (23:03 +0100)
committerJan Palus <atler@pld-linux.org>
Sun, 18 Nov 2018 22:03:33 +0000 (23:03 +0100)
meson-debug.patch [new file with mode: 0644]
systemd.spec

diff --git a/meson-debug.patch b/meson-debug.patch
new file mode 100644 (file)
index 0000000..19db590
--- /dev/null
@@ -0,0 +1,40 @@
+From 8f6b442a78d0b485f044742ad90b2e8271b4e68e Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
+Date: Sun, 19 Aug 2018 19:11:30 +0200
+Subject: [PATCH] meson: rename -Ddebug to -Ddebug-extra
+
+Meson added -Doptimization and -Ddebug options, which obviously causes
+a conflict with our -Ddebug options. Let's rename it.
+
+Fixes #9883.
+---
+ meson.build       | 2 +-
+ meson_options.txt | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index f79ac4b12e7..2209c935ad6 100644
+--- a/meson.build
++++ b/meson.build
+@@ -763,7 +763,7 @@ substs.set('DEBUGTTY', get_option('debug-tty'))
+ enable_debug_hashmap = false
+ enable_debug_mmap_cache = false
+-foreach name : get_option('debug')
++foreach name : get_option('debug-extra')
+         if name == 'hashmap'
+                 enable_debug_hashmap = true
+         elif name == 'mmap-cache'
+diff --git a/meson_options.txt b/meson_options.txt
+index e3140c8c110..7b1f61bf464 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -45,7 +45,7 @@ option('debug-shell', type : 'string', value : '/bin/sh',
+        description : 'path to debug shell binary')
+ option('debug-tty', type : 'string', value : '/dev/tty9',
+        description : 'specify the tty device for debug shell')
+-option('debug', type : 'array', choices : ['hashmap', 'mmap-cache'], value : [],
++option('debug-extra', type : 'array', choices : ['hashmap', 'mmap-cache'], value : [],
+        description : 'enable extra debugging')
+ option('memory-accounting-default', type : 'boolean',
+        description : 'enable MemoryAccounting= by default')
index 5bc164454559b9c6854043c41e1aa120a0d48aec..a36e7875c11c8bdd7398370e83c72bb41bb51b27 100644 (file)
@@ -93,6 +93,7 @@ Patch12:      uids_gids.patch
 Patch13:       sysctl.patch
 Patch14:       pld-pam-%{name}-user.patch
 Patch15:       %{name}-seccomp_disable_on_i386.patch
+Patch16:       meson-debug.patch
 URL:           http://www.freedesktop.org/wiki/Software/systemd
 BuildRequires: acl-devel
 %{?with_audit:BuildRequires:   audit-libs-devel}
@@ -659,6 +660,7 @@ Uzupełnianie parametrów w zsh dla poleceń udev.
 %patch13 -p1
 %patch14 -p1
 %patch15 -p1
+%patch16 -p1
 
 cp -p %{SOURCE2} src/systemd_booted.c
 
This page took 0.287632 seconds and 4 git commands to generate.