]> git.pld-linux.org Git - packages/systemd.git/commitdiff
- partial update to 245; TODO: files + reading ChangeLog and NEWS
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 3 Apr 2020 19:48:38 +0000 (21:48 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 3 Apr 2020 19:48:38 +0000 (21:48 +0200)
systemd-configfs.patch
systemd.spec
tmpfiles-not-fatal.patch
udevadm-in-sbin.patch [deleted file]

index 1769b9746291eecd4c88f0a04d4586a7ae0a671a..345f35ee24bf29cd2f01a99be7bbf3234ad853fb 100644 (file)
@@ -1,15 +1,13 @@
 --- systemd-235/units/meson.build.org  2017-10-21 15:20:03.280741248 +0200
 +++ systemd-235/units/meson.build      2017-10-21 15:20:23.741288778 +0200
-@@ -68,8 +68,9 @@ units = [
-         ['swap.target',                         ''],
-         ['sys-fs-fuse-connections.mount',       '',
+@@ -76,6 +76,7 @@ units = [
           'sysinit.target.wants/'],
          ['sys-kernel-config.mount',             '',
           'sysinit.target.wants/'],
 +        ['sys-kernel-config.service',           ''],
          ['sys-kernel-debug.mount',              '',
           'sysinit.target.wants/'],
-         ['sysinit.target',                      ''],
+         ['sys-kernel-tracing.mount',            '',
 diff -durN -x '*.orig' systemd-208.orig/units/sys-kernel-config.mount systemd-208/units/sys-kernel-config.mount
 --- systemd-208.orig/units/sys-kernel-config.mount     2013-08-13 22:02:52.000000000 +0200
 +++ systemd-208/units/sys-kernel-config.mount  2014-01-10 10:22:04.000000000 +0100
index b953e3294507975f376c63b25f449d0e08aadab5..d0a61892bba2fc14b14645e70d23d955041de11f 100644 (file)
@@ -28,14 +28,14 @@ Summary:    A System and Service Manager
 Summary(pl.UTF-8):     systemd - zarządca systemu i usług dla Linuksa
 Name:          systemd
 # Verify ChangeLog and NEWS when updating (since there are incompatible/breaking changes very often)
-Version:       244
-Release:       2
+Version:       245
+Release:       0.1
 Epoch:         1
 License:       GPL v2+ (udev), LGPL v2.1+ (the rest)
 Group:         Base
 #Source0Download: https://github.com/systemd/systemd/releases
 Source0:       https://github.com/systemd/systemd/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 413121fe918b252ae62310f6fc7c4b32
+# Source0-md5: 04f02d9841ea5992a16f6b03c873da28
 Source1:       %{name}-sysv-convert
 Source2:       %{name}_booted.c
 Source3:       network.service
@@ -66,7 +66,7 @@ Patch1:               config-pld.patch
 Patch2:                pld-sysv-network.patch
 Patch3:                tmpfiles-not-fatal.patch
 Patch4:                udev-ploop-rules.patch
-Patch5:                udevadm-in-sbin.patch
+
 Patch6:                net-rename-revert.patch
 Patch7:                %{name}-completion.patch
 Patch8:                proc-hidepid.patch
@@ -661,7 +661,7 @@ Uzupełnianie parametrów w zsh dla poleceń udev.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%patch5 -p1
+
 # rejected upstream (do not disable!)
 %patch6 -p1
 %patch7 -p1
@@ -676,6 +676,8 @@ Uzupełnianie parametrów w zsh dla poleceń udev.
 
 cp -p %{SOURCE2} src/systemd_booted.c
 
+grep -rlZ -0 '#!/usr/bin/env bash' . | xargs -0 sed -i -e 's,#!/usr/bin/env bash,#!/bin/bash,g'
+
 %build
 %meson build \
        -Daudit=%{__true_false audit} \
@@ -683,9 +685,7 @@ cp -p %{SOURCE2} src/systemd_booted.c
        -Ddefault-kill-user-processes=false \
        %{?debug:--buildtype=debug} \
        -Defi=%{__true_false efi} \
-       -Dhalt-local=/sbin/halt.local \
        -Dkexec-path=/sbin/kexec \
-       -Dkill-path=/bin/kill \
        -Dkmod-path=/sbin/kmod \
        -Dlibcryptsetup=%{__true_false cryptsetup} \
        -Dlibidn2=true \
@@ -705,7 +705,6 @@ cp -p %{SOURCE2} src/systemd_booted.c
        -Drc-local=/etc/rc.d/rc.local \
        -Drootlibdir=/%{_lib} \
        -Drootprefix="" \
-       -Drootsbindir=%{_rootsbindir} \
        -Dselinux=%{__true_false selinux} \
        -Dsetfont-path=/bin/setfont \
        -Dsplit-bin=true \
@@ -750,7 +749,7 @@ ln -s /lib/udev/udevd $RPM_BUILD_ROOT/lib/systemd/systemd-udevd
 ln -s /lib/udev/udevd $RPM_BUILD_ROOT%{_rootsbindir}/udevd
 
 # compat symlinks for "/ merged into /usr" programs
-ln -s %{_rootsbindir}/udevadm $RPM_BUILD_ROOT/bin
+ln -s ../bin/udevadm $RPM_BUILD_ROOT%{_rootsbindir}
 ln -s /lib/udev $RPM_BUILD_ROOT%{_prefix}/lib
 
 # install custom udev rules from pld package
@@ -1070,14 +1069,14 @@ fi
 %endif
 
 %triggerpostun -n udev-core -- udev < 165
-/sbin/udevadm info --convert-db
+/bin/udevadm info --convert-db
 
 %post -n udev-core
-/sbin/udevadm hwdb --update || :
+/bin/udevadm hwdb --update || :
 if [ $1 -gt 1 ]; then
        if [ ! -x /bin/systemd_booted ] || ! /bin/systemd_booted; then
                if grep -qs devtmpfs /proc/mounts && [ -n "$(pidof udevd)" ]; then
-                       /sbin/udevadm control --exit
+                       /bin/udevadm control --exit
                        /lib/udev/udevd --daemon
                fi
        else
@@ -1162,6 +1161,7 @@ fi
 %attr(755,root,root) %{_bindir}/systemd-sysv-convert
 %attr(755,root,root) %{_bindir}/systemd-umount
 %attr(755,root,root) %{_bindir}/timedatectl
+%attr(755,root,root) %{_bindir}/userdbctl
 /lib/modprobe.d/systemd.conf
 /lib/systemd/import-pubring.gpg
 /lib/systemd/resolv.conf
@@ -1346,6 +1346,7 @@ fi
 %{_mandir}/man1/systemd-tty-ask-password-agent.1*
 %{_mandir}/man1/systemd-umount.1*
 %{_mandir}/man1/timedatectl.1*
+%{_mandir}/man1/userdbctl.1*
 %{_mandir}/man5/binfmt.d.5*
 %{_mandir}/man5/coredump.conf.5*
 %{_mandir}/man5/coredump.conf.d.5*
@@ -2093,6 +2094,7 @@ fi
 /lib/udev/hwdb.d/20-usb-vendor-model.hwdb
 /lib/udev/hwdb.d/20-vmbus-class.hwdb
 /lib/udev/hwdb.d/60-evdev.hwdb
+/lib/udev/hwdb.d/60-input-id.hwdb
 /lib/udev/hwdb.d/60-keyboard.hwdb
 /lib/udev/hwdb.d/60-sensor.hwdb
 /lib/udev/hwdb.d/70-joystick.hwdb
index 990150e6aacba05e1b7985bfc09c8abc3b8515bb..fb383378b8f22d26163ac1730cbf36be80b3ffa1 100644 (file)
@@ -1,19 +1,54 @@
---- systemd-238/units/systemd-tmpfiles-setup.service.in~       2018-03-05 23:16:37.000000000 +0100
-+++ systemd-238/units/systemd-tmpfiles-setup.service.in        2018-05-15 13:23:51.990328057 +0200
-@@ -19,5 +19,5 @@ RefuseManualStop=yes
+diff -ur systemd-245/units.org/systemd-tmpfiles-clean.service systemd-245/units/systemd-tmpfiles-clean.service
+--- systemd-245/units.org/systemd-tmpfiles-clean.service       2020-03-06 13:38:52.000000000 +0100
++++ systemd-245/units/systemd-tmpfiles-clean.service   2020-04-03 21:08:42.151365700 +0200
+@@ -17,6 +17,6 @@
+ [Service]
+ Type=oneshot
+-ExecStart=systemd-tmpfiles --clean
++ExecStart=-systemd-tmpfiles --clean
+ SuccessExitStatus=DATAERR
+ IOSchedulingClass=idle
+diff -ur systemd-245/units.org/systemd-tmpfiles-setup-dev.service systemd-245/units/systemd-tmpfiles-setup-dev.service
+--- systemd-245/units.org/systemd-tmpfiles-setup-dev.service   2020-03-06 13:38:52.000000000 +0100
++++ systemd-245/units/systemd-tmpfiles-setup-dev.service       2020-04-03 21:08:42.151365700 +0200
+@@ -18,5 +18,5 @@
+ [Service]
+ Type=oneshot
+ RemainAfterExit=yes
+-ExecStart=systemd-tmpfiles --prefix=/dev --create --boot
++ExecStart=-systemd-tmpfiles --prefix=/dev --create --boot
+ SuccessExitStatus=DATAERR CANTCREAT
+diff -ur systemd-245/units.org/systemd-tmpfiles-setup.service systemd-245/units/systemd-tmpfiles-setup.service
+--- systemd-245/units.org/systemd-tmpfiles-setup.service       2020-03-06 13:38:52.000000000 +0100
++++ systemd-245/units/systemd-tmpfiles-setup.service   2020-04-03 21:08:42.151365700 +0200
+@@ -19,5 +19,5 @@
  [Service]
  Type=oneshot
  RemainAfterExit=yes
--ExecStart=@rootbindir@/systemd-tmpfiles --create --remove --boot --exclude-prefix=/dev
-+ExecStart=-@rootbindir@/systemd-tmpfiles --create --remove --boot --exclude-prefix=/dev
+-ExecStart=systemd-tmpfiles --create --remove --boot --exclude-prefix=/dev
++ExecStart=-systemd-tmpfiles --create --remove --boot --exclude-prefix=/dev
  SuccessExitStatus=DATAERR CANTCREAT
---- systemd-238/units/systemd-tmpfiles-clean.service.in~       2018-03-05 23:16:37.000000000 +0100
-+++ systemd-238/units/systemd-tmpfiles-clean.service.in        2018-05-15 13:24:19.297825542 +0200
-@@ -17,6 +17,6 @@ Before=shutdown.target
+diff -ur systemd-245/units.org/user/systemd-tmpfiles-clean.service systemd-245/units/user/systemd-tmpfiles-clean.service
+--- systemd-245/units.org/user/systemd-tmpfiles-clean.service  2020-03-06 13:38:52.000000000 +0100
++++ systemd-245/units/user/systemd-tmpfiles-clean.service      2020-04-03 21:08:42.151365700 +0200
+@@ -16,6 +16,6 @@
  
  [Service]
  Type=oneshot
--ExecStart=@rootbindir@/systemd-tmpfiles --clean
-+ExecStart=-@rootbindir@/systemd-tmpfiles --clean
+-ExecStart=systemd-tmpfiles --user --clean
++ExecStart=-systemd-tmpfiles --user --clean
  SuccessExitStatus=DATAERR
  IOSchedulingClass=idle
+diff -ur systemd-245/units.org/user/systemd-tmpfiles-setup.service systemd-245/units/user/systemd-tmpfiles-setup.service
+--- systemd-245/units.org/user/systemd-tmpfiles-setup.service  2020-03-06 13:38:52.000000000 +0100
++++ systemd-245/units/user/systemd-tmpfiles-setup.service      2020-04-03 21:08:42.151365700 +0200
+@@ -18,7 +18,7 @@
+ [Service]
+ Type=oneshot
+ RemainAfterExit=yes
+-ExecStart=systemd-tmpfiles --user --create --remove --boot
++ExecStart=-systemd-tmpfiles --user --create --remove --boot
+ SuccessExitStatus=DATAERR
+ [Install]
diff --git a/udevadm-in-sbin.patch b/udevadm-in-sbin.patch
deleted file mode 100644 (file)
index db0ac12..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
---- systemd-240/meson.build.orig       2018-12-21 19:53:33.000000000 +0100
-+++ systemd-240/meson.build    2019-01-13 10:00:36.555639211 +0100
-@@ -243,6 +243,7 @@
- substs.set('pkgsysconfdir',                                   pkgsysconfdir)
- substs.set('bindir',                                          bindir)
- substs.set('rootbindir',                                      rootbindir)
-+substs.set('rootsbindir',                                     rootsbindir)
- substs.set('rootlibexecdir',                                  rootlibexecdir)
- substs.set('systemunitdir',                                   systemunitdir)
- substs.set('userunitdir',                                     userunitdir)
-@@ -2667,7 +2668,7 @@
-                                  libblkid],
-                  install_rpath : udev_rpath,
-                  install : true,
--                 install_dir : rootbindir)
-+                 install_dir : rootsbindir)
- public_programs += exe
- executable('systemd-shutdown',
---- systemd-183/units/systemd-udev-trigger.service.in~ 2012-05-21 15:14:51.642981269 +0200
-+++ systemd-183/units/systemd-udev-trigger.service.in  2012-05-30 13:55:20.229509590 +0200
-@@ -17,5 +17,5 @@
- [Service]
- Type=oneshot
- RemainAfterExit=yes
--ExecStart=@rootbindir@/udevadm trigger --type=subsystems --action=add
--ExecStart=@rootbindir@/udevadm trigger --type=devices --action=add
-+ExecStart=@rootsbindir@/udevadm trigger --type=subsystems --action=add
-+ExecStart=@rootsbindir@/udevadm trigger --type=devices --action=add
---- systemd-183/units/systemd-udev-settle.service.in~  2012-05-30 13:43:34.886201138 +0200
-+++ systemd-183/units/systemd-udev-settle.service.in   2012-05-30 13:55:44.546175399 +0200
-@@ -29,4 +29,4 @@
- Type=oneshot
- TimeoutSec=180
- RemainAfterExit=yes
--ExecStart=@rootbindir@/udevadm settle
-+ExecStart=@rootsbindir@/udevadm settle
---- systemd-199/units/initrd-udevadm-cleanup-db.service.in~    2013-03-11 18:01:33.616138706 +0100
-+++ systemd-199/units/initrd-udevadm-cleanup-db.service.in     2013-03-26 19:09:54.525625477 +0100
-@@ -15,4 +15,4 @@
- [Service]
- Type=oneshot
--ExecStart=-@rootbindir@/udevadm info --cleanup-db
-+ExecStart=-@rootsbindir@/udevadm info --cleanup-db
This page took 0.882136 seconds and 4 git commands to generate.